Object Tracking Not Tracking / Remains Static at midway point

Timoris wrote on 13/08/2019, 19:27

Magix 2016 Pro

I am following all the steps

As the engine is processing, I can see the rectangle follow the object, but when I preview the Title / Image stays static on the midway point.

Comments

johnebaker wrote on 13/08/2019, 22:37

@Timoris

Hi

. . . . I can see the rectangle follow the object, but when I preview the Title / Image stays static on the midway point. . . . .

We need more information and also, if possible, a screen shot of the section of the timeline where the tracking is to take place ie:

  1. Is the tracking object set to the same length, or greater, as the section to be tracked?
     
  2. Is the tracking selection placed on an area which has a good contrast throughout the time the tracking is taking place?
     
  3. Does the tracking box lose track during the analysis?
     
  4. Does the tracking object move with the tracked object at all?

An example of tracking is in this topic

John EB

 

 

Lateral thinking can get things done!

VPX, MEP Premium, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

Timoris wrote on 13/08/2019, 22:43

Same length, white/orange cat going down black stairs, the text I want to animate does not move at all

 

Screenshot comes later

johnebaker wrote on 14/08/2019, 00:15

@Timoris

Hi

I have uploaded a short tutorial on Motion Tracking with MEP here.

HTH

John EB

Lateral thinking can get things done!

VPX, MEP Premium, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

tpolakov wrote on 04/09/2019, 17:17

Nice tutorial. I would like to ask though - has this been done in MEP 2019 or 2020? I am having trouble with this in MEP 2020. In the compute phase, my video preview is black - and the computed path is always just flying off the screen, no tracking.

Thanks!

johnebaker wrote on 04/09/2019, 18:23

@tpolakov

Hi

The tutorial was done in MEP 2019, just before 2020 came out.

I have tested in MEP 2020 with the same video clip and others, and can confirm there is a bug with the screen going black and the tracking is not following the object.

Please raise a support ticket (I will do the same) through the Contact link at the bottom of the page and include detail of what you see and refer Support to the your question using this URL:

https://www.magix.info/uk/forum/object-tracking-not-tracking-remains-static-at-midway-point--1229220/#ca1476181

Thanks

John EB

Forum Moderator

Lateral thinking can get things done!

VPX, MEP Premium, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

CubeAce wrote on 04/09/2019, 23:21

@johnebaker

Can there not be a bug report thread for the new version John?

Windows 10. version 1903. Latest Bios update as well as latest hardware updates for Western digital hard drives.

Asus ROG STRIX Z390-F Gaming motherboard with Supreme FX inboard audio using the S1220A code. Intel i9900K Coffee Lake 3.6 to 5.0GHz CPU with 32GB of 32MHz Corsair DDR4 ram. 1000 watt EVGA modular power supply. 2 x 320GB SSD drives striped for faster R/W times. + x2 WD BLACK internal SATA 7,200rpm hard drives. Total 4TB. Three external WD drives for backup. NVIDIA G Force GT 1030 Graphics clock 1252Mhz Memory data rate 6008Mhz. 384 CUDA cores. Memory interface 64bit Memory bandwidth 48.06 GB/s 2GB of dedicated video memory, shared system memory 9967MB PCi Express x4 Gen3. Running MEP Premium 19.0.2.49

tpolakov wrote on 07/09/2019, 16:36

I just noticed a strange thing about tracking. I bought MEP 2020 and on the machine where it is activated, the tracking does work. On the first one, where I am using the trial version, it does not. Can it be a limitation of the trial? Also the two machines are very different - the working one is a Ryzen/Nvidia desktop, the non working one is an Intel integrated graphics notebook.

johnebaker wrote on 07/09/2019, 16:54

@tpolakov

Hi

. . . . . I bought MEP 2020 and on the machine where it is activated, the tracking does work. On the first one, where I am using the trial version, it does not. Can it be a limitation of the trial? . . . .

I tested on the full version and it is definitely bug, the fact that you have it working suggests it may be hardware specific.

I received a reply from Magix to my support ticket, the issue has been replicated and referred to the developers.

John EB

 

Lateral thinking can get things done!

VPX, MEP Premium, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.