Recording DJ mixes

Lee-Suddick wrote on 03/11/2019, 15:07

Hi

I am trying to record a mix on my technics 1210’s turntable decks and I am able to record from either one separately but not both at the same time. Obviously this is a problem, as I have to select one deck or the other in the audio input settings. I just upgraded to the soundforge software from the Magix Audio cleaning lab 11 which allowed me to record perfectly but I changed computers and it no longer worked on the new computer because it is a windows 7 and audio cleaning lab 11 didn’t support windows 7.
I am also using Traktor DJ software with time code vinyl.

I have plugged the computer into a phono pre amp and that is connected to the dj mixer. I am fairly sure that it is connected properly as I am able to Record but just not both channels at the same time without swapping over in the audio input settings. 
Any one with any suggestions would be greatly appreciated!

Comments

rraud wrote on 04/11/2019, 23:02

Are you referring to Left and Right channels or two pairs of Left and Right?

Otherwise, I am not familiar with Traktor DJ software.

Lee-Suddick wrote on 05/11/2019, 08:12

Hi rraud,

thanks for replying. yes I mean left and right decks/ channels (there are two). I am having to select either one or the other in the audio input. To do a DJ mix i need to record both at the same time. Hope that makes sense.
cheers.
lee.

rraud wrote on 05/11/2019, 16:08

"I mean left and right decks/ channels (there are two)"
> so,,, you a have a total of four inputs? Turntable A: Left and Right, Turntable B: Left and Right, How are you getting these into your PC. Analog in through a soundcard (via RCA (aka, phono)  or 3.5mm TRS mini-plug(s).. or a digital  USB input?

What are your audio device type settings in Sound Forge? "Options> Preferences> Audio> Record> 'Audio device type' and 'Recording device routing'"

Is there a PDF manual for Traktor DJ I can peruse?"

Lee-Suddick wrote on 05/11/2019, 18:20

Hi,

only two inputs. Deck 1 and 2. They are connected to a sound card which connects to the DJ mixer. Then the mixer is connected to a pre amp which is then connected to the PC.
I will have a look at the preferences as you described and see if I can suss it out.
Will let you know.
Cheers.
Lee.

Lee-Suddick wrote on 05/11/2019, 21:02

Hi Rraud

i had a look, and in the options section of my sound forge there is no preferences> audio> record etc ... not sure why?
lee.

rraud wrote on 06/11/2019, 17:40

You must have the AS (Sound Forge Audio Studio) version. I'm not familiar with AS, but the devices settings have to be in there somewhere.

Lee-Suddick wrote on 06/11/2019, 19:24

Hi Rraud,

I have the sound forge audio cleaning lab version. Had a good look but can’t see any other settings. Very annoying!
cheers.
lee.

emmrecs wrote on 06/11/2019, 20:14

@Lee-Suddick

I have the sound forge audio cleaning lab version

That is the "reason" for your problem! "Live" Recording to SFACL is limited to stereo. Although the app can handle up to 8 stereo tracks (multitrack) it allows only one stereo to be recorded at "one go". (I've just checked all this on my installation of SFACL.)

But...

Looking again at what you say your set-up is, I'm a little confused by what you wrote. You said:

only two inputs. Deck 1 and 2. They are connected to a sound card which connects to the DJ mixer. Then the mixer is connected to a pre amp which is then connected to the PC.

I assume, then, that each record deck has its own separate output cable? Correct? I'm not sure why they are connected to a sound card. Can you explain this? (e.g. what is the purpose of this card and does it have two stereo inputs and two stereo outputs?) You then seem to take the signal to your DJ mixer. I assume that the signals arrive at the mixer as two separate stereo signals which you mix/crossfade between. Is that correct? Normally, such mixers output ONE stereo signal (because the "DJ" is controlling the relative levels etc., of the two decks). IOW, this DJ Mixer should enable you to "select" which deck is being recorded at any given instant so a single stereo input to your PC is not going to be a problem.

However, you then are apparently feeding this signal from the mixer to a pre-amp. Why?

Sorry for all the questions but I think your problem may be nothing to do with SFACL but rather something not quite right earlier in the signal chain.

Jeff

Win 10 Pro 64 bit, Intel i7 Quad Core 6700K @ 4GHz, 32 GB RAM, AMD Radeon R7 360 and Intel HD530 Graphics, MOTU 8-Pre f/w audio interface, VPX, MEP, Music Maker, Photo Story Deluxe, Photo Manager Deluxe, Xara 3D Maker 7, Reaper, Adobe Audition CS6 and CC, 2 x Canon HG10 cameras, 1 x Canon EOS 600D

Lee-Suddick wrote on 06/11/2019, 21:25

Hi Jeff,

thanks for the reply.
The way the Traktor scratch software works is that you have cables that allow you to plug your decks into, which in turn plugs into the Traktor sound card, yes it does have two stereo inputs and two stereo outputs. The other end plugs into the mixer. This allows you to switch between playing regular vinyl, and MP3s using time coded vinyl using the Traktor software. Meaning I can have a normal bit of vinyl on one deck and mix a mp3 into it on the other deck using the time coded vinyl.
Then you have a cable running from the Rec out connection on the back of the mixer to the preamp which then is connected to the PC.
When I go to the setting of the Audio inputs on Sound forge it shows The Traktor inputs, channel A and B and I have to select one or the other. I can record from either but only separately. It should just record the output from the mixer but it doesn’t seem to be. It seems that I have to choose one deck at a time to record from. As I said before I had a previous version and it did the job perfectly, so I thought upgrading would be the same. But I guess you know what they say about assumptions!
cheers

lee