Sound Forge " requires elevated privileges ". Fixed in the MAGIX version?

Comments

colinu wrote on 05/06/2017, 19:58

I have had the problem with WAV and MP3 files and it occurs whether clicking on a file in Windows Explorer or when opening Sound Forge from a shortcut on the desktop. The problem occurs whether the file is one that I recorded or one that was sent to me from someone else. I usually don't use FLAC so I don't believe the issue is directly related to FLAC or where a particular file came from.

It seems that different people experience different triggers. Interesting.

richard-davis wrote on 17/09/2017, 00:40

For me, the issue is not related to any specific file type. The program just won't open, and I can't delete the Sony Creative Software folder in the registry. It says "Error while deleting key". Of course, like so many others, it started with the Creator update to Win10.
So I bought Soundforge Audio Studio 12. Just OK, but editing features are very limited. Not happy, and wish there was a real fix for Soundforge 11. Magix should be on this!

Sandflyer wrote on 21/09/2017, 11:33

Just some intro/ background about my SF history: I started with SF Audio Studio 9; got a super deal from Magix on SF-AS 10 with free upgrade to SF-AS12.

When I upgraded to 12 (actually it wasn't an upgrade - unwittingly I installed 12 without uninstalling 10, thinking it would just install on top. It didn't. So I had 10 and 12 sitting there side by side. But, I'm having a hard time getting used to the SF-AS 12 interface - some things changed - so I kept both versions.

Now the relevant stuff, FWIW: 1. I have used SF-AS 10 after I had the creators update already installed and it did not act up. It acted up (i.e. "elevated privileges") for the first time only last night. 2. I have definitely never opened a FLAC file with SF-AS 10 (or 12 for that matter). I do all my work in WAV and save as WAV, converting to FLAC later with other software.

I tried the registry enty delete solution and it did not work (my account as admin, there is another user account on the computer).

I have not yet tried the solutions proposed here (thanks in advance for these).

 

If worse come to worse, and running SF-AS 10 in administrator mode doesn't work for some reason, I will sadly revert to SF-AS9, which worked without a hitch.

scott-markham wrote on 16/11/2017, 05:06

Just experienced this nice hiccup - seems issue should have been eradicated by now. It appears what caused issue was simple system crash. After I rebooted, started SF10 and had same message. After following prompts and answering yes to the Admin privilege nothing happens. Tried multiple times. I will give the registry hack a try in morn, as I've already shut down system for the night.

scott-markham wrote on 16/11/2017, 21:23

Tried fix in regedit with no success. The location differed from the example. Possibly the result of Win OS upgrades. This was my location: S-1-5-21- [user ID] > Software > Sony creative software > Sound forge audio studio > 10.0

Instead of deleting, I renamed the 10.0 folder (as suggested in another post to be safe). Exited regedit, started SF10, same registration authorization window pops up. Tried rebooting, still the same. Checked regedit, new folder 10.0 minus 2 folders (DXcache, Presets) was created. Am I missing something here?

How can this bug exist through so many versions of software? This is absolutely unacceptable, I'm attempting to earn a living with SF Audio Studio and should be able to expect better!

condex wrote on 17/11/2017, 11:08

The Regedit location for the SoundForge 10 or 11 elevated privileges fix should be:

HKEY_USERS\XXXXXX-XXXX_Classes\VirtualStore\MACHINE\SOFTWARE\Wow6432Node\Sony
Creative Software

My computer has the latest W10 Creators version, and the Regedit fix worked as usual when the privileges problem happened again yesterday with SF11.

scott-markham wrote on 21/11/2017, 19:43

Mea culpa... definitely had wrong folder. That did the trick - thanks! Still don't understand why this hasn't been addressed with fix after all these years. Considered upgrading to new version, but hesitant with issues I've experienced in past several months. My clients aren't going to cut me slack, if I can't deliver on time because of software issues. Again thanks for assistance everyone.

satauna-howery wrote on 20/12/2018, 22:28

Try using the Windows Program Compatibility tool to set it to run with admin privileges. Works for me. :)

Lobomdq22 wrote on 23/01/2019, 18:52

After reading and reading I just found a solution. Just head to Sound Forge directory (something like C:\Program files (x86)\Sony\Sound Forge Pro 11.0), right click on the executable (forge110.exe in my case) and select Properties. Click on "Compatibility" and then "Change configuration for all users", then select "Execute this program as an administrator" and that's all.

 

Sorry for my bad english, i wish this helps. Greetings from Argentina.

rraud wrote on 23/01/2019, 21:36

The caveat to this procedure is, before SF opens, one has to select OK in the 'Allow Windows to make changes' dialog.
Editing the registry eliminates that step.
For those comfortable with editing the registry, see this "Elevated Privileges" thread. I've needed to do this numerous times on Pro 10.
 Pro 12 does not seem to have the Elevated Privilege issue.

Kunal-Agarwal wrote on 22/05/2019, 07:33

The Regedit location for the SoundForge 10 or 11 elevated privileges fix should be:

HKEY_USERS\XXXXXX-XXXX_Classes\VirtualStore\MACHINE\SOFTWARE\Wow6432Node\Sony
Creative Software

My computer has the latest W10 Creators version, and the Regedit fix worked as usual when the privileges problem happened again yesterday with SF11.

NOT WORKING! Please help

 

rraud wrote on 25/10/2019, 19:27

The SF "Elevated Privileges" issue usually happens soon after a Win update. I've had to tweak the registry for Sound Forge Pro 10 more times than I care to remember. Pro 12 and 13 are not subject to this annoyance in my experience. I do not have Sound Forge Pro 11 on a Win 10 PC.