VSTi problem in Pro 8

savethematches wrote on 09/01/2019, 21:07

When I try to load the Vita Rock Drums soft synth, I get an error message that the following file is not found. YT-MX SD 01 OH 01 XC#1 Y02. I hit ignore, and it keeps popping the same message with slightly different file names, for example Y01, Y01c, etc. After going through them or hitting Ignore All, the synth loads. I can click on the various drums and see the visual representation but no sound comes out. Help!

Comments

Will-Kenworthy wrote on 10/01/2019, 05:43

No sound comes out because those are the samples(audio files) the instrument needs to play the drum sounds. It's weird that the instrument loads but you have no sounds.

Check this first. look in C:\Users\Public\Public Documents\Magix\Common\MxSynth\Rock Drums

and C:\Users\Public\Public Documents\Magix\Common\MxSynth\Drum Engine

Make sure these folders are there and files are there within them, especially in the "image files" folders. If you are missing some or all of these files you will need to re-download and install the Vita instruments. There are posts here that go into detail on how to do just that. You can start by going to the help menu and clicking on downloading loops and instruments. Some users (but not all) have found that starting ACID in administrator mode makes this possible. Also if the installer suggests "Repair" that should take care of it. Here I've included some images of what 2 of your folders should look like. Both should be checked. Rock Drums & Drum Engine:

Good Luck.

Will

 

savethematches wrote on 11/01/2019, 21:34

Thanks for the reply. I reinstalled all loops and instruments. Now, when I open Rock Drums, the missing file window doesn't pop up, but I can't click on any of the drums or the little keyboard at the bottom. I tried inserting various other soft synths, and most pop up the missing files windows.

I checked the folders you mentioned. The Drum Engine folder doesn't appear; I only see the Rock Drums folder inside the Mx Synth folder. Everything appears to be in place in the Rock Drums folder, though.

savethematches wrote on 11/01/2019, 21:43

Update. I found the missing files and the Drum Engine folder. I copied and pasted them into the MxSynth directory you mentioned above. The missing files pop ups are now gone. So, that's good. I'm still not able to get any sound though. I can't click on any of the drums in Rock Drums. I tried Jazz Drums, and I can click on all elements of the kit except for the first tom, but none of them produce sound. Admittedly, I'm no midi guru, but this doesn't seem right to me.

Will-Kenworthy wrote on 14/01/2019, 00:48

Have you set up your instrument track correctly? What are you using to "click" on the drums? Your mouse or a MIDI keyboard? Your MIDI track that is feeding your instrument track has to have the correct input selected. And there is a program setting as well, "Generic MIDI input device" that must be selected for you to have MIDI input. Also if you've done these correctly I find that sometimes if I put one or the other tracks (MIDI input or Instrument) in record mode it allows ACID to respond to input. Your manual is your best friend here .....

Let us know how you fare, good luck,

Will

savethematches wrote on 14/01/2019, 18:17

And I was being dumb. 😲 I was trying to check the sounds by mouse click but had no midi track loaded. In my defense, I can do that with MTPowerDrumKit. After I added a midi drum loop, it worked as it should. Thanks for your help, and please forgive my ignorance.

Will-Kenworthy wrote on 16/01/2019, 00:20

Oh jeez, no apologies or forgiveness necessary!!! I've made many similar mistakes. MANY, LOL.

Good luck and enjoy!!

Will