MAGIX Help Center

Removing ghosts from projects

Sometimes ghost images or sounds can appear in your project even though there are no objects at that position in the project.
To fix this problem, follow these steps:

  1. Switch to Timeline mode and zoom out of the project until you are able to draw a selection box around the entire movie and all of its tracks. 
  2. Select the entire project and go to "Edit" > "Copy objects" (keyboard shortcut: Ctrl+C) to copy it. Depending on the size of your project, it may take some time to copy everything to the clipboard.
  3. Now, without closing the current project, open a new project by going to "File" > "Manage movies" > "New".
  4. Users of MAGIX Video Pro x 11 can open a new project via "File > Manage project > Add new empty movie".
  5. Go to "Edit" > "Paste objects" (or press Ctrl+V).
  6. Then, select the tab for the "old" movie (above the timeline) and remove it from the project by clicking the small "x" icon.