Kommentare

BilderMacher schrieb am 06.08.2013 um 19:08 Uhr

Micha,

du machst beim Exportieren deiner Grundschule-Homepage auf die Festplatte einen gravierenden Fehler!

Bei der Eingabe des Dateinamens hast du hier "Grundschule-Blankensee" angegeben:

 

und dahinein wurde vom WD der Websiteinhalt abgelegt:

 

Das ist zwar nicht ganz falsch, aber ein Weg, der zu Problemen führen kann - wie man sieht!

 

Nun beschreibe ich, wie du zum index_htm_files-Ordner kommst ...

Öffne die *.web-Datei deines neuen Website-Projektes.

Lege zunächst im Windows-Explorer (Dateimanager) einen neuen Ordner an - z.B: "Webprojekt-Grundschule":

 

In diesen Ordner speicherst du die *.web-Datei, also die Webdesigner Projektdatei.

Dann wählst du im Webdesigner den Export-Dialog aus:

und wechselst in den erstellten Ordner Webprojekt-Grundschule.
Als Dateiname lässt du die Vorgabe index und klickst auf "Exportieren":

Der Webdesigner erstellt nun einen Ordner index_htm-files und legt die Startseite "index.htm" sowie alle Seiten des Projektes an.
Das Wort vor dem Unterstrich "_" vor "htm" ist der verwendete Dateiname. Bei dir war es immer Grundschule-Blankensee statt index.

Im FTP-Programm öffnest du nun den "Webprojekt-Grundschule"-Ordner und überträgst ihn mit allen Seiten.

Nach dem Hochladen hast du dann diese Struktur.

Ab jetzt hast du eine index.htm-Datei als Startseite und den Inhalt der Grundschule-Website im Ordner index_htm_files.

Viel Erfolg beim "Neuanfang".

Zuletzt geändert von BilderMacher am 07.08.2013, 00:12, insgesamt 7-mal geändert.

Gruß, B a lderm I cher

(Ich bin KEIN MAGIX Mitarbeiter, ich bin NICHT beim MAGIX-Support!)

-----------------------------------------------------------------------------------------

Mein System: Windows 10 Home 64Bit | Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz | NVIDIA GeForce 840M, 4GB RAM | Vdl 2016/2019 Premium; Video Pro X 7, 10; Photostory Deluxe 2019 + TRAVEL Maps | MAGIX Photo & Graphic Designer 16; XARA Designer Pro X 16, Web Designer 11/16 | MAGIX Music Maker MX Premium, Music Maker 2016 Live, MAGIX Samplitude Music Studio 2017 | Samplitude Pro X4 Suite | MAGIX Audio & Music Lab 2016 Premium | Panasonic HDC-SD66 | Velbon CX-586 | Delamax Capa Videoschiene 60cm mit Velbon PH-358 Stativkopf | ZOOM H2n | Panasonic Lumix DMC-FZ300 | Focusrite_Scarlett_2i2_2ndGen | Neewer NW800

micha322 schrieb am 06.08.2013 um 22:07 Uhr

Hallo,

bin gerade dabei dein Anleitung umzusetzen. Erstmal vielen dank für die Mühe...

wie sieht es mit dem Verzeichnissnamen auf dem Server aus, laut meines Admins sollte dies /grundschule-blankensee heißen. Auf dem ersten Bild von meinem Serverabbild steht oben nicht hinter dem / Strich, kann ich dieses Verzeichniss wieder /grundschule-blankensee benennen oder in den Namen des akuellen Projektordner Webprojekt-Grundschule... Kann ich dort überhaupt was etwas ändern...??? Ich weiß halt nicht ob es grundsätzlich egal ist wie das Verzeichniss heißt oder wer es ändern darf und kann. War bis jetzt nie Thema.. Ich würde mich dann sonst an den Admin wenden, momentan ist aber Urlaubszeit in der Stadtverw.  momentan ist glaubig keiner da, der sich da so richtig auskennt. Ich hatte schone eine Mailanfrage geschickt zwar mit einem anderen Thema aber eine Antwort habe ich leider noch nicht... 

Lg Micha

Also so richtig hat es nicht geklappt, diese Datei habe ich gar nicht die bei dir da zusehen ist index.htm es scheint ja ein Firefox datei zusein???  bei mir liegt jetzt im Exportordner die aktuelle Magixprojektdatei, diese wurde auch mit  hochgeladen, habe soweit die Schritte umgesetzt oder???

 

 

micha322 schrieb am 06.08.2013 um 22:13 Uhr

sorry... nächste Frage dann wieder in einem Fenster

oh da hat wohl gerade ein Blitz ein Stromausfall ausgelöst.... hoffe es ist nur ein Darstellungsfehler...

 

 

BilderMacher schrieb am 07.08.2013 um 00:18 Uhr

wie sieht es mit dem Verzeichnissnamen auf dem Server aus, laut meines Admins sollte dies /grundschule-blankensee heißen.

Das kannst du so machen. Dann erstellst du auf der Festplatte einen Ordner der so heißt (nicht wie ich in meinem Beispiel vorgeschlagen habe) und exportierst deine Seiten mit index.htm in diesen.

Dann überträgst du diesen per FTP auf den Server. Was du nicht übertragen musst und solltest, ist die Projekt-*.web-Datei und der vom WD erzeugte Ordner.

Auf dem Server gibt es nur zwei Ordner:

  • grundschule-blankensee
  • index_htm_files

Und alle Seiten.

---------------

Hinweis zum Antworten: Verzichte bitte auf Vollzitate! Es reicht, wenn du antwortest, ohne Zitatfunktion!

 

Zuletzt geändert von BilderMacher am 07.08.2013, 00:29, insgesamt 2-mal geändert.

Gruß, B a lderm I cher

(Ich bin KEIN MAGIX Mitarbeiter, ich bin NICHT beim MAGIX-Support!)

-----------------------------------------------------------------------------------------

Mein System: Windows 10 Home 64Bit | Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz | NVIDIA GeForce 840M, 4GB RAM | Vdl 2016/2019 Premium; Video Pro X 7, 10; Photostory Deluxe 2019 + TRAVEL Maps | MAGIX Photo & Graphic Designer 16; XARA Designer Pro X 16, Web Designer 11/16 | MAGIX Music Maker MX Premium, Music Maker 2016 Live, MAGIX Samplitude Music Studio 2017 | Samplitude Pro X4 Suite | MAGIX Audio & Music Lab 2016 Premium | Panasonic HDC-SD66 | Velbon CX-586 | Delamax Capa Videoschiene 60cm mit Velbon PH-358 Stativkopf | ZOOM H2n | Panasonic Lumix DMC-FZ300 | Focusrite_Scarlett_2i2_2ndGen | Neewer NW800

micha322 schrieb am 07.08.2013 um 21:35 Uhr

 

wie sieht es mit dem Verzeichnissnamen auf dem Server aus, laut meines Admins sollte dies /grundschule-blankensee heißen.

Das kannst du so machen. Dann erstellst du auf der Festplatte einen Ordner der so heißt (nicht wie ich in meinem Beispiel vorgeschlagen habe) und exportierst deine Seiten mit index.htm in diesen.

Dann überträgst du diesen per FTP auf den Server. Was du nicht übertragen musst und solltest, ist die Projekt-*.web-Datei und der vom WD erzeugte Ordner.

Auf dem Server gibt es nur zwei Ordner:

  • grundschule-blankensee
  • index_htm_files

Und alle Seiten.

---------------

Hinweis zum Antworten: Verzichte bitte auf Vollzitate! Es reicht, wenn du antwortest, ohne Zitatfunktion!

 

Ich hoffe diese Art einer Antwort ist gemeint, gestern habe ich leiden den falschen Button erwischt... sorry

Also, ich habe jetzt alle Möglichkeiten durch gespielt, ich warte jetzt noch diese beschriebene halbe Stunde, dann sollten die daten ja auf dem Server sein. Ich glaube aber auch dieses mal wird es nicht klappen.

Somit bleibt die Geschichte ohne Happyend, mir ist zwar unbegreiflich warum es nicht funktioniert, aber in den meisten fällen sitzt das Problem vordem PC.

Muß man irgendwelche Dateierweiterungen machen oder eine Datei anlegen die als Webdatei dargestellt wird, wie in deinem Beispiel die  index.htm Datei ist ein Firefox html Dokument dieses scheint ja schon auf deinem PC zusein. Bei mir existiert diese gar nicht, weder auf dem Pc noch auf dem Server wo kommt diese her und wozu braucht man die und am aller wichtigsten wo bekomme ich sie her ?

Ich benutze aktuell Win 8 vorher Win XP seid der Umstellung geht es irgendwie nicht mehr...???Hat es damit vielleicht zutun.

LG Micha

BilderMacher schrieb am 07.08.2013 um 22:28 Uhr

wie in deinem Beispiel die  index.htm Datei ist ein Firefox html Dokument dieses scheint ja schon auf deinem PC zusein

Ich weiß nicht, wie das der WD 6 gemacht hat. Beim WD9 wird die erste Seite automatisch als index bennant, so ist sichergestellt, dass der Export auf die Festplatte immer als index.htm (html) erfolgt und beim Veröffentlichen auch eine Startseite (regelkomform) index heißt.

Bei deinem Grundschule-Projekt ist aktuell keine index.htm vorhanden, was beim Aufruf der Seite z.B. von der Homepage der Stadt Trebbin ins Leere läuft - es wird eine entsprechende 403-Forbidden-Seite angezeigt:

 

 

 

Wie es aber aussieht, hast du auf dem Server einen Unterordner unterhalb von grundschule-blankensee

angelegt der auch "grundschule-blankensee" heißt und in diesen alles kopieren lassen, inklusive index.htm-Datei:

http://www.grundschule-blankensee.de/grundschule-blankensee/index.htm

Es ist ja fast geschafft ...

Auf dem Server muss es eigentlich so aussehen:

Dann erfolgt der Aufruf der Seite 

http://www.grundschule-blankensee.de/

direkt und richtig und es wird vom Browser die index.htm Datei auch gefunden.

Zuletzt geändert von BilderMacher am 07.08.2013, 22:28, insgesamt 1-mal geändert.

Gruß, B a lderm I cher

(Ich bin KEIN MAGIX Mitarbeiter, ich bin NICHT beim MAGIX-Support!)

-----------------------------------------------------------------------------------------

Mein System: Windows 10 Home 64Bit | Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz | NVIDIA GeForce 840M, 4GB RAM | Vdl 2016/2019 Premium; Video Pro X 7, 10; Photostory Deluxe 2019 + TRAVEL Maps | MAGIX Photo & Graphic Designer 16; XARA Designer Pro X 16, Web Designer 11/16 | MAGIX Music Maker MX Premium, Music Maker 2016 Live, MAGIX Samplitude Music Studio 2017 | Samplitude Pro X4 Suite | MAGIX Audio & Music Lab 2016 Premium | Panasonic HDC-SD66 | Velbon CX-586 | Delamax Capa Videoschiene 60cm mit Velbon PH-358 Stativkopf | ZOOM H2n | Panasonic Lumix DMC-FZ300 | Focusrite_Scarlett_2i2_2ndGen | Neewer NW800

marboe schrieb am 07.08.2013 um 23:00 Uhr

Beim WD9 wird die erste Seite automatisch als index bennant

@ Bildermacher

Das ist richtig. Allerdings kann man die erste Seite auch umbenennen, dann kann das passieren was micha hier passiert ist. Der WD korrigiert das also nicht. Es kann durchaus sinnvolle Gründe geben, warum man das macht - aber das gilt für micha nicht. Deswegen führe ich das Thema hier gar nicht weiter aus. Mir ging es nur darum klarzustellen, dass der WD nicht zwingend die erste Seite zu einer index.htm exportiert.

@ Micha

Die Anleitung von Bildermacher ist sehr gut. Genau so solltest du zum Ziel kommen.

Der Thread hier ist mittlerweile so unübersichtlich, dass ich mich nicht mehr traue noch irgendwas dazu zu schreiben. Wie sieht denn deine rechte Seite des FTP-fensters nun aus?

Vielleicht ist es nämlich wesentlich besser, wenn du - sobald die Verzeichnisse auf dem Server stimmen - du den WD den kompletten Upload machen lässt. Dann brauchst du dir  da keine Gedanken mehr machen. Aber es muss halt klar sein, in welchen Ordner du lädst und wie der heißt.

Wenn du nicht weiterkommst, dann könnten wir uns hier auch mit einem Testbild helfen, dass du einfach hochlädst und dann auf bestimmte Weise aufrufst. Dann wissen wir genau welcher Ordner richtig ist.

Aber jetzt versuche erstmal die Anleitung von Bildermacher auszuführen. Gruß Martina

micha322 schrieb am 07.08.2013 um 23:38 Uhr

Hallo Bildermacher,

hier mal zwei Bilder diese sind aktuell, , habe jetzt den WD9 heruntergeladen zum testen.

   

 

beim ersten Versuch habe ich die beiden Ordner komplett mit ins Verzeichniss kopiert also so entsteht also ein Unterordner, es sah von dem Verzeichnissabum gleich aus wie auf deinem Bild, aber nach dem öffnen war dann logischerweise ein zweiter Ordner vorhanden, scheinbar wurde aber wenigstens etwas übertragen nur leider nicht korrekt, Seite ohen Struktur und Funktion...

Zweiter Versuch siehe Bilder,  theoretisch habe ich alles richtig gemacht, aber es kommt die übliche Meldung von 1&1. Ich wundere mich nur warum in deinen Beispielbildern hinter der .htm Datei Firefox Dokument steht und auch ein dementsprechendes Symbol angezeigt wird , muß ich im Firefox etwas einstellen, ich surfe im Privatenmodus hat es etwas damit zutun....???

LG Micha

BilderMacher schrieb am 08.08.2013 um 09:59 Uhr

Ich wundere mich nur warum in deinen Beispielbildern hinter der .htm Datei Firefox Dokument steht und auch ein dementsprechendes Symbol angezeigt wird

Das liegt an meinem Windows bzw. der Dateizuordnung. Der FF ist bei mir der Standardbrowser und alle HTML-Dateien sind so zugeordnet. Deswegen das Symbol und der Dateityp "Firefox-Dokument". Mit dem Privatmodus vom FF hat es nichts zu tun.

Alles andere ist mir langsam unheimlich.

Es scheint die Struktur auf dem Server zu stimmen, aber immer noch keine index-Seite ...

 

Update:

Lass es wie es jetzt ist, denn es funktioniert.

http://www.grundschule-blankensee.de/grundschule-blankensee/index.htm

Die Verlinkung aud der Homepage der Stadt Trebbin muss nur angepasst werden und alle anderen, die noch nicht die "neue" Adresse kennen, sollten informiert werden.

Zuletzt geändert von BilderMacher am 08.08.2013, 13:35, insgesamt 3-mal geändert.

Gruß, B a lderm I cher

(Ich bin KEIN MAGIX Mitarbeiter, ich bin NICHT beim MAGIX-Support!)

-----------------------------------------------------------------------------------------

Mein System: Windows 10 Home 64Bit | Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz | NVIDIA GeForce 840M, 4GB RAM | Vdl 2016/2019 Premium; Video Pro X 7, 10; Photostory Deluxe 2019 + TRAVEL Maps | MAGIX Photo & Graphic Designer 16; XARA Designer Pro X 16, Web Designer 11/16 | MAGIX Music Maker MX Premium, Music Maker 2016 Live, MAGIX Samplitude Music Studio 2017 | Samplitude Pro X4 Suite | MAGIX Audio & Music Lab 2016 Premium | Panasonic HDC-SD66 | Velbon CX-586 | Delamax Capa Videoschiene 60cm mit Velbon PH-358 Stativkopf | ZOOM H2n | Panasonic Lumix DMC-FZ300 | Focusrite_Scarlett_2i2_2ndGen | Neewer NW800

marboe schrieb am 08.08.2013 um 17:01 Uhr

Na endlich .

Bei mir funktioniert auch alles prima. Ich hab mal gesucht und kann vermelden, dass es wirklich nur einen nennenswerten Link zu eurer Startseite gibt, der angepasst werden sollte.

Ob damit diejenigen User dann klarkommen, die sich eine deiner Seiten als Favorit gespeichert haben, weiß ich nicht. Vielleicht musst du da nochmal ein Rundschreiben schicken. Hier noch ein Foto vom BackLinkTest:

Es reicht übrigens, wenn die Stadt nur auf http://www.grundschule-blankensee.de/grundschule-blankensee verweist. Die Startseite wird dann automatisch gefunden.

Gruß Martina

micha322 schrieb am 08.08.2013 um 20:10 Uhr

 

Na endlich .

Bei mir funktioniert auch alles prima. Ich hab mal gesucht und kann vermelden, dass es wirklich nur einen nennenswerten Link zu eurer Startseite gibt, der angepasst werden sollte.

Ob damit diejenigen User dann klarkommen, die sich eine deiner Seiten als Favorit gespeichert haben, weiß ich nicht. Vielleicht musst du da nochmal ein Rundschreiben schicken. Hier noch ein Foto vom BackLinkTest:

Es reicht übrigens, wenn die Stadt nur auf http://www.grundschule-blankensee.de/grundschule-blankensee verweist. Die Startseite wird dann automatisch gefunden.

Gruß Martina

Hallo ihr beiden fleißigen Helfer, es sieht ja so aus als hätte es geklappt, malsehen ob wir den Rest auch noch hin bekommen.

Vielen Dank... an alle Helfer

Update:

Hier mal kurz noch ein Bild, die index.htm Datei wurde erstellt mit einer Weiterleitung zur Homepage aus dem Rootverzeichniss heraus, somit findet man, wie du schon beschrieben hast (Martina) die Seite wieder unter www.grundschule-blankensee.de

 

Vielen Dank.... LG Micha