Kommentare

BeRo schrieb am 03.02.2018 um 23:17 Uhr

[...] ich würde gern eine Schaltfläche mit Dropdown erstellen aber [...] diese werden von einem js platzhalter nicht überdeckt [...]

Dann machst du was verkehrt. 😇

Wenn Du ein Objekt verdecken willst, musst Du ein anderes Objekt darüberlegen. Eine Galerie in einem HTML Platzhalter eignet sich allerdings weniger dafür, weil die von Haus aus einen transparenten Hintergrund hat.
Legst Du ein opaques (undurchsichtiges) Objekt darüber, funktioniert das tadellos.

In Deinem aktuellen Projekt findest Du den Beweis, da liegt ein undurchsichtiges Rechteck unter dem HTML Platzhalter für die einzublendenden Galerien-, Videos-, Slideshows…

Quod erat demonstrandum 😋

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

moppel schrieb am 07.02.2018 um 19:46 Uhr

Also ich Importiere eine neue Navigationsleiste und erstelle die einzelnen Buttons mit dropdown aber wenn ich auf Vorschau gehe verdeckt das Rechteck alles ausser die Navileisten auf meiner Seite.

Ich mache mit Sicherheit nur ne Kleinigkeit falsch aber es nervt😅

BeRo schrieb am 07.02.2018 um 20:07 Uhr

[...] Ich mache mit Sicherheit nur ne Kleinigkeit falsch [...]

So sehe ich das auch. 😉

Aber so ohne weitere Infos zu dem was Du mit der NavBar sonst noch so gemacht hast, bleibt nur die Glaskugel und die sagt mir, dass du evtl. die NavBar fixiert hast?!

Wenn das zutrifft, dann bleibt die NavBar an der obersten Position in der Hierarchie aller Objekte, da hilft dann kein noch so großes Rechteck, das Du darüber legst... 😋

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

moppel schrieb am 07.02.2018 um 22:38 Uhr

Ist nicht fixiert oder gibts da noch eine Option?

Ich habe aus der Designgalerie eine Navigationsleiste importiert weil ich nen normalen Button mit dropdown nicht finden kann...

BeRo schrieb am 07.02.2018 um 23:06 Uhr

[...] gibts da noch eine Option? [...]

Ja, Du musst den NavBar Button mit einem geeigneten Objekt verdecken, das Du in der popup Ebene ablegst.
In der Demo, die ich online gestellt habe, ist das ein Rechteck in der Größe der einzublendenden Media Dateien.
Das Rechteck hat die Farbe des Hintergrunds und es liegt unter den eingeblendeten Media Dateien. Damit wird dann der Hintergrund verdeckt.
Wenn Du dieses Rechteck nach oben ausdehnst, wird auch Dein neu angelegter Button verdeckt, sobald eine Media Datei eingeblendet wird.

Probiers nochmal 🙃

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

moppel schrieb am 08.02.2018 um 07:24 Uhr

Genau das mache ich ja schon von Anfang an... Ich schiebe das Rechteck bis hoch über die ganze Seite und alles wird beim klick auf nen js Link verdeckt nur eben die Navileisten nicht!!!

BeRo schrieb am 08.02.2018 um 14:05 Uhr

[...] Genau das mache ich ja schon von Anfang an... [...]

Hast Du das mal mit der Demo probiert, die ich zum Download bereit gestellt habe?

Du kannst aber parallel auch einen Screenshot des Editor Fensters der Seite zeigen, mit der Du das Problem hast.
Achte dabei bitte darauf, dass die eingefügte NavBar aktiv ist (markiert) und dass die Seiten- & Ebenen-Galerie aufgeklappt- und lesbar zu sehen ist.

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

moppel schrieb am 09.02.2018 um 18:22 Uhr

Wenn ich eine Navbar bei dir in die DEMO einfüge und auf Vorschau gehen wird sie verdeckt aber auf meiner Seite nicht.

Hoffe die Screenshots reichen so.

BeRo schrieb am 09.02.2018 um 21:04 Uhr

[...] Hoffe die Screenshots reichen so. [...]

Nicht so wirklich... 😞
Die Anlage der neuen NavBar scheint korrekt gelungen zu sein. Leider ist nicht erkennbar, wie die Struktur der darüber angelegten Objekte (Platzhalter, Rechteck) aussieht.

So sollte es sein:

Prüf das mal in Deinem Projekt...

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

moppel schrieb am 09.02.2018 um 21:54 Uhr

Genau so hab ich es gemacht und wie gesagt in der Demo geht's aber bei mir nicht. Die navileiste ist immer über dem rechteck als wenn das rechteck eine Position in den Vordergrund müßte.

BeRo schrieb am 09.02.2018 um 22:33 Uhr

[...] Genau so hab ich es gemacht [...]

So werden wir das Problem nicht in den Griff bekommen. 😫
Die ultimative Lösung kann jetzt nur noch eine Prüfung der Original Projektdatei bringen.

Wenn Du möchtest kannst Du gerne eine abgespeckte Version der Projektdatei online stellen. Dazu genügt es, wenn Du das Projekt unter einem neuen Namen speicherst, dann alle Seiten löschst, außer der Galerie Seite und danach die so abgespeckte Projektdatei auf Deinem Webspace ablegst und den Link dahin hier postest.
Ich schau mir das dann gerne an...

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

BeRo schrieb am 11.02.2018 um 15:56 Uhr

@moppel Alaaf 😀

Trotz der gerade grassierenden Narretei kannst Du Dein Problem abhaken, weil es wirklich nur eine Kleinigkeit ist, die Lösung umzusetzen...

Entferne einfach den Haken aus der Checkbox "Auf Seitenrand beschneiden" und gut ist. 😊

Warum die Option "Auf Seitenrand beschneiden" in Deinem Fall solche artfremden Probleme macht, habe ich nicht analysiert. Ich vermute hier einen Bug, den wohl nur die Entwickler finden/beseitigen können.

Viel Erfolg und gerne noch ein paar "tolle Tage"

P.S.
Du solltest unbedingt Deinen WD12 aktualisieren. Du benutzt noch die total veraltete Version 12.0.0.45126.
Aktuell ist die Version 12.6.3.50400.
Auch ein Upgrade auf die neue 15er Version kann sinnvoll sein... 😉

Zuletzt geändert von BeRo am 11.02.2018, 16:03, insgesamt 1-mal geändert.

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

moppel schrieb am 12.02.2018 um 21:35 Uhr

Hat alles bestens funktioniert vielen Dank für deine Hilfe und für die viele Geduld!!!