letzter Frame schwarz

Burglinster schrieb am 18.04.2024 um 15:26 Uhr

Hallo

habe folgendes Problem: in ProX ist bei den iPhone 15 Aufnahmen der letzte Clip fast immer schwarz. Ist kein Problem, den wegzuschneiden. Aber im Original ist es nicht schwarz. in VLC angeschaut, makellos.

Die Einstellung in ProX sind genaus so wie die Clips.

Was ist da los?

Danke

Gruß

Berthold

Kommentare

georg4 schrieb am 18.04.2024 um 17:56 Uhr

Hallo @Burglinster,
du bist nicht allein. Der schwarze Frame kommt bei mir auch in X14 oder VDL-P 2024. Handy Huawei P30 Pro.


Zuletzt geändert von georg4 am 18.04.2024, 17:57, insgesamt 1-mal geändert.

Win 10 Pro 64 bit / 22H2
Mainboard ASUS PRIME Z690M-P
CPU - Intel(R) i7-12700K / RAM - 32,0 GB
iGPU UHD Graphics 770 / GPU - AMD Radeon Pro W5550 8GB GDDR6
2x Samsung 980 PRO M.2 NVMe 1 TB / Samsung 870 EVO SSD (2x1TB)
Pro X 14 (20.0.3.181) + VDL-Premium 2013/2016/2019/2020/2021/2022/2024
DaVinci Resolve 19, Gott sei Dank nach 20 Jahren auch in deutsch
DJI Mavic 2 Pro, Olympus OM-5, DJI Action 4, Huawei P30 Pro + Huawei P20


Manchmal braucht man eine ganze Tankfüllung Sprit, oder muss einen vollen Akku leerfahren, bevor man wieder klar denken kann...

georg4 schrieb am 18.04.2024 um 20:01 Uhr

@Burglinster
hab ganz vergessen, du kannst auch einstellen das der letzte Frame automatisch abgeschnitten wird

Win 10 Pro 64 bit / 22H2
Mainboard ASUS PRIME Z690M-P
CPU - Intel(R) i7-12700K / RAM - 32,0 GB
iGPU UHD Graphics 770 / GPU - AMD Radeon Pro W5550 8GB GDDR6
2x Samsung 980 PRO M.2 NVMe 1 TB / Samsung 870 EVO SSD (2x1TB)
Pro X 14 (20.0.3.181) + VDL-Premium 2013/2016/2019/2020/2021/2022/2024
DaVinci Resolve 19, Gott sei Dank nach 20 Jahren auch in deutsch
DJI Mavic 2 Pro, Olympus OM-5, DJI Action 4, Huawei P30 Pro + Huawei P20


Manchmal braucht man eine ganze Tankfüllung Sprit, oder muss einen vollen Akku leerfahren, bevor man wieder klar denken kann...

Burglinster schrieb am 18.04.2024 um 20:28 Uhr

Danke Georg4. Das weiss ich, aber mir geht es darum, ob es hier einen Bug gibt. Wenn der Filmclip doch in anderen Programmen bis zum Ende läuft.....

 

Marc-Goder schrieb am 18.04.2024 um 20:47 Uhr

@Burglinster

kannst du so einen betroffenen Video File zum testen hochladen ? Zum Beispiel auf Google Drive oder ähnlichen Anbietern.

Dann könnte man diesen Clip herunterladen und mehrere User könnten es testen.

Magix Video Deluxe 2022 Premium (2.138)

Rechner: MSI Leopard GP76 , Intel I7-10870H,

NVidia RTX 3060 Mobile (TDP=130 Watt) (6GB),
Treiber-Version 31.0.15.5222

Arbeitsspeicher RAM 16GB,

Intel HD 630 On-Board I-GPU= deaktiviert.

Windows 10 (Auto-Update + Manuell) Ver.19045.4355

Weitere Video Software: CAPCUT
Konverter: Handbrake

Since 03.02.2024 experementil successfull with K-Lite-Codec Pack.

( Windows 11 kann ich nicht. Krieg ich Blähungen und Bluthochdruck von )

 

vdl-user-v19 schrieb am 18.04.2024 um 20:50 Uhr

Hallo,

mir würde dazu einfallen, dass der Vergleich mit bzw. im VLC-Player schwierig ist, weil es ja nur ein Player ist, der solche Frames auch mal verwirft und gar nicht erst anzeigt.

Aussagekräftiger wäre da vielleicht so einen Clip mal in einem anderen Videoschnittprogramm anzusehen, um herauszufinden, ob da auch ein Frame schwarz ist bzw. so angezeigt wird.

Wenn Du willst @Burglinster, kannst Du ja einen solchen kurzen Clip über einen Cloudspeicher zum Download einstellen (oder per PN einen Download-Link dafür schicken) Ich könnte jedenfalls anbieten in Vegas und noch einem Programm zu schauen, wie es dort interpretiert wird, falls das ein wenig weiterhelfen sollte.

Ach, @Marc-Goder, Du hattest die Idee früher als ich. :-)

georg4 schrieb am 18.04.2024 um 21:04 Uhr

Habe es in 3 anderen Programmen getestet (wegen Werbung kein Namen, aber sind schon sehr bekannte Programme) und da gibt es keinen schwarzen Frame. Bei mir laufen auch ältere Magix Versionen die 2016 und 2021 beide VDL-P und da gibt es in der Version 2016 auch am ende ein schwarzes Bild aber in der Version 2021 ist es in Ordnung, kein schwarzes Bild. Interessant.

Win 10 Pro 64 bit / 22H2
Mainboard ASUS PRIME Z690M-P
CPU - Intel(R) i7-12700K / RAM - 32,0 GB
iGPU UHD Graphics 770 / GPU - AMD Radeon Pro W5550 8GB GDDR6
2x Samsung 980 PRO M.2 NVMe 1 TB / Samsung 870 EVO SSD (2x1TB)
Pro X 14 (20.0.3.181) + VDL-Premium 2013/2016/2019/2020/2021/2022/2024
DaVinci Resolve 19, Gott sei Dank nach 20 Jahren auch in deutsch
DJI Mavic 2 Pro, Olympus OM-5, DJI Action 4, Huawei P30 Pro + Huawei P20


Manchmal braucht man eine ganze Tankfüllung Sprit, oder muss einen vollen Akku leerfahren, bevor man wieder klar denken kann...

georg4 schrieb am 18.04.2024 um 21:34 Uhr

habe mal ein kurzes Video hochgeladen https://drive.google.com/file/d/1y0AZgj3dAbdZh0c4TPGXCSiyVTWpOKK-/view?usp=sharing

Win 10 Pro 64 bit / 22H2
Mainboard ASUS PRIME Z690M-P
CPU - Intel(R) i7-12700K / RAM - 32,0 GB
iGPU UHD Graphics 770 / GPU - AMD Radeon Pro W5550 8GB GDDR6
2x Samsung 980 PRO M.2 NVMe 1 TB / Samsung 870 EVO SSD (2x1TB)
Pro X 14 (20.0.3.181) + VDL-Premium 2013/2016/2019/2020/2021/2022/2024
DaVinci Resolve 19, Gott sei Dank nach 20 Jahren auch in deutsch
DJI Mavic 2 Pro, Olympus OM-5, DJI Action 4, Huawei P30 Pro + Huawei P20


Manchmal braucht man eine ganze Tankfüllung Sprit, oder muss einen vollen Akku leerfahren, bevor man wieder klar denken kann...

Marc-Goder schrieb am 18.04.2024 um 22:14 Uhr

@Burglinster @georg4

Ich habe bei @georg4 seinen Clip auch dieses Phänomen.

Ich muss bei diesem Clip 2 Frames am Ende beschneiden.

Ich kann dies jetzt nicht als BUG benennen, da Magix ja diese Funktion anbietet, mit dem Beschneiden.

Magix Video Deluxe 2022 Premium (2.138)

Rechner: MSI Leopard GP76 , Intel I7-10870H,

NVidia RTX 3060 Mobile (TDP=130 Watt) (6GB),
Treiber-Version 31.0.15.5222

Arbeitsspeicher RAM 16GB,

Intel HD 630 On-Board I-GPU= deaktiviert.

Windows 10 (Auto-Update + Manuell) Ver.19045.4355

Weitere Video Software: CAPCUT
Konverter: Handbrake

Since 03.02.2024 experementil successfull with K-Lite-Codec Pack.

( Windows 11 kann ich nicht. Krieg ich Blähungen und Bluthochdruck von )

 

vdl-user-v19 schrieb am 18.04.2024 um 22:26 Uhr

Ok, vermutlich sind wir da (zumindest bei diesem hochgeladenen Video) u.a. auch wieder bei dem Thema variable Framerate.

Frame rate mode                : Variable
Frame rate                     : 28.003 FPS
Minimum frame rate             : 5.106 FPS
Maximum frame rate             : 30.100 FPS

Da weiß ich leider im Moment interpretationsmäßig auch nicht recht weiter, was da nun richtig oder falsch oder noch anders ist. ;-)

Burglinster schrieb am 19.04.2024 um 07:42 Uhr

Wie man oben sieht ist bei mir die framerate constant. Da achte ich beim filmen sehr drauf.
es kann doch nicht sein dass bei anderen Programmen der Clip bis zum Ende zu sehen ist, bei magix nicht.
Lade später einen Clip hoch.
 

BilderMacher schrieb am 19.04.2024 um 07:59 Uhr

Der Clip von @georg4 wird bei mir unterschiedlich angezeigt. Blackframe oder kein Blackframe, je nach Timelinedarstellung und Fenstergröße.

Der Clip ist aber vollständig, wenn ich ihn abspiele. Nur das zählt für mich.

Zuletzt geändert von BilderMacher am 19.04.2024, 08:00, insgesamt 1-mal geändert.

"Je mehr die Menschen wissen, desto weniger müssen sie glauben!"

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
Ich kann vieles, darf aber nicht alles.
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

-------------

Hardware / Software:
::::::::::::::::::::::::::::::::::::++++:::::::::::::::::::::::::::::::::::::::::::::::::

Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz (8 CPUs), ~2.3GHz
12288 MB RAM
DirectX 12
 

Intel(R) UHD Graphics (für Import, Verarbeitung, Export)

NVIDIA GeForce MX250 (wird nicht in Schnitt-SW verwendet)

  • Video deluxe 2016 Premium
  • Video deluxe 2024 Premium
  • Video Pro X 15
  • Photostory Deluxe 2024
  • Samplitude X7 Suite
  • ACID Pro 11
  • Music Maker 2024
  • MAGIX/XARA Graphic-/Web-Designer

-----------------------------------------------------------------------------------

Edition    Windows 10 Home
Version    22H2
Installiert am    ‎15.‎10.‎2020
Betriebssystembuild    19045.4291
Windows Feature Experience Pack 1000.19056.1000.0

------------------------------------------------------------------------------------

Browser: Mozilla Firefox 124.0.2 (64-Bit)

wabu schrieb am 19.04.2024 um 08:01 Uhr

Ich kenne die black frames auch immer wieder - auch in der 1 frame Darstellung. Und wenn ich das mal übersehe, habe ich die nach dem Export auch im Film

wabu ...............der nie auslernt

Der Rechner  Installierter physischer Speicher (RAM) 32,0 GB / Prozessor Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz, 3600 MHz, 8 Kern(e), 8 logische(r) Prozessor(en),

Intel® UHD Graphics 630 aktiviert

NVIDIA Geforce GTX 1650 HDMI ; 2x DVI ; VGA, PCIe

Samsung (SSD) HD103SJ F3 1 TB Sata 7200 / 2x LG GH22NS SATA schwarz

Betriebsystem Microsoft Windows 10 Home Version 10.0.18362 Build 22H2

geschnitten wird seit 2007 mit Magix immer aktuell VdL und ProX

gefilmt mit Panasonic SDT 750 und FZ 1000 sowie Pentax K30 (Mist) und einer Q500k und SJ 1000 und Hero7

fotografiert mit Pentax K10 und K30 (Super)/Sigma 10-20 und 18-200; Fisheye und 500mm Spiegeltele

Mein Kanal: youtube

georg4 schrieb am 19.04.2024 um 09:48 Uhr

@vdl-user-v19
Ok, vermutlich sind wir da (zumindest bei diesem hochgeladenen Video) u.a. auch wieder bei dem Thema variable Framerate.

Kann ich nicht zustimmen. Auch bei einen Drohnenvideo wo eine Bildwiederholungsrate Konstant ist komme ich zu den schwarzen Ende/Frame.
Habe das Video in die Timeline geladen, gekürzt/geschnitten und als HEWC gespeichert. Dann den gespeicherten Film neu geladen und oala der schwarze Frame ist wieder da. Und ganz egal wo ich schneide.
Das ganze komplette original Drohnenvideo so wie ich es von der SD-Karte runterkopiert habe habe ich zum Download freigestellt unter https://drive.google.com/file/d/1ZKy_g6wfBiCYfapVRygZcZ7h5zIpG7w-/view?usp=sharing
Das heißt das damit eher die Software ein Problem hat.



 

Win 10 Pro 64 bit / 22H2
Mainboard ASUS PRIME Z690M-P
CPU - Intel(R) i7-12700K / RAM - 32,0 GB
iGPU UHD Graphics 770 / GPU - AMD Radeon Pro W5550 8GB GDDR6
2x Samsung 980 PRO M.2 NVMe 1 TB / Samsung 870 EVO SSD (2x1TB)
Pro X 14 (20.0.3.181) + VDL-Premium 2013/2016/2019/2020/2021/2022/2024
DaVinci Resolve 19, Gott sei Dank nach 20 Jahren auch in deutsch
DJI Mavic 2 Pro, Olympus OM-5, DJI Action 4, Huawei P30 Pro + Huawei P20


Manchmal braucht man eine ganze Tankfüllung Sprit, oder muss einen vollen Akku leerfahren, bevor man wieder klar denken kann...

newpapa schrieb am 19.04.2024 um 09:50 Uhr

Hallo,

schwarze Thumbnails in der Timeline lassen für sich allein keine Aussage für einen Frame zu. Im Fall vom hier hochgeladenen Video zeigt sich, dass der Frame nicht leer ist. Man hat ein Vorschaubild, obwohl das Thumbnail schwarz ist. Zoomt man stark auf, gibt es ein kurzes Schwarzbild im Vorschaumonitor (wesentlich kürzer als als eine Framelänge), wenn man den Abspielmarker durch den Frame bewegt. Im Screenshot ist auch zu sehen, dass der letzte Frame etwas zu kurz ist. Das hängt auch davon ab, wie die Framerate im Projekt eingestellt ist. Bei einer Einstellung nach dem Wert lt. Mediainfo ist die Framelänge korrekt. Das kurze Schwarzbild bleibt.

Ein schwarzes Thumbnail ist zunächst mal ein Indiz dafür, dass es Probleme gibt. Zuerst für die Echtzeitberechnung für den Vorschaumonitor und dann natürlich auch für das Ausgabeergebnis.
Schwarzbilder am Anfang oder Ende kommen immer wieder mal vor. Bei mir liefert die in einem Sonderfall die Kamera.

Matthes2 schrieb am 19.04.2024 um 10:22 Uhr

@newpapa weist auf einen ganz wichtigen Punkt hin: korrelieren Framezahl des Projekts und die des eingefügten Materials?
Wenn bei Handyaufnahmen z.B. mit variabler Framezahl gefilmt wurde, so kann es bei der fixen fps-Zahl des Projekts sehr gut vorkommen, dass ein Bruchteil eines Frames hinten stehen bleibt. Das kann dazu führen, dass im Projekt schwarze Frames vorhanden sind, obwohl der letzte Frame der Aufnahme völlig OK ist.

Von vorne herein zu sagen "geht nicht" gibt´s nicht, man hat es halt noch nicht (richtig) versucht!
VDL seit 2003/2004, derzeit VDL und Pro X in den jeweils aktuellen Patchleveln
PC: AMD Ryzen 7 5800X mit 32GB RAM, GeForce RTX3060 und genügend HDD-Kapazität; BS: Win 11 64 Bit Professional; Camera: Sony NEX VG 900 mit SELP 18200, SEL2870 und Leica R-Objektiven (21, 35, 50, 60, 80 - 200, 100 mit Balg und 350 mm); DJI Mini 4 Pro, DJI Pocket 2

georg4 schrieb am 19.04.2024 um 10:23 Uhr

Habe jetzt das gleiche wie oben schon beschrieben mit VDL-P 2024 gemacht (geschnitten und gespeichert). Das Ergebnis ist jetzt in VDL OK. Einstellungen waren die gleichen wie in Pro X14


aber wen ich jetzt die Filme in Pro X14 öffne sind die schwarzen Frames wieder da.


Bei speichern mit AV1 in VDL 2024 gibt es auch keine schwarzen Frame.

Win 10 Pro 64 bit / 22H2
Mainboard ASUS PRIME Z690M-P
CPU - Intel(R) i7-12700K / RAM - 32,0 GB
iGPU UHD Graphics 770 / GPU - AMD Radeon Pro W5550 8GB GDDR6
2x Samsung 980 PRO M.2 NVMe 1 TB / Samsung 870 EVO SSD (2x1TB)
Pro X 14 (20.0.3.181) + VDL-Premium 2013/2016/2019/2020/2021/2022/2024
DaVinci Resolve 19, Gott sei Dank nach 20 Jahren auch in deutsch
DJI Mavic 2 Pro, Olympus OM-5, DJI Action 4, Huawei P30 Pro + Huawei P20


Manchmal braucht man eine ganze Tankfüllung Sprit, oder muss einen vollen Akku leerfahren, bevor man wieder klar denken kann...

vdl-user-v19 schrieb am 19.04.2024 um 10:52 Uhr

Bei @Burglinster steht zwar in MediaInfo konstant 25 fps, jedoch fällt bei dem iPhone-Clip, mit der Cam-App Filmic aufgenommen und codiert, auf, dass es hier auch eine Besonderheit gibt:

Dauer: 6s 120ms aber Source Duration: 6s 160ms

Ob (auch mit Filmic und Co.) wirkliche 100%ige konstante fps über eine Smartphone-Kamera zu erreichen sind, darüber liest man im Netz unterschiedliche Meinungen.

newpapa schrieb am 19.04.2024 um 11:28 Uhr

Hallo @georg4,

es gibt beim hochgeladenen Video (bei mir) keinen schwarzen Frame. Der Vorschaumonitor zeigt einen Bildinhalt an. Jedoch ist der letzte Frame etwas zu kurz. Möglicherweise führt das zu einem schwarzen Thumbnail. Allerdings führt der Lückenbereich zu einem Schwarzbild, weil ein Nachfolgeobjekt an der Framegrenze positioniert wird.

Es scheint hier ein Genauigkeitsproblem zu geben. Ändere ich die Framerate von (nach Mediainfo) 29,970 auf 29,971 ist die Lücke weg.

vdl-user-v19 schrieb am 19.04.2024 um 11:32 Uhr

Bei @georg4s Drohenvideo mit lt. MediaInfo konstanter Framerate sehe ich in Vegas z.B. so einen 'unvollständigen' Frame am Ende:

Mutmaßlich verwerfen manche anderen Programme bearbeitungstechnisch da Frames und Magix stellt es vielleicht genau dar, wie das Material ist, könnte man evtl. daraus schließen.

Burglinster schrieb am 19.04.2024 um 16:32 Uhr

Wer will kann sich drei meiner Filmclips runterladen. Viel Spass beim Testen.

https://www.grosfichiers.com/SMsmXZb6B6G

Liebe Grüße

Berthold

 

newpapa schrieb am 19.04.2024 um 17:44 Uhr

Hallo,

mov 16 und 22 sind korrekt. Mov 18 hat nach Mediainfo eine Videolänge von 7 sek und 4 Frames. Die Quelllänge beträgt 7 sek und 5 Frames. Es gibt keinen schwarzen Frame, MAGIX stellt in der Timeline und im Vorschaumonitor 7 sek und 4 Frames korrekt dar. Das Thumbnail für den letzten Frame ist schwarz. Die Vorschau für den letzten (7 sek, 5.) Frame ist korrekt.

Da der letzte Frame lt. Mediainfo im Video fehlt, gehe ich davon aus, dass das Video nicht regulär endet und es deshalb bei der Erzeugung des letzten Thumbnails Probleme gibt. Ob es auch beim Encoding Probleme gibt, habe ich nicht getestet.

Burglinster schrieb am 19.04.2024 um 18:19 Uhr

Danke newpapa

huebi123 schrieb am 19.04.2024 um 19:05 Uhr

@Burglinster Ich habe die drei Clips runtergeladen. Bei mir enthalten die Clips jeweils am Ende 2 oder drei schwarze Frames. Ob diese erst bei Import generiert werden, weil die Tonspur dies erfordert, habe ich nicht geprüft. Aber in den Programmeinstellungen (Y Taste oder Datei/Einstellungen/Programm) im Reiter Video/Audio gibt es die Option, direkt beim Import z.B. die letzten 10 Frames zu beschneiden. Ich nutze das immer für die ersten 25 Frames, wenn ich die Videotaste an der Kamera drücke, damit der Wackler raus ist. Damit dürfte dein Problem gelöst sein. Musst es nur irgendwann in den Programmeinstellungen wieder zurücksetzen.

Thomas

Spezifikationen:

VPX16, Vegas Pro19, Davinci Resolve Studio

Magix Music Maker Deluxe, FL Studio 21

Pimax Crystal

i9-14900K 96 GB RAM, RTX 4090 und RTX 3090 FE oder Intel Arc A770 16GB. Win11pro.

Kamera: Canon R5 mit RF 5.2mm f2.8L Dual Fisheye

Burglinster schrieb am 20.04.2024 um 08:48 Uhr

Vielen Dank für die vielen Tipps und die viele Info. Dies ist doch manchmal ein nützliches Forum.

Fasse mal zusammen: wer mit variabler framerate filmt handelt sich Probleme ein. Das ist zu vermeiden, wenn das Handy es erlaubt. Auch bei konstanter framerate können am clipende schwarze Frames auftauchen. Ob das ein bug ist, ist unklar.

beim Import die letzten Frames abscheiden ist immer eine einfache Option.

danke

grüße

Burglinster