mailto: email Adresse mit Umlauten funktioniert nicht.

ToToTo schrieb am 20.11.2017 um 13:18 Uhr

Programm Version: 12.6.3.50400

Hallo

Wenn ich meine Grafik, die für die Kontaktaufnahme per email erstellt habe, mit einem mailto link versehe, wird im email programm bzw. der email app irgendein kauderwelsch als adresse angezeigt und die mail kann nicht versendet werden.

Habe es schon mit idn kodierter adresse versucht, was aber nicht half.

 

Hat jemand einen Tip, wie man es hinbekommen könnte?

 

Gruß Tom

 

Kommentare

BeRo schrieb am 20.11.2017 um 14:23 Uhr

Umlaute im sogenannten "local part" einer E-Mail Adresse, also vor dem at Zeichen, sind leider immer noch ein echtes Problem. Viele E-Mail Client Programme/Apps kommen damit absolut nicht klar.

Auch Konverter, wie der idn-Konverter bieten nur eine Notlösung, die nicht in allen Fällen wirklich funktioniert...

Die beste Lösung:
Lege Dir eine weitere E-.Mailadresse an, die anstelle der Umlaute die Schreibweise ae statt ä, oe statt ö usw. enthält und leite alle Mails, die dort eingehen, automatisch auf die problematische Adresse weiter...

Et voilà, Problem gelöst. 😌

Viel Erfolg

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

ToToTo schrieb am 20.11.2017 um 17:06 Uhr

Hallo BeRo. Hast mir hier schon oft durch deine vielen Tipps, die du anderen gegeben hast weitergeholfen.

Nur befinden sich in meinem Fall die Umlaute hinter dem at Zeichen, mein alter Web Easy Professional 7 hat das ohne beanstandungen hinbekommen (wie auch das einfügen einer klickbaren Telefonnummer per Platzhalter, aber dafür mache ich wohl noch einen Thread auf), nur ist der leider total veraltet und hat mit responsive design nichts am Hut. :D

Hoffe du hast dafür auch eine Lösung.

 

Mfg Tom

marboe schrieb am 20.11.2017 um 17:18 Uhr

Eine klickbare Telefonnummer kann im webdesigner angelegt werden unter "Link auf Internetadresse" mit

tel:+4912345678

Dabei ist die anführende "0" der Nummer und ggf der Bindestrich zu entfernen.

Gruß marboe

ToToTo schrieb am 20.11.2017 um 18:02 Uhr

Ach guck, Marboe ist auch da ;D.

Danke, ich werd's gleich mal ausprobieren.

BeRo schrieb am 21.11.2017 um 00:09 Uhr

[...] Nur befinden sich in meinem Fall die Umlaute hinter dem at Zeichen [...]

Im ACE Teil einer Mailadresse steht ja i. d. R. der Domainname.
Anstelle kryptischer Adressen, die ein IDN Konverter spendiert, ist eine lesbarer Name vermutlich vorzuziehen. Das erreichst Du, wenn Du eine zusätzliche Domain reservierst, die den bisherigen Domainnamen ohne Umlaute bekommt. Von dieser Domain leitest Du dann per 301 redirect auf Deine Hauptdomain (mit Umlauten) um.

Fertig 😉

Mehr Infos dazu findest Du hier.

Viel Erfolg

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

ToToTo schrieb am 21.11.2017 um 10:20 Uhr

Weil die Software nicht in der lage ist simpelste Dinge hinzubekommen, soll ich jetzt Geld für eine weitere Domain bezahlen und Umleitungen einrichten? 10 Jahre alte Software für 10€ bekommt das hin, aber der MWD nicht?

Sorry Leute, mein Ärger gehört hier glaube ich nicht hin. Ich werd' mal den Support anschreiben.

FredW schrieb am 21.11.2017 um 10:40 Uhr

@ToToTo,

nun mal langsam ...

Wer eine Mailadresse mit deutschen Umlauten im Domainnamen verwendet, sperrt alle Anwender aus, die keine deutsche Tastatur besitzen. So was macht man einfach nicht. Punkt ! Da schüttelt man man sehr vielen Berufs-Jahren einfach nur den Kopf. Deine Probleme sind hausgemacht und keinesfalls einer Software anzulasten.

ToToTo schrieb am 21.11.2017 um 11:01 Uhr

Moin FredW

Ich habe auch viele Jahre Berufserfahrung, aber halt nicht was Webseitenerstellung und mailto Links angeht.Wenn du mir in der Backstube aushelfen würdest, würde ich auch nicht mit dem Kopf schütteln, wenn du nichts gebacken bekommst.

Das mit der neuen Domain und den Umleitungen erscheint mir einfach zu Umständlich, und ist auch mit mehr Kosten verbunden. Dazu kommt, dass wir ein lokales Kleinunternehmen sind, und ich mir deshalb überhaupt keine Sorgen mache Irgendjemanden durch den Einsatz von Umlauten auzusperren.Wir haben auch keinerlei Ambitionen unser Geschäft international auzubauen. Alles was ich ich möchte, ist unseren Kunden eine einfache Kontaktaufnahme zu ermöglichen. Es ist doch technisch möglich, also warum wird einem im MWD diese möglichkeit nicht geboten?

FredW schrieb am 21.11.2017 um 12:48 Uhr

@ToToTo,

du hast doch eine Antwort von BeRo erhalten. Durchforste das Forum und suche, wieviele ähnliche Anfragen es beim WebDesigner gibt ... ich denke, du wirst kaum etwas finden.

Zu deiner Aussage:

Wir haben auch keinerlei Ambitionen unser Geschäft international auzubauen. 

Nö, darum geht es nicht, aber alleine in meiner Umgebung, Freunden, Arbeitskollegen, ... gibt es viele, die hier wohnen, aber nicht-deutsche Wurzeln haben. Schaue ich mir ihre Laptops an, haben diese spanische, französische, italienische, ... Tastaturen ...

Alles was ich ich möchte, ist unseren Kunden eine einfache Kontaktaufnahme zu ermöglichen.

Genau, dann überlege dir, warum du auf Umlaute beharrst ...

 

 

BilderMacher schrieb am 21.11.2017 um 13:24 Uhr

Du kannst doch eine E-Mail für den schnellen und einfachen Kontakt bei einem freien Dienst registrieren. Geht sogar kostenlos.

Web Easy Professional 7 hat das ohne beanstandungen hinbekommen

Was trägst du in dem Programm als mailto: ein und worin unterscheiden sich der Web Designer und Web Easy? Im Mailprogramm/APP kommt dann was raus?

Gruß, B a lderm I cher

(Ich bin KEIN MAGIX Mitarbeiter, ich bin NICHT beim MAGIX-Support!)

-----------------------------------------------------------------------------------------

Meine Systeme: Windows 10 Home 64Bit | Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz | NVIDIA GeForce 840M, 4GB RAM | Vdl 2013/2014/2015/16 Premium (2017); Video Pro X 5 / 6 / 7 (8); Fotostory 2015/16 Deluxe | MAGIX Foto&Grafik Designer 10/11; XARA Designer Pro X 12, Web Designer 10/11 | MAGIX Video Sound Cleaning Lab 2014 | MAGIX Music Maker MX Premium, MAGIX-Music Maker/Studio 2015; Music Maker 2016 Live; MAGIX Audio & Music Lab 2016 Premium | Panasonic HDC-SD66 | Velbon CX-586 | Delamax Capa Videoschiene 60cm mit Velbon PH-358 Stativkopf | ZOOM H2n | Panasonic Lumix DMC-FZ200

ToToTo schrieb am 21.11.2017 um 13:28 Uhr
Schaue ich mir ihre Laptops an, haben diese spanische, französische, italienische, ... Tastaturen ...

Ja, deshalb will ich ja das der Link funktioniert, damit diese Menschen keine Umlaute irgendwo eintippen müssen.

Außerdem ist diese Diskussion totaler nonsense.

Die einzige Frage die sich stellt ist: Wenn es technisch möglich ist, warum wird einem diese Möglichkeit nicht zur Verfügung gestellt?

 

ToToTo schrieb am 21.11.2017 um 13:40 Uhr

Du kannst doch eine E-Mail für den schnellen und einfachen Kontakt bei einem freien Dienst registrieren. Geht sogar kostenlos.

Du meinst z.B.: bäckerei-soundso@yahoo.de, ich hätte schon lieber eine wie: kontakt@bäckerei-soundso.de. Wäre evtl. eine Notlösung.

Was trägst du in dem Programm als mailto: ein und worin unterscheiden sich der Web Designer und Web Easy? Im Mailprogramm/APP kommt dann was raus?

Was ich eintrage:

Beim MWD kommt raus:

<a href="&#109;&#97;&#105;&#108;&#116;&#111;&#58;&#107;&#111;&#110;&#116;&#97;&#107;&#116;&#64;&#119;&#119;&#119;&#46;&#98;&#97;&#101;&#99;&#107;&#101;&#114;&#101;&#105;&#45;&#114;&#111;&#101;&#98;&#101;&#108;&#116;&#46;&#100;&#101;" target="_top" onclick="return(xr_nn());">

  <img class="xr_ap" src="index_htm_files/47.jpg" alt="" title="" onmousemove="xr_mo(this,0,event)" style="left:125px;top:1452px;width:750px;height:750px;"/>

</a>

 

Und beim Web Easy:

<a href="mailto:kontakt@bäckerei-soundso.de">

                               <img id="e7" name="e7" src="mobilklein001004.jpg" title="" alt="mobilklein001004.jpg" align="right" border="0"></a>

                          

 

BilderMacher schrieb am 21.11.2017 um 14:55 Uhr

Ich habe wohl was falsch gemacht?

Die Adresse im WD eingetragen und veröffentlicht. Outlook öffnet das Formular und die Mail-Adresse ist lesbar ...

Quelltext: Einschränkung für if IE9 beachten!

Zuletzt geändert von BilderMacher am 21.11.2017, 14:59, insgesamt 1-mal geändert.

Gruß, B a lderm I cher

(Ich bin KEIN MAGIX Mitarbeiter, ich bin NICHT beim MAGIX-Support!)

-----------------------------------------------------------------------------------------

Meine Systeme: Windows 10 Home 64Bit | Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz | NVIDIA GeForce 840M, 4GB RAM | Vdl 2013/2014/2015/16 Premium (2017); Video Pro X 5 / 6 / 7 (8); Fotostory 2015/16 Deluxe | MAGIX Foto&Grafik Designer 10/11; XARA Designer Pro X 12, Web Designer 10/11 | MAGIX Video Sound Cleaning Lab 2014 | MAGIX Music Maker MX Premium, MAGIX-Music Maker/Studio 2015; Music Maker 2016 Live; MAGIX Audio & Music Lab 2016 Premium | Panasonic HDC-SD66 | Velbon CX-586 | Delamax Capa Videoschiene 60cm mit Velbon PH-358 Stativkopf | ZOOM H2n | Panasonic Lumix DMC-FZ200

BeRo schrieb am 21.11.2017 um 14:56 Uhr

Nachdem Du uns freundlicherweise die URL zu Deiner Site "www.bäckerei-röbelt.de" genannt hast und auch die gewünschte E-Mail Adresse "kontakt@bäckerei-röbelt.de" sichtbar ist, sehen wir klarer. 😇

Um allen Komplikationen und/oder kostentreibenden Lösungsvorschlägen aus dem Weg zu gehen, kannst Du einfach die fertige Kontakt Seite auf dem Webserver ändern.
Ersetz einfach den von Dir gezeigten Eintrag:

<a href="&#109;&#97;&#105;&#108;&#116;&#111;&#58;&#107;&#111;&#110;&#116;&#97;&#107;&#116;&#64;&#119;&#119;&#119;&#46;&#98;&#97;&#101;&#99;&#107;&#101;&#114;&#101;&#105;&#45;&#114;&#111;&#101;&#98;&#101;&#108;&#116;&#46;&#100;&#101;" target="_top" onclick="return(xr_nn());">

  <img class="xr_ap" src="index_htm_files/47.jpg" alt="" title="" onmousemove="xr_mo(this,0,event)" style="left:125px;top:1452px;width:750px;height:750px;"/>

</a>

Durch:

<a href="mailto:kontakt@bäckerei-röbelt.de" target="_top" onclick="return(xr_nn());">

  <img class="xr_ap" src="index_htm_files/47.jpg" alt="" title="" onmousemove="xr_mo(this,0,event)" style="left:125px;top:1452px;width:750px;height:750px;"/>

</a>

und Ruhe ist 😘

Bei dem Lösungsvorschlag bleibt außen vor, dass Magix bei der Auflösung der E-Mail Adresse die internationale Version eingetragen hat.
Die Diskussion, was denn nun besser ist, will ich an der Stelle gar nicht anstoßen... 😉

Kannst Du damit leben?

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

ToToTo schrieb am 21.11.2017 um 15:47 Uhr
Ersetz einfach den von Dir gezeigten Eintrag:

<a href="&#109;&#97;&#105;&#108;&#116;&#111;&#58;&#107;&#111;&#110;&#116;&#97;&#107;&#116;&#64;&#119;&#119;&#119;&#46;&#98;&#97;&#101;&#99;&#107;&#101;&#114;&#101;&#105;&#45;&#114;&#111;&#101;&#98;&#101;&#108;&#116;&#46;&#100;&#101;" target="_top" onclick="return(xr_nn());">

  <img class="xr_ap" src="index_htm_files/47.jpg" alt="" title="" onmousemove="xr_mo(this,0,event)" style="left:125px;top:1452px;width:750px;height:750px;"/>

</a>

Durch:

<a href="mailto:kontakt@bäckerei-röbelt.de" target="_top" onclick="return(xr_nn());">

  <img class="xr_ap" src="index_htm_files/47.jpg" alt="" title="" onmousemove="xr_mo(this,0,event)" style="left:125px;top:1452px;width:750px;height:750px;"/>

</a>

Den Code selbst umschreiben habe ich schon probiert. Zumindest lokal aus dem Ordner heraus hat das nichts gebracht. Hab evtl. auch was falsch gemacht, wie gesagt - Das ist nicht mein täglich Brot. Werde es jedenfalls nochmal mit deinem Code probieren.

 

Die Diskussion, was denn nun besser ist, will ich an der Stelle gar nicht anstoßen... 😉

Besser hin oder her, es geht um die Kohlen, den Aufwand und das es einfach einfacher gewesen wäre.

Ich habe wohl was falsch gemacht?

Die Adresse im WD eingetragen und veröffentlicht. Outlook öffnet das Formular und die Mail-Adresse ist lesbar ...

Quelltext: Einschränkung für if IE9 beachten!


Kp warum es bei jetzt funktioniert, evtl. bekommt outlook das hin? Und der Quelltaxt sagt mir nicht wirklich viel. Vorerst habe ich deinen Vorschlag angenommen, und eine mail Adresse bei 'nem freien Dienst gemacht.

Das mit der Telefonummer läuft auch, danke Marboe.

Danke auch an Bildermacher.

Noch was vergessen...?

Ach ja FredW und BeRo, danke auch an euch. Wofür auch immer... 😊😊😊 Hoffe ich konnte euch den Nachmittag etwas versüßen. Wir werden uns bestimmt öfters schreiben demnächst...wenn ich die mit dem MWD erstellt Seite hochgeladen habe, und weitere Fragen auftauchen.

MfG Tom