Mobile Navigation mit Unterthemen nutzerfreundlich erstellen

Nina-D schrieb am 23.03.2021 um 11:30 Uhr

Hallo liebe Leute,

mein Projekt schreitet immer weiter voran, allerdings hänge ich jetzt seit einem Tag an dieser mobilen Navigationsleiste fest und komme einfach nicht weiter 😕...ich hoffe, dass mir auch in diesem Bereich ein wenig geholfen werden kann.

 

Ich möchte eine Navigation für meine mobile Variante, die etwa so aussieht:

Startseite

Infos

Themen (->Hier möchte ich, dass sich noch ein Untermenü mit 7 Themen öffnet)

Über Mich

Kontakt

 

= Ich möchte unbedingt, dass meine "Burger- Navigation" auf der rechten Seite eingefügt und anklickbar ist.

 

Folgendes habe ich ausprobiert und bin nicht weitergekommen:

 

1. Fertiges Hamburger-Menü aus einer Webdesigner-Vorlage in meine Seite kopiert und angepasst.

Alles prima, jedoch nicht, wenn ich ein Untermenü bei "Themen" haben möchte.
Ich habe die Navigationsleiste bearbeitet, das Untermenü ist vorhanden. In den Pop- Up-Menü-Einstellungen stelle ich auch ein, dass die Navigation links geöffnet werden soll.

Problem: Burger- Menü ist rechts oben. Beim Anklicken öffnet sich die Navigation auch zur linken Seite hin, dass sie auch schön im Display zu sehen ist. Aber sobald ich das Untermenü unter "Themen" öffnen will, öffnet sich das Untermenü zur rechten Seite hin und ist somit kaum auf dem Display sichtbar, geschweige denn anklickbar.


Ich finde einfach keine Lösung, wie ich mit Burger- Menü rechts solch eine sichtbare Navigation erstellen kann?!

 

Soweit so gut,... davon wollte ich mich nicht unterkriegen lassen 😅...und dachte mir : Dann erstelle ich mir meine Navigations-leiste eben selbst. Also kam mein 2ter Versuch:

 

 

2. Eigene Navigationsleiste mit Aufklapp- Menü erstellen anhand von Marboe's Tutorial


Marboe hat hier ja ein schönes Tutorial dafür gemacht und netterweise auch die web-Datei zur Verfügung gestellt:

https://www.magix.info/de/tutorials/erstellen-einer-mobilen-navigation-mit-untermens--1201952

Ich habe mir, bevor ich mich komplett ans Werk mache die Navigation von Marboes-Webdatei probeweise hochgeladen.
Aufklappmenü funktioniert und sieht für mich auch besser aus, als die Standard-Navi aus meinem ersten Versuch (wenn auch irgendwie komplizierter. Das mit den Ankern habe ich nicht so ganz verstanden...)

Aber gut, ich habe ja die fertige Navigation unverändert hochgeladen, um zu schauen, wie das ganze aussieht.

Problem:

Beim Klick auf das Burger-Menü öffnet sich die Navigation immer nur auf der Seite oben. Wenn jemand aber schon weiter runter gescrollt hat und dann die Navigation wählen möchte und wählt: öffnet sie sich auch OBEN auf der Seite, statt an der Stelle, wo derjenige draufklickt. Die Navigation ist dann nicht sichtbar, es sei denn, man scrollt in Weiser Voraussicht nach oben. Aber das ist ja nicht gerade nutzerfreundlich.
Ebenso fände ich es besser, wenn man die Navigation auch wieder schließen könnte, wenn man auf den "Burger" klickt (falls das überhaupt möglich ist mit dem WD möglich ist?!)

 

Hat jemand eine Idee, wie ich eine mobile Navi nutzerfreundlich hinbekomme, bzw. was ich ändern muss, damit meine Versuche irgendwie funktionieren?

Liebe Grüße 🌻

 

Kommentare

BeRo schrieb am 23.03.2021 um 12:36 Uhr

[...] sobald ich das Untermenü unter "Themen" öffnen will, öffnet sich das Untermenü zur rechten Seite hin [...]

Wen ich das Szenario nachstelle, ist alles i. O. 😖

Für den Test habe ich das Template "Superfood Geschäft" benutzt...

...und ohne Änderung an den Standard Einstellungen vorzunehmen, das Untermenü angelegt. Das Hamburger Menü ist also fixiert. So sehen die Einstellungen aus:

Da das bei Deinem Versuch nicht funktioniert hat, musst Du etwas anders gemacht haben... 😉

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

Nina-D schrieb am 23.03.2021 um 14:56 Uhr

Hey BeRo,

danke fürs Testen 😃!

Also ich weiß auch nicht, irgendwie ist das bei mir verhext...:

Nun habe ich das Menü aus der Superfood-Vorlage genommen, genauso wie du, und siehe da:
Das Ding läuft jetzt optisch 🙂- ...zumindest in der Vorschau vom WD.

Wenn ich diese Beispiel-Seite aber zum Test hochlade, kann ich die Kategorien nicht am Smartphone anklicken.

Wenn ich auf Offerings im Menü klicke, wird sofort die Startseite geladen und das Untermenü verschwindet, bevor ich noch etwas auswählen könnte.
Ich habe die Unterkategorien auch auf eine zweite Seite verlinkt, trotzdem bleibt das Untermenü nicht stehen, bis ich was auswählen könnte...?!

 

Ist das jetzt auch nur bei mir so? Was läuft denn da schief?

 

 

BeRo schrieb am 23.03.2021 um 15:30 Uhr

[...] irgendwie ist das bei mir verhext [...]

Auch wenn das so aussieht, die Ursache ist eher ein Flüchtigkeitsfehler, den die Programmierer begangen haben 😒

Was hinter der Anmerkung steckt, dass siehst Du sofort, wenn Du versuchst, in der NavBar der Desktop Variante ein Untermenü anzulegen. Dann macht Dich der WD mit einer Warnmeldung darauf aufmerksam, dass Dein Vorhaben für die Smartphone Variante nicht funktionieren wird!

Dass die Warnmeldung beim bearbeiten des Hamburger Menüs unterbleibt, das ist der o. a. Flüchtigkeitsfehler. 😝

Die Lösung:
Baue das Menü so um, dass der Link, der aktuell noch dem Button "offerings" zugewiesen ist entfallen kann.

Dann klappt's auch mit dem Untermenü 😉

Zuletzt geändert von BeRo am 23.03.2021, 15:36, insgesamt 2-mal geändert.

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

Nina-D schrieb am 23.03.2021 um 16:03 Uhr

Hi BeRo,

interessant....ja, diese seltsame Fehlermeldung ist mir bei meinen 1000 Versuchen eine mobile Navi zu erstellen, schon untergekommen 😅

Leider scheint es immer noch verhext zu sein:

Ich hatte den Button "offerings" schon zuvor ohne einen Link und trotzdem geht es nicht.
Trotzdem habe ich es nochmal geprüft, aber ohne Erfolg, das Untermenü verschwindet immer noch bevor man es klicken kann😳

 

 

Nina-D schrieb am 23.03.2021 um 16:11 Uhr

Wenn ich mir das genauer anschaue, fällt mir auf, dass wenn ich "Nichts tun" anklicke im Link-Menü, der WD das einfach nicht übernimmt. Anstatt das da steht ("keine Url eingestellt") bleibt das Feld einfach leer.
Jetzt habe ich spaßeshalber den Button doch mit einem Link versehen und krieg den Link jetzt auch nicht mehr weg?!

Update:
Ich habe den Menübutton "Offerings" mit dem Untermenü nochmal neu erstellt. Dann erscheint bei mir die Meldung, dass ("keine Url eingestellt").

Und dann wird es doch wieder einwenig verhext 😅:

Jetzt lassen sich die Unterpunkte annavigieren, juhu.

ABER: Jetzt ragt meine Navigation rechts aus dem Smartphone-Bild raus und ist nur noch zur Hälfte sichtbar
(alle anderen Einstellungen sind gleich geblieben!):

 

 

BeRo schrieb am 23.03.2021 um 16:22 Uhr

[...] Anstatt das da steht ("keine Url eingestellt") bleibt das Feld einfach leer. [...]

Offenbar haben die Programmierer bei der Endabnahme des WD, das Hamburger Menü "vergessen". Die NavBar in der Desktop Version kann selbstverständlich auch Buttons ohne Link verarbeiten und richtig anzeigen.
Aber noch ist nicht alles verloren, probier's mal mit einem "blinden" Link... 😉

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

Nina-D schrieb am 23.03.2021 um 16:37 Uhr

Ich hab es mit dem blinden Link versucht, leider ohne Ergebnis.

Jetzt sind nach dem Upload die Untermenüpunkte endlich da, aber das ganze Menü ist nur noch halb im Bild, nach rechts verschoben, wie zuvor auch nach dem Upload auf den Server.

Wie machen denn alle anderen das mit dieser mobilen Navigation, wenn es so kompliziert ist?
Ich denke so Untermenü-Punkte sind ja eigentlich nichts außergewöhnliches.😟

Es muss doch irgendeinen Weg zu einer soliden Navi geben???

BeRo schrieb am 23.03.2021 um 16:57 Uhr

[...] aber das ganze Menü ist nur noch halb im Bild, [...]

Du machst aber auch Sachen... 😁

Schau Dir mal die Einstellungen für das popup Menü an, vielleicht hast Du da versehentlich falsche Werte eingestellt...

[...] Wie machen denn alle anderen das mit dieser mobilen Navigation, wenn es so kompliziert ist? [...]

Von dem kleinen Bug abgesehen, der verhindert, dass "kein Link" eingestellt werden kann, funktioniert das Hamburger Menü fehlerfrei (s. meinen ersten Kommentar).
Warum das in Deinem Fall anders ist, das versuchen wir gerade heraus zu bekommen 😉.

Zuletzt geändert von BeRo am 23.03.2021, 17:25, insgesamt 2-mal geändert.

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

Nina-D schrieb am 23.03.2021 um 17:25 Uhr

Ja, das ist wohl eine ganz exklusive Sache mit meiner Navi-Bar😂

An den Werten im Pop-Up-Menü habe ich wirklich nichts verstellt, die Navi meint es einfach nicht gut mit mir😄

Aber dein Tipp mit dem waagerechten Versatz ist wahrscheinlich des Rätsels Lösung!
Diese Funktion habe ich gestern schon entdeckt, aber wusste nicht, dass Negativwerte möglich sind!!!

Mit einem Wert von Minus 80 ist das Ding nun endlich bündig mit dem Hamburger 👍💪🙏🙋!

 

Dann werde ich meine Erkenntnisse mal auf mein echtes Projekt übertragen und hoffe, dass es funktioniert.

Vielen lieben Dank mal wieder 👍💐

BeRo schrieb am 23.03.2021 um 18:46 Uhr

[...] Mit einem Wert von Minus 80 ist das Ding nun endlich bündig mit dem Hamburger [...]

Sehr merkwürdig.
Negative Werte sorgen normalerweise dafür, dass das Menü nach rechts verschoben wird.

Dass das in Deinem Fall genau umgekehrt funktioniert, das ist vermutlich auch die Ursache für die falsch positionierte Anzeige im Normalzustand, also ohne Korrekturwerte.
Dein WD hat offenbar eine "Macke" 😕

Welche Version (Releasestand) des WD benutzt Du?

Zuletzt geändert von BeRo am 23.03.2021, 18:50, insgesamt 1-mal geändert.

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

Nina-D schrieb am 23.03.2021 um 21:36 Uhr

Achso...ist ja seltsam! Ich sag ja, es geht nicht mit rechten Dingen zu 😅

In der Info vom WD finde ich das hier:
MAGIX Web Designer Premium 17.1.0.60415  DL x64 Oct 21 2020 (im Oktober habe ich ein Update gemacht)
Das Programm habe ich am 12.11.2019 gekauft...

 

Ich tüfftel ja immer noch an der Navigation und versuche die Nerven zu behalten 😵...

Dabei habe ich Neues feststellen können:

1.) Je länger der Button-Text ist, desto größer muss sogar der (negative) waagerechte Versatz sein. Bei meinem richtigen Button-Text bin ich jetzt schon bei Minus 130 angelangt, damit das Menü rechtsbündig zum Burger angezeigt wird.

2.) Die Textllänge der Schaltflächen im UNTERMENÜ ist begrenzt! Wenn dieser Text zu lang oder zu groß ist (!) ist, wie z.B ein Text entsteht genau der Fehler, den ich im Eingangs-Post beschrieben habe.
Bei einem zu langen Text wie z.B: "Mehr Informationen zum Thema" wird das Untermenü nicht links eingeblendet, sonder RECHTS. Das führt dann dazu, dass das Untermenü aus der Seite rausragt und dann nicht mehr sichtbar wird. Die einzige Lösung ist gerade: Kurzer Text und nicht zu große Schrift...

So viel konnte ich jetzt an Erkenntnis gewinnen.

 

Die feine Lösung ist das irgendwie nicht, weder optisch, noch jetzt auch inhaltlich (müsste dann kürzere Worte für mein Angebot erfinden, damit ich ein sichtbares Untermenü habe.)

Also ich habe mich nun dazu entschieden, auf ein Untermenü in der Navigation zu verzichten und meine Unterpunkte einfach unter die Hauptkategorien zu packen.
In meinem Fall, gefällt mir das optisch auch besser und ich kann die Textlänge und Textgröße variabler machen.

 

Aber eine Sache bleibt dann noch als Frage:

Ebenso kann man die Navigation nicht durch einen erneuten Klick auf den Burger wieder schließen. Wenn man die Navigation lieber schließen möchte, anstatt was auszuwählen, kann man dies nur tun, wenn man auf einen freien Bereich klickt. Schön wäre es mit einem erneuten Klick auf den Burger.

Geht sowas mit dem WD nicht???
 

BeRo schrieb am 24.03.2021 um 00:02 Uhr

[...] Ich spekuliere noch darüber, ob ich das Untermenü nicht einfach sein lasse, damit ich meine Ruhe habe. [...]

Deine NavBar hat nicht viele Buttons, Du könntest also auch darüber nachdenken, auf der Seite für die mobilen Geräte eine normale NavBar anzulegen. Dann bekommst Du die Untermenüs leichter in den Griff...

[...] kann man die Navigation nicht durch einen erneuten Klick auf den Burger wieder schließen [...]

Machbar ist das, aber dazu wäre ein bisschen Programmierarbeit nötig...
Das Problem zeigt sich auf den Mobilgeräten, weil die keine MouseOver/MouseOff Funktionen kennen. Hier kann der Browser also nicht feststellen, wann der nicht vorhandene Mauszeiger das Menü verlässt 😝

Zuletzt geändert von BeRo am 24.03.2021, 00:07, insgesamt 2-mal geändert.

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

marboe schrieb am 24.03.2021 um 07:34 Uhr

Die einzige Lösung ist gerade: Kurzer Text und nicht zu große Schrift...

So viel konnte ich jetzt an Erkenntnis gewinnen.

@Nina-D

Da möchte ich dir gern widersprechen. Probiere deine Navi definitiv mit allen dir zur Verfügung stehenden Smartphones, denen du habhaft werden kannst.
Du wirst feststellen, dass die Schriftgröße bzw natürlich Buttongröße ganz erheblich zur Usererfahrung gehört. Die Schrift sollte also keinesfalls klein sein.
Abgesehen davon meckert auch Google darüber. Da bekommt man in den Webmastertools dann den Hinweis, dass Klickelemente zu nah beeinander sind. Das gibt Rankingabzüge.
Es verbietet ja niemand für Smartphones eine andere Navi aufzubauen als für Desktopversionen. Dass schliesst den Inhalt der Aufbaulogik ein.
Bei einem größeren Projekt habe ich mir mit einer zusätzlichen zweiten Navi geholfen, weil es sonst einfach zu unpraktikabel geworden wäre. Gruß marboe

Nina-D schrieb am 24.03.2021 um 10:33 Uhr

Hallo BeRo und Marboe,

Deine NavBar hat nicht viele Buttons, Du könntest also auch darüber nachdenken, auf der Seite für die mobilen Geräte eine normale NavBar anzulegen. Dann bekommst Du die Untermenüs leichter in den Griff...

Es verbietet ja niemand für Smartphones eine andere Navi aufzubauen als für Desktopversionen. Dass schliesst den Inhalt der Aufbaulogik ein.

Ja, stimmt. Ich wünschte ich wäre früher drauf gekommen. Ich habe das jetzt so umgesetzt und es ist zufrieden stellend. Es gibt ja auch in dem Pop-Up-Menü die Möglichkeit Trennlinien einzubauen, um optisch voneinander abzugrenzen 😃

 

Ok, dann weiß ich ja, dass es mit dem Schließen des Burger-Menüs halt so ist und ich es einfach mal so lassen werde.😉

 

Da möchte ich dir gern widersprechen. Probiere deine Navi definitiv mit allen dir zur Verfügung stehenden Smartphones, denen du habhaft werden kannst.
Du wirst feststellen, dass die Schriftgröße bzw natürlich Buttongröße ganz erheblich zur Usererfahrung gehört. Die Schrift sollte also keinesfalls klein sein.

Ich habe meine Navigation auf einem Samsung Note 10 getestet und auf einem alten Samsung S4. Wenn das Untermenü zu lang/zu groß ist, öffnet es sich nach rechts statt nach links!
Ab einer gewissen Textlänge im Untermenü gibt es diese Verschiebung bereits ebenso in der Vorschau vom WD.
Vielleicht ist das aber auch nur bei mir so...keine Ahnung, was da schief läuft. Diese Experimente haben mich mehrere Stunden Zeit gekostet 😫

Stimmt, der Text sollte nicht zu klein sein. In meinem Fall hätte ich Kompromisse finden müssen, indem ich den Text dann kürzer halte, sodass die Schrift weiterhin groß bleibt.


Aber wie gesagt, ich wähle jetzt den einfacheren Weg ohne das Untermenü, dann kann ich auch mehr reinschreiben und das Problem ist vom Tisch😅

Ps:
@marboe: Was mich noch interessieren würde ist, ob es wie im Eingangspost beschrieben möglich ist, dass sich deine selbsterstellte Navigation mit Aufklappmenü auch mitten in der Seite öffnen kann (wenn bereits nach unten gescrollt wurde). - Oder ist es technisch nur möglich, diese nur oben auf der Seite öffnen zu lassen?

 

Vielen Dank für eure bisherigen Tipps 🌻

marboe schrieb am 25.03.2021 um 06:46 Uhr

@marboe: Was mich noch interessieren würde ist, ob es wie im Eingangspost beschrieben möglich ist, dass sich deine selbsterstellte Navigation mit Aufklappmenü auch mitten in der Seite öffnen kann (wenn bereits nach unten gescrollt wurde). - Oder ist es technisch nur möglich, diese nur oben auf der Seite öffnen zu lassen?

Die oberste Zeile ist fixiert; das Ausklappmenü nicht.
Da die Erstellung schon drei Jahre her ist ... ich weiß es nicht. Probiere es doch einfach aus.
Es würde mich nicht wundern, wenn es nicht ginge. Vielleicht wenn man noch einen Befehl alá scroll to top miteinbauen würde; aber das habe ich nicht getestet. Gruß Marboe

Nina-D schrieb am 08.04.2021 um 09:50 Uhr

Hallo Marboe,

nach einer kleinen Pause habe ich einwenig rumprobiert mit der selbstgemachten Navi, habe es aber wieder verworfen...alle meine Versuche waren vergebens 😞
Ich weiß auch ehrlich nicht genau, wie ich einen "Scroll to top" Befehl einbauen könnte.

Sollte es jemals eine Lösung geben, lasst es mich wissen 😃

Bis dahin begnüge ich mich mit der Standard-Navigation...

 

BeRo schrieb am 08.04.2021 um 12:47 Uhr

[...] Ich weiß auch ehrlich nicht genau, wie ich einen "Scroll to top" Befehl einbauen könnte. [...]

Der WD hilft Dir dabei, weil er die dazu gehörende JScript Funktion anbietet. Wenn Du die Funktion "xr_top()" als Link benutzt, kannst Du damit beliebige Objekte (Grafiken, Text, Bilder, etc.) ausstatten.

So kann das aussehen, wenn Du eine Grafik mit dem Link ausstattest:

Hier der komplette Link, den Du per copy & paste übernehmen kannst.

javascript:xr_top();

Das klappt natürlich auch, wenn Du ein Item einer NavBar damit ausstatten willst... 😉

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

Nina-D schrieb am 08.04.2021 um 14:22 Uhr

Hi BeRo,

oh toll, wieder was gelernt 😃...Diese Funktion kannte ich wirklich noch nicht!

Ich werde es mal interessehalber bald ausprobieren und schauen, ob so etwas mit der nach oben scrollenden Navi dann klappt.

Lieben Dank!🌻