Ränder beim Erstellen von Bitmap-Kopien

christian-juhasz schrieb am 27.03.2018 um 13:05 Uhr

Servus,

um das Laden dr Seite zu beschleunigen, habe ich von Schaltflächen, die eigentlich aus importierten Objektgruppen bestehen, Bitmap-Kopien erstellt. Im WD werden die auch normal angezeigt ...

... in der Vorschau dann allerdings so ...

Das Komische an der Sache ist, dass beide Bitmap-Kopien mit der gleichen Einstellung erstellt wurden und trotzdem unterschiedlich dargestellt werden.

 

Was mache ich falsch?

 

Gruss, Chris

 

EDIT:

Erstellt man eine Kopie der richtig dargestellten Bitmap-Kopie, wird diese auch wieder falsch dargestellt. 😡

Kommentare

BilderMacher schrieb am 27.03.2018 um 13:38 Uhr

Hallo,

bei einer Kopie als PNG sieht das bei mir so aus ...

und in der Vorschau so ...

Wählst du bei "Bitmap-Kopie erstellen" nicht als PNG?

"Je mehr die Menschen wissen, desto weniger müssen sie glauben!"

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
Ich kann vieles, darf aber nicht alles.
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

-------------

Hardware:

:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz (8 CPUs), ~2.3GHz
12288 MB RAM
DirectX 12
Intel(R) UHD Graphics (für Import, Verarbeitung, Export)
NVIDIA GeForce MX250 (wird nicht in Schnitt-SW verwendet)

---------------------------------------------

Edition    Windows 10 Home
Version    21H2
Betriebssystembuild    19044.1949

-----------------------------------------------

marboe schrieb am 27.03.2018 um 13:38 Uhr

Was mache ich falsch?

Das kann ich dir leider nicht beantworten.

Ich bleibe schon an der Frage hängen, was genau dich am Original stört und was an der Bitmapkopie.

zu 1.
Das Original ist 32x32 px mit einer Speichergröße von 1,58 kB.

Wie klein hättest du es denn gern? 😜

 

zu 2.
Ich sehe kaum einen Unterschied bei deinem Bitmap. Meinst du die weißen Ränder? (zumindest rate ich das so; das Bild ist viel zu klein). Oder meinst du den Hintergrund?
Dein Bitmap ist halt kein png.

Gruß Marboe

BeRo schrieb am 27.03.2018 um 13:41 Uhr

[...] Was mache ich falsch? [...]

Du vermutlich nichts... 😉

@marboe und @BilderMacher haben es ja schon richtig gesehen, die Kopie wurde halt nicht im PNG Format erstellt...

Der WD ist der Übeltäter, weil er je nach Einstellung Bitmap Kopien standardmäßig im JPG Format anlegt. Damit geht die Transparenz des Hintergrunds (Rechteck) verloren...

Prüf das mal:

Viel Erfolg

Zuletzt geändert von BeRo am 27.03.2018, 13:42, insgesamt 1-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

christian-juhasz schrieb am 27.03.2018 um 13:52 Uhr

Ich meinte den Hintergrund. Mal ist er transparent, mal nicht.

Laut WD ist es PNG (es gibt ja auch nichts anderes zum auswählen) mit True Color + Alpha.

Mci stört, dass beim laden die Zahlen und die Kreise, aus denen die Gruppe besteht, separat geladen werden, wenn die Internetgeschwindigkeit mal nicht so schnell ist.

 

Gruss, Chris

Zuletzt geändert von christian-juhasz am 27.03.2018, 13:54, insgesamt 1-mal geändert.

Windows 7 Pro 64 bit mit SP 1, AMD FX-8530 4.00 GHz, 16 GB DDR4, GTX 1070 8 GB, 2x Lenovo L24Q-10, MAGIX Web Designer Premium 16.2.1.57326  DL x64 Aug 15 2019, MAGIX Audio & Music Lab Premium, HTML-Level: Depp!

BeRo schrieb am 27.03.2018 um 14:00 Uhr

[...] Laut WD ist es PNG mit True Color + Alpha.[...]

Dann müsstest Du die Transparenz (Farbe) des Hintergrunds nacharbeiten. Klar, dass man auch eine Grafik im PNG Format mit einem nicht transparentenHintergrund kopieren kann... 😊

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

BilderMacher schrieb am 27.03.2018 um 14:05 Uhr

[...]dass beim laden die Zahlen und die Kreise, aus denen die Gruppe besteht, separat geladen werden, [...]

Das beobachtest Du auf deiner Website? Ist eigentlich ausgeschlossen.

Denn Objekt-Gruppen werden zu einer Grafik konvertiert und auf der Homepage gibt es dann auch nur ein Bild.

Also dein Zwischenschritt, eine Bitmap-Kopie zu erstellen, ist überflüssig.

"Je mehr die Menschen wissen, desto weniger müssen sie glauben!"

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
Ich kann vieles, darf aber nicht alles.
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

-------------

Hardware:

:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz (8 CPUs), ~2.3GHz
12288 MB RAM
DirectX 12
Intel(R) UHD Graphics (für Import, Verarbeitung, Export)
NVIDIA GeForce MX250 (wird nicht in Schnitt-SW verwendet)

---------------------------------------------

Edition    Windows 10 Home
Version    21H2
Betriebssystembuild    19044.1949

-----------------------------------------------

christian-juhasz schrieb am 27.03.2018 um 14:07 Uhr

Ja, ich hab gestern bei uns auf Arbeit die Seite mal geöffnet und er hat zuerts die Zahl blau geladen, da da ein Link zu einerm POPUP hinterlegt ist, dann hat der die Kreise geladen, dann die Zahl in weiss mit der richtigen Schriftart.

 

EDIT @BilderMacher: Dieses "normalerweise" in dem Textschnipsel find ich lustig ... 😂 Benutze ich im Verkauf auch immer, wenn ich mir bei einer Sache sicher bin ... abe doch nicht zu 100%. 😆

Zuletzt geändert von christian-juhasz am 27.03.2018, 14:12, insgesamt 1-mal geändert.

Windows 7 Pro 64 bit mit SP 1, AMD FX-8530 4.00 GHz, 16 GB DDR4, GTX 1070 8 GB, 2x Lenovo L24Q-10, MAGIX Web Designer Premium 16.2.1.57326  DL x64 Aug 15 2019, MAGIX Audio & Music Lab Premium, HTML-Level: Depp!

marboe schrieb am 27.03.2018 um 14:13 Uhr

Dann lege den Link doch auf die ganze Gruppe.

Schon ist dein Problem gelöst. Gruß Marboe

christian-juhasz schrieb am 27.03.2018 um 14:15 Uhr

Is er ja ...

... normalerweise.

 

Windows 7 Pro 64 bit mit SP 1, AMD FX-8530 4.00 GHz, 16 GB DDR4, GTX 1070 8 GB, 2x Lenovo L24Q-10, MAGIX Web Designer Premium 16.2.1.57326  DL x64 Aug 15 2019, MAGIX Audio & Music Lab Premium, HTML-Level: Depp!

christian-juhasz schrieb am 27.03.2018 um 14:35 Uhr

Hier mal ein Link zu einem Video. Ich hab mal das Laden in Zeitlupe aufgenommen, da bei mir daheim das Internet schnell genug ist. Selbst da ist der Effekt zu sehen.

Windows 7 Pro 64 bit mit SP 1, AMD FX-8530 4.00 GHz, 16 GB DDR4, GTX 1070 8 GB, 2x Lenovo L24Q-10, MAGIX Web Designer Premium 16.2.1.57326  DL x64 Aug 15 2019, MAGIX Audio & Music Lab Premium, HTML-Level: Depp!

BilderMacher schrieb am 27.03.2018 um 15:16 Uhr

Zu den Speisekarten gab es mal einen Link. Der ist weg. Wo kann man sich nun das Ergebnis (und das Problem) selbst ansehen?

"Je mehr die Menschen wissen, desto weniger müssen sie glauben!"

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
Ich kann vieles, darf aber nicht alles.
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

-------------

Hardware:

:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz (8 CPUs), ~2.3GHz
12288 MB RAM
DirectX 12
Intel(R) UHD Graphics (für Import, Verarbeitung, Export)
NVIDIA GeForce MX250 (wird nicht in Schnitt-SW verwendet)

---------------------------------------------

Edition    Windows 10 Home
Version    21H2
Betriebssystembuild    19044.1949

-----------------------------------------------

BeRo schrieb am 27.03.2018 um 15:24 Uhr

@BilderMacher

[...] Wo kann man sich nun das Ergebnis (und das Problem) selbst ansehen?

hier 😍

Zuletzt geändert von BeRo am 27.03.2018, 15:31, insgesamt 1-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

BilderMacher schrieb am 27.03.2018 um 15:48 Uhr

@BeRo, danke dafür. Ist auf meinem kleinen Bildschirm kaum zu erkennen.

Schön wäre es, wenn man solche Informationen im Profil erhalten würde.

Hier mal meine BA mit Zeitlupe Faktor 0,49 ...

Geht sehr schnell, keine getrennte Darstellung. Und laut Quelltext nur ein PNG für 1 und 2.

Zumindest ist es in meinem Chrome nicht zu erkennen, was du hier als Problem anführst. 😕

Zuletzt geändert von BilderMacher am 27.03.2018, 15:49, insgesamt 1-mal geändert.

"Je mehr die Menschen wissen, desto weniger müssen sie glauben!"

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
Ich kann vieles, darf aber nicht alles.
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

-------------

Hardware:

:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz (8 CPUs), ~2.3GHz
12288 MB RAM
DirectX 12
Intel(R) UHD Graphics (für Import, Verarbeitung, Export)
NVIDIA GeForce MX250 (wird nicht in Schnitt-SW verwendet)

---------------------------------------------

Edition    Windows 10 Home
Version    21H2
Betriebssystembuild    19044.1949

-----------------------------------------------

christian-juhasz schrieb am 27.03.2018 um 16:33 Uhr

Bei mir ist das Ergebnis das selbe, BilderMacher. Auch mein Firefox sagt, dass das ein PNG ist. Aber wie erklärt sich dann mein Video?

Mein Gedanke war: "Dann mach ich das PNG halt selber ...." Das Ergebnis sind die Schatten auf den Hintergründen.

Zuletzt geändert von christian-juhasz am 27.03.2018, 16:40, insgesamt 1-mal geändert.

Windows 7 Pro 64 bit mit SP 1, AMD FX-8530 4.00 GHz, 16 GB DDR4, GTX 1070 8 GB, 2x Lenovo L24Q-10, MAGIX Web Designer Premium 16.2.1.57326  DL x64 Aug 15 2019, MAGIX Audio & Music Lab Premium, HTML-Level: Depp!

BeRo schrieb am 27.03.2018 um 16:47 Uhr

BTW @christian-juhasz

Ich habe gerade mal ein bisschen auf Deiner Site "herumgeklickt". Mir ist dabei aufgefallen, dass Du die Seitengröße für die Vollbilddarstellung auf "Flughafen Monitoren" angelegt hast und schon bei Seitengrößen <1430 Px auf die Mobilversion umgeschaltet wird. Ist das wirklich so gewollt?
Wenn ja, an welches Mobilgerät hast Du dabei gedacht? 😇

Nachteiliger Effekt der "beeindruckenden" Größe ist, dass die Darstellung bei normaler Fenstergröße rechts- und links abgeschnitten wird und dabei auch Seitenobjekte horizontal verschoben werden, z. B. die Kopfzeile der einzelnen Gruppen der Speisekarte (3).

Der rechte Teil des Hintergrunds der Speisekarte wird nach oben gescrollt (1).
Der Text der Speisekarte scrollt unter der Titelzeile durch (2).

Außerdem verschwinden die per popup Ebenen eingeblendeten Inhalte unterschiedlich, z. B. wird je nach Mausaktion die Kopfzeile einer Gruppe der Speiskarte separat ausgeblendet und der Rest der Karte bleibt geöffnet.
Abhängig vom Inhalt (Anzahl Textzeilen) einer angezeigten Karte werden die Zeilen von der Kopfzeile einer Gruppe verdeckt.

usw.

Wenn das nicht alles genauso geplant war, sieht es so aus, als hättest Du noch viel Arbeit vor Dir... 😁

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

christian-juhasz schrieb am 27.03.2018 um 17:13 Uhr

Zur Grösse: Jain, das ist momentan online noch so. Offline gibt es mittlerweile mehrere Grössen. Ich arbeite hier daheim an 2 LENOVO Monitoren mit QHD. Daher die vergrösserte Darstellung. Ich arbeite an einer 1920er, einer 1366er Version. Die mobile Version soll für Tablets sein. Eine 375er für Smartphones kommt noch.

zu den Fehlern: Die Version stammt von vor ein paar Tagen 3:30 ... 😁 Offline sind die meissten schon behoben.

Trotzdem Danke fürs Durchschauen. Wenn Dir noch was auffällt, bitte melden, evtl. hab ichs übersehen.

 

Chris

Windows 7 Pro 64 bit mit SP 1, AMD FX-8530 4.00 GHz, 16 GB DDR4, GTX 1070 8 GB, 2x Lenovo L24Q-10, MAGIX Web Designer Premium 16.2.1.57326  DL x64 Aug 15 2019, MAGIX Audio & Music Lab Premium, HTML-Level: Depp!

BeRo schrieb am 27.03.2018 um 17:36 Uhr

[...] Ich arbeite an einer 1920er, einer 1366er Version [...]

Die Standardgröße von Websites ist aus gutem Grund <1000 Px, der "Rest" wird üblicherweise mit Hintergrundgrafiken/Bildern ausgefüllt, die seitenfüllend (responsive) angelegt werden.
Für den Besucher solcher Seiten sieht es dann so aus, als wäre die komplette Website z. B. für einen QHD Monitor angelegt. Der wichtige Seiteninhalt bleibt in dem Fall auch dann vollständig sichtbar, wenn das Browserfenster "nur" auf 1000Px Breite aufgezogen wird, was der Einstellung entspricht, die am häufigsten benutzt wird.

Vor dem Hintergrund macht es vermutlich Sinn, mal über die Größe (Breite) der Website nachzudenken. 😉

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

christian-juhasz schrieb am 27.03.2018 um 18:10 Uhr

Ja, da hast Du Recht, mit den Grössen. Ich finde nur diese Seiten optisch nicht ansprechend, bei denen in der Mitte ein Streifen Seite steht und links und rechts alles leer ist.

Windows 7 Pro 64 bit mit SP 1, AMD FX-8530 4.00 GHz, 16 GB DDR4, GTX 1070 8 GB, 2x Lenovo L24Q-10, MAGIX Web Designer Premium 16.2.1.57326  DL x64 Aug 15 2019, MAGIX Audio & Music Lab Premium, HTML-Level: Depp!

BeRo schrieb am 27.03.2018 um 19:02 Uhr

[...] Ich finde nur diese Seiten optisch nicht ansprechend, bei denen in der Mitte ein Streifen Seite steht [...]

Dass das so nicht sein muss, zeigen u. a. auch Templates, die der WD als Vorlagen mitliefert.

Eine Seite, die linke, wurde mit einer Breite von 960 Px angelegt, die andere mit 1100 Px

Du siehst, es geht, wenn man das Layout entsprechend plant... 🙂

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

BeRo schrieb am 27.03.2018 um 20:37 Uhr

[...] Das meinte ich ... [...]

Kein Problem, das kannst Du auch, Du musst Deine Site nur mit echtem responsive Design programmieren. 😎

Die Betonung liegt hier auf "programmieren", denn die Funktion gibt's nun mal nicht auf einen Mausklick 😫

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

christian-juhasz schrieb am 27.03.2018 um 21:41 Uhr

Dazu müsste man es aber auch können. Und auf die Schnelle wird man es nicht lernen. Also brauch ich erstmal ein Workaoround.

 

Windows 7 Pro 64 bit mit SP 1, AMD FX-8530 4.00 GHz, 16 GB DDR4, GTX 1070 8 GB, 2x Lenovo L24Q-10, MAGIX Web Designer Premium 16.2.1.57326  DL x64 Aug 15 2019, MAGIX Audio & Music Lab Premium, HTML-Level: Depp!