Scrolling auf einer vorgegebenen Ebene innerhalb der Homepage

fredyzund schrieb am 10.03.2018 um 18:31 Uhr

MAGIX Web Designer Premium 12.0.0.45036  DL x64 May 20 2016

Ich möchte auf einem vorgegebenem Hintergrund meine Bilderdateien präsentieren. Da ich aber nicht genügend Platz auf dem Hintergrundrechteck habe (und nicht das ganze Bildschirmbild scrollen möchte - Kopf und Fuss sollten stabil bleiben) möchte ich die Dateien innerhalb des vorgegebenen Platzes scrollen. Leider habe ich im Handbuch nichts entsprechendes "gefunden".

Kann jemand mir sagen, wie ich dieses Feld mit den Bilderdateien (Link auf Clouddaten) scrollen kann???

Oder kann mir jemand sagen, wo ich die Anweisungen in Handbuch finden kann.

Besten Dank für die Unterstützung

Gruss, Fredy (Neuanwender dieser Software)😟😟

Kommentare

BeRo schrieb am 10.03.2018 um 21:39 Uhr

[...] möchte ich die Dateien innerhalb des vorgegebenen Platzes scrollen [...]

Das Handbuch stellt leider keine Zusammenfassung der Lösung für das Problem zur Verfügung. Im Forum gibt es aber Lösungsvorschläge "en masse", wenn Du die richtigen Suchbegriffe kennst... 😜

Was Du brauchst, ist eine Anleitung zur Nutzung des iframe Codes, den Dir z. B. das Widget "embed a website" zur Verfügung stellt.

In Deinem Fall benutzt Du am besten das vorhandene (oder ein darüber angelegtes) Rechteck als Platzhalter für die Anzeige der Bilderdateien

in diesem Platzhalter speicherst Du im HTML Body den iframe Code, den Du z.B. mit dem o. a. Widget generiert hast. Der kann so aussehen:

<iframe src="./bildergalerie.htm" width="100%" height="100%" frameborder="0" scrolling="auto" name="xara_iframe" ><p>Your browser does not support iframes.</p></iframe>

Im Editor kann das so aussehen:

Jetzt musst Du "nur" noch eine neue-, ansonsten völlig leere Seite anlegen, auf der Du alle Bilder als Galerie ablegst, so, wie sie später im Scrollbereich gezeigt werden sollen.

Der Seite gibst Du den Namen "bildergalerie", damit der o. a. iframe Code funktioniert...

Jetzt kannst Du die Seite lokal exportieren, und testen, indem du die exportierte "index.htm" Datei doppelt klickst. -- Fertig.

Das Ergebnis kann so aussehen:

Viel Erfolg

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

fredyzund schrieb am 14.05.2018 um 22:59 Uhr

Hallo BoRo

Habe meine Seite mit den entsprechenden Inputs bearbeitet und am Anfang ging auch alles wie gewünscht. Leider hat sich dies verändert, ohne mein Wissen etwas angepasst zu haben. Ich habe aber die Befürchtung, dass auf der Googleumgebung die Bedingungen geändert wurden.

1) auf der Testumgebung scheint am Anfang der Überarbeitung alles normal zu funktionieren. Geht man aber auf den Link (Bild oder Text) folgte eine entsprechende Meldung, dass Frames nicht mehr unterstützt werden

2) Auf dem Live-Internet kommt das Bild richtig. Geht man auf einen Link (Bild oder Worte) erscheint überhaupt nichts (nur das schwarze Viereck)

3) scrolled man die Bilderauflistung, geht das Background-bild ebenfalls mit (Beim Testumfeld nicht).

Im Anhang habe ich die entsprechend Sreenprints beigefügt.

 

Fragen: Wie kann ich die Unterdrückung durch Google umgehen. Muss ich da einen anderen Cloudserver zulegen?

Wie kann ich das Backgroundbild fixieren, dass beim Scrolling kein schwarzes Feld erscheint.

Wie aktiviere ich den Link, damit die Daten auch erscheinen - Link zu Google-Datenbank.

 

Besten Dank für die Unterstützung

Gruss, Fredy

BeRo schrieb am 14.05.2018 um 23:57 Uhr

[...] Geht man aber auf den Link (Bild oder Text) folgte eine entsprechende Meldung, dass Frames nicht mehr unterstützt werden [...]

Die Slideshows liegen bei Google auf einer geschützten Seite (https Protokoll).
Du referenzierst per iframe von einer ungeschützten Seite (http Protokoll) auf eine geschützte https Seite und das darf nicht sein, weil durch das Einbinden auf der ungeschützten Seite der Schutz verloren ginge...

Abhilfe:
Ziehe Deine Domain um auf eine https Domain um oder verschiebe die Slideshows auf eine ungeschützte http Domain.

[...] Geht man auf einen Link (Bild oder Worte) erscheint überhaupt nichts (nur das schwarze Viereck) [...]

Siehe oben. Abhängig vom verwendeten Browser siehst Du entweder die bekannte Fehlermeldung, dass iframes nicht unterstützt werden oder nur ein schwarzes Viereck (das ist der "nackte" Platzhalter).

[...] scrolled man die Bilderauflistung, geht das Background-bild ebenfalls mit [...]

Mach einfach den Hintergrund der Seite (des Platzhalters) transparent, die Du für die Einbindung via iframe benutzt, dann sollte das Problem nicht mehr auftreten.

Viel Erfolg

Zuletzt geändert von BeRo am 14.05.2018, 23:58, insgesamt 1-mal geändert.

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.