Seiten löschen

music-1967-magic schrieb am 10.02.2018 um 01:50 Uhr

Ich dreh bald doch noch durch glaube ich:-((( Stell grade fest, daß wenn ich in meinem Projekt auf der Hauptseite (Desktopsite) Seiten lösche, diese auch auf der mobilen Site gelöscht werden. Wie kann ich das vermeiden, denn das hat er gestern noch nicht gemacht. Ich will (muss) meine mobile Site anders strukturieren als die Hauptsite, daher muss ich in der Version der Haupsite Seiten löschen können, ohne das sie auf der mobilen Seite gelöscht werden. Hab ich da irgendwas verstellt? Was kann sonst der Fehler sein????  

Kommentare

marboe schrieb am 10.02.2018 um 08:26 Uhr

Das ist von den Programmierern so vorgesehen und ist nicht zu ändern.

Im unglücklichsten Falle hast du also Seiten in einer Variante, die du da nicht zwingend brauchst. Aber du musst sie ja nicht verlinken bzw kannst auch - nach Trennung der Teilung mit Varianten - die Elemente daraus herauslöschen. Die Seiten selbst aber nicht.

Gruß Marboe

BeRo schrieb am 10.02.2018 um 10:00 Uhr

Wenn ich die Info, die Du von @marboe bekommen hast, ergänzen darf, kannst Du natürlich auch zwei (oder mehr) Websites erstellen, die sich sinnvoll unterscheiden, abhängig davon, ob sie von einem Mobilgerät oder von einem Desktop Gerät geöffnet werden.

Was Du dann noch benötigst, ist eine Browserweiche, die automatisch die "richtige" Seite ausliefert.

Wie das geht, das kannst Du in diesem Thread nachlesen...

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

music-1967-magic schrieb am 10.02.2018 um 11:08 Uhr

Danke für eure Antworten. Für das im Beispiel von Bero und Marboe genannte Szenario fehlen mir echt noch die Kenntnisse. Die Serien leer zu machen war auch schon meine Idee. Ist aber iwie suboptimal. Die Site ist eigentlich fertig. Nur habe ich ja noch das Speicherproblem. Werde mich jetzt mal nach m 64bit Rechner umsehen. Aber doch iwie doof das man die Seiten nicht getrennt löschen kann, oder?

marboe schrieb am 10.02.2018 um 13:16 Uhr

Aber doch iwie doof das man die Seiten nicht getrennt löschen kann, oder?

Nein, nich so ganz.
Der Webdesigner legt diverse Elemente dann nicht automatisch doppelt oder dreifach an, sondern verwaltet sie an einer Stelle. Das führt zB zu einer deutlich kleineren .web-Datei.

Wie wir ja schon an anderer Stelle vermutet haben, ist in deinem Projekt irgendetwas extrem ungünstig angelegt, dass du mit so wenig Seiten und Bildern schon Speicherprobleme bekommst.
Aber grundsätzlich wirst du an einem 64bit-System sicher wesentlich mehr Freude haben beim Arbeiten als mit einem 32bit.

Gruß Marboe

______________________________________________________________________________________

Ergänzung:
Wenn ich deine Seite richtig gefunden habe, dann gibt es da auf jeden Fall noch einiges zu tun.

Hier ein Beispiel aus dem Quelltext:


Unzählige png´s. Darauf habe ich dich schon mal hingewiesen.
Im Quelltext sieht man auch, dass du Links / Seiten erstellt hast, welche ein Leerzeichen im Namen haben. Das sollte man nicht tun.

Du siehst also, das Mitteilen einer URL kann sehr (!) sinnvoll sein.

music-1967-magic schrieb am 13.02.2018 um 17:18 Uhr

Hallo. Danke!! So, erstmal nen neuen Rechner besorgt. Eigentlich komm ich gut voran. Aber es ist noch viel Arbeit. (auch Einarbeit in den Web Designer. Die vielen kleinen PNGS sind übrigens dem Arbeitsbereichshintergrund geschuldet....Die liegen alle im Pasteboardbackground. sind nicht so wirklich gut für die Ladezeiten. Das ist eine Vorlage aus dem Content Katalog. Kann man den Arbeitshintergrund nicht vielleicht als JPEG exportieren? Um ihn dann evt.l als Bild in den Hintergrund (Arbeitsbereichshintergrund) zu laden?? Wenn man sich die Seite ansieht, sind das diese kleinen Kreise (Lens Effekt) Warum Magix das so macht weiß ich nicht.

marboe schrieb am 14.02.2018 um 07:42 Uhr

Das ist eine Vorlage aus dem Content Katalog.

Wo genau findet man sie? Ich kann sie nicht entdecken.

Gruß Marboe

BeRo schrieb am 14.02.2018 um 11:09 Uhr

@marboe

[...] Ich kann sie nicht entdecken. [...]

Guckst Du hier... 😌

Wenn ich nicht noch "Nachwirkungen" habe, müsste das die Vorlage sein, die @music-1967-magic benutzt...

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

BilderMacher schrieb am 14.02.2018 um 11:52 Uhr

Nein, die Vorlage ist "Friseur". 🤓✂️

... die zahlreichen Lichtpunkte ....

 

Gruß, B a lderm I cher

(Ich bin KEIN MAGIX Mitarbeiter, ich bin NICHT beim MAGIX-Support!)

-----------------------------------------------------------------------------------------

Mein System: Windows 10 Home 64Bit | Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz | NVIDIA GeForce 840M, 4GB RAM | Vdl 2016/2018 Premium; Video Pro X 7, 10; Fotostory Deluxe 2018| MAGIX Foto&Grafik Designer 15; XARA Designer Pro X 15, Web Designer 11/15 | MAGIX Music Maker MX Premium, Music Maker 2016 Live, MAGIX Samplitude Music Studio 2017 | MAGIX Audio & Music Lab 2016 Premium | Panasonic HDC-SD66 | Velbon CX-586 | Delamax Capa Videoschiene 60cm mit Velbon PH-358 Stativkopf | ZOOM H2n | Panasonic Lumix DMC-FZ300

marboe schrieb am 14.02.2018 um 12:11 Uhr

Egal, was davon ich importieren will - es hat keinen Hintergrund 😳

Ich glaube meine 15er Version ist wirklich seltsam.
Im Contentcatalog sehe ich den richtigen Hintergrund in der kleinen Vorschau. Eine Smartphonevariante wie Bildermacher habe ich davon auch nicht.

marboe schrieb am 14.02.2018 um 12:21 Uhr

Die vielen kleinen PNGS sind übrigens dem Arbeitsbereichshintergrund geschuldet

Aber zurück zu deinem Problem.

Es müsste doch möglich sein, die "png´s" innerhalb des Hintergrundes einfach zu gruppieren. Dann werden sie als ein einziges PNG exportiert. Die Auflösung (die ich nicht kontrollieren kann) ist sicher auch noch reduzierbar.

Das dürfte deinem Seitenaufruf sehr gut tun.

Gruß Marboe

music-1967-magic schrieb am 14.02.2018 um 12:23 Uhr

Hallo. Ja genau das ist die Vorlage. "Stylist" 😂😂 Fand sie iwie gut. Ich hab mittlerweile auch rausgefunden wo man diese kleinen Lens Effekte findet und bearbeitet. Und auch das im Arbeitsbereichshintergrund Animationen nicht möglich sind. Schade, das wäre nett gewesen. Problem bei diesen Dingen ist, das sie beim Laden, oder auch hochladen auf den Webserver alle einzeln angefragt werden und das verlängert die Ladezeit schon etwas. Zum Glück hab ich jemanden der mir ja wie gesagt Web Space zur Verfügung stellt und ab und an mal drüberher schaut. Und der machte mich drauf aufmerksam. Daher auch die Frage ob man den Arbeitsbereich evtl als JPEG abspeichern kann. Er schaut auf die Seite auch in Bezug darauf das sie bei Google gut funktioniert. SEO etc. Und deswegen kam er drauf. Lieben Gruß und Daaaaanke!

music-1967-magic schrieb am 14.02.2018 um 12:27 Uhr

Marboe.Das Gruppieren werde ich mal versuchen...Danke. Bin grad etwas im Stress und muss die Website mal eben etwas hinten anstellen

BeRo schrieb am 14.02.2018 um 12:44 Uhr

[...] Das Gruppieren werde ich mal versuchen.. [...]

Wenn Du den u. a. Screenshot nimmst kannst Du die Arbeit verkürzen.

Damit hast Du den kompletten Background in 63 kB 😉

Viel Erfolg

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

music-1967-magic schrieb am 14.02.2018 um 13:02 Uhr

Lieben Dank. Wie hast Du die komplette Seite kopiert? Mit dem Snipping Tool kann ich nur das was ich am Bildschirm sehe einfangen.... Habe sonst kein anderes Grafikprogramm auf dem Rechner, da er ja neu ist. Und wie fügt man sie dann passend ein? Wie gesagt, grad etwas stressig hier und ich werde es wohl erst heute Abend oder morgen probieren können. L. G

BeRo schrieb am 14.02.2018 um 13:35 Uhr

[...] Wie hast Du die komplette Seite kopiert? [...]

Mit ein paar Mausklicks... 😋

..............

Fertig.

[...] Und wie fügt man sie dann passend ein? [...]

Einfach mit der Maus, bei gedrückt gehaltener STRG Taste auf den Hintergrund ziehen. Danach kannst Du die Grafik wie in meinem Kommentar von heute, 12:44 h gezeigt, anpassen.

Viel Erfolg

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

music-1967-magic schrieb am 14.02.2018 um 19:49 Uhr


Halloun d lieben Dank zunächst einmal.. Iwie will es noch nicht so richtig klappen, denn ich krieg es nicht auf den Arbeitshintergrund. Und der Hintergrund an sich ist doch als JPEG sehr pixelig....Hmmmm...Wenn man die Lens Ellipsen Gruppiert und dann als JPEG exportiert sieht das bei mir so aus. Der Menupunkt Browserfenster füllen ist bei mir grau hinterlegt, so kann ich ihn nicht anklicken.Und skalieren lässt es sich so(nst) nicht. Ideal wäre es tasächlich wenn man die, die man nicht braucht für alle Seiten markieren könnte und dann löschen. Leider gibt es die "auf allen Seiten löschen" Funktion hierfür nicht, so wie ich das sehe. Wenn man das für jede Site einzeln machen muss, dann ist das echt viel Arbeit. Grade was die mobile Seite angeht,wo man den Arbeitsbereichshintergrund später ja eh nicht sieht. Klar kann man die Ellipsen alle löschen, aber dann ist der Effekt na klar auch weg. Ich find das es dann zu statisch wird. Hmmmmm.....

BeRo schrieb am 14.02.2018 um 21:01 Uhr

[...] ich krieg es nicht auf den Arbeitshintergrund [...]

Wenn Du das Bild für den Hintergrund z. B. auf dem Desktop abgelegt hast, geht das am besten so, nachdem Du zunächst die Pasteboard background Ebene gelöscht hast. Sie muss in jedem Fall zumindest leer sein:

Anschließend...

Dabei unbedingt darauf achten, dass das Schloss für die Pasteboard background Ebene geschlossen ist

Das war's 😊

[...] Und der Hintergrund an sich ist doch als JPEG sehr pixelig [...]

In dem o. a. Beispiel ist der Hintergrund homogen. Zumindest ist er nicht pixeliger als das Original...

[...] Ideal wäre es tasächlich wenn man die, die man nicht braucht für alle Seiten markieren könnte und dann löschen [...]

Das wird nicht nötig sein, weil Du den umgekehrten Weg gehen kannst und den neu eingefügten Pasteboard background automatisch in alle Seiten einfügen kannst...

Deiner Kreativität sind also nur wenig Grenzen gesetzt 😃

 

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

music-1967-magic schrieb am 14.02.2018 um 21:27 Uhr

Uih, Ok. Danke...Versuche das nachher mal.

music-1967-magic schrieb am 19.02.2018 um 09:59 Uhr

Hallo Bero. Bisher habe ich es noch nicht versucht, weil ich erstmal alles was es so an Fragen gibt sammel. Und da ist einiges:-))) Aber ich werde es auf jeden Fall ausprobieren, wenn ich wieder mehr Zeit am Rechner habe und wirklich weiterarbeiten kann. Es gibt ja schon eine ganze Menge zu beachten beim Erstellen einer Website;-)