Suche mit Umlaut im Suchwort unter Hilfe des Programms

marboe schrieb am 23.10.2018 um 11:54 Uhr

Unser User BeRo hat festgestellt, dass im Programm des WebDesigners der Klick auf -> "Hilfe" in den PopUp-Fenstern zwar die erwartete Hilfe aufruft,

aber das Suchen mit Umlauten "ä", "ü", "ö" aber leider nicht zu guten Ergebnissen führt.

Wer hierzu gerne Weiteres lesen möchte, lese bitte seinen Beitrag hier.
 

Das Problem wird an Magix weitergegeben.
Bitte nutzt zum sinnvollen Suchen von Hilfe das mitgelieferte PDF-Handbuch; dort ist auch ein Suchen mit Umlauten möglich.


Gruß Marboe | Moderatorin

Kommentare

BilderMacher schrieb am 25.10.2018 um 08:03 Uhr

Woran liegt es nun, dass die Suche nach Themen und Begriffen mit Umlauten in der chm-Hilfe vom WD nicht klappt?
Denn die Hilfe in MAGIX Videodeluxe Premium (2019) hat hier keinerlei Probleme und zeigt das Ergebnis einwandfrei an.

Hier arbeitet auch der "Microsoft für Windows "spendierten" Interpreter "HTML Help Control".

Liegt wohl doch eher an der CHM?

Gruß, B a lderm I cher

(Ich bin KEIN MAGIX Mitarbeiter, ich bin NICHT beim MAGIX-Support!)

-----------------------------------------------------------------------------------------

Mein System: Windows 10 Home 64Bit Build 1809 | Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz | NVIDIA GeForce 840M, 4GB RAM | Vdl 2016/2019 Premium; Video Pro X 7, 10; Photostory Deluxe 2019 + TRAVEL Maps | MAGIX Photo & Graphic Designer 16; XARA Designer Pro X 16, Web Designer 11/16 | MAGIX Music Maker MX Premium, Music Maker 2016 Live, MAGIX Samplitude Music Studio 2017 | Samplitude Pro X4 Suite | MAGIX Audio & Music Lab 2016 Premium | Panasonic HDC-SD66 | Velbon CX-586 | Delamax Capa Videoschiene 60cm mit Velbon PH-358 Stativkopf | ZOOM H2n | Panasonic Lumix DMC-FZ300 | Focusrite_Scarlett_2i2_2ndGen | Neewer NW800

marboe schrieb am 25.10.2018 um 09:18 Uhr

Denke auch. Deswegen bat ich darum es an die Entwickler zu geben. In NichtMagixProgrammen geht es ja auch. Gruß marboe

BeRo schrieb am 25.10.2018 um 11:35 Uhr

@BilderMacher

[...] die Hilfe in MAGIX Videodeluxe Premium (2019) hat hier keinerlei Probleme [...]

Die Hilfedatei hat Magix ja auch so angelegt, dass der Microsoft Interpreter damit klar kommen kann. 😎

Wie im Editorfenster des Decompilers zu sehen ist, hat Magix hier das Windows konforme Charset "Windows-1252" verwendet.

In der Hilfedatei, die uns Probleme macht, wurde dagegen das international übliche Charset "UTF-8" verwendet

Mit dem Charset kann der auf die Interpretation von "Windows-1252" codierten Dateien ausgelegte Microsoft Interpreter nicht umgehen. Er zeigt also die Umlaute im Index falsch an.

Wenn wir Magix dafür den "Schwarzen Peter" zuschieben wollen, dann bitten wir die Entwickler einfach, die Kodierung der Hilfedatei auf das "Windows-1252" Charset zurück zu bauen, dann ist das Problem gelöst.
Die Mehrzahl der Hilfedateien anderer Magix/Xara Programme sind ja offenbar mit genau dem Charset erstellt worden. Warum hat man bei WD/XD Programmen eine Ausnahme gemacht? 😕

@marboe

[...] In NichtMagixProgrammen geht es ja auch [...]

Klar, da wird wohl auch das "alte" Charset "Windows-1252" benutzt 🙃

Man könnte für die Vorgehensweise von Magix argumentieren, dass das international übliche Charset "UTF-8" das modernere ist, das von aktuellen Programmen richtig interpretiert wird, wenn sie denn ebenfalls "modern" sind...
Folgt man der Argumentation, ist automatisch Microsoft in der Pflicht, den in dem Kontext "veralteten" Interpreter für die Hilfsdateien auf "UTF-8" umzustellen.
Damit würde aber ein Dilemma entstehen. Alle Hilfedateien, die bis zur Umstellung noch mit dem Charset "Windows-1252" ausgestattet wurden, würden dann plötzlich die Umlaute fehlerhaft anzeigen... 😣
Die Universallösung wäre also ein Interpreter, der die Kodierung der Hilfedatei erkennt und in Abhängigkeit des verwendeten Charset die Umlaute korrekt anzeigt.
Also, bleibt der "Schwarze Peter" doch bei Microsoft liegen. Die müssten aktiv werden und in Sachen CHM Interpreter nachlegen. 😉

Du verwendest den CHM Interpreter in der Version 10

Offenbar hat MS den aber genau so angelegt, wie die Version 6.1, die ich verwende und die noch mit Windows 7 ausgeliefert wurde.
AFAIK wurde die Version für Windows 8.1 auf 6.3 "angehoben". Aber auch die kann nur
das Charset "Windows-1252" richtig interpretieren...

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.