TEXT - Umlaute

AnHi schrieb am 23.04.2022 um 10:02 Uhr

Hallo zusammen,

kann mir jemand sagen wie ich "Umlaute" in einem Text wiederherstellen kann? Seit meiner letzten Veröffentlichung sind alle "Umlaute" im Text verschwunden, nur in den Überschriften sind sie noch vorhanden.
Eine erneute Eingabe der "Umlaute" in den Text hat zu keinem Erfolg geführt.

Kann dies mit der Erstellung für Smartphone-Website zusammenhängen, an der habe ich zuletzt gearbeitet.

Kommentare

Robbin schrieb am 23.04.2022 um 15:01 Uhr

@andreas-hirsch2946

Mit dem Umlauteproblem bei Übernahme älterer Projektdateien in die aktuelle 19er Version des WD bist du nicht alleine.
Lies dir dazu z. B. mal diesen Thread durch, da findest du eine Analyse zur Ursache (ein Bug) und Vorschläge zur Fehlerbehebung.

AnHi schrieb am 13.05.2022 um 10:41 Uhr

@Robbin danke für die Info das im aktueller 19er Version ein Bug vorhanden ist. Habe mir auch Deinen Kommentar durchgelesen den Du mir angegeben hast. Nun habe ich eine Frage bzgl. umschalten in die CSS-Datei. Ich finde Keinen Button der mir die CSS-Code Datei anzeigt. Kannst Du mir sagen wie ich in Xara 19 dort hinkomme?

AnHi schrieb am 13.05.2022 um 10:43 Uhr

@Renter11

Die URL- meiner Website heißt: www.andreas-hirsch.com

 

marboe schrieb am 13.05.2022 um 11:40 Uhr

@AnHi

Ich sehe auf deiner Seite keine Umlautprobleme.
Magst du das mal spezifizieren wo du welche gefunden hast, bitte?

Hier mal ein Beispiel deiner Seite:

Ich sehe, dass du die Seite heute morgen hochgeladen hast.
M.E. ist ein weiterer Eingriff in die css-Datei nicht nötig.
Gruß Marboe

AnHi schrieb am 13.05.2022 um 11:47 Uhr

@marboe 

wenn ich meine Website im MS-Edge öffne sehe ich bspw. auf der Seite des Fotografen folgenden Bild

 

AnHi schrieb am 13.05.2022 um 11:52 Uhr

@marboe wie Du richtig gesehen hast, habe ich heute morgen nochmals versucht meine Website neu zu laden.

inzwischen habe ich sie wieder geschlossen und nach Deiner Nachricht neu geöffnet, nun erscheint eine Fehlermeldung.

Obwohl ich über "Datei öffnen" auf die Quelldatei gegangen bin habe nun nur noch diese Meldung.

marboe schrieb am 13.05.2022 um 11:54 Uhr

Ah. Ich sehe das nicht.

Ausschnitt aus Edge.

Wenn man deine Seite analysiert, dann fällt auf, dass du einen Code hochgeladen hast, den ich so nicht erwarten würde. Aber da soll gern BeRo mal drübergucken. Er weiß da besser bescheid.

Was ich meine:
Von deiner Seite. Schrift wird geladen von Google.

Aber neu in der 19er Version ist, dass alle Schriften eigentlich auf dem eigenen Server gehostet werden. Das sieht dann so aus:

Hier ist meine Domain unkenntlich gemacht.
Aber, wie gesagt, da kann Robin mehr dazu sagen. Wahrscheinlich hast du nach seiner Anleitung irgendwas auf den Server geladen dass dies so ist.

Warum du in Edge aber was anderes siehst wie ich, kann ich erst recht nicht beantworten. Hast du mit STRG + F5 die Seite mal komplett neu vom Server laden lassen nachdem du sie aufgerufen hast? Gruß Marboe

BilderMacher schrieb am 13.05.2022 um 11:55 Uhr

Aktuell ist auch in Edge kein Fehlverhalten festzustellen.

"Je mehr die Menschen wissen, desto weniger müssen sie glauben!"

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
Ich kann vieles, darf aber nicht alles.
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
Gruß

BilderMacher

#+#+#+#+#+#+#+#+#+#+#+#+#+#+

Hardware:
:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz (8 CPUs), ~2.3GHz
12288 MB RAM
DirectX 12
Intel(R) UHD Graphics
NVIDIA GeForce MX250

---------------------------------------------

Edition    Windows 10 Home
Version    21H2
Betriebssystembuild    19044.1706
-----------------------------------------------
>>>>> Meine Homepage <<<<

marboe schrieb am 13.05.2022 um 11:58 Uhr

@marboe wie Du richtig gesehen hast, habe ich heute morgen nochmals versucht meine Website neu zu laden.

inzwischen habe ich sie wieder geschlossen und nach Deiner Nachricht neu geöffnet, nun erscheint eine Fehlermeldung.

Obwohl ich über "Datei öffnen" auf die Quelldatei gegangen bin erscheint nun nur noch diese Meldung.

Da haben sich die Beiträge gerade überschnitten.

Mein Tipp: alle Windowsupdates machen lassen. (heute morgen bekam ich zB eins). PC einmal neu hochfahren.

Und noch ein kleiner Tipp: du schreibst hier im WebDesigner Forum, nutzt aber den XaraDesigner, was man an der Endung .xar sieht. Das sind unterschiedliche Programme!
Und es gibt auch unterschiedliche Forumsbereiche dafür. Da dies bei den Umlauten und ihren Problemen aber keine Relevanz hat, lass ich deinen Beitrag mal hier. Gruß marboe

 

AnHi schrieb am 13.05.2022 um 13:05 Uhr

@marboe kann sein das ich hier im falschen Forum bin, aber ich wähle oben halt aus was angegeben ist und dort ist für WEB- Geschichten nur ein Button vorhanden alle andern haben mit Musik, Videos und der gleichen zu tun.

AnHi schrieb am 13.05.2022 um 13:15 Uhr

@marboe was der Code für die Googleschrieft angeht, so bietet Xara über die Galerie an sich Schriften von Google herunter zu laden. Wo die genau abgespeichert werden weis ich leider nicht, bin nur Anwender kein Programmierer, dachte aber das dies bei mir dort abgespeichert wir wo auch alle anderen Schriften abgespeichert werden. Zumindest kann ich jetzt auch in Word die Schriftart "Real..." verwenden.

Soweit ich weis, wurde der Code in meine Seite impliziert, damit andere User, sollten sie die Schriftart nicht haben, Google diese ihnen lädt, so das es meine Darstellung nicht verhaut.

AnHi schrieb am 13.05.2022 um 13:51 Uhr

@BeRo kannst Du mir da weiter helfen?

 

Robbin schrieb am 13.05.2022 um 23:15 Uhr

@AnHi

@BeRo kannst Du mir da weiter helfen

Meines Wissens hat @BeRo vor ca. 1/2 Jahr die Community verlassen. Er ist wohl nur noch sporadisch hier aktiv aber wir können dein Problem vielleicht alleine lösen...

Ich finde Keinen Button der mir die CSS-Code Datei anzeigt.

Wie @marboe hier schon gesagt hat, sollte es nicht mehr nötig sein, die "xr_font..." CSS Dateien zu bearbeiten, wenn die Website mit der neuen 19er Version veröffentlicht wurde. Dass es trotzdem nötig sein kann, das werden wir gleich sehen...

Die CSS Dateien findest du nach einem lokalen Export des Projekts im Verzeichnis "index_htm_files"

Seit meiner letzten Veröffentlichung sind alle "Umlaute" im Text verschwunden

Du trägst zur Verwirrung bei der Ursachenforschung bei, weil du dein Projekt offenbar mal mit der XD Version 18 und mal mit der XD Version 19 veröffentlichst.
Aktuell liegt die Website auf dem Webserver, die du mit der 19er Version angelegt hast. Heute Morgen lagen da noch die Dateien, die du mit der 18er Version erzeugt hast.

Der Unterschied ist gravierend, weil dein Umlauteproblem erst jetzt für alle sichtbar wird.

Die Ursache ist der bekannte Bug des WD/XD 19, der dafür sorgt, dass bei Übernahme einer älteren Projektdatei die Fontdateien, die jetzt auf dem eigenen Webserver abgelegt werden, nur die Standard ASCII Zeichen enthalten. Umlaute und bestimmten Sonderzeichen werden also "unterschlagen"

Das Schriften Problem, das @marboe hier kommentiert hat, ist vermutlich nicht mehr akut, weil du das Projekt jetzt mit der 19er Version hochgeladen hast. Damit sollten die Schriften als (unbrauchbare) WOFF Dateien auf dem Webserver liegen...

Die Lösungen sind nicht trivial, weil du dafür entweder in die o. a. CSS Dateien eingreifen musst oder arbeitsaufwändig alle Texte löschen- und neu anlegen musst. Mehr dazu findest u. a. hier.

Ein Eingriff in die für die Schriftverlinkung zuständigen CSS Dateien "xr_fonts.css" und "xr_fontsie.css" ist einfacher und schneller zu machen, wenn du dir die Arbeiten zutraust. ☺️

Du kannst entweder wieder die Google Fonts direkt verlinken (was nicht DSGVO konform ist!)

@import url('https://fonts.googleapis.com/css2?family—Raleway:wght@100; 200; 300; 400; 700&display=swap');

oder die Google Fonts herunterladen und auf deinem Webserver abspeichern. Wie das geht, das hat @Martin Hahn vor 2 Monaten hier sehr detailliert beschrieben.
Wenn du mit der Methode die Fonts heruntergeladen hast, dann speicherst du sie in einem neu angelegten Verzeichnis "fonts", das du im Verzeichnis "index_htm_files" ablegst.

Den ebenfalls auf der Google Website (Google Webfonts Helper) generierten CSS Code kopierst du nun noch in die beiden "xr_font...css" Dateien im Verzeichnis "index_htm_files", deren Inhalt danach etwa so aussehen sollte...

Das Ergebnis ist eine bzgl. der Schriften DSGVO konforme Website, in der alle Umlaute und Sonderzeichen in der von dir gewählten Schriftart "Raleway" zu sehen sind.

Solltest du "unüberwindliche" Probleme beim Umsetzen bekommen, dann kann ich dir gerne die fertigen "xr_font...css" Dateien und das mit den Schriften gefüllte Verzeichnis "fonts" zum Download anbieten...

Aber vielleicht willst du es ja zuerst mal selbst probieren 🙃

AnHi schrieb am 14.05.2022 um 13:34 Uhr

@Robbin danke für den Hinweis. Ich habe eigentlich die aktuelle 19 Version (19.0.0.63929 M DL x64 Mar 7 2022), da aber in dieser Version die Umlaute gefehlt haben, dachte ich, ich probiere es mal mit der 18er Version, dies hat aber auch zu keinem Ergebnis geführt, worauf ich es nochmals mit der 19er Version probiert habe. Beides hat nicht zur Lösung des Problems geführt.

Ihr müsst wissen, dass ich nur Anwender bin kein Programmiere, werde dennoch versuchen Deine Anweisung umzusetzen, sollte es nicht klappen würde ich Dich um den Download bitten.

AnHi schrieb am 14.05.2022 um 17:16 Uhr

@Robbin, also Robbin ich habe die Page jetzt nochmals mit der 19er Version hochgeladen, ohne Erfolg. Anschließend bin ich Schritt für Schritt Deine Anweisung abgelaufen, die Du hier angegeben hast.
Auf meinem Hostserver-Anbieter habe ich die besagte "Index_htm_files" Datei geöffnet und die beiden Ordner "xr_fonts.css und xr_fontsie.css" Dateien gefunden.

Da Du meintes das die import-Datei von Google nicht DSGVO konform ist, habe ich mir die Google Fonts heruntergeladen und bin nach den Anweisungen von Martin Hahn vorgegangen, dies hat ebenfalls zu keinem Ergebnis geführt. Anschließend habe ich es mit dem "Import url" von Google direkt probiert und es ist ebenfalls zu keinem Ergebnis gekommen. Wärest Du so nett und schaust Dir das mal an was ich falsch gemacht haben könnte?

Am liebsten wäre es mir, wenn wir in den Fonts-Dateien einen direkten Fonts hinterlegen könnten, andernfalls müsste ich die Texte aus meinen Dateien nach dem Vorschlag von @marboe in Notepad++ kopieren und Anschließend wieder zurück holen. Die Frage ist nur, benötige ich unbedingt den Notepad++ oder gibt es eine andere Lösung wie Word oder so. Ich möchte mir ungern wegen diesem Fehler ein neues Programm herunterladen müssen.

Robbin schrieb am 14.05.2022 um 21:12 Uhr

@AnHi

ich habe die Page jetzt nochmals mit der 19er Version hochgeladen, ohne Erfolg

Wäre der Versuch erfolgreich gewesen, hättest du einen Platz in der Gilde der Wunderheiler verdient. 🙂
Wie weiter oben schon gesagt ist der XD in der aktuellen Version 19 buggy. Er kann ältere Projektdateien nicht ohne Umlaute Fehler exportieren/veröffentlichen, wenn Google Fonts- oder andere externe Schriften verwendet werden .

habe ich mir die Google Fonts heruntergeladen und bin nach den Anweisungen von Martin Hahn vorgegangen, dies hat ebenfalls zu keinem Ergebnis geführt.

Das Verfahren hätte sicher zum Erfolg geführt, wenn du die Tipps von @Martin Hahn- und meine ergänzenden Tipps tatsächlich 1:1 umgesetzt hättest. 😍

schaust Dir das mal an was ich falsch gemacht haben könnte?

Du hast deutlich mehr Fonts aktiviert als für deine Site nötig sind und du hast die heruntergeladenen CSS Anweisungen zusätzlich zu den bereits vom XD angelegten Verweisen auf die korrupten WOFF Dateien in die Datei "xr_fonts.css" kopiert.
Das Hauptproblem ist aber das fehlende "fonts" Verzeichnis, das du ja ebenfalls von der Google Site herunterladen musst, um es im Verzeichnis "index_htm_files" deines Projekts zu speichern.
Der Inhalt des Verzeichnisses "index_htm_files" muss in jedem Fall das "fonts" Verzeichnis enthalten und mindestens noch die modifizierte CSS Datei "xr_fonts.css"

Lade dir doch mal die relevanten Dateien hier, von meinem Demoserver herunter. Öffne nach dem Download das ZIP Archiv...

...und kopiere die enthaltenen Dateien und das Verzeichnis "fonts" in das Verzeichnis "index_htm_files" deines Projekts.
Wenn du das direkt auf deinem Webserver machst, dann sollte der Text auf deiner Site unmittelbar danach alle Umlaute anzeigen.
Damit das zuverlässig funktioniert, ist es u. U. nötig, den Browsercache mit STRG+F5 zu leeren, wenn du deine Site aufgerufen hast...

Achtung!
Der XD wird bei jedem neuen Upload (veröffentlichen) der Site die korrigierten CSS Dateien mit den vom Programm generierten Originaldateien Überschreiben und damit wieder den Umlaute Fehler provozieren!

Du kannst das vermeiden, wenn du nach jedem Upload die von dir korrigierten CSS Dateien erneut auf den Webserver kopierst.
Selbst das kannst du vermeiden, wenn du die Dateien einmalig in das Hilfsverzeichnis deines Projekts kopierst. Der XD sorgt dann bei jedem Upload automatisch dafür, dass die unbrauchbaren Originaldateien mit den von dir funktionsfähig korrigierten überschrieben werden.
Das Hilfsverzeichnis findest du auf deinem PC da, wo du die Projektdatei gespeichert hast.
Hat die Projektdatei z. B. den Namen "meinesite.xar", dann hat das dazu gehörende Hilfsverzeichnis den Namen "meinesite_xar_files".
Vermutlich hat der XD das Hilfsverzeichnis schon angelegt, wenn nicht holst du das nach und kopierst die CSS Dateien und das Verzeichnis aus dem Download da hinein. anschließend veröffentlichst du dein Projekt ganz normal und der XD sorgt dafür, dass die Umlaute auf den Seiten ab sofort korrekt angezeigt werden. 😉
Solltest du das Hilfsverzeichnis manuell anlegen, denk daran, dass das Verzeichnis zwingend im selben Verzeichnis liegen muss, in dem deine Projektdatei "meinesite.xar" liegt!

AnHi schrieb am 15.05.2022 um 15:19 Uhr

@Robbin Danke für Deine Info. Nun aber wird es für mich Programmierlaien etwas kompliziert. So wie ich Dich verstanden habe soll ich auf dem Hostordner die alten Raleway-Dateien löschen und die von Dir in die entsprechenden Ordner kopieren.

Das ich mir von der "google-webfonts-helper-Seite" alle Dateien zu "Raleway" heruntergeladen habe liegt daran, dass ich keine Kenntnisse von relevanten und nicht relevanten Dateien habe und meinte auf "Nummer Sicher" zu gehen.

Ein Hilfsverzeichnis gibt es in dem Ordern wo die Page abgelegt ist nicht. Habe dies bzgl. alle Ordner und Dateien, in der die Page liegt, durchsucht sowie alle Ordner des Programmes von der Version 16 bis 19. Womit ich, wenn ich Dich richtig verstanden habe, mir "Manuell" eines anlegen müsste, dass ich dann in dem Ordner, wo die Page liegt, ablegen soll.
Dazu hätte ich die Frage: Wie lege ich diese Datei an (Editor), welche Endung benötigt die Datei (CSS oder "...name..._xar_files") und wie findet XD die Datei in dem Ordner?

Robbin schrieb am 15.05.2022 um 16:40 Uhr

@AnHi

...soll ich auf dem Hostordner die alten Raleway-Dateien löschen und die von Dir in die entsprechenden Ordner kopieren.

Das kannst du so machen, einfacher ist es aber wenn du die automatische Methode benutzt, die das Hilfsverzeichnis bietet.

Ein Hilfsverzeichnis gibt es in dem Ordern wo die Page abgelegt ist nicht

Du hast da gesucht, wo du die Projektdatei "projetkname.xar" gespeichert hast?
Wenn da tatsächlich kein Verzeichnis mit dem Namen "projektname_xar_files" liegt, dann legst du es jetzt manuell an.

Wie lege ich diese Datei an (Editor), welche Endung benötigt die Datei

Das dazu nötige Wissen gehört zum Umgang mit dem Betriebssystem "Windows", das dazu z. B. den Windows eigenen Explorer mitliefert. Den aktivierst du mit der Tastenkombination "Windows Taste + E".

    

wie findet XD die Datei in dem Ordner?

Dazu musst du nichts weiter unternehmen. Der XD sucht und findet alle Dateien und Verzeichnisse, die im gerade angelegten Hilfsverzeichnis "projektname_xar_files" liegen und kopiert den kompletten Inhalt des Verzeichnisses beim nächsten Upload (veröffentlichen) auf deinen Webserver in das da liegende Verzeichnis "index_htm_files". Dabei werden alle eventuell da schon liegenden, gleichnamigen Dateien/Verzeichnisse mit dem Inhalt des Hilfsverzeichnisses überschrieben.

Wenn du alles richtig gemacht hast, dann musst du dich bei Änderungen an deiner Site nicht mehr um die korrekte Zuweisung der Google Fonts kümmern, das macht der XD ab jetzt automatisch im Hintergrund.
Nur, wenn du an den Schriften in deiner Website etwas änderst (andere Schriftschnitte oder Schriften) dann musst du die komplette Prozedur neu durchlaufen. Angefangen mit dem "Google Webfonts Helper" bis zum Einbau der angepassten CSS Dateien und des "fonts" Verzeichnisses in das Hilfsverzeichnis deines Projekts.

P.S.
Nur der Vollständigkeit halber...
Der Name des Hilfsverzeichnisses, das du neu anlegst, muss natürlich den Namen deiner Projektdatei bekommen. Es darf also nicht "projektname..." heißen. 😊

AnHi schrieb am 15.05.2022 um 17:02 Uhr

😆 Wie man einen Ordner anlege wusste ich, dachte ich müsste den Editor öffnen und dort die Codes von dir reinkopieren oder so und ihn dann speziell benenne, aber danke vorerst mal. Werde das jetzt erstmal Umsetzen.

AnHi schrieb am 15.05.2022 um 17:15 Uhr

Also meine Seite sieht genauso aus wie vorher, es fehlen alle Umlaute 😒

Robbin schrieb am 15.05.2022 um 17:22 Uhr

Seite sieht genauso aus wie vorher, es fehlen alle Umlaute

Dann lösch' mal den Browsercache mit der Tastenkombination (Strg + F5) und siehe da...

AnHi schrieb am 15.05.2022 um 18:24 Uhr

😬 immer dieser Vorführeffekt, denn ich hatte mit Strg + F5 den Browsercache gelöscht. Einmal nach dem ich die Seite geladen hatte und beim zweiten mal davor 😕.

Hab aber vielen Dank für Deine Mühe, die Du mit mir hattes. Möchte aber dauerhaft eine andere Lösung finden.
Das ständige korrigieren der CSS-Datei ist mir dann doch zu aufwendig, wenn ich mal die Schrift ändern möchte.

Soweit ich gelesen habe müsst ich jedoch dafür alle Texte löschen und sie neu schreiben bzw. kopieren, richtig?
Weist Du zufällig wie es mit der "Schrift - Raleway" oder einer anderen ist, wenn diese im XD importiert wurde, ob dann der Lösungsvorschlag von Mabo funktionier, wenn ich die Texte komplett aus der Page rauskopiere und dann neu einfüge. Und ob ich dazu wirklich "Notepad++" benötige oder es mit dem stinknormalen Wordprogramm funktionieren würde?

Robbin schrieb am 15.05.2022 um 18:54 Uhr

Weist Du zufällig wie es mit der "Schrift - Raleway" oder einer anderen ist, wenn diese im XD importiert wurde, ob dann der Lösungsvorschlag von Mabo funktionier,

Du kannst nach dem Löschen der vorhandenen Texte/Schriften jede beliebige, frei verfügbare Schrift in deine Website neu einbauen, die dann auch fehlerfrei (mit Umlauten) angezeigt wird, wenn du sie neu anlegst.
Der Vorschlag, den @marboe hier gemacht hat, ist eine gute Anleitung für die dafür nötige Aktion.

ob ich dazu wirklich "Notepad++" benötige oder es mit dem stinknormalen Wordprogramm funktionieren würde?

Das funktioniert mit jedem Texteditor, der in der Lage ist Texte ohne Formatierung zu speichern. MS Word zählt leider nicht dazu. Aber du kannst z. B. mit dem Windows eigenen Editor arbeiten.

AnHi schrieb am 15.05.2022 um 19:08 Uhr

ok danke, mit dem Editor habe ich schon öfter gearbeitet. Eigentlich darf ich das garnicht sagen, denn vor gut 30 Jahren habe ich mal angefangen Web- und Medien Designer zu studieren, leider aus Privatengründen damit wieder aufgehört, daher sind mir einige Begriffe schon bekannt. In der zwischen Zeit hat sich hier aber soviel getan, dass ich erst bei Null wieder anfangen müsste. Wenn man nicht am Ball bleit geht halt vieles einfach verloren. 😏