Timeline Einfügen/Entfernen von Szenen dauert lange

Kommentare

maedschik schrieb am 13.03.2018 um 11:16 Uhr

Wenn ich z.B. ein älteres Projekt (3 Stunden) in VDL18 lade

inzwischen mit meinem aktuellen Projekt bei 60 Minuten

Hallo!wilfried.meier.wiwi!

Das sind schon ganz schön umfangreiche Projekte. Dazu ein Tipp, vielleicht machst Du das aber schon.

Wenn du solch Projekt geladen hast, kicke bitte einmal unten rechts den Button ..Ansicht optimieren (Strg +F )...und warte bis alles komplett geladen ist,........... kann schon ein Moment dauern. Man erkennt es daran ,dass alle Bildsymbole der Dateien von links nach rechts durchlaufend erscheinen. ( geladen werden). Wenn man die Optimierung nicht macht, wird im ersten Moment nur der sichtbare Teil in der Timeline vollständig geladen und wenn Du dann schon arbeitest, wird im Hintergrund immer noch das Projekt geladen. ( Zumindest ist das bei mir so )

Gruß m

wilfried.meier.wiwi schrieb am 13.03.2018 um 18:44 Uhr

an maedschik: Ansicht optimieren habe ich gemacht.

hpnolting schrieb am 14.03.2018 um 11:00 Uhr

Hallo,

ich bin froh, dass ich diesen Beitrag gefunden habe, weil ich (vermutlich) das gleiche Problem habe und also nicht ganz allein bin. Auch bei mir benötige ich ca 6 Sekunden Reaktionszeit nach einem Schnitt (T, Z, U) oder Löschen etc. an einem Filmobjekt.

Dieser Effekt ist ca. vor 2 oder 3 Wochen neu aufgetaucht (Upgrade von Win 10 ?). Vorher war alles flüssig. Nur die Schieberegler für Gamma/Kontrast hatten Wartezeiten.

Ich bearbeite z. Zt. Hi8-Filme aus der Zeit 1994-2001. Sie werden von der Original-Kassette auf der Sony DCR-TRV 210 abgespielt und als avi-Datei (Fire Wire) auf die Festplatte geschrieben, mit Magix Pro X konvertiert zu mp4 576p:25f/s 6000Mb/s Dateien. Diese werden dann als Quell-Basis für die Bearbeitung der alten Filme genutzt. Die Ausgabe erfolgt als AVCHD-DVD als iso-File im Format 720p:25 f/s.

Die langen Reaktionszeiten treten bei der Bearbeitung dieser mp4-SD-Files auf. Aktuelle Filmaufnahmen in FullHD oder 4K auch als Multi-Cam verhalten sich völlig normal.

Ich frage mich, ob das an dem überarbeiteten Codec liegt, bei dem sich Magix eventuell nur auf "moderne" Formate konzentriert hat?

Hat jemand Vorschläge was ich tun kann?

Gruß HPN

marion51 schrieb am 14.03.2018 um 11:20 Uhr

@hpnolting

warum speicherst Du in MP4? ich würde da MPEG2 vorziehen.

Gruß

hpnolting schrieb am 14.03.2018 um 11:27 Uhr

Hallo,

Ich habe noch folgenden Test durchgefüht:

Reaktionszeit= Zeit zwischen 2 schnellen Befehlen: Schneiden=T + Abspielen=Leertaste

Wenn der Film am Anfang nicht bearbeitet ist, ist die Zeit sehr kurz.

Daher: Szenenerkennung durch geführt
Den ganzen Film vorbelegt mit Zoom=1,03 (Ränder wegschneiden), Gradationskurve und mittleren Werten für Gamma, Kontrast etc.
Jeden Clip individuell bearbeitet.

Jetzt steigt die Reaktionszeit an mit dem Fortschritt der Bearbeitung.

Außerdem sehr lange Bearbeitungszeit für "Rückgängig machen", wenn schon viele bearbeitet wurde.

Gruß HPN

 

hpnolting schrieb am 14.03.2018 um 11:38 Uhr

Hallo @marion51

kurze Antwort: Das Format mp4 beim heutigen Stand der Technik ist deutlich besser als mpeg2.

lange Antwort: Ich habe vor einigen Jahren mit mvx gearbeitet. Eine Filmkassette 90 Minuten benötigt für

avi 20GB
mvx 9 bis 11 GB
mp4 4 GB

Heute speichern alle CAMs in mp4 oder m2ts oder Derivaten davon. Alle Videofreunde sind zufrieden mit dieser Bildqualität.

Die Bearbeitung und -szeit von mpeg2 ist umständlich, langsam und fehleranfällig (Frametable). Ich hasse mpeg2- und VOB-Dateien deshalb.

Gruß HPN

A380 schrieb am 14.03.2018 um 11:38 Uhr

Auch etliche Neustart wurden versucht.

@wilfried.meier.wiwi

Reden wir über den selben "Neustart" von Windows, oder hast du nur "Herunterfahren" gemacht ?

Bild ist aus Win 7

FredW schrieb am 14.03.2018 um 12:40 Uhr

@hpnolting,

Ich frage mich, ob das an dem überarbeiteten Codec liegt, bei dem sich Magix eventuell nur auf "moderne" Formate konzentriert hat?

Die Aussage ist schon in sich falsch, da der Codec (Intel) wie der Name schon sagt, von Intel kommt.

Können wir BITTE beide Themen trennen? Du hast dich an einen anderen Thread gehängt und womöglich ganz andere Voraussetzungen. Das irritiert ... BITTE neuen Thread mit allen relevanten Infos öffnen.

Vergiss nicht, dass zahlreiche Windows Updates schon für einigen Ärger gesorgt haben.

hpnolting schrieb am 15.03.2018 um 10:59 Uhr

Hallo wilfried.meier.wiwi

ich habe eine Hypothese über die Ursachen für unser Problem mit der Reaktionszeit.

1) Grundsätzlich sind lange Filme (> 60 Minuten) ab einem bestimmten Punkt an deutlich langsamer beim Bearbeiten als am Anfang. ==> Filmlänge begrenzen (Aufteilen des Filmes)

2) Filme mit vielen Einstellungen für die Bildgestaltung (Helligkeit, Gamma, Kontrast und vor allem HDR, Mercalli 4.0 etc) zeigen eine langsame Bearbeitungsmöglichkeit und anschließend eine lange Renderzeit (nackter Film ohne Einstellungen für FullHD ca. 2-3 mal Länger als die Gesamtdauer des Filmes. Mit vielen Einstellungen ist für diesen Zeitfaktor auch 5 bis 6 beobachtet worden).

Soweit war mir das alles schon bekannt.

3) Für die Bearbeitung der SD-Filme wird leider nur einer der 4 CPUs ausgelastet. Da der alte Film lange nicht so gutes Ausgangamaterial ist wie von einer aktuellen CAM und weil ich damals noch ganz anders und unbekümmert gefilmt habe, muß ich alle Register der Bildbearbeitung ziehen. Daher wird das sehr, sehr langsam.

4) Workaround: sehr kurze Filme (10-20-30 Minuten) bearbeiten. Später können die auch wieder zusammengestzt werden. Die oben erwähnte Voreinstellung (Gamma, HDR etc) erleichtert die individuelle Bearbeitung pro Clip, aber macht auf Anhieb alle Clips zu bearbeiteten Objekten und macht die Reaktionszeit hoch. Daher werde ich die Voreinstellung in Zukunft lieber über abgespeicherte Voreinstellungen anbringen, wenn der Chip an der Reihe der Bearbeitung ist.

Frage an wilfried.meier.wiwi: benutzt Du viele Einstellungen pro Clip? Meine aktuellen FullHD- bzw 4K-Filme brauchen kaum solche Korrekturen. Für diese Filme steht auch mehr Rechenkapazität (4 CPUs + Quicksync) zur Verfügung.

Hallo FredW, meine Wortwahl Codec ist leider falsch. Ich hätte Engine schreiben müssen. So sagt man wohl für das graphische Programm von Magix für den Videoschnitt. Pardon.

Die beiden Fälle zur Reaktionszeit haben vermutlich die gleiche Ursache. Daher bin ich hier genau richtig.

Gruß HPN

 

wilfried.meier.wiwi schrieb am 16.03.2018 um 14:48 Uhr

an hpnolting: die Clips haben keine Korrekturen, nur Blenden wurden eingefügt.

Anscheinend habe ich was gefunden: inzwischen hatte ich alle Szenen vom meinen Ordner in mein Projekt eingefügt und bearbeitet, mit dieser längeren Wartezeit. Dann öffnete ich den nächsten Ordner, um weitere Szenen in das bestehende Projekt einzufügen. Und siehe da....hier klappte alles wunderbar, die Wartezeit war praktisch weg, ich konnte sofort weiterarbeiten. Die Ordner waren auf dem gleichen Pfad auf der Festplatte abgelegt, auch die Dateiformate waren identisch. Zur Sicherheit fügte ich nochmals eine Szene vom ersten Ordner ein, wieder musste ich länger warten. Irgendwas blockiert den Import oder Export von diesem Ordner.

Jedenfalls kann ich jetzt wieder sauber mein Projekt bearbeiten.

Vielen Dank an alle, die sich so sehr für mein Problem bemüht haben. Da sieht man mal wieder, was die Zusammenarbeit von Vielen für Erfolge bringen kann. So sollte es überall sein.

hpnolting schrieb am 17.03.2018 um 15:17 Uhr

Hallo Wilfried,

danke für Deine Antwort.

Ich fasse zusammen. Bei Dir verhalten sich zwei verschiedene Ordner mit ähnlichen Video Dateien bzgl der Reaktionszeit völlig unterschiedlich. Ist das Korrekt?

Wenn ja, schau Dir doch einmal bitte beide Ordner an. Rechts Klick auf Ordner, Sicherheit, schau auf die Liste der Berechtigten und ihre Rechte (Vollzugriff) !. Wenn diese Angaben unterschiedlich sind und Du dich da nicht wiederfindest, führe doch bitte zur Probe den Benutzer "Jeder" mit Vollzugriff ein.

Sollte es jetzt plötzlich funktionieren, solltest Du die Sicherheitsangaben in Ordnung bringen. (Bei Fragen bitte melden).

Gruß HPN

hpnolting schrieb am 17.03.2018 um 15:23 Uhr

Hallo,

nun zu meinem Problem.

Ich kann die Reaktionszeit auf normal einstellen, wenn alle Filme kürzer als 25 Minuten sind. Das ist zwar ein zusätzlicher Aufwand, aber schneller und nicht so ätzend wie die 6 Sekunden Wartezeit. Zum Rendern kann ich die Filme wieder zusammensetzen.

Aber eine Bitte an Magix: Ändert den Code der Bearbeitung von SD-Filmen so dass alle 4 CPUs ausgelastet sind.

Gruß HPN

PS: Das Thema ist aus meiner sicht abgeschlossen.

FredW schrieb am 17.03.2018 um 15:48 Uhr

@hpnolting,

Aber eine Bitte an Magix: Ändert den Code der Bearbeitung von SD-Filmen so dass alle 4 CPUs ausgelastet sind.

Dann teile das doch auch bitte Magix mit. Hier sind Anwender, die sich gegenseitig helfen.

Deine Bitte wird aber nie erreichbar sein, wenn dein PC unausgewogen ist, gibt es immer einen Bottleneck, der das verhindert. Außerdem hat der PC noch mehr zu tun, außer dem Encoding. Es laufen also genügend Prozesse im Hintergrund die auch CPU Zeit verbraten, je nachdem, wie hoch ihre Priorität ist.

Mit Bearbeitung von SD Filmen meinst du aber sicherlich das Encodieren. Da der Encoder nicht von Magix kommt, sondern von Intel, die deine CPU entwickelt haben, sollte man diesen Entwicklern schon zugestehen, dass sie wissen was sie tun.

Du hast dich übrigens auch in diesen Thread reingehängt, ohne bisher verraten zu haben, welchen PC, welche Hardware und welche Betriebssystem du nutzt. Eine denkbar schlechte Ausgangssituation für eine Hilfe. Ich erlebe häufiger, dass auf Windows 10 migrierte Systeme oft Probleme haben, wenn es keine Windows 10 Treiber dafür gibt, gerade nach dem Windows 10 Creator Update. Ich habe aber auch schon Fälle erlebt, bei denen das an alten Versionen vom UEFI Bios liegt. In solchen Fällen könnte Magix gar nichts ausrichten.

Zuletzt geändert von FredW am 17.03.2018, 15:52, insgesamt 1-mal geändert.

Windows 10/7  64-Bit, I7-4771, 16 GB-RAM, NVidia GeForce GTX770, Samsung SSD 512 GB, 2 x 3 TB interne HD, 2 x 4 TB externe USB 3.0 HD, MACmini I7 3.0 GHz, 1 TB SSD MAC OS Sierra VMware Win10

newpapa schrieb am 17.03.2018 um 16:40 Uhr

Hallo,

Aber eine Bitte an Magix: Ändert den Code der Bearbeitung von SD-Filmen so dass alle 4 CPUs ausgelastet sind.

Ich habe probehalber mal 8 Spuren (SD-Video mit Ton auf getrennter Spur) und vielen Effekten belegt. Die Auslastung sieht dann bei mir so aus:

Nachtrag: Aufnahme bei der Bearbeitung. Falls das Encoding gewünscht sein sollte, werde ich das nachliefern. Da sollte genannt werden, ob als SD oder HD mit dem Intel oder MC und mit /ohne Hardwarebeschleunigung ausgegeben werden soll.

wilfried.meier.wiwi schrieb am 17.03.2018 um 19:03 Uhr

an hpnolting: das mit den unterschiedlichen Reaktionszeit stimmt. Ich habe alle Berechtigungen der Ordner überprüft und ich habe überall Vollzugriff. Jedenfalls kann ich jetzt wieder normal arbeiten Vielen Dank.

hpnolting schrieb am 17.03.2018 um 22:09 Uhr

Sorry wilfried,

hast Du die Rechte korrigiert in dem einen Ordner und dann läuft alles wie es sein soll?.

Gruß HPN

wilfried.meier.wiwi schrieb am 17.03.2018 um 23:48 Uhr

an hpnolting: nein die Wartezeit bleibt unverändert lange , trotz voller Berechtigungen. Danke.

hpnolting schrieb am 18.03.2018 um 14:13 Uhr

an wilfried:

hast Du versucht die Filmlänge unter 20 Minuten zu kürzen? Oder evtl noch kürzer?

Und was passiert, wenn Du in einem Film nur 3 Clips hast, zunächst unbearbeitet. Dann muß es doch sehr schnell gehen beim bearbeiten?

Gruß HPN

wilfried.meier.wiwi schrieb am 18.03.2018 um 19:16 Uhr

an hpnolting: ich kann doch jetzt mit den Szenen von den anderen Ordnern ohne Wartezeit weiter arbeiten. Egal ob das Projekt 10 Minuten oder 3 Stunden lang ist. Daher brauche ich auch nicht das Projekt aufteilen.

hpnolting schrieb am 21.03.2018 um 08:20 Uhr

an Wilfried: Ich suche immer nach den Ursachen, um möglichen Ärger zu vermeiden. Daher die Frage: was ist bei dem langsamen Ordner anders?

an Newpapa: Die 8 zeitlich parallelen Spuren kann man nicht mit vielen Clips auf einer Spur vergleichen. Bei 8 parallelen Spuren ist eine Aufteilung der Arbeit auf 8 CPUs sehr einfach. Aber wie macht man die Aufteilung, wenn nur ein Clip in Arbeit ist.

Ich habe noch etwas anderes entdeckt, was leicht nachgestellt werden kann. Ich habe für einen 3 Stundenfilm mit sehr vielen Clips die Bilddarsatellung von Timeline auf Dia-Darstellung umgeschaltet. Nach einer Ewigkeit ohne Ergebnis habe ich den Film in 3 Teile zerlegt. Nach vielen Minuten Wartezeit hatte ich dann endlich die Dia-Darstellung. Bemerkenswert!!!

Gruß HPN

newpapa schrieb am 21.03.2018 um 21:05 Uhr

Hallo,

an Newpapa: Die 8 zeitlich parallelen Spuren kann man nicht mit vielen Clips auf einer Spur vergleichen. Bei 8 parallelen Spuren ist eine Aufteilung der Arbeit auf 8 CPUs sehr einfach. Aber wie macht man die Aufteilung, wenn nur ein Clip in Arbeit ist.

Dargestellt war der Verlauf während der Vorschau. Die 8 Spuren habe ich gewählt, um die Auslastung der Prozessoren zu zeigen. Auch bei einer (zwei mit Ton) Spur arbeiten alle Prozessoren. Aber das ist doch uninteressant. Die Auslastung ist ja nur ganz gering und der Prozessortakt wird heruntergefahren.

Inwieweit die Vorschau bei dir ein Problem ist, dazu hast du nichts gesagt. Bei mir wird sie erst zum Problem bei der Mercalli-Stabilisation und gravierend beim Entrauschen mit Neat.

Die Auslastung des Prozessors beim Umschalten der Sichten ist bei mir unbedeutend und das Umschalten erfolgt ohne Verzögerung. Die Programmeinstellung ist bei mir "Aktualisierung im Hintergrund". Für die Vorschau in der Timeline ist die Einstellung "Einfache Darstellung von Video-Objekten" und "Größenänderung von Bildmaterial in hoher Qualität" ist nicht aktiviert.