Vordergrundobjekt wird nicht vorne angezeigt

OsCor schrieb am 29.01.2014 um 11:23 Uhr

Hallo Helfer,

um meine etwas rechtecklastige Startseite aufzulockern, habe ich eine Schrift an einem Pfad entlang so angeordnet, dass sie den oberen Balken oben und unten überschreitet. Unten überschreitet sie auch einen Html-Platzhalter, der ein Slideshow-Widget beherbergt.

So sieht es (beabsichtigt) im Entwurf aus (siehe auch die Anordnung in der Ebenen-Galerie):

So sieht es leider in Wirklichkeit aus. Siehe die untere Spitze des K der Schmuckschrift:

Das Foto ist ein anderes als oben. Ich war nicht schnell genug beim  „Capture”

Kann man das so wie oben hinkriegen oder muss ich mich bescheiden?

Ergänzung: „Leichte” Korrektur: Der Platzhalter für die Fotos bleibt hinten, aber die Fotos schieben sich nach vorne…

Gruß

Oswald

Kommentare

citylight1976 schrieb am 29.01.2014 um 15:46 Uhr

Stelle doch den Text im Vordergrund. Oder übersehe ich hier was?!

Zuletzt geändert von citylight1976 am 29.01.2014, 15:46, insgesamt 1-mal geändert.

Wenn Stiftung Warentest Vibratoren testet, ist dann "Befriedigend" besser als "Gut"?

Ich bin unehrlich! Bei einem unehrlichen Mann wie mir könnt Ihr darauf vertrauen, dass er unehrlich ist... ehrlich!

BilderMacher schrieb am 29.01.2014 um 17:04 Uhr

Ergänzung:

Dafür hat es hier einen Button:

 

Zur Frage:

Ich sehe online etwas anderes ...

Ist das neue Design noch nicht wirklich online?

Zuletzt geändert von BilderMacher am 29.01.2014, 17:04, insgesamt 1-mal geändert.

"Je mehr die Menschen wissen, desto weniger müssen sie glauben!"

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
Ich kann vieles, darf aber nicht alles.
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

-------------

Hardware:

:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz (8 CPUs), ~2.3GHz
12288 MB RAM
DirectX 12
Intel(R) UHD Graphics (für Import, Verarbeitung, Export [Video deluxe 2023 | Video Pro X 14 | Photostory Deluxe 2023])
NVIDIA GeForce MX250 (wird nicht in Schnitt-SW verwendet)

---------------------------------------------

Edition    Windows 10 Home
Version    22H2
Installiert am    ‎15.‎10.‎2020
Betriebssystembuild    19045.2364
Leistung    Windows Feature Experience Pack 120.2212.4190.0

-----------------------------------------------

OsCor schrieb am 29.01.2014 um 17:09 Uhr

Oder übersehe ich hier was?!

Ja, der Text steht laut Ebenen-Galerie schon im Vordergrund. Das siehst du auf dem ersten Bild rechts; die zwei blau unterlegten Zeilen zeigen, dass der Platzhalter hinter der Textzeile liegt.

Edit:

@BilderMacher

Das neue Design ist noch nicht online, es sind noch zig Fotos zu löschen, ersetzen, ergänzen und eine Unmenge Texte zu schreiben, zu verschlanken, zu löschen. Es handelt sich um eine umfangreiche Änderung.

Die auch noch nicht ganz fertigen, aber schon geänderten Seiten sind unter einer 2. Domain zu betrachten: http://www.come-design.net

Die in der Navigationsleiste vorgesehenen Links sind erst vereinzelt hinterlegt. Aber das ist hier ja egal.

Was den Ergänzen-Button anbelangt, so muss ich sagen, dass ich den übersehen hatte und einfach so verfuhr, wie ich es aus anderen, weniger komfortablen Foren kenne. Danke für den Hinweis.

2. Ergänzung: Mein Bildausschnitt stammt aus der Designer-internen Vorschau.

Gruß

Oswald

BilderMacher schrieb am 29.01.2014 um 17:37 Uhr

Der Slider liegt vor dem Text ...

<img class="xr_ap" src="index_alt_htm_files/2111.png" alt="Karten, Hochzeit, Schmuck" title="" style="left: 232px; top: 62px; width: 633px; height: 151px;"/>

 

<div id="xr_xo0" class="xr_ap" style="left:0; top:0; width:907px; height:100px; visibility:hidden;">
<a href="" onclick="return(false);">
<img class="xr_ap" src="index_alt_htm_files/2112.png" alt="Brautschmuck" title="" style="left: 18px; top: 178px; width: 151px; height: 36px;"/>
<img class="xr_ap" src="index_alt_htm_files/2113.png" alt="Karten" title="" style="left: 18px; top: 215px; width: 151px; height: 36px;"/>
<img class="xr_ap" src="index_alt_htm_files/2114.png" alt="Kerzen" title="" style="left: 18px; top: 252px; width: 151px; height: 36px;"/>
<img class="xr_ap" src="index_alt_htm_files/2115.png" alt="Deko" title="" style="left: 18px; top: 290px; width: 151px; height: 36px;"/>
<img class="xr_ap" src="index_alt_htm_files/2116.png" alt="Sonstiges" title="" style="left: 18px; top: 327px; width: 151px; height: 36px;"/>
<img class="xr_ap" src="index_alt_htm_files/2117.png" alt="Fragen?" title="" style="left: 18px; top: 364px; width: 151px; height: 37px;"/>
<img class="xr_ap" src="index_alt_htm_files/2118.png" alt="Startseite" title="" style="left: 18px; top: 402px; width: 151px; height: 36px;"/>
</a>
</div>

 

Zuletzt geändert von BilderMacher am 29.01.2014, 17:37, insgesamt 1-mal geändert.

"Je mehr die Menschen wissen, desto weniger müssen sie glauben!"

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
Ich kann vieles, darf aber nicht alles.
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

-------------

Hardware:

:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz (8 CPUs), ~2.3GHz
12288 MB RAM
DirectX 12
Intel(R) UHD Graphics (für Import, Verarbeitung, Export [Video deluxe 2023 | Video Pro X 14 | Photostory Deluxe 2023])
NVIDIA GeForce MX250 (wird nicht in Schnitt-SW verwendet)

---------------------------------------------

Edition    Windows 10 Home
Version    22H2
Installiert am    ‎15.‎10.‎2020
Betriebssystembuild    19045.2364
Leistung    Windows Feature Experience Pack 120.2212.4190.0

-----------------------------------------------

marboe schrieb am 29.01.2014 um 17:41 Uhr

Hallo OsCor,

dein Fehler ist nicht reproduzierbar. Bei mir klappt das einwandfrei.

Ich habe eine Slideshow in MouseOff und eine darüber erstellte Textzeile.

In der Vorschau ist das Erscheinungsbild so, wie man es gerne hätte.

Das funktioniert auch, wenn die Schrift des Textes so verändert wird, dass daraus ein Bild entsteht. (also zB Schatten oder Transparenz).

Wie genau hast du deine Schrift erstellt?  Da musst du irgendetwas anders gemacht haben. Gruß Martina

OsCor schrieb am 29.01.2014 um 18:05 Uhr

@BilderMacher

Das gelb hinterlegte Codeschnipsel verwirrt mich ein wenig: Seit wann erzeugt der Web Designer denn eine Datei namens index_alt_html_files? Ich habe die probeweise mal auf dem Server gelöscht, mit der Konsequenz, dass ein ganz rudimentäres Bild der Seite zu sehen war. Ich verschiebe die mal auf dem lokalen Ordner und schaue, was dann passiert.

@Martina

Dass der Fehler bei Dir nicht reproduzierbar ist, läßt mich hoffen, dass ich das auch auf die Reihe kriege. Aber ich habe noch keine Ahnung, wie.

Gruß

Oswald

OsCor schrieb am 29.01.2014 um 20:23 Uhr

Zefix, ich kriegs nicht gebacken! Bei mir bleibt die Schrift immer hintendran!

marboe schrieb am 30.01.2014 um 09:27 Uhr

Hi Oswald, welche Slideshow hast du genau eingebaut? Gruß Martina

BilderMacher schrieb am 30.01.2014 um 09:44 Uhr

Hi Oswald, welche Slideshow hast du genau eingebaut? Gruß Martina

Es liegt am Slider, leider!

 

 

Zuletzt geändert von BilderMacher am 30.01.2014, 09:44, insgesamt 1-mal geändert.

"Je mehr die Menschen wissen, desto weniger müssen sie glauben!"

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
Ich kann vieles, darf aber nicht alles.
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

-------------

Hardware:

:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz (8 CPUs), ~2.3GHz
12288 MB RAM
DirectX 12
Intel(R) UHD Graphics (für Import, Verarbeitung, Export [Video deluxe 2023 | Video Pro X 14 | Photostory Deluxe 2023])
NVIDIA GeForce MX250 (wird nicht in Schnitt-SW verwendet)

---------------------------------------------

Edition    Windows 10 Home
Version    22H2
Installiert am    ‎15.‎10.‎2020
Betriebssystembuild    19045.2364
Leistung    Windows Feature Experience Pack 120.2212.4190.0

-----------------------------------------------

OsCor schrieb am 30.01.2014 um 11:04 Uhr

Hallo Ihr beiden!

Es ist tatsächlich der Slidorion Akkordeon rechts, mit dem man außer dem Foto auch noch Zusatzinfos anbieten kann. Eigentlich eine sehr elegante Möglichkeit, ein breites Portfolio anzubieten.

Ich meine, es ist nicht soo schlimm, wenn ich den Schmuckschriftzug ein wenig höher ziehen muss. Aber wenn man gerade ein feines Detail gefunden zu haben meint, wäre es halt der saure Apfel, in den man nur ungern beißt. Ich tröste mich in solchen Fällen damit, dass 99% der Besucher dieses Detail überhaupt nicht beachten 

Gruß

Oswald

OsCor schrieb am 30.01.2014 um 17:13 Uhr

Ein Zusatz, der mir wichtig genug erscheint, einen extra Beitrag zu schreiben: Ich habe bei Magix.info angefragt, ob es sich bei dem Verhalten des angesprochenen Widgets um ein Feature oder einen Bug handelt und ob im letzteren Fall Aussicht auf Änderung besteht. Die Antwort werde ich hier einstellen.

Gruß

Oswald

BeRo schrieb am 30.01.2014 um 21:47 Uhr

@ OsCor

Frei nach Bill Gates, wird es sich bei dem Verhalten des Widgets natürlich um ein Feature handeln...

Du kannst das Verhalten aber zu Deinen Gunsten verändern, wenn Du dem Grafiktext, den Du (teilweise) auf der Slidorion Slideshow sehen willst, einen höheren z-index Wert verpasst.

Die Slideshow bekommt über ein JQuery Script einen z-index von 6. Sie liegt damit über vielen anderen Objekten, die der WD anlegt.
Gibst Du Deinem Grafiktext einen höheren z-index Wert, siehst Du ihn in jedem Fall vollständig, er wird also nicht mehr von der Slideshow abgeschnitten.

Nach der Änderung sieht das Ergebnis z. B. so aus:

 

Die dazu nötige Änderung muss in der Datei "index.htm" vorgenommen werden.
Dazu musst Du Dein Projekt zunächst in ein Verzeichnis auf Deinem PC exportieren. Anschließend öffnest Du die Datei "index.htm" mit einem einfachen Texteditor, z. B. Notepad++
Such die Zeile, in der Dein Grafiktext definiert wurde und hänge vor dem abschließenden Anführungszeichen das folgende z-index Statement an: " z-index: 10;"

So sieht das für das o. a. Beispielbild aus:

Die Auswirkung der Änderung kannst Du nur sehen, wenn Du die exportierte/geänderte "index.htm" doppelt klickst. In der WD Vorschau funktioniert das nicht.

Da der WD beim Veröffentlichen des Projekts die Änderungen zurücksetzt, musst Du die "index.htm" vor der Veröffentlichung sichern, z. B. in einem anderen Verzeichnis und sie nach der Veröffentlichung des Projekts manuell auf den Webspace schieben.

Viel Erfolg

Zuletzt geändert von BeRo am 30.01.2014, 21:48, insgesamt 2-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

OsCor schrieb am 30.01.2014 um 22:38 Uhr

Hallo BeRo,

es ist gewiß nicht zuviel behauptet, wenn ich sage, dass ich platt bin und Augen wie Wagenräder habe vor Staunen: Es klappt!

So, das hatte ich geschrieben vor 10 Minuten nach dem ersten Anblick der Startseite. Dann wollte ich mich weiter ergötzen an meiner Pracht… tja, und was passiert? Nach 4 Fotos ist der Slider die Sache leid und schiebt sich wieder nach vorn. Dann macht man einen Refresh und die Sache geht von vorne los .

Edit: Was ich noch gemacht habe: Alle Vorkommen von slidorion gesucht, aber keines gefunden, wo man einen z-index hätte verändern können. Aber im Ordner index_htm_files gibt es eine nivo-slider.css Datei. Allerdings ist da keiner der z-Indizes höher als 9: Den z-index meines Schriftzuges von 10 hätte das also nicht übertroffen.

Gruß und ein dickes Danke!

Oswald

BeRo schrieb am 30.01.2014 um 22:59 Uhr

[...] was passiert? Nach 4 Fotos ist der Slider die Sache leid und schiebt sich wieder nach vorn [...]

Du hast recht. Ich konnte das nachstellen

Aber Da kannst Du locker mithalten...

Ändere den z-index Wert einfach auf z. B. "100" , dann ist das neue Problem auch vom Tisch. Zumindest habe ich bei etlichen Slide-Wechseln keine Probleme gesehen.

Das für den originalen z-index Wert der Slideshow zuständige JQuery Script ist sehr komplex. Schon bei oberflächlicher Analyse kann man sehen, dass der z.-index Wert für unterschiedliche Objekte mehrfach manipuliert wird. Da der Ausgabewert durch Variable gesteuert wird, ist der tatsächliche Wert nur sehr aufwändig zu ermitteln.

Mit dem o. a. Wert von "100" solltest Du aber auf der sicheren Seite sein. Wenn es dennoch Probleme gibt, kannst Du ohne weiteres auch einen Wert von "1000"- oder mehr einsetzen...

Viel Erfolg

--------------------

Edit 23:14 h

Nachtrag zu Deiner Info von 23:05 h.

Den "Urheber" des Problems findest Du in der komprimierten JQuery Datei "jquery.slidorion.min.js"

Hier ein Auszug:

Zuletzt geändert von BeRo am 30.01.2014, 23:14, insgesamt 3-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

OsCor schrieb am 30.01.2014 um 23:21 Uhr

Ah, jetzt, ja! Meine Güte! Morgen lasse ich den Slider mal einige Zeit Fotos schieben mit dem jetzigen z-Wert von 100. Die angenommene Besuchszeit für diese Seite sollte dieser Wert halten. Den 1000-er habe ich ja noch in Reserve . Und die Script-Datei schaue ich mir auch mal an. Ich habe schließlich viele Jahre lang Software entwickelt, allerdings keine Webentwicklung - wenn man von der Erzeugung von html-Dateien per Delphi mal absieht.

Gute Nacht

Oswald

BeRo schrieb am 31.01.2014 um 00:03 Uhr

[...] Den 1000-er habe ich ja noch in Reserve [...]

Vielleicht brauchst Du ihn tatsächlich...

Den Firefox Analysetools sei Dank, war unschwer festzustellen, dass das die Slideshow steuernde Skript den z-index Wert tatsächlich bei jedem Durchlauf um den Wert "6", also um die Anzahl der gezeigten Bilder erhöht.

Nach 8 Durchläufen steht der Wert demnach schon bei 48:


[...] Die angenommene Besuchszeit für diese Seite sollte dieser Wert halten [...]

Das ist schon mal eine Messlatte. Da es nichts kostet, kannst Du aber getrost eine x-fache Sicherheit einbauen.

Viel Erfolg

 

Zuletzt geändert von BeRo am 31.01.2014, 00:07, insgesamt 2-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

OsCor schrieb am 31.01.2014 um 09:21 Uhr

Hallo BeRo,

also kommt der Tausender doch zum Einsatz. Es ist nämlich noch nicht vollständig geklärt, wieviele Bilder in der Show durchlaufen sollen; dreie mehr brächten den Hunderter möglicherweise schon ins Wanken! Aber da draus ergibt sich natürlich die Sinnfrage, wie lange ein Besucher willens ist, das Ende der Show abzuwarten bzw. was man dem Besucher sinvollerweise zumutet.

Das Ergebnis Deiner Nachforschung ist für mich, dass das Verhalten des Skripts im Falle des z-Index mir nicht unbedingt sinnvoll erscheint, dass also der Begriff Bug evtl. durchaus berechtigt wäre.

Gruß

Oswald

BeRo schrieb am 31.01.2014 um 10:34 Uhr

[...] dass also der Begriff Bug evtl. durchaus berechtigt wäre. [...]

Sagen wir mal, dass die Entwickler der Slideshow vielleicht etwas ungeschickt- oder nachlässig agiert haben. Das Script ist so angelegt, dass jedes neu eingeblendete Bild einen höheren z-index Wert bekommt, als das vorhergehende, damit es immer oben auf dem Stapel angezeigt wird

Soweit ist das sicher i. O. Hätten die Entwickler nun nach Durchlaufen aller Bilder den z-index Wert wieder auf "0" gesetzt und dem letzte Bild einen z-index Wert von "-1" gegeben, wäre alles perfekt...

AFAIK ist der Maximalwert für z-index nur von den Möglichkeiten des gerade genutzten Browsers abhängig. Der IE soll da schon bei "2147483647" schlapp machen

Wenn Du den o. a. Grenzwert ausnutzt, bleiben einem Besucher Deiner Site ca 340 Jahre Zeit, in denen er die Site an jedem Tag 24 Stunden lang ansehen kann...

Die Aussage gilt, wenn Die anzuzeigenden Bilder eine Standzeit von 5 Sekunden haben.
Die Anzahl der Bilder ist dabei unerheblich, weil bei z. B. bei 9 Bildern auch die Zeit 9 x länger dauert, bis der der z-index Wert um den Wert "9" angehoben wird.

Sei also ruhig großzügig, bei der Vergabe des z-index Wertes.

Viel Erfolg

 

Zuletzt geändert von BeRo am 31.01.2014, 10:36, insgesamt 2-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

OsCor schrieb am 31.01.2014 um 11:30 Uhr

Wenn Du den o. a. Grenzwert ausnutzt, bleiben einem Besucher Deiner Site ca 340 Jahre Zeit, in denen er die Site an jedem Tag 24 Stunden lang ansehen kann... :-D

Ich werde mir es aber dennoch verkneifen, dazu zuschreiben „Lassen Sie sich ruhig Zeit”

Für Deine investierte viele Zeit danke ich Dir ganz herzlich

Oswald