Web Designer 10 Bilder einbinden

Peter_P schrieb am 31.03.2015 um 16:45 Uhr

Hallo,

 

meine seite wird immer besser, was ich jedoch noch nicht ganz lösen könnte,
ist das einbinden von EXTRA bildern, die vorgegebenen bilder habe ich ausgetauscht, also alles gut..

nur wenn ich neue bilder in die seite ziehe veschwinden sie hinter der textebene
- und eins nach vorne etc bringt nix.

ggf mag mal jemand drauf schauen...

http://vdna.de/test/index.htm

bei Über uns und Ihre Fragen klappt es noch nicht wie ich will

 

und dann noch
Technische Probleme :  Seite Übersicht

wenn man die Button

Leistungen, Finanzielles, Rechtliches, usw. anklickt, erscheint die gewünschte Fläche zwar,
aber beim Runterscrollen bzw reinklicken springt man gleich auf die Seite
Was genau bedeutet 24 Stunden Betreuung? zurück

http://vdna.de/test/uebersicht.htm

 

 

besten dank gruß peter

Kommentare

BeRo schrieb am 31.03.2015 um 18:48 Uhr

[...] wenn ich neue bilder in die seite ziehe veschwinden sie hinter der textebene [...]

Mit größter Wahrscheinlichkeit ist das das klassische Ebenen Problem.

Das heißt, dass Du die Bilder in das Editor Fenster ziehst, während eine andere Ebene als die "MouseOff" Ebene aktiv ist.

Abhilfe: Klicke zunächst die MouseOff Ebene, um sie zu aktivieren und ziehe erst dann die Bilder ins Fenster...

Viel Erfolg

Zuletzt geändert von BeRo am 31.03.2015, 18:48, insgesamt 1-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

Peter_P schrieb am 01.04.2015 um 13:56 Uhr

so wie ich rausgefunden habe, wo ich hinklicken muss, mach ich das,
es hört sich aber genau an wie meine lösung, melde mich in jedem fall,

wenn die bilder da sind wo sie hinsollen..

 

Danke

Peter_P schrieb am 01.04.2015 um 15:02 Uhr

- o -

Peter_P schrieb am 01.04.2015 um 15:05 Uhr

- o -

BeRo schrieb am 01.04.2015 um 15:36 Uhr

Du antwortest hier auf eine Antwort von mir, zu einer Frage, die Du in einem anderen Thread gestellt hast.

Wer soll denn daraus jetzt noch schlau werden?

Wenn Du Deine Antworten- und die neuen Fragen im richtigen Thread postest, gibt es auch passende Tipps...

Zuletzt geändert von BeRo am 01.04.2015, 15:36, insgesamt 1-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

BilderMacher schrieb am 01.04.2015 um 16:06 Uhr

Wir führen die Kommunikation zu diesem Thema hier weiter. Den anderen Thread schließe ich.

Das ist im Sinne aller, die Hilfe anbieten wollen und bringt Mitleser nicht zur Verzweiflung, weil sie nicht mehr dem "roten Faden" folgen können.

 

Zuletzt geändert von BilderMacher am 01.04.2015, 16:15, insgesamt 2-mal geändert.

"Je mehr die Menschen wissen, desto weniger müssen sie glauben!"

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
Ich kann vieles, darf aber nicht alles.
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

-------------

Hardware:

:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz (8 CPUs), ~2.3GHz
12288 MB RAM
DirectX 12
Intel(R) UHD Graphics (für Import, Verarbeitung, Export)
NVIDIA GeForce MX250 (wird nicht in Schnitt-SW verwendet)

---------------------------------------------

Edition    Windows 10 Home
Version    21H2
Betriebssystembuild    19044.1949

-----------------------------------------------

Peter_P schrieb am 01.04.2015 um 16:10 Uhr

 

Du antwortest hier auf eine Antwort von mir, zu einer Frage, die Du in einem anderen Thread gestellt hast.

Wer soll denn daraus jetzt noch schlau werden?

Wenn Du Deine Antworten- und die neuen Fragen im richtigen Thread postest, gibt es auch passende Tipps...

 

ja habe ich getan... Sollte passen - leider zu selben zeit als du es auch regeln wolltest

BeRo schrieb am 01.04.2015 um 17:59 Uhr

In Deinem zwischenzeitlich geschlossenen Thread hattest Du geschrieben...

Ich erlaube mir mal ein bild anzuhängen,

das mit dem lock hat schon auswirkungen leider noch nicht die gewünschten, den welche der popup-seiten muss gelockt werden

das sind die eigenschaften der Navi-leiste links, ggf stört das Standart ?

den unabhängig wo ich das lock setze blockiert das nav-menü.

Auf den gezeigten Screenshots sehe ich nicht, dass Du eine Ebene "gelockt" hättest...

Unabhängig davon solltest Du, wie schon gesagt,  jede popup Ebene mit der "lock" Eigenschaft versehen, die Du über die Link Buttons einblendest.

Zu der Info, wie diese popup Ebenen wieder geschlossen werden können,  hatte ich Dir schon einen Link gegeben.

Probier's also nochmal und wenn Du nicht klar kommst, schreibe bitte genau was Du gemacht hast und was ggf. nicht funktioniert hat...

Viel Erfolg

Zuletzt geändert von BeRo am 01.04.2015, 17:59, insgesamt 1-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

Peter_P schrieb am 01.04.2015 um 18:29 Uhr

um weiter mißverständnisse zu unterbinden habe ich eine neue version online geladen..

mit folgenden einstellungen

 

www.vdna.de/test/

wie ich sehe macht das lock bei mir nicht das was es soll den es blockiert die Übersicht seite...

gruß

peter

BeRo schrieb am 01.04.2015 um 21:23 Uhr

[...] wie ich sehe macht das lock bei mir nicht das was es soll den es blockiert die Übersicht seite. [...]

Die "Lock" Funktion macht genau das, was sie soll.
Sie sorgt dafür, dass die per popup eingeblendeten Ebenen nicht inaktiv werden, wenn irgendwo auf den Seitenbereich geklickt wird.

Wenn Du die zuletzt eingeblendete popup Ebene wieder ausblenden willst und damit die "Übersicht" Seite wieder angezeigt werden soll, legst Du am besten einen kleinen JavaScript Befehl auf den Button "zurück", der die Seite "Übersicht" neu startet. Damit sind alle popup Ebenen automatisch wieder ausgeblendet.

So sieht der JavaScript Aufruf aus:

-------------------------
javascript:location.reload()
-------------------------

Die Zeile trägst Du  als Link für den Button "zurück" ein.

Für eine NavBar sieht der Eintrag z. B. so aus:

Probier's nochmal...

Viel Erfolg

Zuletzt geändert von BeRo am 01.04.2015, 21:23, insgesamt 1-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

Peter_P schrieb am 02.04.2015 um 08:53 Uhr

Guten Morgen,

Lies sich gut, 

Die "Lock" Funktion macht genau das, was sie soll. ;-) Trifft aber nicht zu.

d.h. die lock funktion schein schon ok, aber das ergebnis entspricht nicht dem was ich will.
der ZURÜCK-Button verweit auf die seite Übersicht was ja ohne den Lock auch gut klappt

denn wenn ich die seite öffne

www.vdna.de/test/   dann auf übersicht dann im nav-bereich auf
Leistungen
Finanzielles
Rechtliches
Ihre Vorteile

passt alles wie du sagt...

Danach aber steht die seite. der Zurück button macht gar nix...
dann wäre deine lösung Java... ein guter ansatz - dazu unten mehr...

ABER

wenn ich die seite öffne

www.vdna.de/test/   dann auf übersicht dann im nav-bereich auf

zB Ihre Vorteile friert die seite ein....
und um dies zu beseitigen ist es notwentig die übersichtsseite zu verlassen,

zB Kontakt um dann erneut zurück zukehren
deshalb meine ich das da noch was anderes hängt...

ZUM Java-ansatz

würde mir gut gefallen, jedoch weiß ich nicht wie die zeile bearbeitet werden kann

ggf gibts da noch ein türchen :-)

gruß

peter

BeRo schrieb am 02.04.2015 um 18:29 Uhr

[...] deshalb meine ich das da noch was anderes hängt... [...]

Ja, da hängt noch was. Aber das kannst Du ganz einfach lösen.

Hintergrund des Problems ist die Ebenen Technik, die der WD verwendet. Beim Einblenden einer Ebene, wird die zuvor eingeblendete Ebene nicht ausgeblendet, wenn sie die Eigenschaft "Lock" hat.
Wie schon beschrieben ist für die popup Ebenen die Eigenschaft "Lock" aber notwendig.

Die Lösung des Problems ist deshalb einfach, weil Du nur dafür sorgen musst, dass eine eingeblendete Ebene dann geschlossen wird, wenn du eine bestimmte Mausaktion ausführst. In Deinem Fall ist das ein Klick auf einen der NavBar Buttons.
Der Klick muss also 2 Aktionen einleiten: Das Ausblenden einer Ebene- und das Einblenden einer anderen Ebene.
Dazu muss der Link ein JavaScript Befehl sein, der 2 verschiedene Funktionen aufruft.

So kann ein entsprechender Link aussehen:

---------------------------
javascript:my_CloseAll(), xr_cpu(4)
---------------------------

Die Funktion "my_CloseAll()" sorgt dafür, dass alle eingeblendeten Ebenen ausgeblendet werden. Die Funktion "xr_cpu(4)"  blendet die Ebene mit dem Indexwert 4 ein.

Klick mal hier, da habe ich detailliert beschrieben, wie das umgesetzt werden kann. Da findest du auch den kompletten JS Code für die Funktion "my_CloseAll()".
Die online Demo findest Du hier. und die Projektdatei zum Download gibt es hier.

Jetzt sollte dem Erfolg nichts mehr im Weg stehen...

Zuletzt geändert von BeRo am 02.04.2015, 18:29, insgesamt 1-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

Peter_P schrieb am 02.04.2015 um 18:56 Uhr

kann allles in der theorie nachvollziehen, jedoch die praxis mag noch nicht :-(

ich weiß nicht wie die zeile URL fürs JAVA  bearbeitet werden kann...

es scheint als wenn dies meine "letzte" hürde in dieser angelegenheit wäre ..

hast du noch nen tipp

danke

peter

BeRo schrieb am 02.04.2015 um 21:00 Uhr

[...] ich weiß nicht wie die zeile URL fürs JAVA  bearbeitet werden kann [...]

Sei froh, dass es kein Java Programm ist, das Du eintragen musst. Es ist "nur" JavaScript.

So geht's:

Und dann:

Das war's schon.

Viel Erfolg

Zuletzt geändert von BeRo am 02.04.2015, 21:00, insgesamt 1-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

Peter_P schrieb am 08.04.2015 um 13:11 Uhr

ziemlich froh, dass es kein JAVA ist habe ich die scriptzeilen eingetragen,

leider noch nicht mit dem gewünschtem ergebnis...

Jetzt bewegt sich gar nichts meht, heißt das nav-menü in der übersichtsseite ignoriert das klicken...

vdna.de/test

ÜBERSICHT

Evtl. interessant, die seite (im bereich ÜBERSICHT) welche beim bearbeiten aktiv war, z.B. leistung , finanz. rectliches, ihre vorteile... bleibt nach dem hochladen sichtbar

BeRo schrieb am 09.04.2015 um 00:03 Uhr

[...] das nav-menü in der übersichtsseite ignoriert das klicken. [...]

Im Quellcode der Seite "uebersicht.htm" sind beim ersten Durchsehen schon die u. a. Auffälligkeiten zu finden:

  • Die Funktion "my_CloseAll()" wurde nicht definiert. Der entsprechende JS Code gehört in den HTML Head der Seite.
  • Die Indexwerte der popup Ebenen scheinen falsch zu sein. Du hast die Werte 22-25 verwendet, vom WD wurden aber Zuordnungen von 32-35 vergeben.
  • Die NavBar für die Unterseiten scheint in einer falschen Ebene zu liegen. Trifft das zu, ist das schon ein Grund für die Fehlfunktion...

Die genaue Analyse der Seite ist sehr aufwändig, wenn nur der Quellcode zur Verfügung steht. Das will ich mir nicht wirklich antun.

Wenn Du aber ein paar (lesbare) Screenshots der aufgeklappten popup Ebenen postest und eine Beschreibung anhängst, wie, auf welcher Ebene Du das Untermenü angelegt hast, kann man das Problem sicher besser erkennen.

CU

 

Zuletzt geändert von BeRo am 09.04.2015, 00:03, insgesamt 1-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

Peter_P schrieb am 09.04.2015 um 17:16 Uhr

HALLO ICH SCHREIB MAL GROSS; IST ABER NICHT BÖSE GEMEINT :-)

[...] das nav-menü in der übersichtsseite ignoriert das klicken. [...]

Im Quellcode der Seite "uebersicht.htm" sind beim ersten Durchsehen schon die u. a. Auffälligkeiten zu finden:

  • Die Funktion "my_CloseAll()" wurde nicht definiert. Der entsprechende JS Code gehört in den HTML Head der Seite.

HABE ICH BISHER NOCH NICHT GEWUSST; WAR WÄRE DEN DER ENTSPRECHENDE UND WO TRAGE ICH DEN EIN - einfach in head geht ja nicht wie ich meine weil das programm es wieder überschreibt - ODER GIGTES EIN MENUE DAS ICH AUS DEM PROGRAMM ANKLICKEN KANN?

 

  • Die Indexwerte der popup Ebenen scheinen falsch zu sein. Du hast die Werte 22-25 verwendet, vom WD wurden aber Zuordnungen von 32-35 vergeben.

INTERESSANTE THESE ICH HABE IN DER BESCHREIBUNG GELESEN; MIT MAUS ÜBER DEN BUTTON UND UNTEN LINKS IM BROWSWEFENSTER STEHT DANN NE ZAHL...

SIEHT BEI MIR SO AUS...

 

 

  • Die NavBar für die Unterseiten scheint in einer falschen Ebene zu liegen. Trifft das zu, ist das schon ein Grund für die Fehlfunktion...

DIE NAVBAR LIEGT DA SEIT ANBEGINN ICH  MEINE NIX VERÄNDERT ZU HABEN UND OHNE LOCK WAR DIE BEDIENUNG PROBLEMLOS MÖGLICH - schließt aber nicht das das es trotzdem falsch ist...

 

Die genaue Analyse der Seite ist sehr aufwändig, wenn nur der Quellcode zur Verfügung steht. Das will ich mir nicht wirklich antun.

Wenn Du aber ein paar (lesbare) Screenshots der aufgeklappten popup Ebenen postest und eine Beschreibung anhängst, wie, auf welcher Ebene Du das Untermenü angelegt hast, kann man das Problem sicher besser erkennen.

HIER EIN PAAR HOFFE DA IST WAS DRAUF WAS WEITER HILFT...

 

CU

 

so das wäre es erstmal wenn genauere infos gewünscht mache ist das gerne, habe auch schon ein schlechtes gewissen wegen deiner zeit... kann auch gerne die ganze datei senden ca. 1,5 MB - woe bist du den zuhaus ggf treffen wir uns ja mal kommt ja bald die biergartenzeit das gibts auch spezi :-)

BeRo schrieb am 09.04.2015 um 23:11 Uhr

[...] HABE ICH BISHER NOCH NICHT GEWUSST; WAR WÄRE DEN DER ENTSPRECHENDE UND WO TRAGE ICH DEN EIN [...]

Zu Deiner Eingangsfrage hatte ich Dir hier, am 2.4. einen Link gegeben, der zu diesem Kommentar führt, in dem ich u. a. genau erklärt habe, wie die Funktion "my_closeAll()" funktioniert-, wie sie eingebaut wird- und wie sie aussieht. Außerdem findest Du in dem verlinkten Thread detaillierte Informationen zur Anlage- und zur Notwendigkeit von Dummy Linkbutton.

Wenn Du ohne diese Infos versucht hast, Dein Problem zu lösen, wundert es mich nicht, dass es nicht geklappt hat.

[...] INTERESSANTE THESE ICH HABE IN DER BESCHREIBUNG GELESEN; MIT MAUS ÜBER DEN BUTTON UND UNTEN LINKS IM BROWSWEFENSTER STEHT DANN NE ZAHL... [...]

Das ist prinzipiell richtig. Der Link, den Du abgelesen hast, ist aber nicht der direkte Link auf eine popup Ebene sondern der JavaScript Eintrag, den Du dem Linkbutton manuell verpasst hast.
Den korrekten Link kannst Du nur sehen, wenn Du einem beliebigen Objekt (z. B. einem Dummy Button) einen direkten "Link auf Popupebene" (s. Screenshot)

 

[...] HIER EIN PAAR HOFFE DA IST WAS DRAUF WAS WEITER HILFT... [...]

Das, was auf den Screenshots zu erkennen ist, sieht normal aus. Insofern tragen sie also leider nicht zur Fehleranalyse bei

[...] kann auch gerne die ganze datei senden ca. 1,5 MB [...]

Die Projektdatei ist sicher die 1. Wahl, wenn es um die Beurteilung mysteriöser Fehler geht...

Verpacke die *.web Datei einfach als ZIP Archiv und kopiere sie (z. B. mit FileZilla) auf Deinen Webserver. Wenn Du die URL für die ZIP Datei hier postest, kann sich jeder ein genaues Bild Deines Problems machen.

Eine Lösung wird dann nicht lange auf sich warten lassen

Viel Erfolg

-------------------------
P.S.
Es ist sinnvoll, bei eigenen Antworten nicht den kompletten Text zu zitieren, den du als Antwort erhalten hast. Das sogenannte "Fullquote" ist überflüssig und unübersichtlich.
Es genügt, wenn Du ein paar relevante Worte aus der erhaltenen Antwort zitierst, zu denen Du selbst Stellung nehmen willst. Diese Worte kopierst Du in Deine Antwort und markierst Sie als Zitat, indem Da das Zitat Icon klickst.

Zuletzt geändert von BeRo am 09.04.2015, 23:11, insgesamt 1-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

Peter_P schrieb am 10.04.2015 um 12:29 Uhr

<script type="text/javascript">
window.onload=(xr_cpu(8));
</script>

findet sich bei mir deshalb nicht, weil ich es überlesen habe...

NUR wer sagt mir welche zahl bei mir stimmt ??? xr_cpu(8) die 8 wird es wohl kaum sein 

u.a. meine bitte die datei mal anzuschauen den ich glaube nun wieder an eine lösung,
jedoch nicht wenn ich das projekt weiter kaputt-repariere ;-(

hier die datei.. besuchensie.de/imalterdaheim.zip

dann wird sicher auch meine "noch" unfähigkeit fragen vernünftig zu formulieren ein ende haben ;-)

guten start ins wochende..

peter

 

BeRo schrieb am 10.04.2015 um 19:02 Uhr

[...] </script> findet sich bei mir deshalb nicht, weil ich es überlesen habe..  [...]

Dann hast Du den Wald vor lauter Bäumen nicht gesehen, denn das Script öffnet in der von mir beschriebenen Demo lediglich die Standard popup Ebene.
Mit der gesuchten Funktion "my_closeAll()" hat es nichts zu tun. Du musst es also nicht einbauen.

[...] meine bitte die datei mal anzuschauen [...]

Gerne. und da sieht man schon nach 10 Sekunden, wo das Problem liegt.

Du hast keine Dummy Links auf die popup Ebenen angelegt, die notwendig sind, weil ansonsten der WD die Indexwerte nicht setzt!
Diese Dummy Links müssen direkt auf die popup Ebene zeigen. Sie dürfen also keine JavaScript Statements enthalten.
 

Auch der Code für die schon besprochene Funktion "my_closeAll()" fehlte.

Der gehört zwingend in den HTML Head der Seite "uebersicht"

Hier ist der komplette Code, den Du mit copy & paste übernehmen kannst:

---------------------------
<script type="text/javascript">
function my_CloseAll(){var ll=document.getElementsByTagName('div');for(var i=ll.length-1;i>=0;i--){if(ll[i].id.indexOf("xr_xp")==0){xr_v0(ll[i]);};};};
</script>

--------------------------

Und hier kannst Du Dir die reparierte, funktionsfähige Projektdatei herunterladen

Jetzt sollte dem weiteren Vergnügen beim Erstellen Deiner Website nichts mhr im Weg stehen

Zuletzt geändert von BeRo am 10.04.2015, 19:04, insgesamt 2-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

Peter_P schrieb am 10.04.2015 um 22:45 Uhr

Hallo und guten Abend BeRo, und mitleser...

 

na klar habe ich sofort deine datei geladen und in vdna.de/test3 geschickt...

und siehe da alles gut, was ich mich gefreut habe, allein zu sehen das es klappt ;-)))
ja dann wollte ich es auch verstehen und näherte mich mit ganz kleinen schritten....

die smartphone version war noch auf meinen als defekten stand, ich kopierte die da fehlenen dummis rüber baute baute direkte links zum dokumenten das vorher mit (lock) versehen waren..

danach in der navbar schnell noch javascripte 22-25 eingefügt und bei der zurücktaste mit uebersicht.htm eingetragen

so und da ging es schon los, da stand dann immer http://uebersicht.htm was natürlich zu einer fehlerseite im netz führte, also uebersicht.htm wieder eingetragen und AUTOMATISCH KORRIGIEREN rausgemacht also geht..

ICH HELD dachte ist - nur nach erneutem upload, war alles wie ich es von meinem webfähigkeiten her kenne...
diemobiele seite kann nix - im bereich übersicht die extra-navbar steht
macht ja nix, suche ich halt ein paar stunden nach dem fehler - head-code drin rechtschreibung in der datei scheint auch zu passen - aber es geht nicht....

nun habe deine von mit im smartphone bereich verbastelte datei nochmal hochgeladen, in der hoffnung das du nochmal ein 10sec meine nadel im heuhaufen findest...

schönes wochenende an alle...

gruß

peter

 

 

BeRo schrieb am 10.04.2015 um 23:37 Uhr

[...] in der hoffnung das du nochmal ein 10sec meine nadel im heuhaufen findest... [...]

Na ja, "back to the roots" ist die Lösung und dann noch eine kleine Anpassung.

Ändere in beiden Varianten (Smartphone + Desktop) den Link für den "zurück" Button auf "javascript:my_CloseAll()", dann sollte es klappen.

Es ist kontraproduktiv, wenn du die Dummy Buttons in der Smartphone Variante erneut anlegst. Da der WD die Link Info aus der Desktop Variante benutzt kommt es zu Kollisionen, die die Link Funktion stören.

Du musst (darfst) also die NavBar nicht weiter "verbessern". Benutze die Projektdatei, die ich Dir zum Download angeboten habe und ersetze den Link auf die "uebersicht" Seite mit dem oben gezeigten Codeschnipsel.

Viel Erfolg

Zuletzt geändert von BeRo am 10.04.2015, 23:37, insgesamt 1-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

Peter_P schrieb am 11.04.2015 um 20:21 Uhr

Guten abend,

da bin ich wieder, habe nahezu alle anweitunhen befolgt weiles fast perfekt funtioniert..

desktopseite ganz prima weil ich die finger davon ließ...

siehe imalterdaheim.de

smartphone schwächelt die übersichtsseite noch ein bisserl, die navbar läßt sich nur von links nacht rechts bedienen - nur durch drücken - des zurück knopfes - komme ich auf die links-liegenden seiten , aber wenns das das endergegnis ist soll es mir recht sein...

die inhalte können alle angezeigt werden -

auffällig ist, das die desktopseite von 22-25 linkt
und die handyseite von 32-35
und der javabefehl des head 2 mal im quelltext auftaucht

schönes restwochenende und danke für die unterstützung -
und BeRo sollte ich mal was in Sachen RC-Modellflug für dich zun können laß es mich wissen.

 

gruß
peter

 

PS. als ich hier anfang mit WD - was eine meiner fragen welche seiten den schon damit gebaut wurden..
hier meine bisherigen projekte im-alter-daheim.de
(wie man eine Handy-seite daraus baut finde ich hoffendlich noch raus :-)

BeRo schrieb am 11.04.2015 um 21:44 Uhr

[...] smartphone schwächelt die übersichtsseite noch ein bisserl, die navbar läßt sich nur von links nacht rechts bedienen [...]

Wenn Du die erste-, reparierte Projektdatei heruntergeladen- und den Link für den "Zurück" Button geändert hast, funktioniert jede Variante einwandfrei (getestet mit Android Smartphone/Tablet, IE11, FF37).

Hier findest Du die dazu gehörende online Demo und hier die zu der Demo gehörende Projektdatei, inkl. aller Änderungen.

Bevor Du daran "Anpassungen" vornimmst, teste die Projektdatei nach einem lokalen Export ausgiebig...

Viel Erfolg

 

Zuletzt geändert von BeRo am 11.04.2015, 21:44, insgesamt 1-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓