Wie 360°-Panorama in HP einbinden?

jsffm schrieb am 14.07.2016 um 17:18 Uhr

Hallo, ich versuche seit etlichen Tagen ein mit PT Gui erstelltes 360°-Panorama auf meine HP einzubinden.

Es gibt in diesem Programm eine Funktion "Puplish to Website", hierbei werden diverse jpg´s, eine html-datei, ein PTGuiViewer.js und eine PTguiViewer.swf-Datei erstellt.

Diese soll man dann auf seinen Webserver hochladen und die html-Datei verlinken und schon könnte man das Pano auf seiner HP anschauen.

Irgdenwie bin ich aber diesbezüglich ein blutiger Anfänger oder einfach nur doof.

Meine Fragen nun:

Wie verlinke ich ein Objekt auf meiner HP mit dieser html-Datei?

Oder gibt es da evtl. eine andere Lösung?

Benutze im übrigen den WebDesigner 12

Wäre um Hilfe wirklich dankbar.....Viele Grüße Jürgen

Kommentare

BeRo schrieb am 14.07.2016 um 23:57 Uhr

Die Lösung Deines Problems haben wir im Forum schon oft besprochen. Sie ist für viele Anwendungen gültig, die über eine eigene HTML Datei gestartet werden.

In den FAQ zum PT GUI ist das auch zu lesen:

-------------------------------------
go to Tools -> Publish to Website to open the authoring tool. [...] Press the Convert button to process the panorama. This creates a HTML page and 17 other files; all files should be uploaded to a folder on your web server. Then you may add a link from an existing page to the generated .htm page which will open the panorama.
------------------------------------

Wie die Lösung in der Praxis aussehen kann, das kannst Du z. B. hier nachlesen. Da haben wir vergleichbare Export Dateien des Image Sliders "JAlbum" mit der Methode in eine Seite des Web Designer eingebunden...

Probier's mal

Viel Erfolg

Zuletzt geändert von BeRo am 14.07.2016, 23:57, insgesamt 1-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

jsffm schrieb am 15.07.2016 um 15:09 Uhr

Soory, aber ich kriege es immer noch nicht hin.

Die Dateien sind auf dem Webserver (siehe Screenshots)

 

Und was muß ich jetzt genau in das Feld ""Link auf Internet oder E-Mail-Adresse" einsetzen?

Möglicherweise stelle ich mich hier auch besonders blöd an....Gruß Jürgen

 

PS. Kann man die Screenshots sehen?....Ich sehe nur irgendein Blitzsymbol

BeRo schrieb am 15.07.2016 um 15:35 Uhr

[...] Kann man die Screenshots sehen?....Ich sehe nur irgendein Blitzsymbol [...]

Die Screenshots sind leider nicht zu sehen.

[...] was muß ich jetzt genau in das Feld ""Link auf Internet oder E-Mail-Adresse" einsetzen? [...]

Wenn Du, wie in den PT GUI FAQ beschrieben,  die HTML Datei und die 17 anderen Dateien, die PT GUI generiert hat, in ein separates Verzeichnis auf Deinem Webspace abgelegt hast, dann verlinkst Du auf die HTML Datei.

Nehmen wir an, dass Du dem Unterverzeichnis auf Deinem Webspace den Namen "pano" gegeben hast und dass die vom PT GUI generierte HTML Datei "index.html" heißt, dann muss der Link so aussehen:

----------------------------
./pano/index.html
---------------------------

So sieht der Link im Editor aus:

Die Checkbox "Automatisch korrigieren" muss leer bleiben!

Also, auf ein Neues...

Viel Erfolg

P.S.
Ich weiß ja nicht, wie Du das Panorama präsentieren willst. Mit den o. a. Einstellungen wird jedenfalls eine Seite geöffnet, die nur das Panorama zeigt.
Wenn Du das Panorama als Teil einer bestehenden Seite sehen willst, solltest Du nicht direkt darauf verlinken. In dem Fall ist das Einbinden mit einem Platzhalter und einem passenden iframe Code sinnvoller...

Zuletzt geändert von BeRo am 15.07.2016, 15:42, insgesamt 2-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

jsffm schrieb am 15.07.2016 um 17:00 Uhr

Funktioniert leider immer noch nicht.....

Hier nochmal ein Screenshot vom Webserver-Verzeichnis....

Ich habe auf der leeren "index"-Seite meiner HP ein Rechteck damit verlinkt, ich wollte halt erstmal wissen ob das funktioniert bzw wie das dann aussieht.

Kann es sein daß das Panorama in der Vorschaufunktion nicht gezeigt wird?

Grüße Jürgen

 

BeRo schrieb am 15.07.2016 um 18:34 Uhr

[...] Ich habe auf der leeren "index"-Seite meiner HP ein Rechteck damit verlinkt [...]

Wie sieht denn der Link aus?

Der Screenshot der Dateiliste ist ja leider kaum zu lesen (zu großer Ausschnitt) aber soweit das zu erraten ist, heißt die HTML Startdatei für die Anzeige des Panoramas "DJI_0002-Panorama.htm".
Der Link, der auf die Panorama Seite zeigt, muss dann z. B. so aussehen, wenn Du ihn vollständig notieren willst:

jsffm.magix.net/pano/DJI_0002-Panorama.htm

Alternativ kannst Du die Kurzform "./pano/DJI_0002-Panorama.htm" benutzen

[...] Kann es sein daß das Panorama in der Vorschaufunktion nicht gezeigt wird? [...]

Wenn Du eine aktive Internetverbindung hast, sollte das Panorama auch in der Vorschau angezeigt werden, wenn Du die Langform des o. a. Links benutzt.

Die Kurzform funktioniert in der Vorschau auch offline, wenn Du den Ordner "pano" auf Deinem PC dort abgelegt hast, wo der WD die Site exportiert. Den Ablageort kannst Du vorgeben, wenn Du manuell einen HTML Export der Site in ein beliebiges Verzeichnis vornimmst.

Probier's nochmal

Zuletzt geändert von BeRo am 15.07.2016, 18:34, insgesamt 1-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

jsffm schrieb am 15.07.2016 um 18:54 Uhr

Jetzt mal ne grundsätliche Frage: Muss der Panoramaordner ein Unterorder meiner Homepage auf dem Webserver sein?

jsffm schrieb am 15.07.2016 um 19:13 Uhr

So hier nochmal ein Screenshot von der Verzeichnichstruktur des Websevers:

Und der Link den ich im WD eingetragen habe lautet: .pano/DJI_0082-Panorama.htm

Ich vermute daß das Problem irgendwo im Webserver-Verzeichnis bzw Pfad zu finden bzw. zu suchen ist.

 

Gruß Jürgen

BilderMacher schrieb am 15.07.2016 um 20:39 Uhr

Auf deinem Screen sieht man, dass der Ordner pano bei www.jsasse.de im Unterordner index_htm_file liegt!

Da findet sich aber nichts ...

Der Link (aus den einzelnen Ordnern zusammengesetzt) funktioniert nicht.

 

www.jsasse.de/V203/index_htm_files/pano/DJI_0082-Panorama.htm

Ist das ein L oder ein I - DJI?

Mache aus dieser DJI_0082-Panorama mal eine index.htm ... 

Zuletzt geändert von BilderMacher am 15.07.2016, 20:41, insgesamt 3-mal geändert.

"Je mehr die Menschen wissen, desto weniger müssen sie glauben!"

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
Ich kann vieles, darf aber nicht alles.
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

-------------

Hardware:

:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz (8 CPUs), ~2.3GHz
12288 MB RAM
DirectX 12
Intel(R) UHD Graphics (für Import, Verarbeitung, Export)
NVIDIA GeForce MX250 (wird nicht in Schnitt-SW verwendet)

---------------------------------------------

Edition    Windows 10 Home
Version    21H2
Betriebssystembuild    19044.1949

-----------------------------------------------

BeRo schrieb am 15.07.2016 um 20:47 Uhr

[...] der Link den ich im WD eingetragen habe lautet: .pano/DJI_0082-Panorama.htm [...]

Du hast das Verzeichnis "pano" im Verzeichnis "index_htm_files" angelegt, wie auch @BilderMacher schon angemerkt hat. In dem Fall muss der Link so aussehen:

./index_htm_files/pano/DJI_0082-Panorama.htm

Dass danach, beim Aufruf der Pano Seite, trotzdem eine Fehlermeldung erscheint, liegt daran, dass Du die Namen der Bilddateien manipuliert hast, ohne die Verweise darauf anzupassen.

Der PT GUI Viewer möchte die Datei "DJI_0082 Panorama_00.jpg" öffnen, Im Verzeichnis ist stattdessen die Datei "DJI_0082-Panorama_00.jpg" abgelegt. Klar, dass das nicht funktioniert.

Wenn Du das Minuszeichen in den Dateinamen durch ein Leerzeichen ersetzt, sollte es funktionieren...

Noch ein Versuch?

Zuletzt geändert von BeRo am 15.07.2016, 20:49, insgesamt 3-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

BilderMacher schrieb am 15.07.2016 um 21:02 Uhr

Der WebFTP-Verzeichnisbaum (im Screen) stimmt aber auch nicht mit dem Online-Verzeichnis überein ... Der Unterordner V203 ist nicht aktuell ...

http://www.jsasse.de/index_htm_files/pano/DJI_0082-Panorama_01.jpg

 

Zuletzt geändert von BilderMacher am 15.07.2016, 21:02, insgesamt 1-mal geändert.

"Je mehr die Menschen wissen, desto weniger müssen sie glauben!"

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
Ich kann vieles, darf aber nicht alles.
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

-------------

Hardware:

:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz (8 CPUs), ~2.3GHz
12288 MB RAM
DirectX 12
Intel(R) UHD Graphics (für Import, Verarbeitung, Export)
NVIDIA GeForce MX250 (wird nicht in Schnitt-SW verwendet)

---------------------------------------------

Edition    Windows 10 Home
Version    21H2
Betriebssystembuild    19044.1949

-----------------------------------------------

jsffm schrieb am 15.07.2016 um 21:11 Uhr

Ja, habe den Unterordner geändert....da ich den Ordner "V203" gelöscht habe und das ganze Panoramazeigs nochmal hochgeladen habe.

 

So, habe die Bindestriche entfernt....funktioniert immer noch nicht....

Hat jemand ne Möglichkeit per Remote auf meinen Rechner zuzugreifen....vielleicht kriegt man es ja so hin?

BeRo schrieb am 15.07.2016 um 21:19 Uhr

[...] funktioniert immer noch nicht.... [...]

Hmmm, wo hast Du denn geguckt?

Nimm mal diesen Link, dann siehst Du ein sehr schönes Panorama

Viel Spaß beim "Rundflug"

Zuletzt geändert von BeRo am 15.07.2016, 21:19, insgesamt 1-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

jsffm schrieb am 15.07.2016 um 21:24 Uhr

Bei mir kommt das da:

Ich kucke in der Vorschau des WD

Versteh ich jetzt auch wieder nicht: wenn ich deinen Link anklicke funktioniert es, versuche ich aber das Pano über die Vorschau des WD anzuschauen funktioniert es nicht.

BeRo schrieb am 15.07.2016 um 21:41 Uhr

[...] versuche ich aber das Pano über die Vorschau des WD anzuschauen funktioniert es nicht. [...]

Wie schon in meinem Posting von 18:34h geschrieben, muss eine aktive Internetverbindung bestehen und es muss die vollständige URL eingetragen werden, wenn Du das Panorama in der Vorschau sehen willst.

Aktuell müsstest Du also den u. a. Link eintragen:

http://www.jsasse.de/index_htm_files/pano/DJI_0082%20Panorama.htm

Wenn Du die Kurzform "./index_htm_files/pano/DJI_0082%20Panorama.htm" des Links benutzen willst, musst Du (wie schon erklärt) dafür sorgen, dass das Verzeichnis "pano" auf Deinem PC im Verzeichnis "index_htm_files" liegt, bevor Du die Vorschau öffnest.

Alle Klarheiten beseitigt?

Zuletzt geändert von BeRo am 15.07.2016, 21:41, insgesamt 1-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

jsffm schrieb am 15.07.2016 um 21:42 Uhr

Ich habe die Seite jetzt veröffentlicht.

Startseite:

Das schwarze Rechteck ist nur zu testzwecken da, dieses Rechteck habe ich mit der Panodatei auf dem Webserver verlinkt.

Wenn ich das Rechteck anklicke kommt das:

????

jsffm schrieb am 15.07.2016 um 21:47 Uhr

[...] versuche ich aber das Pano über die Vorschau des WD anzuschauen funktioniert es nicht. [...]

Wie schon in meinem Posting von 18:34h geschrieben, muss eine aktive Internetverbindung bestehen und es muss die vollständige URL eingetragen werden, wenn Du das Panorama in der Vorschau sehen willst.

Aktuell müsstest Du also den u. a. Link eintragen:

http://www.jsasse.de/index_htm_files/pano/DJI_0082%20Panorama.htm

Wenn Du die Kurzform "./index_htm_files/pano/DJI_0082%20Panorama.htm" des Links benutzen willst, musst Du (wie schon erklärt) dafür sorgen, dass das Verzeichnis "pano" auf Deinem PC im Verzeichnis "index_htm_files" liegt, bevor Du die Vorschau öffnest.

Alle Klarheiten beseitigt?

 

Ähm....nicht so ganz: Wenn ich den von dir oben geschriebenen Link einsetzen und dann die Vorschau im WD anklicke kommt auch nur das Magix Hier entsteht....bla bla bla-Bild.

jsffm schrieb am 15.07.2016 um 21:51 Uhr

Und nebenbei erwähnt: jetzt funktioniert gar kein Link mehr.....

http://www.jsasse.de/index_htm_files/pano/DJI_0082%20Panorama.htm

 

BeRo schrieb am 15.07.2016 um 21:57 Uhr

[...] dann die Vorschau im WD anklicke kommt auch nur das Magix Hier entsteht....bla bla bla [...]

Das liegt daran, dass Du in der Zwischenzeit fleißig Daten auf dem Webspace "herumgeschoben" hast. Dann greift der vorhin noch funktionierende Link natürlich ins Leere.

Wenn ich das richtig gesehen habe, dann hast Du jetzt die Startdatei "DJI_0082 Panorama.htm" aus dem Verzeichnis "pano" herausgenommen und in das Verzeichnis "index_htm_files" gepackt. Da scheinen aber die Bilddateien zu fehlen, was das Chaos perfekt macht.

Zuletzt geändert von BeRo am 15.07.2016, 21:57, insgesamt 1-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

jsffm schrieb am 15.07.2016 um 22:07 Uhr

Erwischt!.....im Moment sieht die Verzeichnis-Struktur so aus...

Unn das ist der Link dazu:

Und ich zweifle so langsam wirklich an mir selbst, das kann doch nicht so schwierig sein...

Sag jetzt nicht das es wieder an den Bindestrichen liegt...lach

BeRo schrieb am 15.07.2016 um 22:31 Uhr

[...] Sag jetzt nicht das es wieder an den Bindestrichen liegt [...]

Na ja, es bleibt mir nichts Anderes übrig.

Der PT GUI Viewer erwartet nun mal die Dateinamen ohne Bindestrich. Ersetze also mal wider alle Bindestriche in den Bilddateien durch Leerzeichen.
Du hast aber noch ein weiteres Problem "erfunden", mit dem Du Dir selbst ein Bein gestellt hast...

Das Verzeichnis "pano" hat jetzt einen neuen Namen bekommen, es heißt nun "Pano".
Was einem Windows PC völlig egal ist, lässt einen Unix befeuerten Apache Server scheitern. Der unterscheidet akribisch zwischen Groß- und Kleinschreibung. Wenn Du ihm sagst, er soll eine Datei im Verzeichnis "pano" öffnen, geht das nicht, wenn die Datei tatsächlich im Verzeichnis "Pano" liegt...

Entweder änderst Du den Verzeichnisnamen wieder in Kleinschreibung oder Du passt den Link an...

BTW
Das Wochenende ist noch lang...

 

 

Zuletzt geändert von BeRo am 15.07.2016, 22:31, insgesamt 1-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

jsffm schrieb am 15.07.2016 um 22:36 Uhr

Dann werde ich mich dranmachen.....bzw. morgen früh.

Vielen Dank euch allen die mir so geduldig geholfen haben.

Sollte ich noch Fragen haben, werde ich mich vertrauensvoll wieder an euch richten....hihihi

 

Viele Grüße Jürgen 

jsffm schrieb am 16.07.2016 um 09:50 Uhr

Jubel, Trubel, Heiterkeit....es scheint jetzt zu funktionieren. 

Nun habe ich aber trotzdem noch eine Frage: Wie kann ich denn ein Panorama als iFrame einbetten?

BeRo schrieb am 16.07.2016 um 10:44 Uhr

[...] Wie kann ich denn ein Panorama als iFrame einbetten? [...]

Das ist schnell gemacht...

  1. Lege auf der Seite, die das Panorama zeigen soll, eine neue Ebene an, die Du z. B. "panorama" nennst.
  2. Lege in der neuen Ebene einen Platzhalter (Rechteck) in der gewünschten Größe an.


     
  3. Füge den folgenden iframe Code in den HTML Body des Platzhalters ein:

    ---------------------------------------------------
    <iframe src="./index_htm_files/pano/index.htm" width="100%" height="100%" frameborder="0" scrolling="auto" name="xara_iframe" ><p>Your browser does not support iframes.</p></iframe>
    --------------------------------------------------



    Den Namen der Panorama Startdatei "index.htm" musst Du natürlich noch auf Deine Vorgaben "DJI_0082 Panorama.htm" oder "DJI_0082-Panorama.htm" anpassen. Der Pfad sollte allerdings ohne Änderung bei Dir passen...
     
  4. Lege einen Button auf der Seite an, über den nach einem Klick das Panorama angezeigt werden kann und verlinke den Button auf die neu erstellte Ebene "panorama"


     
  5. Bewundere das Ergebnis schon in der Vorschau

That's all...

Viel Erfolg und einen schönen Rest vom WE

Zuletzt geändert von BeRo am 16.07.2016, 10:46, insgesamt 2-mal geändert.

Auf den Tag genau gehen heute, am 14.08.2021, 10 Jahre online Support für die Community zu Ende.
Ich freue mich auf eine neue, berufliche Herausforderung, die sich gerade ergeben hat. Leider bleibt dann keine Zeit mehr für die Community übrig, aber Ihr seid bei den aktiven Mitgliedern in besten Händen.
Sicher schaue ich auch ab und zu nochmal rein... 🤓

jsffm schrieb am 16.07.2016 um 17:30 Uhr

Wie könnte es auch anders sein.....es funzt natürlich nicht.....lach