brauche hilfe beim Einbau von PHP CMS & News Script light

kundmueller schrieb am 01.05.2014 um 14:39 Uhr

Hallo, ich möchte ein PHP CMS & News Script light von www.hinnendahl.com bei mir einbauen.

hier wurde das thema von bero schon angesprochen http://www.magix.info/de/wd-7-teile-einer-homepage-von-extern-bearbeiten.forum.858848.html#ca740457

aber auch nach dem durchlesen verstehe ich immer noch bahnhof :(

Habe von Holger Hinnendahl die vollversion bekommen und würde diese gerne als Blog nutzen, um von meiner Fahrradreise zu berichten.

Wer hat Lust mir da zu helfen?

Kommentare

kundmueller schrieb am 01.05.2014 um 15:01 Uhr

Und noch eine Frage hinterher: Gibt es keine ähnliche Alternative die zum einbauen einfacher ist?

kundmueller schrieb am 01.05.2014 um 15:48 Uhr

und schon tauchen die ersten probleme auf ... grrrr

soll ich mir das wirklich antun, so ganz ohne kenntnisse ein skript bei mir einbauen?

hab das skript gemäss Anleitung eingebaut. Ergebnis ... funktioniert natürlich nicht, was zu erwarten war :(

hier erstmal die Anleitung von hinnendahl: bonetrip.com/Bedienungsanleitung.pdf

Hab die Anleitung von Seite 5 aufgeführt: die Seite ist aufrufbar, aber kein script zu sehen: http://bonetrip.com/blog.php

weiss auch nicht wie ich in der oberen menüfuhrt auf blog.php verweisen soll, weil ich im WD nur die "blog" auswählen kann, nicht aber die Endung. wenn ich über menü auf den Reiter blog klicke, sucht der natürlich blog.htm und nicht blog.php

 

marboe schrieb am 01.05.2014 um 17:18 Uhr

Hallo Kundmüller, ich hab momentan keine Ahnung ob das so richtig ist, was du vorhast. Aber du kannst im WD einfach eine php Seite erstellen, indem du in der Ebenengalerie auf den Namen deiner Seite klickst und ein ".php" dahinter ergänzt. Gruß Martina

BeRo schrieb am 01.05.2014 um 18:01 Uhr

[...] Gibt es keine ähnliche Alternative die zum einbauen einfacher ist? [...]

AFAIK nicht.

[...] soll ich mir das wirklich antun, so ganz ohne kenntnisse ein skript bei mir einbauen [...]

Wenn Du einen Mitmenschen kennst, der Dich gut kennt, frag' ihn mal...

Aus meiner Sicht spricht nichts dagegen. Wenn Du Dich akribisch an die Vorgaben hältst, sollte es klappen.

[...] hab das skript gemäss Anleitung eingebaut. Ergebnis ... funktioniert natürlich nicht [...]

Offenbar hast Du die Anleitung nicht buchstabengetreu umgesetzt. In der "blog.php" ist keine Zeile PHP zu finden, wie Du ja schon selbst gesehen hast.

[...] weiss auch nicht wie ich in der oberen menüfuhrt auf blog.php verweisen soll [...]

Das ist ganz einfach, wenn Du vorher der entsprechenden Seite im WD eine ".php" Erweiterung verpasst. Dazu editierst Du einfach den Seitennamen in der Seiten- & Ebenen-Galerie, wie marboe es schon ganz richtig angemerkt hat.

 

Auf der Blog Seite, im Head Bereich, baust Du mit dem WD Editor noch folgende Zeile ein:

--------------------------------
<?php $url = $_SERVER['PHP_SELF']; $custom_css = ""; $cms_script_pfad = "news_system/"; require($cms_script_pfad."news_wrset.php"); ?>
-------------------------------


Wenn Du dann auf der Seite noch einen Platzhalter einbaust, der die Größe des später sichtbaren Blogs hat und im HTML Body die in der Anleitung genannte PHP Zeile in den HTML Body einbaust, bist Du fast am Ziel.


Abschließend exportierst Du das Projekt in ein Verzeichnis auf Deinem PC und öffnest die Seite "blog.php" mit einem einfachen Texteditor, z. B. mit dem kostenfreien "Notepad++"

Dann setzt Du die in der Anleitung genannte "PHP Kopfzeile" ein.

Die Zeile muss unbedingt an allererster Stelle in der Seite erscheinen und es darf weder ein Leerzeichen- noch irgendein anderes Zeichen davor stehen! Sie muss also noch vor der üblichen Zeile: "<!DOCTYPE html PUBLIC..." stehen.
So sieht die Zeile aus:

--------------------------------
<?php session_start(); ob_start(); ini_set("arg_separator.output","&amp;"); ?>
--------------------------------

Speichere die geänderte Seite "blog.php" unbedingt in ein separates Verzeichnis!

Danach kannst Du Dein Projekt veröffentlichen und abschließend die geänderte Datei "blog.php" manuell auf den Webserver schieben. Dazu eignet sich jeder externe FTP Client, z. B. das kostenfreie FileZilla.

Wenn Du alles richtig gemacht hast, funktioniert es jetzt...

Viel Erfolg

 

Zuletzt geändert von BeRo am 01.05.2014, 18:02, insgesamt 2-mal geändert.

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

kundmueller schrieb am 03.05.2014 um 17:45 Uhr

Hoi Bero, vielen Dank für Deine Anleitung. Klingt alles ganz logisch und hab mich schon gefreut, das es klappt :)

Klappt leider nicht, obwohl ich alles ganz genau befolgt habe, bis auf "Speichere die geänderte Seite "blog.php" unbedingt in ein separates Verzeichnis!"

Warum muss ich das machen und wie mache ich das? Das muss ich ja eigentlich im WD machen, damit WD auch weiss, wo er die seite findet.

Ich habe nix gefunden, wo ich die seite blog.php woanders speichern kann.

dann noch ne frage, ich sollte die PHP Kopfzeile einsetzen, was ich auch gemacht habe, sehe sie aber online im Seitenquelltext nicht, siehe http://bonetrip.com/blog.php

wenn ich die seite http://bonetrip.com/blog.php aber runterlade und im editor öffne, sehe ich die PHP Kopfzeile

ist das richtig so, oder habe ich was falsch gemacht?

auch den platzhalter habe ich gesetzt, mit dem code, sehe aber gar nix :(

hochgeladen habe ich alles mit filezilla (den ich ausschliesslich verwende)

kundmueller schrieb am 03.05.2014 um 17:53 Uhr

und was ist mit dieser Anweisung gemeint?

Nach dem Hochladen müssen Sie noch Schreibrechte vergeben, damit in diversen Dateien und Ord-
nern gespeichert werden darf. Die Ordner: „data“, „dl_files “, „images“ und „temp“ brauchen Schreibrechte
777 (Vollzugriff). Bitte jeweils die Unterordner und Dateien mit einbeziehen!

marboe schrieb am 03.05.2014 um 20:44 Uhr

Hallo kundmüller,

klicke mit der rechten Maustaste im FileZilla auf die genannten Dateien und verändere unter "Berechtigung" die entsprechende Zahl auf die genannte. Speichern. Fertig. Der Rest mit den Unterordnern ist selbsterklärend.

Gruß Martina

BeRo schrieb am 03.05.2014 um 22:41 Uhr

[...] Warum muss ich das machen [...]

Nun, die Änderungen die Du an der PHP Seite vornimmst werden vom WD nicht unterstützt. Wenn Du die geänderte Seite vom WD hochladen lässt, überschreibt/löscht er Deine Änderungen wieder...

[...] und wie mache ich das? [...]

Genauso, wie in meinem letzten Kommentar beschrieben, indem Du einen externen Texteditor benutzt (z. B. Notepad++). Mit diesem Editor manipulierst Du die PHP Seite wie beschrieben und speicherst sie in einem separaten Verzeichnis.
Tust Du das nicht, überschreibt der WD Deine Änderungen in der Datei und veröffentlicht später auch die nicht lauffähige WD Version der PHP Datei!

[...] Das muss ich ja eigentlich im WD machen, damit WD auch weiss, wo er die seite findet. [...]

Prinzipiell ist das richtig. Da der WD Deine Änderungen aber nicht akzeptiert, musst Du ihn umgehen. Der WD wird die geänderte Seite trotzdem finden, weil Du sie ja nach dem Upload aller Seiten mit dem WD, manuell mit FileZIlla ersetzt. Damit überschreibst Du die vom WD "kastrierte" PHP Seite mit der manipulierten, aber lauffähigen Version.

[...] was ist mit dieser Anweisung gemeint? Nach dem Hochladen müssen Sie noch Schreibrechte vergeben,[...]

marboe hat Dir ja schon erklärt, wie Du die Anweisung umsetzen musst. Allerdings solltest Du darauf achten, dass die in der Anweisung genannten Verzeichnisse markiert werden, nicht nur die Dateien (s. Screenshot)


Damit auch die entsprechenden Dateien in den Verzeichnissen die gewünschten Berechtigungen erhalten, muss der Haken bei "Unterverzeichnisse einbeziehen" gesetzt sein und es muss der Radio Button "Auf alle Dateien anwenden" aktiv sein.

Klar, dass Du den o. a. Schritt erst durchführen kannst, wenn Du Dein Projekt online gestellt hast.

[...] wenn ich die seite http://bonetrip.com/blog.php aber runterlade und im editor öffne, sehe ich die PHP Kopfzeile [...]

Das ist normal, weil der ausliefernde Webserver den Inhalt einer PHP Seite beim Aufruf durch einen Browser anpasst.

[...] auch den platzhalter habe ich gesetzt, mit dem code, sehe aber gar nix [...]

Das darf Dich nicht wundern, weil PHP Code nur von einem Webserver genutzt werden kann. Auf Deinem PC funktionieren solche Seiten nicht, es sei denn, Du installierst Dir einen Apache Server, wie z. B. Xampp.

Versuch's nochmal, viel kann jetzt nicht mehr schief gehen.

Viel Erfolg

 

Zuletzt geändert von BeRo am 03.05.2014, 22:41, insgesamt 1-mal geändert.

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

kundmueller schrieb am 04.05.2014 um 08:38 Uhr

also das mit den Schreibrechten, etc. habe ich hinbekommen :)

Deine ganzen anderen Erklärungen kann ich nicht nachvollziehen, da ich - wie ich bereits geschrieben habe - zum upload - ausschliesslich - filezilla nutze.

mit dem WD lade ich nie was hoch, demzufolge kann WD auch nix überschreiben. Ausser beim offline Speichern?

Deshalb müsste es doch funktioneren, oder? So sieht mein Verzeichnis aus:

Und du meinst, ich soll jetzt einfach ein neuen neuen Ordner erstellen, den ich z.B. blog nenne, und dann blog.php da hinein verschiebe? Und dann solls gehen?

Versteh ich zwar nicht, aber ich probier's :)

Funktioniert leider nicht, jetzt kommt genau die Meldung die ich meinte:

The requested URL /blog.php was not found on this server

Habs jetzt wieder rückgängig gemacht. sie seite blog.php ist jetzt wieder im gesamtverzeichnis, wie im oberen Bild zu sehen.

kundmueller schrieb am 04.05.2014 um 09:13 Uhr

Also ... ich hab jetzt festgestellt, dass WD die seite blog.php auch beim offline speichern "kastriert"

Also habe ich die blog seite, nach dem bearbeiten mit dem editor in dem ordner blog gespeichert, das ganze mit filezilla hochgeladen, und danach online die seite blog.php aus dem ordner blog zurück in das hauptverzeichnis kopiert.

theoretisch ist jetzt alles ok und "sollte" funktionieren, oder?

Tut es aber nicht

Zurzeit sieht es bei mir so aus:

 

Habe mir gerade nochmal die seite blog.php vom online hauptverzeichnis runter geladen und mit dem Editor angeschaut und die 3 einbauten Zeilen gesucht und auch gefunden.

Ich bin jetzt echt gespannt, wo Du den Fehler findest :)

BeRo schrieb am 04.05.2014 um 14:17 Uhr

[...] Ich bin jetzt echt gespannt, wo Du den Fehler findest [...]

Bei dem, was in den Screenshots zu sehen ist, kann ich keinen Fehler entdecken. Allerdings scheint die Zuweisung der Berechtigungen für einige Verzeichnisse Deines Webservers nicht zu stimmen:


Das hat IMO für die Anzeige der News keine Bedeutung, für die korrekte Funktion der Updates aber natürlich schon.

Dein Webserver bei "united-domains.de" unterstützt offenbar PHP 5.4. Von der Seite sind also keine Probleme zu erwarten. Sicherheitshalber solltest Du aber kontrollieren, ob die PHP Nutzung von Seiten des ISP freigeschaltet ist (Anruf beim Support).

Wenn ich mir Deine Website herunterlade, fehlen im Unterverzeichnis "news_system", die Verzeichnisse "data", "dl_files" und "images". Es kann sein, dass das durch die fehlenden Berechtigungen verursacht wird (s. o.).
Korrekt sollte der Inhalt des Verzeichnisses "news_system" etwa so aussehen:


Kontrolliere das mal. Vielleicht ist das Fehlen der Verzeichnisse/Dateien schon die Ursache Deines Problems...

Du kannst als Gegenprobe zu Deinen Bemühungen natürlich auch die Projektdatei herunterladen, die ich zu meiner News Demo online gestellt habe.

Zum Test kannst Du die Demo in einem neu angelegten Unterverzeichnis auf Deinem Webspace veröffentlichen (mit FileZilla).
Die Demo sollte danach problemlos online, auf Deinem Webspace funktionieren.

Viel Erfolg

 

Zuletzt geändert von BeRo am 04.05.2014, 14:17, insgesamt 1-mal geändert.

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

kundmueller schrieb am 04.05.2014 um 14:45 Uhr

sali bero,

also die der ordner news_system ist vollständig und richtig auf dem server.

ich finde es eigentlich ganz gut das niemand zugriff darauf hat  http://bonetrip.com/news_system/

sonst könnte doch jeder herkommen, und in meinem system rumpfuschen, oder?

Oder geht es hier nur um die Lese berechtigung?

Also muss ich bei meinem Provider anrufen?

Hab eigentlich fast nix verstanden was du geschrieben hast, nur das das was ich gemacht habe - unter deiner anleitung - fehlerfrei zu sein scheint.

Na dann ruf ich morgen mal meinen provider an ... ;)

Mein online verzeichnis news_system sieht so aus, und die in der bedienungsanleitung angegeben ordner mit allen unterverzeichnissen hab ich auf 777 gestellt: 

BeRo schrieb am 04.05.2014 um 15:03 Uhr

[...] Oder geht es hier nur um die Lese berechtigung? [...]

Jein

Das System Verzeichnis braucht natürlich keine Pauschalberechtigung. Die Unterverzeichnisse "data", "dl_files" und "images" aber schon.

Wie Hinnendahl in seiner Einbauanleitung explizit angemerkt hat, ist es wichtig, dass diese Verzeichnisse (und die darin enthaltenen Dateien)  die Berechtigung "777" bekommen:


Wenn das auf Deinem Webspace noch nicht so aussieht, was ich vermute, dann ändere es einfach ab...

Vielleicht platzt der Knoten dann automatisch.

[...] Hab eigentlich fast nix verstanden was du geschrieben hast [...]

Vielleicht genügt es, eine schöpferische Pause" einzulegen, um hinter all den Bäumen, den Wald wieder zu finden...

Viel Erfolg

Zuletzt geändert von BeRo am 04.05.2014, 15:03, insgesamt 1-mal geändert.

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

kundmueller schrieb am 04.05.2014 um 15:10 Uhr

ne daran liegts nicht, das hab ich mehrfach kontrolliert :)

BeRo schrieb am 04.05.2014 um 15:26 Uhr

[...] ne daran liegts nicht [...]

Aber vielleicht an der ".htacces" Datei, die in dem gelisteten Verzeichnis nicht sein muss.

Was steht denn da drin? Wenn da Einschränkungen definiert wurden, können die Dein News Projekt "kaputt" machen.

Lösche doch mal probehalber die .htaccess oder benenne sie um. Mit ein bisschen Glück war's das dann.

Viel Glück

Zuletzt geändert von BeRo am 04.05.2014, 15:26, insgesamt 1-mal geändert.

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

kundmueller schrieb am 04.05.2014 um 16:33 Uhr

ne daran lags nicht. die htacces datei ist auch im original von hinnendahl vorhanden.

vielleicht liegts daran das ich eine vollversion habe? holger meinte nämlich das die vollversion auf meine domain läuft.

vielleicht liegts auch daran ... keine ahnung.

ich hab jetzt mal holger angemailt und ihm mein problem geschildert. mal gucken was er dazu sagt.

ich berichte hier :)

kundmueller schrieb am 04.05.2014 um 20:36 Uhr

hier ist die Antwort von Holger Hinnendahl (aus der ich jetzt auch nicht schlau werde. Du bero?)

Hallo Patrick,

wenn ich mir die URL in deinem Screenshot anschaue, kann das so auch nicht funktionieren!
Schau einfach noch mal in Ruhe in die Anleitung.
Du bindest ja ganzen Ordner „news_system“ in deine URL ein, was nicht funktioniert, da in dem Ordner keine Seite, sondern das PHP Script steckt,
welches du in eine Seite (mit den Befehlen aus der Anleitung) einbinden musst.

Ich weiß ja nicht, auf welcher Seite du das CMS / News Script einbinden möchtest.

Angenommen, du hast eine Seite news.html. Diese Seite musst du dann in news.php umbenennen, da .html kein PHP ausführen kann.
In die PHP Seite setzt du dann die Befehle aus der Anleitung.

Du kannst auch einfach mal in die Demoseite schauen, die dem Script beiligt.

Hier habe ich nochmal die Bedienungsanleitung hochgeladen:

http://bonetrip.com/Bedienungsanleitung.pdf

BeRo schrieb am 04.05.2014 um 22:41 Uhr

Holger schreibt in seiner Anleitung unter Punkt 6 u. a.

--------------------------
[...] Laden Sie
Ihre geänderte Datei(en) und den Ordner „news_system“ auf Ihren Webspace hoch. Es empfiehlt sich, den Ordner „news_system“ in das gleiche Verzeichnis zu legen, wo Sie auch Ihre bearbeitete(n) Seiten abgelegt
haben.
[...]
------------------------

Warum er dann in seiner Antwort auf Deine Frage davon ausgeht, dass das nicht funktionieren kann, erschließt sich mir nicht.
Er schreibt u. a.

-----------------------
[...] Du bindest ja ganzen Ordner „news_system“ in deine URL ein, was nicht funktioniert [...]
-----------------------

Ich könnte mir allenfalls vorstellen, dass er damit sagen will, dass der Aufruf der News Seite nicht funktioniert, wenn Du in der URL nur das Verzeichnis "news_system" angibst...
Klar, dass das nicht funktioniert. In der von Dir hier im Thread angegebenen URL "http://bonetrip.com/blog.php" ist das ja auch nicht der Fall.

Die von mir online gestellte (funktionierende) Demo ist folgerichtig genauso aufgebaut, wie in der Anleitung vorgegeben, also mit dem Verzeichnis "news_system" im root Verzeichnis.

Um das Verfahren der Fehlersuche abzukürzen, kann ich Dir nur noch einmal ans Herz legen, Dir die Projektdatei zu meiner Demo hier herunter zu laden.
Lege Dir dann auf Deinem Webspace ein Unterverzeichnis an (z. B. "test")
Kopiere jetzt den kompletten Inhalt (Verzeichnisse + Dateien) des Verzeichnisses "Export" aus der heruntergeladenen Datei "news2.zip" mit FileZilla in das gerade angelegte Verzeichnis "test" auf Deinem Webspace.

Anschließend solltest Du über die URL "http://bonetrip.com/test/newsp.php" die funktionsfähige News Demo sehen können.

Wenn das nicht funktioniert, bleibt nur noch der Weg zum Support von "united-domains.de". Dann müsste sich dort ein berufener MA dazu äußern...

Viel Erfolg

Zuletzt geändert von BeRo am 04.05.2014, 22:42, insgesamt 3-mal geändert.

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

kundmueller schrieb am 04.05.2014 um 23:11 Uhr

deine demo funktioniert http://bonetrip.com/test/newsp.php

und jetzt?

hatte gerade die idee, dass es an der anordnung der Ebene liegen könnte, und den Platzhalter eine Ebene weiter vor  geholt :)

jetzt sehe ich auf der Seite http://bonetrip.com/blog.php 2 schlösser und kann mich einloggen :)

mal gucken wie es weiter geht :)

BeRo schrieb am 04.05.2014 um 23:33 Uhr

deine demo funktioniert [...]

Hmmm, nicht so richtig. Der Scroll Balken fehlt...  Vermutlich hast Du die Dateiberechtigungen für die neu angelegten Verzeichnisse/Dateien noch nicht angepasst. Aber für die Fehlersuche ist das jetzt nicht so wichtig.

Du musst jetzt sehr genau vergleichen, wo die Unterschiede zwischen den beiden Projekten (meine Demo und Dein Projekt) zu finden sind.

Du kannst es Dir einfach machen, indem Du z. B. in der Demo die Seite "newsp.php" austauschst gegen Deine News Seite "blog.php".

Wenn die nicht funktioniert, kannst Du die Fehersuche auf den Inhalt (Scripte?) dieser Seite begrenzen.
Funktioniert die ausgetauschte Seite, liegt der Fehler in den Verzeichnissen/Dateien die zum News System gehören.

So solltest Du relativ schnell den Übeltäter lokalisieren- und eliminieren können.

Viel Erfolg

Zuletzt geändert von BeRo am 04.05.2014, 23:33, insgesamt 1-mal geändert.

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

kundmueller schrieb am 05.05.2014 um 21:47 Uhr

also es hat alles geklappt :) bin mich jetzt am einarbeiten in das skript von holger :)

es lag definitiv an den Ebenen.

weiss nicht, warum ich da nicht gleich drauf gekommen bin ... kenne ja das ebenenproblem ausreichend :)

oft gehen links bei mir nicht, bis ich es eine ebene weiter hervor hole :)

danke für all eure hilfe :)

BeRo schrieb am 05.05.2014 um 22:22 Uhr

[...] es lag definitiv an den Ebenen. [...]

Wenn es doch immer so einfach wäre...

Gratuliere zum Erfolg.

Jetzt musst Du nur noch das Admin Passwort ändern, damit Du nicht bei nächster Gelegenheit von einem "freundlichen" Zeitgenossen von Deiner eigenen Seite ausgesperrt wirst, indem er es ändert...


Wie Holger es in seiner Anleitung empfiehlt, wäre es obendrein sicherer, die Login-Prozedur nicht über das Schlüssel Symbol zu ermöglichen.

Gerne weiterhin viel Erfolg bei den kommenden "Operationen'" an Deiner Site

Zuletzt geändert von BeRo am 05.05.2014, 22:22, insgesamt 1-mal geändert.

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

kundmueller schrieb am 15.05.2014 um 14:23 Uhr

und weiter gehen die probleme ;) obendrein meldet sich holger seit  2 wochen nicht mehr und langsam habe ich keine Lust mehr.

Kann doch nicht sein, das ich an so einem blöden script mehr zeit brauche, als mit einer kompletten website?

möchte echt wissen was an dem script "light" sein soll? Der Einbau ganz bestimmt nicht.

 

jedenfalls möchte ich jetzt das archiv einbauen, aber glaubst du ich krieg das hin?

also, die bedienungsanleitung ist noch hier: http://bonetrip.com/Bedienungsanleitung.pdf

Auf Seite 14 wird der Einbau von dem Blog Archiv Plugin beschrieben.

Den Platzhalter fürs Archiv habe ich links erstellt und die anweisung je in body und head geschrieben

 

aber sobald ich dann die php seite hochlade ist wieder alles weg.

ausserdem hat mir hoger noch eine zip datei gegeben, mit der ich überhaupt nix anzufangen weiss. steht ja auch nix in der anleitung

http://bonetrip.com/CMS_News_V2_Archiv_Plugin.zip

BeRo schrieb am 15.05.2014 um 23:16 Uhr

[...] möchte echt wissen was an dem script "light" sein soll? n[...]

Das klingt nach (berechtigtem?) Frust.

[...] jedenfalls möchte ich jetzt das archiv einbauen, [...]

Wenn ich Deine Eingangsbemerkung lese, hast Du die "Light" Version. Wenn das stimmt, wird der Einbau des Plugins nicht funktionieren. Wenn Du aber die Pro Version hast, sollte es gehen.

Aus der Anleitung- und aus den Scripts kann ich ableiten, dass die beiden Dateien, die Du mit der ZIP Datei bekommen hast, zusätzlich zu den bestehenden Dateien in den Ordner "news_system"- bzw. in den Ordner "news_system/css" integriert werden müssen.

  • Die Datei "news_archiv.php" gehört in den Ordner "news_system"
  • Die Datei "news_archiv.css" gehört in den Ordner "news_system/css"

Im Head der News Seite sollte außerdem die folgende Zeile gespeichert sein:

-----------------------
<?php $url = $_SERVER['PHP_SELF']; $custom_css = ""; $cms_script_pfad = "news_system/"; require($cms_script_pfad."news_wrset.php"); ?>
-----------------------

In die erste Zeile der News Seite gehört in jedem Fall die folgende Zeile:

----------------------
<?php session_start(); ob_start(); ini_set("arg_separator.output","&amp;"); ?>
---------------------

Davor darf absolut nichts stehen, nicht einmal ein Leerzeichen!

Die anderen PHP Zeilen, die Du in Deinen Screenshots gezeigt hast sind IMHO korrekt und können so bestehen bleiben.

Alle anderen News Scriptlets, die Du vorher ja schon funktionsfähig eingebunden hattest, bleiben natürlich ebenfalls erhalten!

Hast Du die News Seite wie oben geschildert komplettiert, kannst Du sie- und die zusätzlichen Dateien mit FileZilla auf Deinen Webspace bringen. Es sollte dann funktionieren (hoffentlich).

Viel Erfolg

Zuletzt geändert von BeRo am 15.05.2014, 23:16, insgesamt 1-mal geändert.

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.