Keyframes fertig, dann aber durcheinander & Exportfehler

enila-g schrieb am 23.11.2022 um 15:20 Uhr

Hallo,

ich bin, auch wenn ich inzwischen ein paar Videos geschnitten habe, noch absolut auf Anfänger-Level unterwegs und hoffe, dass meine Frage daher recht simpel und schnell zu beantworten ist...

Bei der Arbeit mit den Keyframes für Größe/Position bzw. Kamera/Zoomfahrt passiert es mir ständig, dass ich das Projekt fertig bearbeite, es dann nochmal von vorne ansehe und dabei merke, dass sich sämtliche Keyframes komplett verschoben haben bzw. auch neue dazugekommen sind - an vermeintlich völlig zufälligen Positionen. Die Verschiebungen sind so krass, dass man auf dem Video tw. überhaupt nichts mehr erkennen kann.

Ich habe meistens mehrere Clips, die auf der ersten Spur aneinandergereiht sind und auf einer zweiten Spur noch kurze zusätzlich Clips.

Beim Schneiden arbeite ich meistens einfach von Anfang bis Ende durch, also von links nach rechts.

Wenn ich am Ende ankomme, muss ich sehr häufig wieder ganz links anfangen und wieder alles "zurechtschieben" - teilweise sogar in 2 - 3 Durchläufen.

Hat jemand eine Idee, auf was ich achten könnte, um das zu verhindern???

...und dann noch eine andere Frage:

woran kann es liegen, dass die Animationen beim Export als MPEG4 zum Teil nicht korrekt ausgegeben werden? Teilweise fehlen Zoomfahrten, teilweise fehlen sogar einige Clips auf der zweiten Spur (diese ist aber nicht gemutet). Nach 2-3 Export-Versuchen klappts dann meist irgendwann fehlerfrei - aber kann ich irgendetwas einstellen, damit schon der erste Export ein "Treffer" wird?

Version:

Video Deluxe 2023 22.0.3.165 (UDP3)
Rechner: Windows 10, Intel(R) Core(TM) i7-4820K CPU @ 3.70GHz   3.70 GHz 32,0 GB

Danke euch vorab für die Hilfe!

Liebe Grüße

 

P.S.: kleiner Nachtrag: dass die Keyframes tw. nicht mehr sichtbar sind, wenn die Clips gekürzt werden, hab ich schon bemerkt und das auch entsprechend immer korrigiert ;-) - daran kann es glaube ich also nicht liegen, dass sich alles durcheinanderwirft...

Kommentare

H.S. schrieb am 23.11.2022 um 18:09 Uhr

@enila-g

Hört sich ja nach einem großen Durcheinander an. Hast Du die richtigen Mausmodi bei der ganzen Hin- und Herschieberei ihrer Funktion nach richtig eingesetzt? Irgendein Objekt mittendrin gelöscht und damit alles rechts dahinter liegende mit beeinflusst? Video/Audio-Objekte voneinander gelöst? Bei mir läuft alles wie gewünscht, auch im Nachhinein versucht, Dein Keyframe-Problem nachzuvollziehen. Bei mir sitzen Keyframes nach einer Kürzung noch an genau den richtigen Stellen wie mit einer Zwecke festgeheftet.

wabu schrieb am 23.11.2022 um 18:30 Uhr

So mal vorab auf die Schnell:

Wenn ein KF gesetzt wird und dann wird das Bild mal eben noch ausgerichtet und wieder zurück - das sind alles neue KFs!!

wabu ...............der nie auslernt

Der Rechner  Installierter physischer Speicher (RAM) 16,0 GB / Prozessor Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz, 3600 MHz, 8 Kern(e), 8 logische(r) Prozessor(en),

Intel® UHD Graphics 630 aktiviert

NVIDIA Geforce GTX 1650 HDMI ; 2x DVI ; VGA, PCIe

Samsung (SSD) HD103SJ F3 1 TB Sata 7200 / 2x LG GH22NS SATA schwarz

Betriebsystem Microsoft Windows 10 Home Version 10.0.18362 Build 20H2

geschnitten wird seit 2007 mit Magix immer aktuell VdL und ProX

gefilmt mit Panasonic SDT 750 und FZ 1000 sowie Pentax K30 (Mist) und einer Q500k und SJ 1000 und Hero7

fotografiert mit Pentax K10 und K30 (Super)/Sigma 10-20 und 18-200; Fisheye und 500mm Spiegeltele

Mein Kanal: youtube

enila-g schrieb am 23.11.2022 um 18:43 Uhr

@enila-g

Hört sich ja nach einem großen Durcheinander an. Hast Du die richtigen Mausmodi bei der ganzen Hin- und Herschieberei ihrer Funktion nach richtig eingesetzt? Irgendein Objekt mittendrin gelöscht und damit alles rechts dahinter liegende mit beeinflusst? Video/Audio-Objekte voneinander gelöst? Bei mir läuft alles wie gewünscht, auch im Nachhinein versucht, Dein Keyframe-Problem nachzuvollziehen. Bei mir sitzen Keyframes nach einer Kürzung noch an genau den richtigen Stellen wie mit einer Zwecke festgeheftet.

Danke dir für deine Rückmeldung! Was genau meinst du mit Maus-Modi?

Ehrlich gesagt - sobald ich versuche, das Problem nachzustellen, klappt bei mir auch alles wie gewünscht :-D! Daher habe ich auch so wenige Anhaltspunkte. Es passiert leider nur in der praktischen Anwendung. Einen Fehler im Programm schließe ich aber auch auf jeden Fall aus.

Zu deinen anderen Punkten:

Objekt mittendrin gelöscht - könnte durchaus sein. Darauf werde ich nächstes Mal verstärkt achten
Video/Audio Objekte voneinander gelöst - das definitiv mehrmals!
 

enila-g schrieb am 23.11.2022 um 18:45 Uhr

So mal vorab auf die Schnell:

Wenn ein KF gesetzt wird und dann wird das Bild mal eben noch ausgerichtet und wieder zurück - das sind alles neue KFs!!

Aaaaah.. ich glaube, da könnte das Problem liegen. Das heißt, wenn ich mehrere Clips markiere und z.B. 10 sekunden weiter nach rechts ziehe, werden automatisch neue KFs gesetzt und gleichzeitig die alten beibehalten?

wabu schrieb am 23.11.2022 um 20:48 Uhr

nein, das eher nicht - Clips nehmen ihre Keyframes mit. Aber jedes kürzen/verlängern positioniert die KF neu.

Keyframes

wabu ...............der nie auslernt

Der Rechner  Installierter physischer Speicher (RAM) 16,0 GB / Prozessor Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz, 3600 MHz, 8 Kern(e), 8 logische(r) Prozessor(en),

Intel® UHD Graphics 630 aktiviert

NVIDIA Geforce GTX 1650 HDMI ; 2x DVI ; VGA, PCIe

Samsung (SSD) HD103SJ F3 1 TB Sata 7200 / 2x LG GH22NS SATA schwarz

Betriebsystem Microsoft Windows 10 Home Version 10.0.18362 Build 20H2

geschnitten wird seit 2007 mit Magix immer aktuell VdL und ProX

gefilmt mit Panasonic SDT 750 und FZ 1000 sowie Pentax K30 (Mist) und einer Q500k und SJ 1000 und Hero7

fotografiert mit Pentax K10 und K30 (Super)/Sigma 10-20 und 18-200; Fisheye und 500mm Spiegeltele

Mein Kanal: youtube

enila-g schrieb am 24.11.2022 um 20:11 Uhr

nein, das eher nicht - Clips nehmen ihre Keyframes mit. Aber jedes kürzen/verlängern positioniert die KF neu.

Keyframes

Gibts da einen Trick, um das zu verhindern?

 

wabu schrieb am 25.11.2022 um 08:47 Uhr

Ja - bei den keyframes mit Objektlänge verbinden

kann man im Tutorial nachsehen

Zuletzt geändert von wabu am 25.11.2022, 08:48, insgesamt 1-mal geändert.

wabu ...............der nie auslernt

Der Rechner  Installierter physischer Speicher (RAM) 16,0 GB / Prozessor Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz, 3600 MHz, 8 Kern(e), 8 logische(r) Prozessor(en),

Intel® UHD Graphics 630 aktiviert

NVIDIA Geforce GTX 1650 HDMI ; 2x DVI ; VGA, PCIe

Samsung (SSD) HD103SJ F3 1 TB Sata 7200 / 2x LG GH22NS SATA schwarz

Betriebsystem Microsoft Windows 10 Home Version 10.0.18362 Build 20H2

geschnitten wird seit 2007 mit Magix immer aktuell VdL und ProX

gefilmt mit Panasonic SDT 750 und FZ 1000 sowie Pentax K30 (Mist) und einer Q500k und SJ 1000 und Hero7

fotografiert mit Pentax K10 und K30 (Super)/Sigma 10-20 und 18-200; Fisheye und 500mm Spiegeltele

Mein Kanal: youtube