mov in avi umgewandelt: Ruckeln (nur!) in VDL / Gibt es eine Alternative?

chrisly schrieb am 02.03.2016 um 17:38 Uhr

Hallo.

Ich habe massive Probleme mit mov-Filmchen in meinem Projekt (schwarzes Bild), deshalb komme ich wohl nicht drum herum, die Filme zu konvertieren.

http://www.magix.info/de/mov-filme-teilweise-und-nur-sporadisch-ohne-bild-.forum.1143916.html

Dort wurde mir folgendes Vorgehen von geschi empfohlen:

Zieh dir XMediaRecode, beim Format stellst du auf AVI, bei Video KOPIEREN, bei Audio auf PCM, dann konvertieren, diese erzeugten Videos nun in die Timeline.

Das habe ich so gemacht. Ergebnis des Videos: avi mit Bildstörungen (kurze Aussetzer / Ruckeln) - komischerweise nur in VDL (teilweise auch beim Abspielen in der Timeline). Mit z.B. VLC: keine Störungen

Jetzt weiß ich nicht mehr weiter. Wie kann ich die mov-Filme so "behandeln", dass sie in VDL 2016 sauber laufen - und das ohne Qualitätsverlust?

Kommentare

geschi schrieb am 02.03.2016 um 17:54 Uhr

Hallo

Du kannst einen Player nicht mit einer Videoschnittsoftware vergleichen, das kannst du so nicht beurteilen und schon gleich garnicht mit VLC.

Was hast du als BS?

Deine Graka?

@alle die mitlesen, sein Format ist MOV, als Codec MJPEG 1280x720, mit PCM als Audio, sonst kennst sich doch keiner mehr aus.

chrisly schrieb am 02.03.2016 um 19:22 Uhr

Danke für die Zusatzinfos. 

Mein Mainboard ist ein ASRock H97 Anniversary Intel H97 (Intel Core i7 4790 4x 3.60GHz), Betriebssystem: Win10.
Grafikkarte Onboard: Intel HD Graphics 4600

Mit älteren VDL-Versionen hatte ich nie Probleme. Erst mit VDL 2016 + mov ging´s los. Warum jetzt auch avi nicht sauber läuft - keine Ahnung. Wenn es Alternativen gibt, probiere ich das gerne aus. Ich bin ohne eure Hilfe damit leider überfordert ...

geschi schrieb am 02.03.2016 um 19:53 Uhr

Naja, die Graka wird das ruckeln bringen, die CPU ist gut, aber nur die integriete Graka, da happerts, aber das hat dir Fred, im ersten Teil sicher schon mitgeteilt.

Mit älteren VDL-Versionen hatte ich nie Probleme.

Da hattest du auch kein Win10.

Jetzt machst du ein WindowsUpdate, auch die optionalen und zwar MANUELL.

chrisly schrieb am 02.03.2016 um 20:03 Uhr

Windows 10 ist auf dem neuesten Stand (manuell). An der GraKa liegt es eher nicht - abgesehen von den in avi umgewandelten Filmen gibt es keine Probleme. 

Das Ruckeln tritt übrigens nicht nur in VDL beim Abspielen auf, sondern (meistens noch viel stärker!) auch auf der BluRay, die mit VDL erzeugt wurde. Aktuell habe ich also die Wahl: oft schwarzes Bild mit mov oder Ruckeln mit avi. 

Die Umwandlung in avi ist ja sowieso nur die (bei ansonsten fertigem Projekt) extrem aufwändige Alternative. Wenn es noch irgendeine Chance gäbe, das Projekt inkl. mov-Filmchen fehlerfrei auf eine BluRay zu brennen, wäre das deutlich nervenschonender. Aber das wird wohl nix mehr. 

Also brauche ich irgendeine Alternative - egal wie aufwändig sie auch ist. 

BilderMacher schrieb am 02.03.2016 um 20:06 Uhr

Ich lese immer was von AVI. Warum nimmt man AVI? Mpeg-4 erzeugt auch keine großen Datenmengen. Warum nicht das?

Zuletzt geändert von geschi am 02.03.2016, 21:22, insgesamt 3-mal geändert.

Gruß, B a lderm I cher

(Ich bin KEIN MAGIX Mitarbeiter, ich bin NICHT beim MAGIX-Support!)

-----------------------------------------------------------------------------------------

Mein System: Windows 10 Home 64Bit | Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz | NVIDIA GeForce 840M, 4GB RAM | Vdl 2016/2018 Premium; Video Pro X 7, 10; Fotostory Deluxe 2018| MAGIX Foto&Grafik Designer 15; XARA Designer Pro X 15, Web Designer 11/15 | MAGIX Music Maker MX Premium, Music Maker 2016 Live, MAGIX Samplitude Music Studio 2017 | MAGIX Audio & Music Lab 2016 Premium | Panasonic HDC-SD66 | Velbon CX-586 | Delamax Capa Videoschiene 60cm mit Velbon PH-358 Stativkopf | ZOOM H2n | Panasonic Lumix DMC-FZ300

geschi schrieb am 02.03.2016 um 21:26 Uhr

Ich lese immer was von AVI. Warum nimmt man AVI? Mpeg-4 erzeugt auch keine großen Datenmengen. Warum nicht das?

Weil AVI der einzige brauchbare Container ist der auch MJPEG kann und da kann man dann KOPIEREN.

Wenn alles nix nützt, ja dann wird es MPEG4 werden, nur AVCHD, was auch besser wäre, denn der User denkt an BD, da läuft nix in MP4, wie du ja weißt, aber ich sehe das Problem zur Zeit bei der Graka, da kommt die Rucklerei her, in Verbindung mit Win10.

chrisly schrieb am 02.03.2016 um 22:09 Uhr

Wieder was gelernt.

Kann denn die Graka die Ursache sein, wenn ja auch das Ergebnis auf BD ruckelt (und das nur bei avi-Film)?

Bliebe dann nur MPEG4? Welche Einstellungen müsste ich denn dann in XMediaRecode wählen? Gäbe es Quali-Einbußen?

geschi schrieb am 02.03.2016 um 23:04 Uhr

Was nimmst du bei der BD als Template und welches Format?

chrisly schrieb am 02.03.2016 um 23:09 Uhr

Ich verstehe gerade nicht, was Du meinst. 

Gerade stand doch hier auch noch, mit welchen Einstellungen zu MPEG4 konvertiert werden sollte. Hast Du das aus Versehen wieder gelöscht?

geschi schrieb am 03.03.2016 um 08:40 Uhr

Einfach auf die letzte Frage von mir antworten.

chrisly schrieb am 03.03.2016 um 13:01 Uhr

Ich weiß nicht genau, was Du meinst. Ich gehe auf "Brennen" und wähle bei Disc-Auswahl "Blu-Ray PLayer" Medium: Blu-Ray. Datenträgerformat: BD / H.264 (passt das so? Hab´es nie geändert)

Die Encoder-Einstellungen lasse ich auch unverändert:

MPEG-4-Export (Blu-ray)
Video: H.264; 1920x1080i; 25 frames/s; VBR 25684 kbit/s; software encoding
Audio: AC-3; Stereo; 48000 Hz; 384 kbit/s

geschi schrieb am 03.03.2016 um 17:40 Uhr

Was soll das aufblasen auf FullHD, als Template nimmst du mal:

den H.264 wie gewohnt, als Template, 1280x720 PAL, dann encodierst du.

Was zeigt sich dann beim Abspielen und wo spielst du das ab, auf einen BD Player oder am PC?

chrisly schrieb am 03.03.2016 um 19:58 Uhr

Neben den mov-Filmen werden auch Bilder und Full-HD-Filme im gleichen Projekt verarbeitet (im Testprojekt war es nur mov und avi zum Vergleich - und da hat es schon massiv geruckelt). Da macht FullHD doch Sinn.

Abgespielt wird auf BD-Player, aber am PC hat die BD auch geruckelt.

chrisly schrieb am 03.03.2016 um 23:41 Uhr

Ich habe jetzt schon mehrere Stunden geforscht, bin aber immer noch nicht schlauer. Es kann doch nicht sein, dass ich der Einzige bin, der diesen mov-Mist mit VDL 2016 verarbeiten muss ...

Das Problem: ich brauche das Ergebnis bis nächste Woche und muss am Wochenende drauf halten, wenn ich das schaffen will. Der Aufwand zum Austausch der Filme ist ja enorm. Dann muss ich aber wenigstens sicher sein, dass es auch funktioniert.

Aber nach den bisherigen Erfahrungen mit mov und avi sieht das eher schlecht aus. Gibt es denn keine sichere Methode (ohne Bildstörungen) - notfalls auch mit leichtem Qualitätsverlust ?

FredW schrieb am 04.03.2016 um 08:37 Uhr

Hallo chrisly

wende dich doch bitte an den Magix Support. Wir als Anwender können weder das Coding des Programmes ändern, noch auf deine Probleme eingehen. Nur soweit:

Wenn eine Wandlung deiner mov-Videos wie von geschi vorgeschlagen auch bei AVI "Bildfehler" aufzeigt, liegen mit hoher Wahrscheinlichkeit bereits Fehler im Quellmaterial vor. Ein Player hat im Gegensatz zu einer Videoschnittsoftware immer die Aufgabe fehlerhafte Frames auszufiltern und das letzte intakte Frame solange anzuzeigen, bis wieder ein sauberes Frame kommt.

Leider ist mir auch bekannt, dass es gerade bei mov-Videos Quellen gibt, die es mit dem Codec nicht so genau nehmen und irgendetwas erzeugen, was eben nicht so einem mov-Standard entpricht. Auch der im Qicktimeplayer enthaltene Codecs von der Prgramm DVD ist ein anderer als würde man sich den aktuellen von Apple laden.

Das macht das Thema sehr schwer. Daher lautet meine Empfehlung genauso wie die von geschi ... in solchen Grenzfällen immer das Video mit xMediaRecode in ein sauberes Format wandeln und damit weiter arbeiten. Zeigt das gewandelte Video ebenso Probleme auf, kann/muss man davon ausgehen, dass bereits die Quelle unsauber ist.

Gruß FredW

Zuletzt geändert von FredW am 04.03.2016, 08:37, insgesamt 1-mal geändert.

Windows 10/7  64-Bit, I7-4771, 16 GB-RAM, NVidia GeForce GTX770, Samsung SSD 512 GB, 2 x 3 TB interne HD, 2 x 4 TB externe USB 3.0 HD, MACmini I7 3.0 GHz, 1 TB SSD MAC OS Sierra VMware Win10

geschi schrieb am 04.03.2016 um 08:57 Uhr

Da macht FullHD doch Sinn.

Nein, das macht es nicht, da bist du bei i und nicht bei p.

chrisly schrieb am 04.03.2016 um 16:38 Uhr

@FredW: Magix hatte ich ja schon kontaktiert. Die konnten nicht mehr weiterhelfen. Deshalb seid Ihr ja meine letzte Hoffnung! Das Quellmaterial ist sauber (abgesehen von dem Sch...Format), ich habe zum Test extra einen mov-Film ausgesucht, der mit älterem VDL (und mit Windows 7) sauber auf eine BD gebrannt werden konnte. Also ist das Problem eher bei VDL 2016 oder dessen Kombination mit Win10 zu suchen. Aber das hilft mir ja jetzt auch nicht weiter - deshalb bleibt wohl nur die Koonvertierung.

Aber mit welchen Einstellungen sollte ich die in XmediaRecode durchführen?

 

@geschi: ich verstehe da wohl was nicht richtig. Ich habe neben den mov-Filmen (1280x720) auch Fotos (3648x2056) und mts-Filme (1920x1080) im gleichen Projekt. 

Wenn ich jetzt als Template 1280x720 PAL wähle, führt das doch (unabhängig von i oder p) zu Qualitätseinschränkungen bei Fotos und mts-Filmen - oder?

Ich hoffe, ich nerve Euch noch nicht zu sehr mit meinem Unwissen und Ihr könnt mir nochmal eine Empfehlung geben, wie ich mit den mov-Filmen (und dem Rest des Projekts) umgehen sollte. Vielen Dank für Eure Geduld und Hilfe!!!

chrisly schrieb am 05.03.2016 um 15:24 Uhr

Ich habe jetzt mal zum Test einen mov-Film in m2ts konvertiert. 

Codec: MPEG-2 / Bitrate: 25.000 / Framerate: 25 (Pal) - Ausgangsmaterial hat aber 30; sollte ich dann besser auf 30 umstellen?

Audio: AAC

Es ruckelt nix mehr auf der BD und die Qualität ist auf den ersten Blick ähnlich. Passen die Einstellungen dann so?

Mit welcher Einstellung sollte dann die BD gebrannt werden (wie gesagt: auch Full-HD-Material enthalten!)? H.264; 1920x1080i; 25 frames/s? 

 

Edit: zur Bildqualität des konvertierten Films - ich habe nochmal genauer hingesehen: er ist etwas unschärfer (lässt sich wohl nicht vermeiden!?) und auch die Farben sind etwas flauer. Also auch nicht wirklich ideal, aber wenn Ihr keine bessere Idee habt, muss ich wohl damit leben ... 

A380 schrieb am 05.03.2016 um 19:31 Uhr

Moin moin aus Bremen,

Congratulation.... du hast es geschafft, auf ein und dasselbe Thema, 100 Antworten zu bekommen.

Daran siehst du aber, wieviel Anteilnahme von den Usern für dein Problem erbracht wird.

mfg William... Der A380

Zuletzt geändert von A380 am 05.03.2016, 19:34, insgesamt 2-mal geändert.

Panasonic AG-AC90/X909 VDL2014/2016 Prem - WIN 7 Home 64Bit - ASUS P8P67 PRO - I5-2500K - 8GB DDR3, Nvidia 1050TI 4GB - 6 * 1TB Intern - Samsung SSD 240GB - ACER 27" - ShuttlePRO V2

chrisly schrieb am 05.03.2016 um 20:03 Uhr

Falls Du es nicht bemerkt hast: in diesem Thema geht es darum, wie ich mov am Besten konvertiere, damit es endlich funktioniert. In dem anderen Thema ging es darum, mov zum Laufen zu bringen.

Jetzt suche ich also immer noch nach einer Notlösung und wäre für HILFREICHE Kommentare weiterhin dankbar.

Gerade habe ich einige der mov-Filme mit VDL2014 (+ Win10) bearbeitet - ohne Probleme. Leider kann ich das Projekt nicht damit brennen, weil das ja zu anderen Problemen führen würde. Aber es zeigt, dass die Ursache bei VDL 2016 zu suchen ist - auch wenn Magix wohl keine große Lust mehr hat, den Fehler zu beheben ...

geschi schrieb am 06.03.2016 um 10:52 Uhr

Ich habe jetzt mal zum Test einen mov-Film in m2ts konvertiert. Codec: MPEG-2 / Bitrate: 25.000 / Framerate: 25 (Pal) - Ausgangsmaterial hat aber 30; sollte ich dann besser auf 30 umstellen? Audio: AAC

Das ist so nix:

Codec H.264, Bitrate 16.000, Framerate 25, Audio AC3

 

chrisly schrieb am 06.03.2016 um 11:44 Uhr

Danke für den Tipp - hatte ich inzwischen auch probiert. Aber VDL 2016 hatte auch mit der konvertierten Datei Probleme: nur Ton, kein Bild!

Um - hoffentlich - zum Ende zu kommen, hier mein Vorgehen (vielleicht hilft´s ja Leidensgenossen ...):

ich habe zig Varianten mit XMediaRecode ausprobiert (AVI - nur kopieren; konvertieren in mp4, M2TS mit versch. Einstellungen). Ergebnis: mal mehr, mal weniger Ruckeln

Einzige Variante mit nicht sichtbarem Qualitätsunterschied und ohne ruckeln: Konvertierung mit VDL

Weil es mit VDL 2016 ja nicht funktioniert, habe ich VDL 2014 nochmal installiert und aus dem bestehenden Projekt alles rausgelöscht, was nicht mov ist. Dann habe ich den Rest (also die mov-Filme + Lücken vom Rest) als Film exportiert. Unkomprimiert als AVI hat geruckelt, also blieb nur MPEG4: Einstellung: 

Exort als MPEG4; 1920x1080; Framerate 30 (25 ruckelt, weil TZ5-Ausgangsmaterial auch 30 liefert)

Jetzt werde ich den erzeugten Film in VDL 2016 ins bestehende Projekt einfügen, die ehemaligen mov-Filmchen ausschneiden und damit die Original-Mov-Filme ersetzen.

Sehr umständlich, aber ich habe keine andere Variante gefunden, die ruckelfrei funktioniert. Ein erster kleiner Test war vielversprechend ...

Bleibt nur eine Frage für die nächsten Projekte: hin und wieder muss ich leider noch mov-Filme verarbeiten (die Masse wird aber mts sein). Um dann nicht wieder so umständlich vorzugehen, müssten die mov-Filme dann aber VORHER konvertiert werden. Aber mit XMediaRecode habe ich keine ruckelfreie Variante gefunden. Bleibt dann nur die Möglichkeit, jeden mov-Film mit VDL 2014 in m2ts zu konvertieren? Das wäre ja auch ziemlich aufwändig ...

Mit den Einstellungen vonm geschi wird in VDL 2016 nur ein schwarzes Bild gezeigt (VLC: läuft einwandfrei!)

geschi schrieb am 06.03.2016 um 11:53 Uhr

Mit den Einstellungen vonm geschi wird in VDL 2016 nur ein schwarzes Bild gezeigt

Vo diesen Video möchte ich eine Analyse sehen.

chrisly schrieb am 06.03.2016 um 11:58 Uhr

Gerne doch - ich hoffe, es ist nur ein Einstellungsfehler beim Konvertieren:

General
ID                          : 1 (0x1)
Complete name               : D:\Downloads\2010 04 02_1614.ts
Format                      : MPEG-TS
File size                   : 40.8 MiB
Duration                    : 19s 920ms
Overall bit rate mode       : Variable
Overall bit rate            : 17.1 Mbps

Video
ID                          : 20 (0x14)
Menu ID                     : 1 (0x1)
Format                      : AVC
Format/Info                 : Advanced Video Codec
Format profile              : Main@L4.1
Format settings, CABAC      : Yes
Format settings, ReFrames   : 2 frames
Codec ID                    : 27
Duration                    : 20s 0ms
Bit rate                    : 16.0 Mbps
Width                       : 1 280 pixels
Height                      : 720 pixels
Display aspect ratio        : 16:9
Frame rate mode             : Variable
Color space                 : YUV
Chroma subsampling          : 4:2:0
Bit depth                   : 8 bits
Scan type                   : Progressive
Stream size                 : 38.4 MiB (94%)
Writing library             : x264 core 148 r2665
Encoding settings           : cabac=1 / ref=1 / deblock=1:0:0 / analyse=0x1:0x131 / me=hex / subme=5 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=0 / me_range=16 / chroma_me=1 / trellis=0 / 8x8dct=0 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=0 / threads=12 / lookahead_threads=3 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=0 / b_adapt=1 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=abr / mbtree=1 / bitrate=16000 / ratetol=1.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / vbv_maxrate=24000 / vbv_bufsize=24000 / nal_hrd=none / filler=0 / ip_ratio=1.40 / aq=1:1.00

Audio
ID                          : 21 (0x15)
Menu ID                     : 1 (0x1)
Format                      : AC-3
Format/Info                 : Audio Coding 3
Mode extension              : CM (complete main)
Format settings, Endianness : Big
Codec ID                    : 129
Duration                    : 20s 0ms
Bit rate mode               : Constant
Bit rate                    : 192 Kbps
Channel(s)                  : 1 channel
Channel positions           : Front: C
Sampling rate               : 48.0 KHz
Compression mode            : Lossy
Delay relative to video     : -5ms
Stream size                 : 469 KiB (1%)
Language                    : English

Menu
ID                          : 4096 (0x1000)
Menu ID                     : 1 (0x1)
Duration                    : 19s 920ms
List                        : 20 (0x14) (AVC) / 21 (0x15) (AC-3, English)
Language                    :  / English
Service name                : Service01
Service provider            : FFmpeg
Service type                : digital television