Photostory Deluxe und Hardwarebeschleunigung

Kommentare

w-m-l schrieb am 05.08.2018 um 16:08 Uhr

Ich fand eure Diskussion so spannend und habe mich - obwohl ich offenbar nicht ganz so fit in programmtechnischen Dingen bin wie ihr - deshalb entschlossen, den von @Ehemaliger User beschriebenen Weg mal zu versuchen. Die Einstellungen ließen sich auch problemlos vornehmen, aber beim Rendern kam wieder "keine Hardwarebeschleunigung". Ich gehe davon aus, dass es daran liegt, dass für's Rendern nicht der Grafikchip der internen INTEL-CPU genutzt wird, sondern die NVIDIA GTX 1050. Mir wird hier

außer der NVIDIA Geforce GTX 1050 allerdings nur der "Microsoft Basic Render Driver" angeboten. Muss ich diese Auswahl treffen, oder den INTEL-Grafik-Chip über das BIOS ansteuern? Und - falls ich so vorgehe - bleibt dann nicht die NVIDIA-Karte auch in allen anderen Anwendungen außen vor? Danke, wenn ihr mir weiterhelfen könnt!

Ehemaliger User schrieb am 05.08.2018 um 16:32 Uhr

Hallo w-m-l,

um wirklich beim Encodieren die Hardwarebeschleunigung zu nutzen, bitte genau so vorgehen, wie ich dies bereits beschrieben habe. Nach Deinem o. g. Post gehe ich davon aus, dass die interne GPU (IGPU) nicht aktiviert ist, bitte unbedingt im Bios den entsprechenden Eintrag von Disable auf Enable stellen. Wenn der Eintrag der IGPU nicht zu sehen ist, muss wahrscheinlich im Bios der ERWEITERTE MODUS eingeschaltet werden, dürfte vom eingesetzten Mainboard abhängig sein. Rechner nach den Änderungen im Bios neu Starten und im Gerätemanager schauen ob die UHD 630 oder UHD 620 auftaucht. Dann wie von mir mit den beigefügten Screenshots vorgehen. Photostory neu Starten und schauen ob beim Export der entsprechende Eintrag der UHD auftaucht...müsste. Zur zweiten Frage betreffend Grafikkarte. Die interne GPU der Intel-CPU ist nur relevant beim Encoding/Export, beim Arbeiten mit dem Programm gilt der Grundsatz:"je Stärker und Leistungsfähiger die Hardware, also das Gesamtsystem", desto flüssiger ist es mit dem Arbeiten. Bitte zukünftig keinen NEUEN Beitrag aufmachen, erschwert die Historie zu verfolgen. Gruss Borrelly Anmerkung: die von Dir eingesetzte Nvidia GTX 1050 unterstützt als Einstiegskarte die NVENC Technik, allerdings nur bei ProX, es bleibt abzuwarten, ob in der Version Video Deluxe Plus 2019 (erscheint in der Preview Mitte August 2019) diese Technik unterstützt, um es vorweg zu nehmen, ich bin wenig begeistert, die Nutzung der IGPU ist derzeit am effektivsten was das Encodieren betrifft.

Gruss Borrelly

w-m-l schrieb am 05.08.2018 um 16:41 Uhr

@Ehemaliger User: Danke für deine schnelle und eingehende Antwort. Da werde ich mich wohl ans BIOS machen müssen. Aber was meinst du mit "NEUEM Beitrag"? Ich hab mich doch an meinen (eigenen) Post gehängt. Es gab jetzt wohl nur eine zweite Seite. ☺️

Ehemaliger User schrieb am 05.08.2018 um 17:19 Uhr

Hallo w-m-l,

Sorry, habe ich jetzt auch gesehen, ist zwischenzeitlich ne neverending Story, kann passieren bei 37 Grad.

So muss es in den Programmeinstellungen nach erfolgreicher durchgeführter Maßnahme in den Exporteinstellungen aussehen:

Gruss Borelly

 

BilderMacher schrieb am 05.08.2018 um 18:36 Uhr

@w-m-l, wenn im BIOS/UEFi die iGPU nicht aktiviert ist (und bei manchen auch kein Monitor am Ausgang angeschlossen ist), dann kann das Programm Photostory Deluxe keine iGPU und die Hardwareunterstützung nutzen. Das ist alles unabhängig von Windows 10 (1803) schon bisher so gewesen. Dazu gibt es unzählige Beiträge hier und auch der SUPPORT hat auf seinen Seiten dazu informiert.

Inwieweit der Eingriff in die Grafikeinstellungen von Windows auf die MAGIX-Programme tatsächlich Auswirkungen hat, muss man über den Support in Erfahrung bringen. Ob sie allgemeingültig sind oder doch rechnerabhängige Auswirkungen haben.

Die Exportzeit ist also stark abhängig von der Auflösung in der Exportiert wird und der Komplexität der genutzten Medien und Effekte.

@michael-stamm, Deine Beobachtung trifft auf alle Videoschnittprogramme zu. Je umfangreicher das Projekt, um so länger kann der Export dauern. Wenn dann auch die Hardware an die Leistungsgrenze kommt, nutzen auch keine "Schönheitsreparaturen".

"Je mehr die Menschen wissen, desto weniger müssen sie glauben!"

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
Ich kann vieles, darf aber nicht alles.
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

-------------

Hardware:

:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz (8 CPUs), ~2.3GHz
12288 MB RAM
DirectX 12
Intel(R) UHD Graphics (für Import, Verarbeitung, Export [Video deluxe 2023 | Video Pro X 14 | Photostory Deluxe 2023])
NVIDIA GeForce MX250 (wird nicht in Schnitt-SW verwendet)

---------------------------------------------

Edition    Windows 10 Home
Version    22H2
Installiert am    ‎15.‎10.‎2020
Betriebssystembuild    19045.2364
Leistung    Windows Feature Experience Pack 120.2212.4190.0

-----------------------------------------------

michael-stamm schrieb am 05.08.2018 um 21:29 Uhr

@Ehemaliger User

Leider habe ich mich zu früh gefreut!

Nachdem ich 2 Projekte in annehmbarer Geschwindigkeit exportiert hatte, habe ich erst mal Pause gemacht und dann später den Rechner neu gestartet.

Jetzt läuft das Exportieren wieder genauso schlecht wie vor der Optimierung.

Ein 30 Minuten Film war nach 90 Minuten 10% exportiert.

Auch die anderen Projekte laufen nur noch langsam.

Ich habe alle Einstellungen nochmals geprüft – alles so wie es soll.

Ich habe nur einen Unterschied festgestellt:

Als der Export schnell lief waren die Leistungsdaten wie folgt:

Jetzt sind Leistungsdaten anders. Die CPU ist fast immer auf 100% und die GPU ist bei 0%. Sollte die GPU von Intel nicht etwas arbeiten???

Ich weiß nicht mehr weiter!!

 

Ehemaliger User schrieb am 06.08.2018 um 08:49 Uhr

Hallo Michael Stamm,

zunächst sind die Informationen nicht aussagefähig genug, um die Ursache zu lokalisieren. Bitte beim erneuten Export den Taskmanager aufrufen, aber nicht auf den Kartenreiter "Leistung" sondern "Prozesse klicken, siehe beigefügten Screenshot. Wenn dann tatsächlich die CPU Last direkt dem Programm von Magix zugeordnet werden kann, bitte den Export erneut starten, aber nicht über die automatische Exportfunktion, sondern über "Datei-Exportieren-Format gehen" dann öffnet sich ein Exportfenster, hier bitte schauen, ob bei "Export auf GPU berechnen, ein Haken gesetzt ist, der muss unbedingt raus. (siehe Screenshot) Darüber hinaus beim starten des Programms in die Programmeinstellungen gehen und schauen, ob der Standardmodus und die UHD erscheint, siehe Screenshot.

Bin ab Morgen im Ausland, aber bestimmt gibt es noch andere Forumsmitglieder die Unterstützen können.

Gruss Borrellly

Anmerkung: welche Mediadaten als Eingangsmaterial und welche Formate und Auflösungen beim Export???

 

BilderMacher schrieb am 06.08.2018 um 11:47 Uhr

dann öffnet sich ein Exportfenster, hier bitte schauen, ob bei "Export auf GPU berechnen, ein Haken gesetzt ist, der muss unbedingt raus. 

Damit wird eine Programmfunktion ausgeschaltet, die für bestimmte Effekte notwendig ist. Und das nur, damit der Export schneller geht?

Natürlich wird der Export mit dieser Option nicht kürzer, aber er wird vollständig und ohne Fehler erfolgen.

Effektiv ist das nicht, was hier veranstaltet wird.

"Je mehr die Menschen wissen, desto weniger müssen sie glauben!"

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
Ich kann vieles, darf aber nicht alles.
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

-------------

Hardware:

:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz (8 CPUs), ~2.3GHz
12288 MB RAM
DirectX 12
Intel(R) UHD Graphics (für Import, Verarbeitung, Export [Video deluxe 2023 | Video Pro X 14 | Photostory Deluxe 2023])
NVIDIA GeForce MX250 (wird nicht in Schnitt-SW verwendet)

---------------------------------------------

Edition    Windows 10 Home
Version    22H2
Installiert am    ‎15.‎10.‎2020
Betriebssystembuild    19045.2364
Leistung    Windows Feature Experience Pack 120.2212.4190.0

-----------------------------------------------

michael-stamm schrieb am 06.08.2018 um 18:42 Uhr

@BilderMacher

Es geht mir ja nicht um ein "wenig schneller", ich finde 8 Stunden für einen Export zu lang! Besonders da die vorletzte Version Fotostory delüx 2016 deutlich schneller war (Bei gleicher Harrdware). Magix hat aber behauptet jetzt 5 Mal schneller zu sein?? Außerdem kann es nicht sein, dass der Export mal 2 und mal 8 Stunden dauert. Das kann nur an irgenwelchen Einstellungen liegen. Heute habe ich meine Grafikkarte deaktiviert und den Monitor direkt ans Motherbord, also direkt an den Intel Grafikchip angeschlossen und wieder ist das Verhalten ganz anders. Bedauerlich finde ich auch, dass die Hotline von Magix auf meine Mails nur mit Standard Mails antwortet.

BilderMacher schrieb am 06.08.2018 um 19:51 Uhr

Magix hat aber behauptet jetzt 5 Mal schneller zu sein??

Nein, MAGIX behauptet das nicht.

MAGIX wird aber auch nicht sagen, dass dieser Wert auch bei Hardware aus 2016, die mit Windows 10 läuft und wo das Programm im Kompatibilitätsmodus auf Windows 8 ausgeführt wird, erreicht wird.

Wie schon gesagt, die Hardware ist der Flaschenhals - u.a.

"Je mehr die Menschen wissen, desto weniger müssen sie glauben!"

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
Ich kann vieles, darf aber nicht alles.
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

-------------

Hardware:

:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
Intel(R) Core(TM) i7-10510U CPU @ 1.80GHz (8 CPUs), ~2.3GHz
12288 MB RAM
DirectX 12
Intel(R) UHD Graphics (für Import, Verarbeitung, Export [Video deluxe 2023 | Video Pro X 14 | Photostory Deluxe 2023])
NVIDIA GeForce MX250 (wird nicht in Schnitt-SW verwendet)

---------------------------------------------

Edition    Windows 10 Home
Version    22H2
Installiert am    ‎15.‎10.‎2020
Betriebssystembuild    19045.2364
Leistung    Windows Feature Experience Pack 120.2212.4190.0

-----------------------------------------------

michael-stamm schrieb am 07.08.2018 um 10:41 Uhr

Natürlich wird das von MAGIX behauptet!

Siehe z.B. Handbuch Seite 8

Soweit ich mich erinnere stand dass auch in der Mail mit der MAGIX mich zum Update von Version 2016 zu 2018 animiert hat!

Natürlich weiß ich, dass das nur eine typische Marketing Floskel ist, da ja keine Referenz angegeben ist. Aber diese Aussage suggeriert dem Kunden, dass die Software merklich schneller ist. Das ist aber nicht der Fall.

Zum Thema Hardware:

MAGIX gibt auf seiner Homepage minimal Voraussetzungen an die so gering sind, das fast jeder heutige PC leistungsstärker ist. Was fehlt sind aber die entscheidenden Angaben, die ja hier im Forum Beschreiben sind.

Die Hotline schreibt z.B.:

Zitat MAGIX:

Der Intel Encoder des Programmes unterstützt als Hardwarebeschleunigung nur Quicksync der aktuellen Intel-Grafikchips, was in Verbindung mit Ihrem AMD Prozessor nicht verfügbar ist.

Also AMD Prozessor ist nicht optimal. Das Betrifft z.B. Markus73.

Im Moment sieht es so aus, dass man für den Export von Aufwendigen Fotoshows eine Hochleistung PC benötigt.

Im Handbuch steht zum Thema exportieren mit höchster Qualität (4K, HEVC):

Zitat: „Die Encodierung kann in solchen Fällen sehr lange dauern“

Sehr lange ist bei mir bis zu 10 Stunden bei 30 Minuten Fotoshow.

Wenn das normal ist und MAGIX hier etwas genauere Angaben machen würde, dann könnte ich das auch akzeptieren.

Ich habe die Hotline auch gefragt, was die optimale Hardware für den Export ist – leider seit einer Woche keine Antwort!

Die Aussage, dass es nur an der Hardware liegt ist zwar richtig, aber wenn top Hardware falsch eingestellt wird,  dann läuft die Software halt besser oder schlechter.

Bei mir läuft der Export am besten, wenn ich meine Nvidia Grafikkarte deaktiviere und nur den Intel Grafikchip verwende. Da bedeutet für mich, dass es wenig Sinn ergibt eine leistungsfähige Grafikkarte zu installieren. Auch diese Frage habe ich der Hotline gestellt.

michael-stamm schrieb am 07.08.2018 um 10:57 Uhr

@w-m-l

Noch mal zu dem Thema aktivieren des Intel Grafik chip.

Der Prozessor Intel Core i5-8500 CPU hat eindeutig einen eingebauten Intel® UHD-Grafik 630 Chip,

Daher müsste er auch im Gerätemanager von Win 10 angezeigt werden.

So siht das bei mir aus:

Ist das nicht der Fall (war bei mir auch so) dan ist er im Bios deaktiviert.

Wen die Intel Grafik im Gerätemanager nicht angezeigt wird, dann kann sie bei Fotostory natürlich nicht gewählt werden.

Im Bios gibt es dazu einen Eintrag – das hat Borrely ja ausreichend beschrieben. Zu dem Thema gibt es auch Videos bei Youtube.

Im schlimmsten Fall ist das BIOS oder UEFI vom PC Hersteller so abgespeckt, das der Eintrag gar nicht vorhanden ist. Bei meinem HP Notebook ist das so. Bis jetzt konnte ich die vorhandene Intel Grafik noch nicht aktivieren.  

w-m-l schrieb am 13.08.2018 um 18:36 Uhr

Da ich diesen Thread “losgetreten“ und mich zwischenzeitlich auch schon mit dem Hinweis zufrieden gegeben habe, dass die Hardwarebeschleunigung und QuickSync ein sehr komplexes Thema seien und man vielleicht besser die Finger davon lassen solle, möchte ich nun doch noch mitteilen, wie das Problem bei mir gelöst werden konnte und vor allem warum sich die Mühen gelohnt haben:

Wie in einigen Kommentaren bereits beschrieben wurde, lag der Grund für die Schwierigkeiten nicht an Photostory Deluxe, sondern am Betriebssystem (Windows 10, Version 1803). Die Aktivierung der iGPU im UEFI brachte allein noch keine Abhilfe. Aus unerfindlichen Gründen wurde bei meinem neuen Rechner – im Gegensatz zu allen anderen Treibern – weder bei der Einrichtung noch bei den automatischen Updates der Treiber für die integrierte Grafikkarte der CPU (Intel Core i5-8500) installiert. So wurde im Gerätemanager auch nur die dedizierte Grafikkarte (NVIDIA GeForce GTX 1050) angezeigt. Dementsprechend erschien in Photostory unter > Programmeinstellungen > Anzeige als Auswahl außer der NVIDIA GeForce GTX 1050 auch nur ein Microsoft Basic Render Driver. Nach dem Hinzufügen des fehlenden Treibers  und der Auswahl des neu aufgetauchten Eintrags  INTEL® UHD Graphics 630 (ein zweiter Monitor musste übrigens bei mir dazu nicht am Mainboard angeschlossen werden) verkürzte sich der Export einer ca. 16-minütigen Diashow (MPEG4, Full HD 1920 x 1080) von vorher 18 Minuten auf weniger als 7 Minuten. Das Fenster beim Rendern hatte dabei auch in der Überschrift den Eintrag „Hardwarebeschleunigung“ statt wie vorher „keine Hardwarebeschleunigung“.

Ich hoffe, dass auch andere User von den Hinweisen in diesem Thread profitieren konnten und bedanke mich bei allen, die so zahlreich zur Lösung beigetragen haben, in diesem Fall insbesondere bei @Borrelly. Schönen Urlaub noch! 😉

Ehemaliger User schrieb am 13.08.2018 um 20:53 Uhr

Da ich diesen Thread “losgetreten“ und mich zwischenzeitlich auch schon mit dem Hinweis zufrieden gegeben habe, dass die Hardwarebeschleunigung und QuickSync ein sehr komplexes Thema seien und man vielleicht besser die Finger davon lassen solle, möchte ich nun doch noch mitteilen, wie das Problem bei mir gelöst werden konnte und vor allem warum sich die Mühen gelohnt haben:

Wie in einigen Kommentaren bereits beschrieben wurde, lag der Grund für die Schwierigkeiten nicht an Photostory Deluxe, sondern am Betriebssystem (Windows 10, Version 1803). Die Aktivierung der iGPU im UEFI brachte allein noch keine Abhilfe. Aus unerfindlichen Gründen wurde bei meinem neuen Rechner – im Gegensatz zu allen anderen Treibern – weder bei der Einrichtung noch bei den automatischen Updates der Treiber für die integrierte Grafikkarte der CPU (Intel Core i5-8500) installiert. So wurde im Gerätemanager auch nur die dezidierte Grafikkarte (NVIDIA GeForce GTX 1050) angezeigt. Dementsprechend erschien in Photostory unter > Programmeinstellungen > Anzeige als Auswahl außer der NVIDIA GeForce GTX 1050 auch nur ein Microsoft Basic Render Driver. Nach dem Hinzufügen des fehlenden Treibers  und der Auswahl des neu aufgetauchten Eintrags  INTEL® UHD Graphics 630 (ein zweiter Monitor musste übrigens bei mir dazu nicht am Mainboard angeschlossen werden) verkürzte sich der Export einer ca. 16-minütigen Diashow (MPEG4, Full HD 1920 x 1080) von vorher 18 Minuten auf weniger als 7 Minuten. Das Fenster beim Rendern hatte dabei auch in der Überschrift den Eintrag „Hardwarebeschleunigung“ statt wie vorher „keine Hardwarebeschleunigung“.

Ich hoffe, dass auch andere User von den Hinweisen in diesem Thread profitieren konnten und bedanke mich bei allen, die so zahlreich zur Lösung beigetragen haben, in diesem Fall insbesondere bei @Borrelly. Schönen Urlaub noch! 😉

Hallo w-m-l,

vielen Dank fürs Dankeschön...noch ein wichtiger Hinweis! Solltest Du aus welchen Gründen auch immer, dass Programm (Photostory) auf Standardeinstellungen zurücksetzen oder durch ein Upgrade von Magix neu installiert werden, muss die IGPU über Grafikeinstellungen bei den Windows-Einstellungen erneut im Energiesparmodus zugewiesen werden, sonst wundert man sich erneut beim Encodieren, warum es wieder länger dauert. Beste Grüße Borrelly

w-m-l schrieb am 14.08.2018 um 11:15 Uhr

Stichwort: Energiesparmodus: Ich habe in meinem letzten, als Lösung gekennzeichneten Post vergessen hinzuzufügen, dass bei mir die Aktivierung des Energiesparmodus nicht erforderlich gewesen ist. Der beschriebene Geschwindigkeitszuwachs wurde schon durch die anderen Schritte (Aktivierung der iGPU im UEFI / Installation des Treibers für die integrierte Grafikkarte der CPU / Vornehmen der entsprechenden Einstellungen für die Hardwarebeschleunigung in Photostory) erreicht. Nach der testweise vorgenommenen zusätzlichen Aktivierung des Energiesparmodus über > Rechtsklick auf Desktop  > Anzeigeeinstellungen > Grafikeinstellungen … (vgl. Post von Borelly am 04.08.2018 um 17:09 Uhr) wurde in exakt derselben Zeit gerendert wie vorher. Daher stehen die Optionen in den Grafikeinstellungen von Windows bei mir nach wie vor nicht auf „Energiesparmodus", sondern auf "Standardeinstellung des Systems". Durchaus denkbar, dass bei anderen Rechnerkonfigurationen anders vorgegangen werden muss.