Umlaute in Überschriften verschwunden

Kommentare

Robbin schrieb am 30.05.2022 um 21:25 Uhr

@nicole.l

Ich habe die Schriftarten heruntergeladen die ich auf der Seite verwende, wobei ich Freestyle Script und noch eine nicht finden und umbenennen konnte.

Eine Ursache deiner Probleme könnte darin liegen, dass du nicht den mehrfach aufgezeigten, leichten Weg zu deiner "Krönung" gehst, sondern lieber den umständlichen, fehlerträchtigen Weg durch den "Dschungel" nimmst... 😟

Der Download, den du wohl 3x durchgeführt hast und den ich weiter oben gemeint habe, ist das ZIP Archiv "used_fonts.zip", das du von hier, von meinem Demoserver heruntergeladen hast.

In dem Archiv sind, wie schon mehrfach gesagt, alle Schriften fehlerfrei im xar .woff Format enthalten, die du jemals auf deinen Seiten im aktuell besprochenen Projekt verwendet hast.

wobei ich Freestyle Script und noch eine nicht finden und umbenennen konnte.

In dem heruntergeladenen ZIP Archiv musst du nichts suchen oder hast du unnötigerweise woanders gesucht? Wenn ja, wo?
Die Dateien aus dem Archiv müssen- und dürfen nicht umbenannt werden und ja, auch die "Freestyle Script" ist vollständig, mit allen Umlauten im ZIP Archiv enthalten.

Auf deiner Site hat der WD die "Freestyle Script" 2x angelegt, 1x als "XaraWDGeneratedHTMLfont15.woff" und ein 2. Mal als "XaraWDGeneratedHTMLfont16.woff". Genau so, aber leider korrupt, liegen die Schriften jetzt immer noch auf deinem Webserver im Verzeichnis "index_htm_files"

Wenn du den kompletten Inhalt des oben gezeigten und von dieser URL heruntergeladenen ZIP Archivs "used_fonts.zip" ohne Änderungen in das Hilfsverzeichnis deines Projekts kopierst, dann solltest du anschließend darin 20 xar .woff Schriftdateien sehen, die genau so aussehen, wie oben im 1. Screenshot gezeigt. Die Dateinamen dürfen nicht geändert werden! Andernfalls funktioniert die automatische Reparatur der korrupten Fontdateien auf deinem Webserver nicht.

Gerne nochmal step by step, was du tun solltest, um das Umlaute Problem innerhalb von 15 Minuten zuverlässig zu beheben, ohne irgendwelche Änderungen an den Formatierungen der Seiten- oder an den vorhandenen Texten vornehmen zu müssen!

  1. Hilfsverzeichnis zu deinem Projekt suchen und öffnen (Hilfsverzeichnis evtl vorher anlegen wie weiter oben beschrieben)
  2. ZIP Archiv mit den korrekt angelegten xar .woff Fonts von hier herunterladen
  3. ZIP Archiv öffnen und die enthaltenen 20 xar .woff Fontdateien ohne jede Änderung vollständig in das Hilfsverzeichnis kopieren
  4. Wenn du das Hilfsverzeichnis manuell angelegt hast, Projekt jetzt schließen und erneut öffnen. War das Hilfsverzeichnis schon vorhanden, Projekt geöffnet lassen und mit Schritt 5 weitermachen
  5. Projekt veröffentlichen (Upload der Website auf deinen Webserver)
  6. Website online öffnen. Alle Umlaute sollten jetzt auf allen Seiten deiner Website zu sehen sein. Wenn nicht, mit der Tastenkombination "STRG + F5" den Browsercache leeren (kann für jede Seite einmalig nötig sein)

Solltest du danach immer noch Probleme mit den Umlauten haben, dann beschreibe bitte mal ganz genau, Schritt für Schritt, wie du die Tipps 1-5 umgesetzt hast und ob du dabei irgendwelche "Überraschungen" erlebt hast...

nicole.l schrieb am 31.05.2022 um 14:40 Uhr

Hallo Robbin, das war jetzt die beste Antwort überhaupt!!! 💯

Wo soll ich Anfangen.
Ein Problem war, dass ich nicht DEINEN zip Ordner runtergeladen habe, sondern die Fontdatein von Google (der andere Link) Das lag unter anderem daran, dass der Download nicht ausgeführt wurde (wurde vom IE geblockt) und mir das (wegen Tabs) nicht aufgefallen war. Ich hatte ja ausreichend zu tun... Da mit jedem erneuten Öffnen des IE auch das Tab mit aufging wurden so quasi mehrere Downloads angezeigt, obwohl ich es nicht runtergeladen hatte.

Dann hat sich hier noch ein ganz anderes Problem aufgetan.
Der Webdesigner hat ständig gehangen und wollte überhaupt nicht das machen was ich wollte. Teilweise konnte ich nichtmal die Projekte öffnen ohne dass sich alles aufgehängt hat. Es war alles sonderbar. Ich habe dann bemerkt, dass er die Projekte im WD 18 öffnet. Muss man nicht verstehen. Gut, Problem erkannt, Problem gebannt. Also manuell die Option geändert mit welchem Programm die Dateien geöffnet werden sollen.
Dann hatte ich endlich meine Hilfedateien erstellt und konnte die Schriftarten reinkopieren und alles hochladen.
Der Teil hat soweit tadellos funktioniert.

Nun kommen wir zu meinen 25.956 anderen Problemen ^^
Ich sagte ja Eingangs dass ich die Seite in 4 Teile geteilt habe, weil es über die Jahre mega groß geworden ist. (das war hier im Forum mal ein Tipp zwecks übelst langer Ladezeiten)

Nun habe ich also für den Teil der sich wuerfe nennt eine Hilfedatei erstellt. Da die .woff Dateien rein und das Projekt wuerfe.htm hochgeladen. 😏 Ergebnis: http://www.spinoneitaliano.de/a_einzelvorstellung.htm

Eigentlich sollten das die selben Überschriften sein wie auf der Hauptseite...

Eigentlich sollte oben links, beim Logo die selbe Schrift sein wie auf der Hauptseite...

 

Das war der Grund, weswegen ich sehen wollte welche Schrift als welche Nummer abgelegt wird.

Sagte ich schon, dass die Seite aus VIER Teilen besteht?

index
wuerfe
archiv
galerie

Lieben Gruß, Nicole

Robbin schrieb am 31.05.2022 um 19:55 Uhr

Ein Problem war, ... dass der Download nicht ausgeführt wurde (wurde vom IE geblockt)

Das Problem wird durch die verschärften Sicherheitseinstellungen einiger Browser provoziert, die bei Protokoll übergreifenden Links Alarm geben. hier die Info die der neue Firefox generiert wenn von einer SSL geschützten Seite Inhalt von einer ungeschützten Seite heruntergeladen werden soll.

Da muss manuell eingegriffen werden, um den Download zu erlauben...

Nun habe ich also für den Teil der sich wuerfe nennt eine Hilfedatei erstellt. Da die .woff Dateien rein und das Projekt wuerfe.htm hochgeladen.

Der danach sichtbare Fehler ist leider normal, weil der WD die Zuordnung der von ihm angelegten Fontdateien nicht nach einer bestimmten Regel vornimmt. Die Nummerierung erfolgt in Abhängigkeit vom Zeitpunkt der Erstellung der Texte. Das Ergebnis ist also nicht vorhersehbar und in jedem Projekt (Teilprojekt) anders.

Das war der Grund, weswegen ich sehen wollte welche Schrift als welche Nummer abgelegt wird.

Die Info, welche Schrift-, welcher Schriftschnitt in welcher xar .woff Datei liegt, kannst du sehr übersichtlich anzeigen lassen, wenn du in den einzelnen Teilprojekten die zugehörige Datei "xr_fonts.css" öffnest.
Das kannst du mit "notepad" machen oder direkt mit dem Browser (IE, Chrome, Firefox, etc.).
Öffnest Du die Datei im Browser, kann das Ergebnis so aussehen, wie hier am Beispiel der "xr_fonts.css" aus dem Teilprojekt "index" gezeigt:

Die zu deinen Teilprojekten gehörenden "xr_fonts.css" Dateien kannst du direkt sehen wenn du auf die folgenden Links klickst: Teilprojekt index, Teilprojekt wuerfe, Teilprojekt galerie

In deinen Teilprojekten hast du eine unterschiedliche Anzahl von Schriften angelegt, die ich in 3 verschiedenen Verzeichnisse gesammelt habe...

Wenn du dir hier nochmal das ZIP Archiv "used_fonts.zip" herunterlädst, dann findest du darin jetzt die 3 o.a. Verzeichnisse mit allen xar .woff Fontsets, die du in den jeweiligen Teilprojekten einsetzen kannst. Die Fontsets enthalten natürlich alle Umlaute und Sonderzeichen...

Um die Teilprojekte "wuerfe" und "galerie" nun auch noch zu reparieren, benutzt du einfach die entsprechenden Fontdateien aus dem neuen Download des ZIP Archivs.

Apropos Teilprojekte.
Ich finde nur die Projekte "index", "wuerfe" und "galerie" auf deinem Webserver. Das Teilprojekt "archiv" ist wohl abhanden gekommen? 🙃

zu guter Letzt...

Obwohl du mit der o. a. Methode die Umlaute Fehler auf deinen 150 Seiten mit ein paar Mausklicks beseitigen kannst, ist die Ursache des Problems noch aktiv. Der WD kann dir nach jeder Änderung in der Text Formatierung oder nach Löschung- und/oder Umstellung von Textblöcken auf den Seiten neue Probleme nach dem alten Muster machen.
Du weißt zwar jetzt, wie du ggf. auftretende, neue Umlaute Fehler wieder beseitigen kannst, aus meiner Sicht ist es aber empfehlenswert mit größeren Änderungen an der Site zu warten, bis Magix/Xara den Bug mit einem Update beseitigt.
Textänderungen die nur Ergänzungen- oder Löschungen von Textteilen beinhalten oder die Beseitigung von Tippfehlern etc. dürften keinerlei Probleme machen. Da hast du also freie Hand. 😉

nicole.l schrieb am 31.05.2022 um 20:11 Uhr

Das Archiv ist da. Hab es nach dem Löschen vom Server "falsch" abgespeichert. Es nennt sich 2021.htm_files

Du bist einfach nur der Wahnsinn! Vielen lieben Dank!

Robbin schrieb am 31.05.2022 um 21:09 Uhr

Das Archiv ist da ... Es nennt sich 2021.htm_files

Ok, die "xr_fonts.css" aus dem Datenverzeichnis "2021_htm_files" enthält im Wesentlichen die Fonts, die schon im Teilprojekt "wuerfe" vorkommen.


Du kannst also die xar .woff Fonts da herauskopieren, die Nummerierung anpassen und das Ergebnis in das Hilfsverzeichnis "2021_web_files" hineinkopieren. Dann sollten die Umlaute auf allen Seiten inkl. der Teilprojekte funktionieren.

nicole.l schrieb am 01.06.2022 um 17:13 Uhr

Gestern und heute hat mich der WD massiv geärgert. Das hat alles gelaggt, dass ich schon dachte es hat mir den Arbeitsspeicher oder den Prozessor geschossen. Nach Deinstallation, Neuinstallation und letztendlich dem exportieren der Webseite läuft er aktuell wieder einigermaßen.
Deswegen erst die späte Rückmeldung.
Habe die Seite Würfe erst heute zustande gebracht.

Wird Zeit für ein Update...

 

Es hat auf alle Fälle funktioniert! Die archiv, bzw. 2021 Seite spare ich mir. Daran passiert nichts. Das ist quasi die Ablage für die News aus den vergangenen Jahren...

 

Nochmals vielen lieben Dank für deine Mühe!

 

Lieben Gruß, Nicole