UTF-8

ralfbo schrieb am 07.01.2018 um 15:09 Uhr

Xara Webdesigner Premium:

Es ist zwar gut und schön, dass man durch einen Platzhalter UTF-8 als charset einstellen kann, jedoch funktioniert das bei mir nicht, denn es werden im Titel immer noch "Sonderzeichen" angezeigt ...

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>

<meta name="Generator" content="Xara HTML filter v.8.4.0.215"/>

<meta name="XAR Files" content="index_htm_files/xr_files.txt"/>

<title>xxxx xxxxx Home - Getr�nke Lieferservice f�r

Kommentare

ralfbo schrieb am 07.01.2018 um 17:01 Uhr

Ich habe da noch eine Frage zu ... warum werden die Dateien im ANSI-Code abgespeichert. Wenn ich die Dateien im UTF-8 Format abspeichere, bestehen diese Fehler nicht. Leider ist das für ein großes Projekt mit über 50 Seiten sehr müssig, jede einzelne Datei abzuspeichen. Hier wäre es hilfreich, ein Patch für das Programm zu erstellen oder eine Schaltfläche, die es ermöglicht, alle Dateien im UTF-8 Format abzuspeichern. Es ist doch sehr umständlich, wenn man zunächst ein Platzhalter erstellen muss, der dann den UTF-8 Code erstellt.

 

BeRo schrieb am 07.01.2018 um 21:13 Uhr

[...] Es ist doch sehr umständlich, wenn man zunächst ein Platzhalter erstellen muss, der dann den UTF-8 Code erstellt. [...]

Richtig, deswegen erstellen die neueren Versionen (ab Ver. 12) des Web Designer den HTML Code direkt im UTF-8 Format.

Dass es dann immer noch Probleme mit der richtigen Codierung geben kann und wie man das beheben kann, das haben wir u. a. hier ausführlich behandelt.
Lies Dich da mal ein...

Viel Erfolg

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

ralfbo schrieb am 08.01.2018 um 08:57 Uhr

Ich habe die MAGIX Web Designer Premium Version 12.0.0.45036 DL x64 von Mai 2016. Da ist es aber noch nicht Standard....

ralfbo schrieb am 08.01.2018 um 09:09 Uhr

Programm "Aktualisierungen" klappen wohl nicht, wenn es - wie ich jetzt auf der Seite von Magix gesehen habe - bereits die Version 15 gibt.

BeRo schrieb am 08.01.2018 um 09:20 Uhr

[...] habe die MAGIX Web Designer Premium Version 12.0.0.45036 [...]

Dann hast Du etliche Updates verpasst. Die aktuellste Version outet sich so:

Und damit exportierte HTML Dateien zeigen ganz klar die Ausrichtung auf das internationale Format UTF-8

Also, dringend updaten...
Ein Upgrade auf die brandneue Version 15 ist auch möglich, wenn Dein 12er sich noch innerhalb des 365 Tage Zeitraums für die gratis Updates befinden sollte.

Zuletzt geändert von BeRo am 08.01.2018, 09:25, insgesamt 2-mal geändert.

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

ralfbo schrieb am 08.01.2018 um 09:52 Uhr

Ich habe "Aktualisierungen" angeklickt, aber es kam die Meldung "auf dem aktuellsten Stand" oder so ähnlich. Hab jetzt Version 15 heruntergeladen und installiert. Alles gut!!!!