Zugriffsverletzung bei Export / Vorschau

fuerteventura-2007 schrieb am 11.03.2019 um 12:40 Uhr

Hallo liebes Forum,

ich stehe recht ratlos vor folgendem Problem:

Ich habe in einem Projekt zum letzten Mal am 26.05.2018 Änderungen durchgeführt und es erfolgreich exportiert. Heute stehen wieder Änderungen an, ich erhalte aber bei jedem Export (im letzten Schritt) sowie bei jeder Vorschau einen "Schweren Fehler" mit "Zugriffsverletzung bei 0x0E0047CB", ohne dass ich auch nur eine einige Änderung gemacht hätte!!!

Ich habe das Projekt bereits aus einem Backup wiederhergestellt, aber das Problem bleibt bestehen.

Ich habe nun einmal eine kleine Textänderung durchgeführt und erneut exportiert. Gleicher Fehler. Die Textänderung ist angekommen, aber z. B. das Menü funktioniert nicht (Adressen nicht aufgelöst).

Hier findet ihr die Seite im Internet.

Habe ich hier überhaupt eine Chance, der Ursache auf den Grund zu gehen? Oder muss ich in den sauren Apfel beißen und die Seite komplett neu erstellen (grusel)?

 

Ergänzung:
Es liegt wohl an der verwendeten Schrift Verdana. Habe eine neue Website gebaut mit einem kurzen Text Verdana auf ansonsten leerer Seite. Vorschau führt zum gleichen Fehler. Schrift in Arial geändert - alles ok.

Nun muss ich schauen, wie ich Verdana wieder flott kriege...

 

Vielen Dank im Voraus für eure Unterstützung.

Viele Grüße
Michael

 

---
Magix Web Designer 15 Premium
Windows 7

Kommentare

BeRo schrieb am 11.03.2019 um 15:33 Uhr

[...] Nun muss ich schauen, wie ich Verdana wieder flott kriege... [...]

Das sollte kein Problem sein... 😉

Am besten löscht Du zunächst die installierte "Verdana" Version.

Dann lädst Du hier die aktuelle Version herunter und installierst sie neu.

Fertig. 😊

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

fuerteventura-2007 schrieb am 11.03.2019 um 16:56 Uhr

Und tatsächlich, das war es!!!
Habe mir die Schrift neu aus meinem Schriftartenkatalog installiert und der Spuk ist vorbei.

Danke Dir, BeRo!
Und wo ich gerade dabei bin:
Ich habe die Schriftart als OpenType installiert, nicht als TrueType. Sind Dir da irgendwelche Unterschiede / Nachteile bei der Verwendung im WD bekannt?

Viele Grüße aus dem winterlich-grauen Hamburg
Michael

fuerteventura-2007 schrieb am 11.03.2019 um 17:57 Uhr

LEIDER - zu früh gefreut.

Mein voreiliger Jubel resultierte aus dem Mini-Test "Habe eine neue Website gebaut mit einem kurzen Text Verdana auf ansonsten leerer Seite." Hier funktionierte die Vorschau.

Habe dann die o. g. Website mit den Änderungen versehen, und bei Export und Vorschau tritt wieder der Fehler auf. Und danach schlägt dann auch der Mini-Test wieder fehl.... Daraus werde ich nicht wirklich schlau... :-(

Es gibt eine Datei "XaraWDGeneratedHTMLfont1.woff" mit der Größe von 0 Byte. Da liegt wohl der Hase im Pfeffer. Kann dazu jemand etwas beitragen?

Viele Grüße
Michael

FredW schrieb am 11.03.2019 um 17:58 Uhr

@fuerteventura-2007,

Google hat das 1001 Antwort darauf ...

z.B. https://janamaenz.photography/2015/02/hilfe-was-ist-der-unterschied-zwischen-postscript-truetype-opentype-schriften/

 

fuerteventura-2007 schrieb am 11.03.2019 um 18:18 Uhr

Hallo FredW,

danke für Deinen Hinweis. Die grundsätzlichen Unterschiede sind mir schon klar, die Frage ging speziell auf den WD ("Sind Dir da irgendwelche Unterschiede / Nachteile bei der Verwendung im WD bekannt?").

Denn die Schriftart ist auf dem System vorhanden und lässt sich z. B. in den Office-Anwendungen auch problemlos nutzen. Und in der betroffenen Website bisher ja auch, wie der Link auf die Online-Seite zeigt....

BilderMacher schrieb am 11.03.2019 um 18:26 Uhr

Es gibt eine Datei "XaraWDGeneratedHTMLfont1.woff" mit der Größe von 0 Byte.

Wo liegt diese? Im Export deiner HP auf der Festplatte oder auf dem Server im Ordner index_htm_files?

Da sie eh leer ist, lösche sie doch mal. Vielleicht erstellt der WD dann diese Datei neu?

Gruß, B a lderm I cher

(Ich bin KEIN MAGIX Mitarbeiter, ich bin NICHT beim MAGIX-Support!)

-----------------------------------------------------------------------------------------

Mein System: Windows 10 Home 64Bit Build 1903 | Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz | NVIDIA GeForce 840M, 4GB RAM | Vdl 2016/2019 Premium; Video Pro X7, X10, X11; Photostory Deluxe 2019 + TRAVEL Maps | MAGIX Photo & Graphic Designer 16; XARA Designer Pro X 16, Web Designer 11/16 | MAGIX Music Maker MX Premium, Music Maker 2016 Live, MAGIX Samplitude Music Studio 2017 | Samplitude Pro X4 Suite | MAGIX Audio & Music Lab 2016 Premium | Panasonic HDC-SD66 | Velbon CX-586 | Delamax Capa Videoschiene 60cm mit Velbon PH-358 Stativkopf | ZOOM H2n | Panasonic Lumix DMC-FZ300 | Focusrite Scarlett 2i2 2ndGen | Mikro: Neewer NW800

fuerteventura-2007 schrieb am 11.03.2019 um 18:43 Uhr

Hallo Bildermacher,

auf dem Server gibt es die folgenden Dateien im Ordner index_htm_files:
XaraWDEmbeddedHTMLfont1.eot
XaraWDEmbeddedHTMLfont2.eot
XaraWDEmbeddedHTMLfont3.eot
XaraWDEmbeddedHTMLfont1.woff
XaraWDEmbeddedHTMLfont2.woff
XaraWDEmbeddedHTMLfont3.woff

Die genannte Datei liegt im Export-Verzeichnis index_htm_files auf der Festplatte.
Den Ordner index_htm_files lösche ich vor jedem Export, da er sonst unangenehm groß wird. Vermutlich eine "Spezialität" der OnePager. Der Fehler tritt aber auch dann auf, wenn ich die Site als "normale Website" exportiere.

BilderMacher schrieb am 11.03.2019 um 18:52 Uhr

War so eine Idee. Aber welche Bedeutung die *.woff genau haben, weiß ich nicht.

Und den Magix Web Designer 15 Premium unter Windows 7 gibt es bei mir nicht mehr.

Bin mit meiner HP noch beim WD 11. Den WD 16 habe ich zwar, aber da zeichnen sich schon wieder andere Probleme ab - im Zusammenhang mit Varianten und dem Hamburger Menü.

Edit:

Das Hamburger Menü geht nun wieder. Die neue Gruppenbehandlung ist der Auslöser für das Verhalten. Man muss die neue Funktion abschalten und die Gruppe als Ganzes behandeln lassen (Webeigenschaften).

Zuletzt geändert von BilderMacher am 13.03.2019, 07:07, insgesamt 1-mal geändert.

Gruß, B a lderm I cher

(Ich bin KEIN MAGIX Mitarbeiter, ich bin NICHT beim MAGIX-Support!)

-----------------------------------------------------------------------------------------

Mein System: Windows 10 Home 64Bit Build 1903 | Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz | NVIDIA GeForce 840M, 4GB RAM | Vdl 2016/2019 Premium; Video Pro X7, X10, X11; Photostory Deluxe 2019 + TRAVEL Maps | MAGIX Photo & Graphic Designer 16; XARA Designer Pro X 16, Web Designer 11/16 | MAGIX Music Maker MX Premium, Music Maker 2016 Live, MAGIX Samplitude Music Studio 2017 | Samplitude Pro X4 Suite | MAGIX Audio & Music Lab 2016 Premium | Panasonic HDC-SD66 | Velbon CX-586 | Delamax Capa Videoschiene 60cm mit Velbon PH-358 Stativkopf | ZOOM H2n | Panasonic Lumix DMC-FZ300 | Focusrite Scarlett 2i2 2ndGen | Mikro: Neewer NW800

fuerteventura-2007 schrieb am 11.03.2019 um 22:37 Uhr

Hallo BilderMacher,

so ganz blicke ich da auch nicht durch. Ich habe gelesen, dass dadurch Schriften auf der Website eingebunden werden. Aber das widerspricht ja eigentlich der Verwendung der websicheren Schriften, die auf jedem Client vorhanden sein sollen. Und auf der betroffenen Website verwende ich ausschließlich Verdana - warum dann drei Dateien für die Schrifteneinbettung? Heaven knows....

Noch habe ich keine genau Vorstellung davon, wie ich mit diesem Problem umgehen soll. Da schaut man wie die Sau ins Uhrwerk.... Vielleicht mal Seite für Seite in eine neue web-Datei übernehmen? Morgen gehts weiter - der Kunde möchte ja Ergebnisse sehen!

Viele Grüße
Michael

BeRo schrieb am 12.03.2019 um 00:43 Uhr

Ein paar gut gemachte Infos zu den verschiedenen Formaten von Webschriftarten findest Du auf dieser Site.

Hier ein kleiner Auszug:
--------------------------------------------------
[...]
Derzeit werden vier Formate von Schriftartcontainern im Internet verwendet: EOT, TTF, WOFF und WOFF2. Trotz der großen Auswahl gibt es leider kein einzelnes universelles Format, das in allen alten und neuen Browsern funktioniert: EOT eignet sich nur für den IE, TTF bietet partielle IE-Unterstützung, WOFF verfügt über die breiteste Unterstützung, ist aber in einigen älteren Browsern nicht verfügbar und die WOFF 2.0-Unterstützung ist für viele Browser noch nicht implementiert.
[...]
-------------------------------------------------

Lies Dich mal ein, dann wird's ein bisschen klarer. 😇

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

fuerteventura-2007 schrieb am 12.03.2019 um 14:12 Uhr

Danke BeRo - lesen bildet 😆

Und so ein kleines bisschen Erfahrung mit Schriften habe ich, weil ich schon vor ca. 20 Jahren an der Nahtstelle zwischen Windows- und Mac-Welt tätig war. Aber das nützt mir hier herzlich wenig, denn ich habe ja gar keinen Einfluss darauf, was der WD treibt!

Habe jetzt direkt an den Support von Magix angeschrieben. Leider kann ich auch keine parallele Installation des WD auf einem zweiten Rechner durchführen, da im Service-Center schlicht kein Download-Link angeboten wird. Wohl weil der Service-Zeitraum abgelaufen ist. Hat schon was von Nötigung, diese Update-Politik von Magix...

Viele Grüße
Michael

BilderMacher schrieb am 12.03.2019 um 14:24 Uhr

da im Service-Center schlicht kein Download-Link angeboten wird. Wohl weil der Service-Zeitraum abgelaufen ist.

Wenn nicht direkt angezeigt, sollte sich nach dem Klick auf

das Installationsprogramm und das Handbuch herunterladen lassen. Egal, ob abgelaufen oder nicht.

Gruß, B a lderm I cher

(Ich bin KEIN MAGIX Mitarbeiter, ich bin NICHT beim MAGIX-Support!)

-----------------------------------------------------------------------------------------

Mein System: Windows 10 Home 64Bit Build 1903 | Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz | NVIDIA GeForce 840M, 4GB RAM | Vdl 2016/2019 Premium; Video Pro X7, X10, X11; Photostory Deluxe 2019 + TRAVEL Maps | MAGIX Photo & Graphic Designer 16; XARA Designer Pro X 16, Web Designer 11/16 | MAGIX Music Maker MX Premium, Music Maker 2016 Live, MAGIX Samplitude Music Studio 2017 | Samplitude Pro X4 Suite | MAGIX Audio & Music Lab 2016 Premium | Panasonic HDC-SD66 | Velbon CX-586 | Delamax Capa Videoschiene 60cm mit Velbon PH-358 Stativkopf | ZOOM H2n | Panasonic Lumix DMC-FZ300 | Focusrite Scarlett 2i2 2ndGen | Mikro: Neewer NW800

fuerteventura-2007 schrieb am 12.03.2019 um 14:53 Uhr

@BilderMacher:

tatsächlich!

Aus mir nicht ersichtlichen Gründen wird aber eine Installationsdatei WD 12 bereitgestellt.