2017. MIDI fails. Same startup message. Worst program.

nothingbuterrors wrote on 8/22/2019, 1:27 AM

Ha! Hahahaha! Ha! Funny and ironic! This idiotic program crashed my computer AS I WAS WRITING THIS POST! I had to rewrite it from scratch! That's poetry right there!

Anyway, I recently had to reinstall the program, because it got corrupted, because it froze up and I had to end it using Task Manager. Like I said, idiotic program. Sometimes it doesn't get corrupted, sometimes it doesn't freeze. This time it did both. Normally when I reinstall, everything's peachy from there. Not this time. Idiotic program.

I'm using MMM Premium 2017 here. Don't tell me to buy the new version to fix this, I'll be making a separate post on that bug.

Anyway, I reinstall and I reactivate and I get the message "You can download instruments and soundpools in this full version." Apologies if that's not the exact wording, I'm not going to start the program to check, because last time I did that, as I said, it crashed my entire computer and I had to rewrite this entire post. I check the "don't tell me this anymore" box. I exit it. Of course, that box doesn't work. I've tried all the buttons. I've tried "later", I've tried "OK" and then canceling on the permission-request-thing, I've tried accepting the permission-request-thing and then exiting out of the installationsmanager. No dice. Same message every time.

I could deal with that, even if it is a really stupid bug to have. My main problem, though, is that MIDI fails completely. I've tried both VirtualMIDISynth and the inbuilt Windows MIDI driver, though I must confess I'm still not exactly sure what VirtualMIDISynth does. When I use VirtualMIDISynth, I get a bunch of error messages that give no context (besides "maybe another program is using virtualmidisynth in exclusive mode", something that only Magix Music Maker has ever done on my computer) and, as far as Google is concerned, nobody else has ever encountered. When I use the Windows driver, I don't get any error messages. (Likely irrelevant, see edit) Regardless. This happens when I try and double click on a MIDI object. If I place down a new note, it immediately disappears. No matter what, no matter where, no matter how. The only time it doesn't disappear is when I use the pattern editor or I'm just editing the position of a preexisting note. From the sound I get when I place down the note, it seems as if it's creating a note at the lowest possible velocity, rather than the default velocity for MMM. From the outside view of the object (in the main program interface), every note I place down is still there, but extended all the way backwards from its original position to the beginning of the MIDI object. This is the only evidence that the notes didn't just disappear entirely. They don't play. I have a theory that somehow the beginnings of the notes are being placed before the beginning of the MIDI object, and that's why they neither show up nor sound when played over. No clue how to fix it.

I've had this problem, and the magnifying glass bug, before. In the past I've been able to restart my computer and fix everything thereby. Now, nothing. I've restarted the computer multiple times since reinstalling and I've tried uninstalling and reinstalling again two separate times. Same result. My program may be forever busted. Help?

(Note: I correctly predicted that my computer would error and delete my post when I tried to post it, so I successfully saved myself from a second rewrite by copying the full text prior. One of my only victories this evening. Go me.)

EDIT: The VirtualMIDISynth error messages are likely irrelevant to this. I just received the same error messages in 2019/2020 edition, and, after a brief moment of utter panic, found that MIDI was working just fine. Seems I just had some problems with VirtualMIDISynth at inconvenient times.


No comments yet - be the first to write a comment...