Acid 8 not letting me chose an editor app

evan-mitchell wrote on 5/6/2018, 2:11 PM

This is a major issue, will this be fixed soon???

When I go to Options > Preferences > Editing, I put my preferred audio editor into "Editing application 1." I browse, select the folder and .exe where my preferred audio editor resides, and yet, after choosing that audio editor, Acid behaves as if I had never made a setting (as if I had never chose an audio editor).

Comments

ShawnMH wrote on 5/6/2018, 3:00 PM

I have Sound Forge Pro 12 listed in preferences and working (mostly) correctly within Acid Pro 8. I cannot, however, get Steinberg Wavelab 9.5 LE to be seen or used from within AP8.

william-buck wrote on 5/7/2018, 6:01 AM

Yes, this has been reported and acknowledged last month after the AP8 release. I noticed it straight away, as adding an external audio editing app is one of the first Preferences changes I make when initially installing ACID.

FYI, I tried adding Magix's own SF Studio 12 (which is 64 bit) and it would not work. Hopefully, Magix will release a patch fix soon with the more obvious reported bugs fixed (like the reported Beatmapper Wizard bug).

https://www.magix.info/us/forum/acid-pro-not-letting-me-choose-an-editing-application--1205297/

ShawnMH wrote on 5/7/2018, 9:16 AM

Sound Forge Pro 12 added itself to Acid Pro 8's editor preferences. I didn't do anything, just noticed after the SFP12 installation.

GaryLee wrote on 5/9/2018, 7:41 AM

Can't get AP8 to see SF11 or SLP any version. Only SF12

backbeat69 wrote on 5/10/2018, 7:03 AM

same here wont see SF 11 pro.I do not like that I can only have Acid Pro 8 on 2 Computers.I have different ones in my studio.The ones I take on the road.They say I can move them around once a month.WHAT A JOKE.Give us a doggle or internet like reason or Pro Tools

browj2 wrote on 5/10/2018, 12:41 PM

@backbeat69

If I am correct, put the programs on more than 2 computers. Only 2 will be activated. In other Magix programs, like Movie Edit Pro, under Help, there is a "Deactivate button." If I click on this, I deactivate the current machine which immediately frees up an activation; no need to wait a month. Then in another machine, I load the program and activate it. See if you have the Deactivate button under Help. I don't have Acid Pro 8, only 7.

John CB

John C.B.

Desktop System - Windows 10 Home 1903; 16Gb RAM; i7 CPU 860@2.80Gz; ATI Radeon HD5770 w1GB; SSD 500GB, HD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB; dual monitors - 27" main, 25" secondary; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer; Notebook - Microsoft Surface Pro 4, i5, 8 GB RAM, 256 SSD, W10 Pro 1903

MrSoundman wrote on 5/10/2018, 4:38 PM

In AP8, from the Help menu, "Deactivate the software on this PC...", it's very simple.

Back on topic, here's a workaround to get your choice of editor set up:

1. Hold down the shift key while selecting Options | Preferences.
2. Click the Internal tab.
3. In "Show only prefs containing:", type "editor".
4. In "External Editor 1", under "Value", type the exact path to your audio editor's executable.
5. In "Editor 1 name", under "Value", type whatever you want to see this displayed as.
6. Click OK and have some fun!

william-buck wrote on 5/10/2018, 6:25 PM

In AP8, from the Help menu, "Deactivate the software on this PC...", it's very simple.

Back on topic, here's a workaround to get your choice of editor set up:

1. Hold down the shift key while selecting Options | Preferences.
2. Click the Internal tab.
3. In "Show only prefs containing:", type "editor".
4. In "External Editor 1", under "Value", type the exact path to your audio editor's executable.
5. In "Editor 1 name", under "Value", type whatever you want to see this displayed as.
6. Click OK and have some fun!

Thanks, your step by step worked like a charm! 😎

GaryLee wrote on 5/10/2018, 8:26 PM

This works beautifully MrSoundman! Thanks so very much! Hoorah!

MrSoundman wrote on 5/25/2018, 2:25 PM

Amazingly, this is NOT fixed in the 8.0.3 (Build 223) update! 😡

william-buck wrote on 5/25/2018, 3:35 PM

Amazingly, this is NOT fixed in the 8.0.3 (Build 223) update! 😡

Yes, this was the first thing I checked and quite an obvious bug a boo. I was surprised this was not addressed as well. But using your step by step I was able to get my Sound Forge Audio Studio 12 (64bit) to AP8. Thanks again for the workaround, MrSoundman!

 

MrSoundman wrote on 5/26/2018, 1:39 PM

As the person whose post was marked as "The Solution" (it was not a solution, rather a workaround), can I request that the topic be "un"-resolved?

Seriously, how difficult a fix could this be? The text boxes in the preferences dialog are not editable. This is almost unchanged from AP7 .... surely there was not much re-writing of code involved here? I'm still trying to find anything in the "patch" that has changed which could be considered more important than being able to set the wave editor to use in an applicaiton which is based on sample manipulation. 😲

johnebaker wrote on 5/26/2018, 3:29 PM

@MrSoundman

Hi

While I agree with your comment that this is a workaround, tagging the answer as a solution is the only means of indicating to other users that there is a method available for at least changing the editor in the program.

JohnEB

Forum Moderator

Lateral thinking can get things done!

VPX, MEP Premium, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

MrSoundman wrote on 5/26/2018, 4:01 PM
tagging the answer as a solution is the only means of indicating to other users that there is a method available for at least changing the editor in the programrum Moderator

Fair enough, accepted as a compromise ..... for now!

william-buck wrote on 6/27/2018, 7:43 PM

FYI, adding an external editing app via AP8's Preferences|Editing tab seems to be fixed now with the latest v8.0.5 (build 226) update.

MrSoundman wrote on 6/28/2018, 6:44 PM

Confirmed, it does appear to be fixed.

Sarge727 wrote on 2/16/2019, 10:38 AM

In AP8, from the Help menu, "Deactivate the software on this PC...", it's very simple.

Back on topic, here's a workaround to get your choice of editor set up:

1. Hold down the shift key while selecting Options | Preferences.
2. Click the Internal tab.
3. In "Show only prefs containing:", type "editor".
4. In "External Editor 1", under "Value", type the exact path to your audio editor's executable.
5. In "Editor 1 name", under "Value", type whatever you want to see this displayed as.
6. Click OK and have some fun!

Thanks, your step by step worked like a charm! 😎

This is great help, finally

Matt-Francis wrote on 3/2/2019, 6:39 AM

In AP8, from the Help menu, "Deactivate the software on this PC...", it's very simple.

Back on topic, here's a workaround to get your choice of editor set up:

1. Hold down the shift key while selecting Options | Preferences.
2. Click the Internal tab.
3. In "Show only prefs containing:", type "editor".
4. In "External Editor 1", under "Value", type the exact path to your audio editor's executable.
5. In "Editor 1 name", under "Value", type whatever you want to see this displayed as.
6. Click OK and have some fun!

Wow, thank you so much, Mr. Soundman. It hadn't been completely fixed as I couldn't add an editor when I started using AP8 after the latest update. Now I can edit my tracks!

MrSoundman wrote on 3/2/2019, 9:01 AM

It hadn't been completely fixed as I couldn't add an editor when I started using AP8 after the latest update.

Strange .... I've applied the latest update (Build 8.0.8.29) too and it's definitely still fixed here, in fact it has been for some time. I also added a second editor since applying the update and that worked fine too.

sheppo wrote on 3/2/2019, 5:33 PM

Updated the FAQ to this link. Thanks again @MrSoundman!

1. Hold down the shift key while selecting Options | Preferences.
2. Click the Internal tab.
3. In "Show only prefs containing:", type "editor".
4. In "External Editor 1", under "Value", type the exact path to your audio editor's executable.
5. In "Editor 1 name", under "Value", type whatever you want to see this displayed as.
6. Click OK and have some fun

Matt-Francis wrote on 3/3/2019, 6:22 AM

It hadn't been completely fixed as I couldn't add an editor when I started using AP8 after the latest update.

Strange .... I've applied the latest update (Build 8.0.8.29) too and it's definitely still fixed here, in fact it has been for some time. I also added a second editor since applying the update and that worked fine too.

If I click Apply nothing happens. I thought your workaround was the answer but when I loaded up AP8 today it had gone back to no editor available, so it's back to square one.

ShawnMH wrote on 3/3/2019, 9:27 AM

I still have it working here with the recent update - used both SF Pro 12 and Wavelab Pro 9.5 from within Acid Pro 8.

Matt-Francis wrote on 3/4/2019, 6:05 AM

I tried the workaround again and now it seems to be remaining available, so cross fingers I guess.