ACID Pro 10 Suite install completely messed up!

Joseph-Bourke wrote on 7/10/2021, 2:32 PM

I recently purchased an upgrade to ACID Pro 10, then decided I wanted the additional features of the Suite. Within a couple of days I purchased the ACID Pro 10 Suite and installed it (V 10.0.5, build 38 - 64-bit) in Windows 7. Shortly after installation, and downloading and activation of the various VITA instruments and the bx_oberhausen synth, the VITA instruments disappeared from my plugins list. I managed to find where they were installed (Users/Public/Public Documents/Magix/Mxsynths), or something close to that. Everything was there, but nothing was opening in the Suite other than the VITA Sampler. All other 3rd party VSTs were fine.

I tried uninstalling the software, doing a registry clean, and reinstalling. When I tried to install the VITA instruments, it showed that they had installed, but upon searching for them in the software (by trying to load a SoftSynth, they were not there! There is nothing for VITA instruments showing up, even after doing several rescans of the soft synths! I have installed and reinstalled the Suite, with no luck at all getting the instruments, which are showing up in ACID PRO 10 (NOT the Suite), but in many cases (Piano, saxophone, etc.) not finding the sounds, and throwing errors. All of the VITA instruments are missing from ACID Pro 10 Suite. I purchased the Suite in order to get the additional instruments and bx plugins, so, so far, my purchase has been useless! I don't want the new sounds, partially broken, in ACID Pro 10 - I want them where I purchased them to go - in the Suite. Thanks for any help you can give. I have spent days of my time trying to fix this broken wreck, rather than enjoying the creation of music!


SP. wrote on 7/11/2021, 2:05 AM

@Joseph-Bourke You can uninstall Vita instruments by uninstalling Magix Content and Soundpools from Windows. This will give you a list where you can select which instruments to uninstall. Then try to reinstall them again.

Joseph-Bourke wrote on 7/12/2021, 1:41 PM

Thanks for your quick response! Just to be on the safe side, I uninstalled ACID 10 Pro (which is where the VITA softsynths were showing up although some were missing the sound files). I then did a registry clean, uninstalled the Magix Content and Soundpools, did another registry clean, a reboot, and went in to ACID Pro 10 Suite, and reinstalled the VITA softsynths (just the 1st collection) from ACID Pro 10 Suite. They installed to - E:/Users/Public/Documents/MAGIX/Common/Mxsynth. This should be just fine, since my E: drive is where ACID Pro 10 Suite is installed (as are all my apps - I have an OS C: drive, an Apps E: drive, and two Media Drives (F: and G:), the standard configuration for a video/music editing workstation.

It did not work - when I started up ACID Pro 10 Suite, none of the softsynths loaded, as usual (the VITA sampler did, and has been loading, all along). My next attempt will be to uninstall the MAGIX content again, clean the registry again, uninstall and reinstall ACID Pro 10 Suite, then attempt the same reinstallation of the softsynths. This is eating up all of my time, which should be spent enjoying creating music! I am at the point of returning the Suite, and going back to ACID Pro 10, which worked, all the time, reliably. Thanks for your help.

Joseph-Bourke wrote on 7/12/2021, 2:36 PM

ABSOLUTELY NO LUCK WITH THIS STINKING PILE! Completely uninstalled ACID Pro 10 Suite, uninstalled the MAGIX content (AGAIN), cleaned the registry, reinstalled the app, reinstalled Instruments 1, 2, and 3 (watched them install to the correct location), rebooted, restarted ACID, set the Fx path to the correct path. NOTHING! Not a single Vita softsynth! I am at my wit's end with this! Everything worked fine for about a day after the first installation, then nothing as far as the Vita instruments go! They are the reason I upgraded to the Suite, and it was a waste of my money. I will await a solution, then I will await a refund, and go back to ACID Pro 10.

Rednroll wrote on 7/13/2021, 7:15 PM

Your typical drive configuration may be the problem, I no longer feel it's typical. I used to configure my systems the same way in the past, especially when you often ran out of C: drive space. With recent setups I find just installing programs to their default C:drive locations to often be the best option. Too many similar problems with other programs as you describe where links are hardcoded into the application instead of dynamic based on user preference settings in installer where a developer overlooked a hardcoded path in the app and it never got caught when tested outside of the default location paths.

Only paths I change now on plugin installs are some installers default to C:\Program Files\Vstplugins while others to

C:\Program Files\Steinberg\Vstplugins

I set to non Steinberg folder inclusion.

Joseph-Bourke wrote on 7/14/2021, 3:52 PM

Thanks Rednroll -

Not to be difficult, but if my drive configuration is the problem, why is it that the Adobe Suite, Blender 2.9, 3DS Max, and numerous other software packages which use plugins, all have no problem with accessing external and third party plugins with no problem. It's been working for years with the above software (plus the newer Blender version), and the ONLY software that's failing miserably is ACID Pro 10 Suite! The other versions of ACID, by the way, all work just fine with this drive configuration as well.

In several years of work as an audio and animation professional, the only other package which has given me trouble has been one of the Red Giant plugins for After Effects, which installed by a hard-wired path, to my C: drive. They, however, realized the folly in this, and posted a detailed workaround, which worked quickly, and perfectly. I don't get it.

My next step, which I am working on right now, is to try uninstalling the ACID Pro 10 Suite AGAIN, and doing the install to the C: drive. I am also, of course, doing a registery clean and hard boot before doing this. I'll post how it works out, but it's definitely not the solution I need, because my C: drive is very low on room.

Joseph-Bourke wrote on 7/14/2021, 4:53 PM

Oh...this just gets better and better! After uninstalling everything and doing a registry clean, I started to reinstall ACID Pro 10 Suite. Now the registration at MAGIX is no longer accepting my Serial Number. I have spent upwards of 5 days on this piece of garbage, and I think it is time to pack it in and get a refund from MAGIX.

HERE"S ANOTHER UPDATE: Finally got the Serial Number to work. ACID Pro 10 Suite is installed on the C: drive. Installed the first set of Vita instruments - NOTHING! They do not appear! The correct path is in the setup, but no Vita softsynths! So the C: drive was NOT the solution. The solution is for MAGIX to come up with a fix for me! It seems that every time I reinstall, the installer puts the Mxsyths folder in a different place. Sometimes ProgramData, sometimes Users/Public. None of this makes any sense!

Rednroll wrote on 7/14/2021, 11:49 PM

I have nothing.....

I would additionally try running AP10 as administrator to see if that changes anything.

I'm not familiar with the Vita Synths, etc.

However, I will say that I ran across a similar situation installing Toonstrack's EZdrummer2 instrument where that installer, installed the VST3 version of the instrument plugin into the default C:\ Program Files\Common Files\VST3 folder location, where I had Acid scanning that particular folder. However, AP10 identified it as a "Failed" plugin. I found it in the AP plugin manager under the "Failed" folder.

The thing that I noticed "different" was that particular plugin had a .DLL file extension where VST3 plugins typically have the .VST3 file extension. I therefore copied that .DLL file into my C:\Program Files\VSTplugins folder where I typically install my VST2 plugins which have a .DLL file extension, restarted Acid and magically that plugin now showed up and worked in Acid.

So although I had Acid setup scanning both of those folders originally, it was like it looked at that plugin under the VST3 folder and said, "That's not suppose to have a .DLL file extension in this folder, this folder is only suppose to have .VST3 file extension plugins and decided to just throw it in the "Failed" plugin folder.

Similarly, you'll probably want to look under these folders in Acid's Plugin-in Manager and see if by chance Acid is doing something similar and marking those instruments as a Failed, ignored, or Unavailable plugins.

See here:

Joseph-Bourke wrote on 7/15/2021, 4:31 PM

I have come to the conclusion that you have to live at 221B Baker Street to use this software! I just finally nailed it! I started searching on the C: drive, knowing that if the Vita softsynths had installed, they had to be somewhere on my C: drive, since in this last install, I let it go for the default, just in case that was the problem (my having put the install to the E: drive, that is).

I began a laborious search, and finally, by typing in the name of one of the softsynths (Urban Drums), which I had installed, I found the install location. It is C:\Program Files (x86)\Common Files\MAGIX Services\Mxsynth. Why in God's name they would have put it there - plus to not give any indication in the manual (which covers the Vita synths) as to where they might be hidden! I went to Plug In Manager, chose the path, and the Vita Synths are now up and running! Thank you everyone for your help on this, and don't take for granted that the path that worked for me will be the same on any other installs of ACID Pro 10 Suite. It put the Mxsynths in totally different locations on every other install I tried! Should you ever want a list of all the different locations they showed up in, give me a shout!

Chad-Dutton wrote on 11/11/2022, 10:46 AM

I realize I'm stepping in more than a year later... but for anyone else with this problem, please remember:

If it's VST3, it's under (Drive Letter)\Program Files (x86)\Common Files\(Plug-In Manufacturer Folder)

DX, VST & VST2 use the old path. This was done to distance the new plug-in format for the newer VST3.

This is true of almost all VST3 instruments & effects.

Greg-Behringer wrote on 3/23/2024, 2:09 AM

I had the same problem. I went to the Help menu and saw "Download Instruments and Loop Collections" at the bottom. I figured, what the heck. Clicked on it and about 10 minutes later everything was back.