Acid Pro 8 ReWire issue.

charlie-s wrote on 5/3/2018, 5:53 AM

Hi there. A long time user of Acid Pro but I kind of gave up on it when Sony ceased its support so I reluctantly moved on to Reaper DAW. Of course I was delighted to see that Magix had saved Acid and am currently experimenting with the trial version.

My ideal workflow now would be to use Reaper as a host and Acid as a slave via ReWire. However, although both programs are 64bit, are capable of both host and slave functions and were installed in the correct order, Acid simply will not show up as a rewire device in Reaper.

Interestingly when I tried to find the Acid machine .dll in order to try a registry hack the only similar item I could find in the Acid files was that a legacy from Acid 7 and perhaps a reason why I am experiencing this issue?

Reaper will slave to acid, it appears in an 'ignored' folder which I don't quite understand but it does work, however I really need Acid to slave to Reaper so can you think of anything I might do to correct this anomaly?



anthony-james wrote on 5/3/2018, 6:40 AM

I could be wrong but I don't think previous versions of ACID Pro allowed it to be a rewire slave... Only a master and AP8 is probably the same at this stage of development.

charlie-s wrote on 5/3/2018, 7:28 AM

In the documentation/help files which accompany AP8, the first part of the section on ReWire begins by saying that it is capable of acting as either a host or a slave, hence my query and the hours of head scratching, uninstalling/reinstalling of both programs which I lost a day to! I am exceptionally old so lost days start to be measured in dog year terms for me ;O).

The fact that when I explored the files which get installed with AP8 I discovered the only rewire reference was labelled ACID7ReWire.dll might have something to do with it but as I said, the help files clearly state that the program is capable of acting as either a host/mixer or a slave/device but no matter what I do it simply won't show up in Reaper in the ReWire VST box so now I am completely lost.

anthony-james wrote on 5/3/2018, 11:22 AM

I have been rewiring to Ableton live with AP8 as the master... When I get a chance to I will see if I can get AP8 to slave to Live.

charlie-s wrote on 5/3/2018, 11:41 AM

That would be very interesting indeed, many thanks. I've kind of gotten around it by using Reaper's ReaRoute function which will essentially do everything I need but I'm still highly puzzled by the ReWire issue.

Just a few minutes ago I got that erroneous 'System is low on memory' warning which was prevalent when using previous versions of Sound Forge and Acid Pro, not too encouraged to get that annoyance again.

When you go through the AP8 directory you discover multiple files with Acid Pro 7 labels so I'm starting to wonder how much of a rebuild this actually is!

anthony-james wrote on 5/4/2018, 1:26 AM

OK just tested AP8 in both slave and master modes with Ableton live 9 and it indeed does work and connect as both a slave and master.

Regarding the low memory message.. If you have 4 gig RAM or less upgrading to 64 bit won't make any difference to how much physical memory Acid can access... 4gig is the limit for 32 bit apps (actually some of that 4 gig RAM is also reserved for the OS)

But if you have more than 4 gig RAM and upgraded from a 32 bit application to 64 bit you can access as much physical memory as the computer has so running into memory limitations is far less likely...

rainer-kothig wrote on 5/14/2018, 9:14 AM

no they not worked on rewire at all, that is not magic, sorry usally acid worked fine with any daw in slave mode by pro7..that was magic..what that has to do with an updatet version to acid pro 8 showing me ACID7ReWire.dll..what a crap is that about..

sheppo wrote on 5/15/2018, 8:33 AM

Sounds like ACID7ReWire.dll might be from an older installation of Acid Pro that's still on your system, and this may be causing issues. If possible, try removing older versions of Acid

rainer-kothig wrote on 5/22/2018, 4:54 AM

no its not it comes with the installation with the new acid pro 8 on an fresh new windows 64 bit system / i do have two computer one for experiments bevor i but on the studio system..and they dont rewire update acid pro 8, defintley not they forgot about it..on a fresh sytem showing slave under cubase rewire a proof...and at my studio system acid pro 7 workes still in a rewire slave withhin cubase 32 bit this why i keep 32 bit cubase 8 on an 64 bit system..funny but it is so..i am a acid pro user since it came out..and it is original no crack.


sheppo wrote on 5/22/2018, 2:35 PM

Interesting. I do not have ACID7ReWire.dll on my system, and I only have Acid Pro 8, 32bit/64bit installed. Can you tell me where on your system the file exists? which folder, also file size, modified date, and other such details.

rainer-kothig wrote on 5/24/2018, 10:37 AM

Acid Pro 8, 32bit ?????..i thought there is only a new upgradet acid pro 8 and only in 64 bit how come you have a 32 bit version acid pro 8 in your system..strange too me i am getting more confused than ever ..did you tryed running cubase 64 bit and rewire acid pro 8 64 in slave mode and its working and showing a acid rewire 8.dll in your cubase daw..i really doubt it..sorry

nanito wrote on 5/25/2018, 8:31 PM

I have cubase 6.5.5 64bit, acid7 32 and acid8 64 installed on my computer. I can´t rewire acid8 into cubase. I dont know if having both versions installed can cause problems. I also have the file ACID7Rewire.dll. It´s in the folder "Audio Hardware Drivers". In both versions acid7.32/acid8.64

shintobi wrote on 5/29/2018, 8:16 AM

I could be wrong but I don't think previous versions of ACID Pro allowed it to be a rewire slave... Only a master and AP8 is probably the same at this stage of development.

ACID is currently not available as a slave to other DAWs.


Best Regards,


rainer-kothig wrote on 6/6/2018, 10:38 AM

acid pro7 as rewire slave with cubase as master work and is still working on my 32 bit system and i do work with it still, on 64 bit updated system acid pro 8 -64 bit does not do it anymore as slave..rewire 7 pro dll is showing up and rewire is not updatet for 64 bit engine systems..thats the fact..try out by yourself if you dont belive me..all other comments here are some sort of guessing and not real knowlegbased .magix did not updatet rewire 64 bit forgotten

Sean-Weyers wrote on 9/14/2018, 6:47 PM

I had this same problem and I couldn't let it go- especially since the manual, and the information about Acid Pro 8 on the Magix site states that 8 runs as both a slave and master. Apparently, sometimes during the install, the registry key that exposes Acid as a ReWire slave doesn't get created. This key simply needs to be added into the registry for it to work. The .dll file in Acid Pro 8 has NOT been renamed from Acid 7, although it is a different file (7 wasn't 64 bit). Also, it shows up in the ReWire master as Acid Pro 7. If you are using Reaper (64 bit), and have both Acid 7 and 8 installed: Acid 7 will show as Acid Pro 7/32 and Acid 8 will show as Acid Pro 7.
First, find the rewire .dll in for Acid Pro 8. It should be in C:\Program Files\ACID\ACID Pro 8.0\Audio Hardware Drivers and will show up as ACID7ReWire.dll. It's just important to know where it is. If you installed Acid somewhere else, it will be there.
Next, add the registry key. Hit the windows key and type regedit to open your registry editor. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Propellerhead Software\ReWire. Right click on the ReWire key in the navigation tree and add a new key. It will add a new key with a default name and default value. Name it ACID Pro 8.0 and then right click in the blank area on the right and add a new String Value. Name the new string value Device Path. Double click on the new Device Path entry, and in the Value data box, type the path to Acid 8 rewire .dll that we found earlier.
That's it, all done. It should work now, at least it does for me- I can ReWire Acid Pro 8 as a device in Reaper and Cubase. I haven't tried it with anything else. I hope this helps- I really loved using Acid as a device to Cubase, and I'm SO stoked to finally get my old workflow back after so many years.

charlie-s wrote on 9/20/2018, 10:36 AM

Hi Sean, I have absolutely no idea who or where you are but if you were close at hand I could give you a gigantic man hug!

I don't get any notifications at all from this forum (probably something else I'm doing wrong) but today, by some bizarre coincidence I was thinking about starting a loop based reggae song and my mind returned to my original problem of trying to get Reaper to see Acid 8 as a slave and so I randomly Googled 'Reaper Acid slave' and lo and behold the first thing I came across was my original question on this forum. Of course, as I don't receive any notifications I was highly surprised to discover that there had been a number of replies.

Scrolling past the kind gentleman who said I was talking crap about the ACIDPro7.rewire.dll I came to your comment which was well written and obviously informed so I followed your instructions to the letter and miracle upon miracle it worked like a charm.

You sir are a bona fide genius and a tenacious one at that for persevering and finding a way round the problem, I seriously can't thank you enough.

As I mentioned in my OP, I'm pretty damn ancient and information tends to leave my brain as fast as new information enters it (a bit like Homer Simpson in that regard!) so I am struggling to get to grips with computer recording having previously only used a hardware multitrack, thanks to your perspicacity though I now have one less migraine inducing issue, I'm so extremely grateful.


Sean-Weyers wrote on 9/20/2018, 6:04 PM

You're welcome! :D

passionfly1 wrote on 7/17/2019, 9:03 PM

Just FYI, here is a video I found that mods a registry entry to enable ReWire to work with any DAW. It is really this simple and the OS is irrelevant as all modern Windows OS's (XP through version 10) use registry keys. Hope this helps.

Solving a ReWire instrument not showing up issue on Windows

passionfly1 wrote on 7/17/2019, 9:09 PM

FYI, here is the CORRECT name for the rewire file your supposed to be using and the reason yours is not working is because your either on 32-bit version of Acid which is using 32-bit DLL's or your registry is just pointing to the wrong file. Find this one and it should work. (Acid 8 is a 64-bit program also, so use that install instead not 32-bit.)