Can not download extra content for Pro Premium 2021

William-Mertz wrote on 8/28/2021, 3:24 PM

Hello. I posted recently about trying to download this program using the installer. It stays at zero and will not download. I have had brief contact with customer service, which is abysmal, followed their limited instructions and again they wouldn't answer for days. I found a "workaround" to get the actual program, not the installer, and installed it, using my valid key I then activated it. It works. However, the "extra content" that I paid for will not download because it uses the same installer software. I have already done all of the steps to remedy this, going so far as to deactivate all protections. Still at zero. Any other suggestions or does anyone know where I can download this pack without the installer?

I really like their products but MAGIX has the worst customer service.

 

Comments

CubeAce wrote on 8/28/2021, 4:13 PM

@William-Mertz

Hi William.

Sorry to hear you are having such a hard time of it.

I've only been on this forum for around three years but have only seen similar topic requests to yours less than a handful of times. I know Magix can seem to take a while to reply for some people but normally I found I have had a reply from them within the four working days they state on their main website.

The problems regarding connecting to various servers are numerous and I'm not going to pretend to know any answers to your specific problem although connections are seldom direct from one's PC to the server in question.

In short I don't think anyone here is going to be able to offer an adequate solution although I hope Magix gets back to you by Tuesday. There are one or two packages that do take a long time to download compared to the rest but most have downloaded at my end with no problems. Have you looked your internet providers forums to see if anyone else has had similar problems with downloads from other servers?

Looking at your system specs I see nothing that could hinder any downloading even though you are about three Windows updates behind. Have you also checked all your drivers are up to date including your Intel® Ethernet Connection driver ? Have you tested trying to download a large file from another site such as a TV show or movie?

Are you allowing the files to be downloaded to your C: drive?

Ray.

Last changed by CubeAce on 8/28/2021, 4:14 PM, changed a total of 1 times.

Windows 10 Enterprise. Version 21H2 OS build 1945.2193. Direct X 12.1 latest hardware updates for Western Digital hard drives. Page file space 4.75GB.

Asus ROG STRIX Z390-F Gaming motherboard Rev 1.xx with Supreme FX inboard audio using the S1220A code. Driver No 6.0.8960.1 Bios version 1401

Intel i9900K Coffee Lake 3.6 to 5.1GHz CPU with Intel UHD 630 Graphics .Driver version 31.0.101.2114 with 32GB of 3200MHz Corsair DDR4 ram.

1000 watt EVGA modular power supply.

1 x 250GB SSD D: drive for C: drive backup 1 x 250GB SamSung Evo 970 drive for Operating System. + x2 WD BLACK 2TB internal SATA 7,200rpm hard drives.I for internal projects 1 for Library clips/sounds/music/stills./backup of working projects. 1x WD RED 2TB drive. Total 12TB of four external WD drives for backup.

Gigabyte NVIDIA G Force GTX 1650 Super . nVidia gaming driver version 526.86 1280xCUDA cores Direct X 12.1. Memory interface 128bit Memory bandwidth 192.03GB/s 4GB of dedicated GDDR6 video memory, shared system memory 16307MB PCi Express x16 Gen3.

Running MEP Premium 21.0.2.138 and VPX 18.0.1.95 (UDP3)

M Audio Axiom AIR Mini MIDI keyboard Ver 5.10.0.3507

William-Mertz wrote on 8/28/2021, 4:30 PM

Thanks. That's the thing is this is a new PC so I had to download and install everything I use for my work. Around 10 programs. Every single one without issues. I download and upload large files, websites, photos and more almost daily. It is only MAGIX programs that I have issues with and the only customer support that does not respond. The last inquiries told me my emails had gone to their spam folder. Then they gave me the same suggestions I had told them I already tried. Then no response again...

CubeAce wrote on 8/28/2021, 6:30 PM

@William-Mertz

That's an odd response from Magix. To say your email ended up in their spam folder.

Do you host your own email or use a business one?

I'm wondering if it is difficult for the servers to identify whether that would be a problem for the download initiation.

You could try making say a Google based email account and change your email address in your personal login page and then see if the installer works if that is the case.

Other than that I can't think of anything. sorry.

Ray.

Windows 10 Enterprise. Version 21H2 OS build 1945.2193. Direct X 12.1 latest hardware updates for Western Digital hard drives. Page file space 4.75GB.

Asus ROG STRIX Z390-F Gaming motherboard Rev 1.xx with Supreme FX inboard audio using the S1220A code. Driver No 6.0.8960.1 Bios version 1401

Intel i9900K Coffee Lake 3.6 to 5.1GHz CPU with Intel UHD 630 Graphics .Driver version 31.0.101.2114 with 32GB of 3200MHz Corsair DDR4 ram.

1000 watt EVGA modular power supply.

1 x 250GB SSD D: drive for C: drive backup 1 x 250GB SamSung Evo 970 drive for Operating System. + x2 WD BLACK 2TB internal SATA 7,200rpm hard drives.I for internal projects 1 for Library clips/sounds/music/stills./backup of working projects. 1x WD RED 2TB drive. Total 12TB of four external WD drives for backup.

Gigabyte NVIDIA G Force GTX 1650 Super . nVidia gaming driver version 526.86 1280xCUDA cores Direct X 12.1. Memory interface 128bit Memory bandwidth 192.03GB/s 4GB of dedicated GDDR6 video memory, shared system memory 16307MB PCi Express x16 Gen3.

Running MEP Premium 21.0.2.138 and VPX 18.0.1.95 (UDP3)

M Audio Axiom AIR Mini MIDI keyboard Ver 5.10.0.3507

William-Mertz wrote on 8/28/2021, 6:34 PM

I would agree.

Dear WIlliam,

Thank you for your message. We are sorry that you previous requests haven't been answered. I have checked what happened and these mails went to our Spam folder. This is why nobody has seen it. 

So I am stuck with a lame product...

browj2 wrote on 8/28/2021, 6:54 PM

@William-Mertz

Hi,

Usually the problem seems to be with anti-virus software. There are many threads about this.

Did you try deactivating your anti-virus software, then downloading?

One other thing, it seems that you had this loaded on another computer. If so, then did you not check off the box to keep the downloads (exe files) of everything? That is what I do to avoid having to download everything again. I just copy the exe files to the other computer and execute them. The downloads would likely be under:

C:\Users\Admin\Documents\MAGIX downloads\Installationsmanager

Did you check on your other computer?

John CB

John C.B.

VideoPro X(14); Movie Studio 2023 Platinum; MM2023 with MM2022 Premium Edition; see About me for more.

Desktop System - Windows 10 Pro 21H1; MB ROG STRIX B560-A Gaming WiFi; Graphics Card Zotac Gaming NVIDIA GeForce RTX-3060, PS; Power supply EVGA 750W; Intel Core i7-10700K @ 3.80GHz (UHD Graphics 630); RAM 32 GB; OS on Kingston SSD 1TB; secondary WD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB, 8TB; three monitors - HP 25" main, LG 4K 27" second, HP 27" third; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer.

Notebook - Microsoft Surface Pro 4, i5-6300U, 8 GB RAM, 256 SSD, W10 Pro 20H2.

William-Mertz wrote on 8/28/2021, 7:01 PM

I disabled everything, thanks. This program is fresh on the new computer.