Can't save as MP3 in SF13

Paul-Fegan wrote on 1/31/2021, 1:44 PM

I have a brand new PC with Windows 10 and freshly installed SF13, but I cannot save as MP3. It doesn't recognise the format. MP3 format is essential for my work (lots of elearning clients require this format) and I need to be able to convert to it in Batch Converter. What am I doing wrong? I have rebooted the PC many times and also reset "all preferences and cached data" from the file menu, but still, MP3 is not an option in either the Save As format list or in Batch Converter.



rraud wrote on 1/31/2021, 5:30 PM

HI @Paul-Fegan. Check to see if there is a FileIO Plug-Ins> mp3plug2 folder in Program files> SOUND FORGE folder.

Re-installing SF has been known to fix the MP3 issue. If a repair reinstall does not help, uninstall and reinstall

Otherwise Work-a-round, I like the WinLAME RC3 encoder/UI. More options than SF and custom scripts can be written to the 'presets' file, HP, LP filters, ect, ect. It is much faster than SF and does batches as well.

FWIW, If you encode a lot of MP3s, Mp3Tag editor is a nifty time saver as well. It also supports adding an image (album cover or artist for instance)




Paul-Fegan wrote on 2/1/2021, 10:49 AM

Hi Rick, thanks for the reply. Yes, that folder (mp3plug2) is there alright but it's still not working. I have batch files going back years for clients that are already set-up for batch converter so it'll break my workflow to change this. I'll try installing Sound Forge as I see no reason why it shouldn't work (even though it isn't). I have to say, it's a surprisingly glitchy install for a professional product. Fingers crossed the reinstall will work otherwise I'm in trouble.

Thanks again, as always, for your help, Rick.

rraud wrote on 2/1/2021, 11:57 AM

You can try installing the 32 bit version as well, the 64 and 32 bit versions share a lot of the same settings, data and co-exist w/o issue. This fixes the usually missing internal F1 'Help' menu as well (install bug). MP3 encoding is faster with the 32 bit version as well, but not by a lot.

Paul-Fegan wrote on 2/1/2021, 12:07 PM

Good to know, Rick. Will try that if installing the 64 bit version doesn't work. However, I've only installed the 64 bit version of my Izotope plug-ins (Neutron, Ozone, Nectar, etc.). Will they work inside a 32-bit SF? Thanks.

rraud wrote on 2/1/2021, 3:05 PM

Will the 64 bit iZ plugs work inside 32-bit SF?

I don't really know..probably not. I installed both since I have other 32 bit host apps. Installing 32 bit SF 'may' fix the MP3 issue in the 64 bit version. A lot of data is shared,

btw, installing the 32 bit version does not count as a second activation, so it can still be activated in another PC.

Paul-Fegan wrote on 2/2/2021, 4:59 AM

OK, thanks, Rick. I installed the same SF on the same OS (Windows 10) in the studio without any problems. Seems bizarre to me that MAGIX aren't releasing fixes. It's almost like we're talking about software from a company that folded. I use Reaper (developed by a small independent group) and it's rock-solid. I just can't believe that I can install SF13 on two new Windows 10 machines and on one, MP3s don't work. It's just dumbfounding.

Anyway, not getting at you as I know you're just an independent helper here (and are always extremely helpful), but this is enough to make me look for an alternative to SF. I've been using it since 2000 and love it, but I've been losing faith in its stability since MAGIX took it over.

Thanks again for all your help. I'll let you know if a reinstall works.

Paul-Fegan wrote on 2/22/2021, 3:18 PM

Been editing in the studio a lot, so didn't get to try reinstalling SF13 at home until the weekend. Unfortunately, it didn't work. I just don't understand why it worked first time in the studio. Same OS and a very similar PC. Oh and same install file. Anyway, I'll try reinstalling once more and if it doesn't work again, then I'm going to send an email to Tech Support. Very frustrating.

rraud wrote on 2/22/2021, 3:55 PM

I may have mentioned this before, but prior to reinstalling, have you tried uninstalling SF-13 using a third-party uninstaller that can remove left-over registry entries and other pertinent data the OS uninstall leaves behind, which is usually the root of recurring issues.
Revo Uninstall and Geek Uninstall are two that have pro and freeware versions.

If you have other Magix software installed, do not remove any shared <.dll> VST Fx files, Revo has the option to choose after the 'scan' stage.

Paul-Fegan wrote on 2/23/2021, 4:10 AM

OK, Rick, I might try one of those for this install. I don't have other MAGIX software so I don't think shared dlls will be an issue. I'll try Revo and reinstall SF13 and see how I get on. Thanks again.

Paul-Fegan wrote on 2/23/2021, 12:27 PM

I tried Revo and it seemed to do a full clean of the registry alright, but now, after my third install of SF13, I still can't save as an MP3. This is a show-stopper for me. It should work without me installing third-party software so I'm going to ping MAGIX about it. Thanks for your help anyway, Rick.

rraud wrote on 2/23/2021, 1:10 PM

The Revo uninstall usually fixes a lot of abnormalities. Sorry it did help in your case @Paul-Fegan . Otherwise, I am curious if the MP3 encoder file got installed, go to "C:\Program Files\SOUND FORGE\SOUND FORGE Pro 13.0\FileIO Plug-Ins\mp3plug2" folder and see if there is a "mp3plug2.dll" file. If not I can post the folder or file to paste in.

Either way, there is one more thing you can try, install the 32 bit version of SF-13, both the 32 and 64 bit versions will coexist without issue, they share many of the same settings and data and it does not count as another activation, if you need SF-13 on the second PC.

I am interested what the deep thinkers at Magix have to say. Please keep us updated.
btw, requesting a tech support ticket from Magix in somewhat confusing. Let me know if you need instructions, there are a whopping 14 steps to get the request through.