ericlnz wrote on 6/21/2020, 7:03 PM

What makes you say it's invalid? Did you get an error message? If so what was it?

Dustin-Farnum wrote on 6/21/2020, 7:36 PM

I had to reset my drive and do clean installs. CD Architect did no show up on list of my registered programs. I tried to re-register but it said my serial number was not valid. I used and old link to download and install. When I tried to start up it said that my serial number was not valid. It appears that my registration is no longer on the system.

ericlnz wrote on 6/21/2020, 9:31 PM

Go to this recent thread and see if any of the links in the last couple of posts assist you

Dustin-Farnum wrote on 6/21/2020, 10:49 PM

I have the serial number. It used to be listed on my account. I downloaded it from Magix a few years ago with no problem. I use the old link to download it and install this time. It is just that Magix does not recognize my serial number and does not have it registered? Even though they are not selling it any more, I would think that they would still have my serial number registered? Thanks for trying to help.