Drag and drop into SF 11

scott-gorman wrote on 1/11/2018, 2:56 PM

SF 11 will not allow me to drag and drop audio files into the work space anymore. I have to use the "Open" icon or right click on a file and select either the "Send to..." or "Open with..." options. Any way to fix this?

BTW: SF 11 also stopped allowing access of a hardware controller and will no longer allow me to use text expander apps to help with file naming. It's almost like this is a permissions issue or something.


rraud wrote on 1/16/2018, 9:13 AM

i don't know about the hardware controller, but you likely need to preform the registry tweak. This 'permissions' issue seems to happen on just about every Win 10 update to both SF Pro 10 and 11. Yeah it's a pain.

"Open regedit
- Find the key named ''HKEY_USERS\XXXXXX-XXXX_Classes\VirtualStore\MACHINE\SOFTWARE\Wow6432Node\Sony
Creative Software" or "MAGIX" in later versions
- Delete the key
- Close regedit
- Soundforge now works again

Note: in the key name above, 'XXXXX-XXXX' is a number which may be unique to
your machine."

As always, copy the registry before hand in case something goes wrong

Rednroll wrote on 1/18/2018, 9:55 PM

I tried to go through the regedit stuff, and it wasn't as described and didn't work for me. I found 3 paths in my registry that all looked similar to the path described but none of them matched as described.

Here's the paths I found in my registry

\HKEY_CURRENT_USER\Software\Sony Creative Software\Sound Forge Pro\11.0
\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Sony Creative Software\Sound Forge Pro\11.0
\HKEY_USERS\S-1-5-21-2822192545-2847659882-2700481763-1001\Software\Sony Creative Software\Sound Forge Pro\11.0

I deleted the 11.0 folder in the last one and still had errors. I ended up restoring my system from a HDD image backup which I had prior to the SF 11.0 Build 345 install and then followed the method below which went much smoother and didn't require any regedit monkey business. The joys of installing the Sony stuff in making sure you have all those proper ".NET" packages installed prior.

1. Go to the search point next to the Start menu and type 'Windows Features'.
2. 'Turn Windows Features on or off' will appear.
3. Click on this. You may be asked for your Administrator password, so enter it.
4. At the top of the list, you will see '.NET framework 3.5 (includes .Net 2.0 and 3.0)'. Expand this item and check the check boxes next to the two items that drop down and ensure that the main item is also checked. Press OK.
5. You will be asked to confirm the download of some additional components. Do so and let the system do its stuff.
6. You'll be prompted when the process has completed.
7. Close the panel.

I can see wherever Magix touched this release. Someone must like to program with the CAPS LOCK on. Found a new "MAGIX" folder and my shared plugin folder after install was in a folder named "VEGAS", and I hadn't even installed Vegas on this system yet.


GoneToMaui wrote on 7/14/2018, 11:52 PM

Sorry, I'm having issues getting assigned files to SF 11 to open from outside the pgm even though Windows says these type of files are assigned to it. Instead I have to open them from within SF11. This seems to have started happening when an older Adobe Audition pgm got installed and tried to take over all the file types, which were reassigned back to SF11. I have previously deleted the 11.0 folder but in response to Rick's comment above, which folder or key as you are calling it, do I need to dump? The 'Sony Creative Software folder' and everything under it? Your suggestion is not clear as to exactly what you are saying to delete. Thanks.

rraud wrote on 7/15/2018, 11:15 AM

This is for the Elevated Privileges' issue.  I don't know if this will fix your file association.  For file type/program associations, about the easiest way is to;
- Right-click the type of file you desire to have SF open by default,
- Select 'Choose default file type',
- Check-mark the box for "Always use the selected program to open this kind of file",
- Browse for and select "Forge110.exe" in 'Program files',
--- BTW, Default Programs Editor is a handy utility to use for many file type issues.

Otherwise for 'elevated privileges', delete the entire 11.0 registry sub folder, it will be recreated when SF is re-opened).
"HKEY_USERS > [user SID]_Classes > VirtualStore > MACHINE > SOFTWARE > Wow6432Node > Sony Creative Software > Sound Forge Pro > 11.0"