Edit images in external editor

emmrecs wrote on 9/2/2019, 5:37 AM

Photo Manager Deluxe, version 13.1.1.12. Computer spec is in my signature.

Using the File>Options>Path settings screen I have designated a third-party program as my external photo editor of choice. However, I can find no method of opening any image in this editor from within PM Deluxe. Am I missing something?

TIA of any thoughts.

Jeff

Win 10 Pro 64 bit, Intel i7 Quad Core 6700K @ 4GHz, 32 GB RAM, AMD Radeon R7 360 and Intel HD530 Graphics, MOTU 8-Pre f/w audio interface, VPX, MEP, Music Maker, Photo Story Deluxe, Photo Manager Deluxe, Xara 3D Maker 7, Reaper, Adobe Audition CS6 and CC, 2 x Canon HG10 cameras, 1 x Canon EOS 600D

Comments

johnebaker wrote on 9/2/2019, 7:12 AM

@emmrecs

After extensive testing - I too cannot get PM to launch an external editor - and that includes Magix's own Photo Designer and Xara Photo and Graphics Designer.

Looking at an older versions manual it appears that the only allowed external editor was Photo Designer 7.

One consolation is the external editor works in MEP and VPX - I use Paintshop Pro X9 64bit.

HTH

John EB

Lateral thinking can get things done!

VPX, MEP Premium, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

emmrecs wrote on 9/2/2019, 8:44 AM

@johnebaker

Hi John.

Thanks for confirming this.

Jeff

Win 10 Pro 64 bit, Intel i7 Quad Core 6700K @ 4GHz, 32 GB RAM, AMD Radeon R7 360 and Intel HD530 Graphics, MOTU 8-Pre f/w audio interface, VPX, MEP, Music Maker, Photo Story Deluxe, Photo Manager Deluxe, Xara 3D Maker 7, Reaper, Adobe Audition CS6 and CC, 2 x Canon HG10 cameras, 1 x Canon EOS 600D

browj2 wrote on 9/2/2019, 11:01 AM

@emmrecs @johnebaker

Hi Jeff and John EB,

Select the photo, click on Tasks in the top menu, pop down Optimize, select Creative image editing. Simple, no?😁

This opens my designated editor, PSP 2019.

Why they don't put this in the right-click menu is a mystery.

I have an outstanding beef with Magix. They have the wrong field names for the file name and date; they have File size and Path. They said that there would not be a patch.

John CB

John C.B.

Desktop System - Windows 10 Home 1903; 16Gb RAM; i7 CPU 860@2.80Gz; ATI Radeon HD5770 w1GB; SSD 500GB, HD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB; dual monitors - 27" main, 25" secondary; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer; Notebook - Microsoft Surface Pro 4, i5, 8 GB RAM, 256 SSD, W10 Pro 1903

johnebaker wrote on 9/2/2019, 11:25 AM

@browj2

Hi John

Thanks for that - it works now, so another puzzle - why did it not work earlier when I tried this 😭?????

Added: what version number of Photo Manager are you on?

John EB

Last changed by johnebaker on 9/2/2019, 12:08 PM, changed a total of 1 times.

Lateral thinking can get things done!

VPX, MEP Premium, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

emmrecs wrote on 9/2/2019, 1:07 PM

@browj2

Hi John, thanks for your post.

Simple, no?

Indeed so, ifΒ it worked. It certainly doesn't for me. Clicking as you describe does nothing at all on my computer???

Jeff

Edit: just tried again, this time double-clicking, and it works!!!πŸ˜•

Last changed by emmrecs on 9/2/2019, 1:08 PM, changed a total of 1 times.

Win 10 Pro 64 bit, Intel i7 Quad Core 6700K @ 4GHz, 32 GB RAM, AMD Radeon R7 360 and Intel HD530 Graphics, MOTU 8-Pre f/w audio interface, VPX, MEP, Music Maker, Photo Story Deluxe, Photo Manager Deluxe, Xara 3D Maker 7, Reaper, Adobe Audition CS6 and CC, 2 x Canon HG10 cameras, 1 x Canon EOS 600D

browj2 wrote on 9/2/2019, 11:55 PM

Glad to hear that you both have it working.

Mondays!

Thanks for getting me to look at Photo Manager. It fit perfectly with the video that I'm putting together. Some of the photos have gps info and I used PM to open the old TRA. It opens with the location of the selected photo, something that the new Travel Maps does not do. I selected the topo map and saved the location of each so that I would be able to id where the photo was taken along the route. The route was done using TM with topo. Then I was able to link up the photos without GPS info using the time. Etc.

John CB

John C.B.

Desktop System - Windows 10 Home 1903; 16Gb RAM; i7 CPU 860@2.80Gz; ATI Radeon HD5770 w1GB; SSD 500GB, HD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB; dual monitors - 27" main, 25" secondary; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer; Notebook - Microsoft Surface Pro 4, i5, 8 GB RAM, 256 SSD, W10 Pro 1903

johnebaker wrote on 9/3/2019, 3:21 AM

@browj2

Hi John

Re your column headings issue - what version are you on ?

John EB

Lateral thinking can get things done!

VPX, MEP Premium, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

browj2 wrote on 9/3/2019, 8:06 AM

@johnebaker

Hi John EB,

Same as you, 13.1.1.12.

I had tried other views and also looked at the pop down for field names. File name is not on the list as, I presume, that it should always be there. I always ended up with File size in the File name column, and Path for the date.

John CB

Last changed by browj2 on 9/3/2019, 8:07 AM, changed a total of 1 times.

John C.B.

Desktop System - Windows 10 Home 1903; 16Gb RAM; i7 CPU 860@2.80Gz; ATI Radeon HD5770 w1GB; SSD 500GB, HD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB; dual monitors - 27" main, 25" secondary; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer; Notebook - Microsoft Surface Pro 4, i5, 8 GB RAM, 256 SSD, W10 Pro 1903

johnebaker wrote on 9/3/2019, 8:28 AM

@browj2

Hi John

I am puzzled this is what I get

John EB

Β 

Lateral thinking can get things done!

VPX, MEP Premium, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

browj2 wrote on 9/3/2019, 8:57 AM

@johnebaker

Hi John,

Something is wrong somewhere, but I can't find it and neither could Magix.

In the popdown for sorting, Name and Creation date appear, but no way can I get them as the correct headings for the 2 columns.

John CB

John C.B.

Desktop System - Windows 10 Home 1903; 16Gb RAM; i7 CPU 860@2.80Gz; ATI Radeon HD5770 w1GB; SSD 500GB, HD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB; dual monitors - 27" main, 25" secondary; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer; Notebook - Microsoft Surface Pro 4, i5, 8 GB RAM, 256 SSD, W10 Pro 1903

johnebaker wrote on 9/3/2019, 12:25 PM

@browj2

Hi John

. . . . no way can I get them as the correct headings for the 2 columns . . .

I could not find any cfg or ini file that had any data in it about the headings or is changed if you add more columns to the display.

Obviously if you add extra columns or remove them then the config must be saved somewhere, and the only place I can think of, is in the Database.

Have you tried backing up the database, deleting it and then letting PM create a new one to see if the issue is corrected?

John EB

Β 

Lateral thinking can get things done!

VPX, MEP Premium, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

browj2 wrote on 9/4/2019, 12:33 PM

Have you tried backing up the database, deleting it and then letting PM create a new one to see if the issue is corrected?

@johnebaker

Hi John,

No, I'm afraid to try. And, I can't see how doing this would change the headings of the columns (field names).

I also looked at ini files and found nothing. I can live with it, but I find it strange.

Here is what my db contains:

John CB

John C.B.

Desktop System - Windows 10 Home 1903; 16Gb RAM; i7 CPU 860@2.80Gz; ATI Radeon HD5770 w1GB; SSD 500GB, HD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB; dual monitors - 27" main, 25" secondary; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer; Notebook - Microsoft Surface Pro 4, i5, 8 GB RAM, 256 SSD, W10 Pro 1903

johnebaker wrote on 9/4/2019, 1:11 PM

@browj2

Hi John

That is one big database - do you use it for everything video/music/image orientated?

John EB

Lateral thinking can get things done!

VPX, MEP Premium, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

browj2 wrote on 9/5/2019, 12:06 AM

@johnebaker

Hi John,

I rarely use it - program looking for a use. I used an earlier version (12), categorized many photos, but gave up when Magix dumped the Database from MEP. The work was lost in the update to the current version.

I just pointed it to folders with music, photos and videos and let it run, if I recall correctly. This includes Soundpools. However, if I click on Photos under Database in the left column, it says Create the database, so I don't really know what it does or is doing, maybe just updating it. Oh, I see! I have 48,781 files under photos, all sorted by filename.

Then I clicked on Year, under Photos, and it said the same, then everything appeared.

Then I clicked on Video, started to create database, crashed. I have had this before, so I have avoided Database/Video.

Clicked on Database/Audio and it said creating database and I got everything, I presume.

Clicked on Database/Video again, and it's thinking about it...5 hours later I forced an exit. At least it didn't crash right away.

I had done something on the audio side with MP3 Deluxe, but it crashes before I can do anything with it. I presume that it shares a common database. I should try reinstalling it, I suppose.

John CB

Last changed by browj2 on 9/5/2019, 12:10 AM, changed a total of 1 times.

John C.B.

Desktop System - Windows 10 Home 1903; 16Gb RAM; i7 CPU 860@2.80Gz; ATI Radeon HD5770 w1GB; SSD 500GB, HD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB; dual monitors - 27" main, 25" secondary; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer; Notebook - Microsoft Surface Pro 4, i5, 8 GB RAM, 256 SSD, W10 Pro 1903