Edit in Spectralayers has an erratic behaviour.

ReverendLove wrote on 2/22/2017, 7:54 AM

When I want to edit a selection from Sound Forge 11 in SL 4.78 SL4 interprets the settings wrong.
In SF I recorded a file with 44.1k / 32 bit depth. When I try to edit this in SL4, SL interprets it as 48k file. I can hear it because SL plays it slower than SF11 and the original recording.
But that is not all: In SF11 the "File Properties" window shows sample rate and bit depth correctly before opening SL, but coming back from SL to SF11 this window shows nearly nothing at all. That seems to be not very trustworthy...


ReverendLove wrote on 2/22/2017, 7:57 AM

BTW: Even "File Size" is completely wrong after opening in SL4.

ReverendLove wrote on 2/22/2017, 8:13 AM

It looks as SL4 interprets the Sound Forge project file (.frg) as media file.
Even if I do nothing in SL4 it corrupts the file properties in Sound Forge.
The size shown in file properties seems to be the size of the SF project alone without the included media files.
There is definitely sth scary going on.

ReverendLove wrote on 2/22/2017, 8:16 AM

SF11 project file looks like this normally

DivideFrame wrote on 2/22/2017, 8:17 AM

Weird, I just tried with SF 11.0.299, generated a 32bit 44.1Khz file (as you can see in the status bar bottom right), then made a selection and clicked Tools/Edit in SpectraLayers Pro, and got a 44.1Khz file as expected (as you can see in the status bar bottom left). Does the status bar in SF and SL shows the same sample rate in your case ?

SL does not read or try to interpret frg file. It just reads the wav file SF sends to it.

The larger file size is not an issue, it can expand during the back and forth due to extra processing, SF only takes back what it needs.

ReverendLove wrote on 2/22/2017, 8:40 AM

I see your file isn't yet saved as .frg project file.
I had exactly this issue with two different recordings this morning. I created them just today. No old heritage from earlier versions.
SF 11.345 here. The status bar of SF shows correct values like yours but file properties shows nothing.

ReverendLove wrote on 2/22/2017, 8:44 AM

Well and SL4 shows the correct sample rate but plays the file distinguishable slower and at a lower pitch. I don't drink or took some strange drugs...

ReverendLove wrote on 2/22/2017, 11:17 AM

Looks I found the culprit.

When I change the configuration in SL4 from ASIO to WASAPI nothing is altered or shredded in the file properties window of SF11. Also the playback is exactly as expected.
I tried it with the ASIO driver of my Presonus AB1818 and with Voicemeeter (a virtual audio bridge and mixer). Both led to the strange behaviour of slowing down in SL4 and deleting the file properties in SF11.

Both behave polite if configured as WASAPI devices in SL4.

But now it works and short latencies aren't highest priority for my tinkering in SL4.

DivideFrame wrote on 2/22/2017, 11:20 AM

Glad to hear that !

The next update (4.0.80) has better ASIO support. Should be released next week I think.