error code -1

awen wrote on 10/5/2021, 8:35 PM

Acid pro suite 10.

Installed ok and loaded ok only first time after install but after close down, i then tried to reopen it but get error code -1

Nothing loads.

My previous installation was even worse, i uninstalled that and acid pro 8 because installing ruined that as well.

so please do not say uninstall reinstall, i did that, this is a clean install.

i went through the internet explorer settings on some help page (regarding magix error -1) none worked, same error.

O/S: Windows 7 sp1, not fully updated but have some updates

my license is an upgrade from acid pro ? to acid pro 10 suite.

I no longer have a previous version of acid on my pc as i uninstalled it.

Comments

awen wrote on 10/5/2021, 9:04 PM

Forgot to add...

First try install i enabled everything of the 3 install settings. then celemony melodyne essential failed because version 5.xx no longer lets you even install it on windows 7. i then cancelled the update install i just did not install it, main program acid pro suite 10 installed ok, but on load it opened then crashed soon after idk why. then i had same problem of error code -1 on start would not start.

then i uninstalled acid 8 and 10 and reinstalled 10 this was my clean install, where i still get the same problem. but for this install i only selected acid to install, not updater, not melodyne. it inst alled perfectly, opened up. i got a message to whitelist the vst finder file i forget the name and i did that then it let me continue ok, program was left running for a few mins, then i closed and reopened and i get the error code -1 again.

in between all this i tried the internet explorer 11 options in control panel to make them as shown in some help file from magix regarding error -1

 

johnebaker wrote on 10/6/2021, 5:56 AM

@awen

Hi

This sounds like your Antivirus/Firewall is blocking access o to the Internet, does the program launch correctly if you temporarily turn the AV/Firewall off, or run it as Administrator?

John EB
Forum Moderator

VPX 15, Movie Studio 2024, 2023, and earlier versions 2015 and 2016, Music Maker Premium 2024.

PC - running Windows 11 23H2 Professional 64bit on Intel i7-8700K 3.2 GHz, 16GB RAM, RTX 2060 6GB 192-bit GDDR6, 1 x 1Tb Sabrent NVME SSD (OS and programs), 2 x 4TB HDD (Data) internal HDD + 1TB internal SSD (Work disc), + 6 ext backup HDDs.

Laptop - Lenovo Legion 5i Phantom - running Windows 11 23H2 on Intel Core i7-10750H, 16GB DDR4-SDRAM, 512GB SSD, 43.9 cm screen Full HD 1920 x 1080, Intel UHD 630 iGPU and NVIDIA GeForce RTX 2060 (6GB GDDR6)

Sony FDR-AX53e Video camera, DJI Osmo Action 3 and Sony HDR-AS30V Sports cams.

awen wrote on 10/6/2021, 12:37 PM

Hi johnebaker,

I closed my anti virus from the system tray (Kaspersky Internet Security) , waited a bit then run the below as an administrator...

"C:\Program Files\ACID\ACID Pro Suite 10.0\acidsuite.exe"

It did not work though thanks for the suggestion.

My previous version of Acid Pro non suite version 8 also had this same problem before i uninstalled it, though i cant say how long previously i had had that problem with 8 for.

 

awen wrote on 10/11/2021, 1:13 PM

Does anyone else have any suggestions to solve this problem? Thanks in advance.

 

SP. wrote on 10/11/2021, 2:17 PM

@awen I would suggest you to disable Windows Defender temporarily. If this doesn't help then uninstall everything completely with this tool from Microsoft

https://support.microsoft.com/en-us/topic/fix-problems-that-block-programs-from-being-installed-or-removed-cca7d1b6-65a9-3d98-426b-e9f927e1eb4d

Is your Windows 7 version updated to the latest version?

ACID-Support wrote on 10/12/2021, 2:46 AM

Hello!

Error code 1 means that an internet connection to our activation server cannot be made.

Please go to the system's Control Panel and proceed to "Internet Options". Switch to the "Advanced" tab and find the "Security" section in the long list of checkboxes. Among other things, you will find entries for the different Internet communication protocols here.

Please check whether the options TLS 1.0, TLS 1.1, and TLS 1.2 are ticked. If that is not the case, please enable/tick these options and confirm your settings.
Furthermore, it is possible that there is an active internet connection but it is not being recognized. Here please close all MAGIX programs. Click on Windows Start - All programs - Windows Accessories and right-click on the program Wordpad and choose "Run as Administrator".

Now open up the following file:

C:\Programs\MAGIX\[programname]\Install.cfg

Look for the path [magixofa-overrides]

Underneath please add the following line:

main*checkoffline=0

Now the internet functionality should be given.

Have a nice day!

awen wrote on 10/12/2021, 2:22 PM

@awen I would suggest you to disable Windows Defender temporarily. If this doesn't help then uninstall everything completely with this tool from Microsoft

https://support.microsoft.com/en-us/topic/fix-problems-that-block-programs-from-being-installed-or-removed-cca7d1b6-65a9-3d98-426b-e9f927e1eb4d

Is your Windows 7 version updated to the latest version?

My Windows 7 Professional has the latest service pack (Service pack 1 it says) and updated to most of the updates as of 2-3 years before microsoft ended windows 7 support.

I have windows Firewall, but that is t urned off due to having kaspersky internet security installed and turned on, which has its own firewall.

I am unsure whether my pc has windows defender installed? I vaguely remember that is the anti virus part because definitions files get downloaded by windows update automatically. I do not know how to disable windows defender, or whether I should.

I am not going to uninstall everything from my operating system, whether its the actual software or just the registry parts of te software which willl stop the software functioning anyway.

Thanks for your suggestions.

awen wrote on 10/12/2021, 2:31 PM

Hello!

Error code 1 means that an internet connection to our activation server cannot be made.

Please go to the system's Control Panel and proceed to "Internet Options". Switch to the "Advanced" tab and find the "Security" section in the long list of checkboxes. Among other things, you will find entries for the different Internet communication protocols here.

Please check whether the options TLS 1.0, TLS 1.1, and TLS 1.2 are ticked. If that is not the case, please enable/tick these options and confirm your settings.
Furthermore, it is possible that there is an active internet connection but it is not being recognized. Here please close all MAGIX programs. Click on Windows Start - All programs - Windows Accessories and right-click on the program Wordpad and choose "Run as Administrator".

Now open up the following file:

C:\Programs\MAGIX\[programname]\Install.cfg

Look for the path [magixofa-overrides]

Underneath please add the following line:

main*checkoffline=0

Now the internet functionality should be given.

Have a nice day!

The error code is minus one (-1) rather than error code 1.

TLS 1.0, TLS 1.1, and TLS 1.2 are all enabled, i checked. Note that while I have internet explorer 11 installed my defsault browser is firefox set to auto update.

I still performed your fix as instructed...

I opened wordpad as administrator and opened the file...

C:\Program Files\ACID\ACID Pro Suite 10.0\install.cfg

I found the heading [magixofa-overrides]

Directly under the heading i added a new line of...

main*checkoffline=0

I saved the file and closed wordpad.

I did not have any Magix software open though who knows what is running in services. I closed all other programs. Then I ran ...

"C:\Program Files\ACID\ACID Pro Suite 10.0\acidsuite.exe"

But I get the same error message

Error code: -1

with an OK button on it.

Acid never loads at any time, I click ok and nothing happens.

 

awen wrote on 10/12/2021, 2:38 PM

It is worth noting that I have the following other Magix software installed and working perfectly...

"C:\Program Files\MAGIX\Samplitude Pro X6 Suite\Sam_x64.exe"

"C:\Program Files (x86)\MAGIX\Music Maker\28\MusicMaker.exe"

"C:\Program Files\SOUND FORGE\SOUND FORGE Pro 12.0\Forge120.exe"

"C:\Program Files\SOUND FORGE\SOUND FORGE Pro 14.0\Forge140.exe"

I also used to have an older Acid version installed which gave the same exact error code (minus one) when i try to launch it... It looks like I uninstalled that older acid version, I think it was called ACID Pro 8 (non suite). You can check my licenses to be exact.

Thanks for your help so far.

johnebaker wrote on 10/13/2021, 1:45 PM

@awen

Hi

The error code is 1, the 'minus' is a hyphen commonly used to separate the 'message' from the error result code such that if an error occurs and there is no code from the erroring module you will see Error - indicating that no code was returned to the error handler from the faulting module.

. . . . My previous installation was even worse, i uninstalled that and acid pro 8 because installing ruined that as well. so please do not say uninstall reinstall, i did that, this is a clean install. . . . .

Did you clean up the files and registry fragments that were left behind after uninstalling, if not then re-installing can fail with the same errors.

Use Revo Uninstaller Free to start the uninstall and scan for leftover files/registry fragments that relate to Acid Pro. Do a restart of the computer - not shutdown and then try installing again ensuring that you use the correct email address as the software was initially registered with.

John EB

VPX 15, Movie Studio 2024, 2023, and earlier versions 2015 and 2016, Music Maker Premium 2024.

PC - running Windows 11 23H2 Professional 64bit on Intel i7-8700K 3.2 GHz, 16GB RAM, RTX 2060 6GB 192-bit GDDR6, 1 x 1Tb Sabrent NVME SSD (OS and programs), 2 x 4TB HDD (Data) internal HDD + 1TB internal SSD (Work disc), + 6 ext backup HDDs.

Laptop - Lenovo Legion 5i Phantom - running Windows 11 23H2 on Intel Core i7-10750H, 16GB DDR4-SDRAM, 512GB SSD, 43.9 cm screen Full HD 1920 x 1080, Intel UHD 630 iGPU and NVIDIA GeForce RTX 2060 (6GB GDDR6)

Sony FDR-AX53e Video camera, DJI Osmo Action 3 and Sony HDR-AS30V Sports cams.

awen wrote on 10/13/2021, 9:42 PM

@awen

Hi

The error code is 1, the 'minus' is a hyphen commonly used to separate the 'message' from the error result code such that if an error occurs and there is no code from the erroring module you will see Error - indicating that no code was returned to the error handler from the faulting module.

. . . . My previous installation was even worse, i uninstalled that and acid pro 8 because installing ruined that as well. so please do not say uninstall reinstall, i did that, this is a clean install. . . . .

Did you clean up the files and registry fragments that were left behind after uninstalling, if not then re-installing can fail with the same errors.

Use Revo Uninstaller Free to start the uninstall and scan for leftover files/registry fragments that relate to Acid Pro. Do a restart of the computer - not shutdown and then try installing again ensuring that you use the correct email address as the software was initially registered with.

John EB

Hi johnebaker,

I know revo uninstaller, I actually had it installed already so I know its legit.

I actually downloaded the portable version of revo uninstaller from their oficial website so its the latest version.

NOTE: My version of ACID 10 Pro Suite is the UPGRADE VERSION, not full version, I no longer have any acid versions on my PC to upgrade from. I dont know if that will make a difference.

I had to run revo uninstaller quite a few times with pc restarts as well but finally ACID 10 Pro Suite was completely removed. I restarted my pc and then ran the ACID 10 Pro Suite installer again...

I only selected to install the main proram, I chose to unselect the other two options including the auto updater & melodyne essentials (since I can update acid myself and I dont want that taking up pc resources) and melodyne (since the version that is installed is the latest version and is no longer supported on windows 7 I tested this with this or another software (even though acid 10 pro suite still states it supports windows 7), it literally will not let you install it, no problem as I have an earlier version of melodyne essentials already installed.)

Install worked without problems. I waited a while after install to see if acid would auto start, it did not.

So I then launched acid from my start menu...

"C:\Program Files\ACID\ACID Pro Suite 10.0\acidsuite.exe"

Acid did load up (It always seems to the first time going by pervious installs) I got the main acid software window up on screen and then it crashed with an error. There were two error boxes for this crash, both displayed below...

I chose close the application rather than debug since it had crashed and it closed.

I then re-launched Acid pro 10 suite from the start menu and it never loaded at all, now it gives the same problem as this thread, an error box the same as usual which is below...

So Acid never even loaded like it did the first time, I never see the acid application window load like before it just gives the above erro code: -1 box now, I click ok the box closes and nothing happens, acid never loads. So now I have this problem every time i try to launch it as per the main problem of this thread.

So I have already performed a thorough uninstall using revo, we now know that does not work.

I am hoping for magix support to post here again with the next steps.

Thanks for all help so far.

NOTE: I selected Safe removal option when using revo uninstaller

 

awen wrote on 10/13/2021, 10:31 PM

Seeing as my problem seems to be connection relat ed here are a few details....

Firefox 93.0 (64 bit). I have changed many of the default settings to make things more secure and add more privacy. Firefox is my default browser, If ACID uses firefox in any way I can forsee huge problems due to the settings I have for it ...

I have these 3 settings enabled just as a taster to what I have changed...

Enable HTTPS-Only Mode in all windows
Proxy DNS when using SOCKS v5
Enable DNS over HTTPS

I have these extensions enabled in firefox, downloaded from the firefox store...
AdBlocker Ultimate
NoScript Security Suite
Kaspersky Protection

I have a vpn installed though it was active/loaded just not set to proxy my connection during any of the uninstall or install of acid tonight. I had it turned off essentially...

Hideaway VPN v4.18.3

Internet Explorer 11 (version 11.0.9600.18163 installed, update versions 11.0.27 KB3124275, It has a product ID im not stating just in case its a serial), it is not my default browser. I have in the last days reset my internet settings in control panel so they are now the default (i choose recommended settings). I just checked and TLS 1.0, TLS 1.1, and TLS 1.2 are all still ticked.

Windows firewall - turned off because i use kaspersky...

Kaspersky Total Security - application version 21.3.10.391 (f). With latest updated virus definitions file. Operating System (according to kaspersky) Microsoft Windows 7 x64 Service Pack 1 Build 7601. I have changed some kaspersky settings. As far as i can tell in application control -> manage applications, kaspersky has all of the ACID executables as trusted and allows network activity.

Windows Defender = I must have this installed because in windows update i found the below...

Security Intelligence Update for Windows Defender Antivirus - KB915597 (Version 1.351.159.0). Installation date: ‎12/‎10/‎2021 04:17

Note I have set windows update not to automatically download and install updates. The last time i updated this pc was a few years ago. I have also turned off and/or removed the windows telemetery updates and use spybot anti beacon to further limit windows spying behaviour.

I have made a few system changes to settings over the years that i cant recall right now.

My laptops original wireless on board I turned off, wireless on my laptop is turned off. I did install a wifi dongle netgear brand to my laptop in a usb slot and i get my internet connectivity through that, connecting to the router in teh house. I do not have a rj45 connection to the internet but i used to.

If you provide an email address i could sent a system information checker, i know kaspersky has one, there is also the dxdiag one, or whatever one you want me to use. I will not post the sensitive contents o such a check to these forums.

Thanks in anticipation.

 

 

awen wrote on 10/13/2021, 11:03 PM

I forgot to mention just before ACID started up I got the add license key screen, It already had my license key in there but i added it again and continued, it said it had sucessfully added my license key, then acid started i saw it open then it crashed.

I forgot to mention that revo uninstaller never found any traces of acid pro 8 (non suite) the previous version i had installed that at least ended up with the same error code on launch. So my uninstall of acid 8 pro via control panel uninstall must have removed enough of it to not display in revo when i ran it earlier.

If acid stores crash reports for itself then i can email you 6he crash report, if you tell me where to find it and give me an email address to send it to and ticket number.

If the crash is stored in control panel - administrator tools - event viewer, i could not find it, probably wont store much in there anyway. I did notice some problems with WLAN (red and yellow events) in the event viewer that may be unrelated, i get some errors anyway. If you want me to find a crash report in event viewer and send it to you let me know how to find it.

 

johnebaker wrote on 10/14/2021, 2:41 AM

@awen

Hi

The new error message, error code -1 and the rest of the relevant information, the Firefox setup is not irrelevant, suggests that the program Acid is not detecting or cannot make the Internet connection which uses the Internet Explorer routines and Internet options settings.

Windows Defender is never totally disabled when another AV are present - it is still there functioning and providing secondary protection.

I would suggest you either temporarily turn off Windows Defender and Kasperksy or put exceptions in both for real time protection, Ransomware protection and Folder protection (or equivalent) and then try running Acid again.

Additionally check in the Internet options dialog that, SSL2 and SSL3 (if present) are checked.

John EB

VPX 15, Movie Studio 2024, 2023, and earlier versions 2015 and 2016, Music Maker Premium 2024.

PC - running Windows 11 23H2 Professional 64bit on Intel i7-8700K 3.2 GHz, 16GB RAM, RTX 2060 6GB 192-bit GDDR6, 1 x 1Tb Sabrent NVME SSD (OS and programs), 2 x 4TB HDD (Data) internal HDD + 1TB internal SSD (Work disc), + 6 ext backup HDDs.

Laptop - Lenovo Legion 5i Phantom - running Windows 11 23H2 on Intel Core i7-10750H, 16GB DDR4-SDRAM, 512GB SSD, 43.9 cm screen Full HD 1920 x 1080, Intel UHD 630 iGPU and NVIDIA GeForce RTX 2060 (6GB GDDR6)

Sony FDR-AX53e Video camera, DJI Osmo Action 3 and Sony HDR-AS30V Sports cams.

awen wrote on 10/14/2021, 8:14 PM

@awen

Hi

The new error message, error code -1 and the rest of the relevant information, the Firefox setup is not irrelevant, suggests that the program Acid is not detecting or cannot make the Internet connection which uses the Internet Explorer routines and Internet options settings.

Windows Defender is never totally disabled when another AV are present - it is still there functioning and providing secondary protection.

I would suggest you either temporarily turn off Windows Defender and Kasperksy or put exceptions in both for real time protection, Ransomware protection and Folder protection (or equivalent) and then try running Acid again.

Additionally check in the Internet options dialog that, SSL2 and SSL3 (if present) are checked.

John EB

Hi,

I did all 3 of these...

1) I set up a folder exclusion in kaspersky to exclude ALL scanning. (I already tried completely turning off kaspersky and it did not work.)

2) I disabled real time scanning in windows defender. (I have never tried this before)

3) I selected/enabled SSL 2.0 and SSL 3.0 as these were disabled. (I tried this previously though and it did not solve my problem).

I did all 3 things together before I ran ACID and when i did run it I got the same error message.

FYI I have now reverted back these three changes to how they were as this did not work.

Thanks

 

 

Black2Production wrote on 1/17/2022, 12:20 AM

I have the same error and i can not start the program after I have registered it. Still get code: -1. I have Windows 10 21H2 update.

awen wrote on 1/17/2022, 5:39 PM

Good luck getting any help in the forums, my problem is unresolved.

I have plenty other music making software rom other companies so i use them instead and don't even attempt to use acid pro any more, still get the same bug.

My advice contact magix support directly however that works, email or contact form or submit a ticket to them. I dont think I did that but cant be sure, either way my problem is unresolved.

Please post in this thread the fix if you found a solution, any, all solutions, to help others with this problem, im sure there are more out there, this is an entire error code (-1) that seems to have no solutions LOL.

Best of Luck

 

 

Joao-Franco wrote on 3/6/2022, 12:42 PM

This worked for me:

I signed in for trial, updated the program and then run it as admin when I registered. Its running fine now and doesn't need to be run in admin mode. I suspect you need to run it as admin when you register your SN but I cant be sure.

awen wrote on 3/10/2022, 10:11 AM

Hi Joao-Franco, I have never managed to get Acid to work since i posted here.

I just uninstalled Acid.

Reinstalled Acid wit h administrator privledges i right clicked the installer and selected run as administrator - i installed without the updater and melodyne, only installed Acid. It installed ok.

not sure if this came 1st or second cant remember) There was no way for me to activate the trial instead of my email and license kkey, this was because it said my acid trial had expired when i tried by removing my email and license from the boxes. So i had to continue activating with my email and license key.

not sure if this came 1st or second can't remember)I went into my start menu found acid folder and acid executable i right clicked it and run as administrator, it loaded acid fine i left acid to load completely for 10 mins, i came back to a notification in acid about a fruity loops plugin being ran as administrator and that may cause slowdowns, i ok to thatr and the next, all plugins were then scanned it was on around 90% anyway, it went to 100%, i left acid for a little then closed it.

I then ran acid but forgot to run as administrator i still got the -1 error.

I then ran acid as administrator i still got the -1 error.

I guess i could try and redownload the installer but maybe magix stores the trial info on my pc somewhere that will now always state that my trial has expired? So i cannot try your fix.

Many thanks for your help though I hope others are able to get acid working who encounter this problem.

 

awen wrote on 3/10/2022, 10:12 AM

Note the only time Acid run today the 1st time i forgot to update it, oops, not sure if that would have helped.

awen wrote on 3/10/2022, 10:25 AM

Ok i judt did the same as before, uninstalled, reinstalled, activated with my key and email, when it loaded i waited for it to finish loading then i went to help? update online? and it searhed for updates the new window had major update in the title, but it said it found no new updates i was up to date. i closed it then ran it as admin and still get the -1 error code.

Product version: 10.0.5.38
that is the version of acid that my installer installed to my system according to add/remove programs when i uninstalled it.

 

Alan-Pitt wrote on 9/20/2022, 2:28 PM


Seems like no one gets any joy with this error but here goes. I've had the usual multiple Acid Pro 11 Suite crashes but tried opening Acid today and got error code 1. Error Code application initialization.

Does anyone know why this happens and how to resolve it? I see that the uninstall and reinstall option quoted to many does not seem to work.

SP. wrote on 9/20/2022, 2:52 PM

@Alan-Pitt Can you get it to work by holding CTRL and SHIFT and double clicking on the program icon? Then select to reset the program settings and to delete the cache.

Alan-Pitt wrote on 9/21/2022, 2:50 PM

Tried that SP but still no joy.