Comments

PATIENT-X wrote on 5/14/2022, 10:45 AM

@Nicholas-Smilek3917

Hello, welcome

I have closed your duplicate post.

Please refer to this one for answers.

If no one can help you, register and login to toontrack forum here for further assistance.

Stephen

Forum Moderator

 

 

Friedrich Nietzsche: "Without music, life would be a mistake."

Pc1: Currently building my new computer based on RTX40 series and Intel i9 13th gen. Just waiting on new main board components.

Pc2: Zoostorm Crystal Intel i5 10400f 2.9ghz, 16gb ram, Rtx2060 super Gpu, 1tb SSD,

Monitors: MSI Optix MPG321QRF-QD 32 Inch, Quantum Dot, WQHD, 175Hz, IPS, 1ms, RGB, G-SYNC Compatible.

BenQ EL2870U 28 Inch UHD 4K Gaming Monitor - 1ms, HDR, Eye-Care,. LED, Free-Sync, B.I. Plus Sensor

Laptop: Acer Nitro 5 AN517-54 79d2 Gaming Laptop - 17.3in QHD 165Hz, GeForce RTX 3060, Intel Core i7 11800H. Corsair Vengeance 16gb ram DDR4 3200. 1st M.2 Acer NVMe 512gb SSD. 2nd M.2 Samsung 980 PRO 500GB NVMe SSD. 3rd Samsung 870 EVO 500GB SSD drive.

Music hardware: AKAI MPK mini mk2, Yamaha PSRE373 keyboard, Hercules Impulse 300 & Hercules Jogvision DJ controllers.

PreSonus 68c Audio Interface, Audio Technica ATH-M50x headphones.

MCSE, MCSA, MCSA:MESSAGING, MCE, MCP, CCNA, A+, N+ Year 2005 ID#3485188

 

mystery-man wrote on 5/16/2022, 8:17 AM

after reading this post I tried EZD3 in AP10 and the results were just as Nicholas posted. Magix, this needs to be corrected ASAP.

Nicholas-Smilek3917 wrote on 5/28/2022, 7:52 AM

I have created a ticket for Magix to investigate I have not heard anything.
I hope they get this figured out quickly or I will switch DAW.

SP. wrote on 5/28/2022, 8:00 AM

@Nicholas-Smilek3917 I would guess a fix will probably take months or will not be released until the next major version. They just started development again after nearly two years. ACID was put on the back burner because Magix probably doesn't have the manpower.

mystery-man wrote on 5/31/2022, 12:38 PM

EZD3 has had 2 updates since it's release on May 3rd and it's still not functioning in AP10....Magix, it's you're turn to update AP10

Nicholas-Smilek3917 wrote on 5/31/2022, 4:14 PM

I also created a EZD3 Ticket and they seem a bit more promising the the Magix team. If not I am dumping AP10 for Reaper.

mystery-man wrote on 5/31/2022, 9:25 PM

@Nicholas-Smilek3917, It works fine in Reaper. I don't have a single plugin that doesn't. Rather sad because AP could be a great DAW

Rednroll wrote on 6/7/2022, 9:21 AM

I ran into this same problem with EZDrummer 2 as well as Superior Drummer 3 when working with Acid Pro. I'm guessing since I don't own EZD3.....but it's likely the same problem.

What you may notice is that all ToonTrack Plugins are currently VST3 plugins. What I noticed is that all my other VST3 instrument plugins install with a ".VST3" file extension for the plugin, where ToonTrack's plugs install with a ".DLL" file extension instead. By default, they get installed to your PC's "C:\Program Files\Common Files\ VST3\" plugins folder.

For some reason Acid Pro seems to have a problem with the the different file extension and being located in the default VST3 plugin folder but Reaper doesn't as mentioned.

So how to get it to work?

1. Navigate to your VST3 plugin folder : "C:\Program Files\Common Files\ VST3\"

2. Find the EZDrummer3 plugin file

3. Copy or move that file to your VST2 64bit install plugins folder, typically located at C:\Program Files\VSTPlugins\ or C:\Program Files\Steinberg\VSTPlugins\ (ie which ever folder you have Acid setup to scan for 64bit VST2 plugins).

4. Restart Acid. Acid will go through a re-scan of your plugins and EZDrummer will now load and function correctly.

I don't visit here often since I've moved onto other DAW programs but may fire up Acid via re-wire from time to time if working with loops. This should likely be stickied to the top of the forum, if Magix isn't going to get around to fixing the issue. I responded to a few other posts in the past with the same issue of ToonTrack plugins not working in Acid after I had the same problem and eventually figured out how to solve it.

Good luck!

sheppo wrote on 6/7/2022, 3:31 PM

thanks @Nicholas-Smilek3917 , I'll put this in the FAQ and mention it in the feedback thread as a bug for fixing in the next release, seems like it would be a relatively easy one.

Nicholas-Smilek3917 wrote on 6/9/2022, 4:53 PM

Thanks for that!
I did exactly what @Rednroll mentioned but no luck at all.
I sure hope hey get a patch happening or I figure Reaper sales may jump with everyone leaving ACID.

I appreciate everyone's efforts.

Nicholas-Smilek3917 wrote on 6/26/2022, 8:25 AM

I recently received an ACID Pro 10 Update and was hoping t6hat they addressed the issue with ACID's issue with EZDrummer3 but no luck.
I have no clue what they think that have fixed but it certainly was NOT their VST3 issue regarding EZDrummer 3.
Considering that I have only had ACID Pro Suite for lass than 6 months before all of these issues with EZD3.
I am going to seek for a refund and move to Reaper.
I suggest you all do the same.