Fixes for crashes | Failed to create VST effect | 0xc0000005 ...

very-stubborn-guy wrote on 7/15/2020, 2:06 PM

Failed to create VST effect - Magix Audio & Music Lab 2017 / (Soundforge) crashes,
Memory cannot be read. Memory Allocation Failed. Out of Memory. Error: 0xc0000005 (ntdll.dll) / (qt5xxxxx.dll). Broken interface without plugin names. Crash on loading 2MB+ projects or on exceeding.

To fix all of the above issues you need to simply use Large Address Aware tool to override memory limit for the main program's executable (e.g. AMlab.exe). It also works when you have only 4GB RAM or less.
Most of the most complicated projects now should open and still possible to further worked on, at least without custom VSTs (which may still cause the issue, but maybe less frequently).

You can still encounter on some problems during work on some complicated projects like random crashes, program exits, no sound during playback, which can be fixed be just restarting the project. Alternatively see below for some workarounds.

"The computer is overloaded by the real time effects calculation"

Don't let the DAW play the transition between tracks or press play more than once; mark playing field on timeline by holding LBM to not play transition; sometimes playing one track before may fix the issue for a while, but in most cases you might be forced to load the project again; in the end you can go to edit and apply all realtime effect, or the same option by pressing RBM on separate object.

-||- Problems with background noise preset of video sound optimizer plugin

It is very resource-consuming plugin functioning using strongly the first thread usually by 100%, so fast CPU is recommended.
Also, other video sound optimizer presets may frequently cause overload error.

Output file broken or incomplete and rendering frequently takes a lot of time

Long rendering is frequently a sign of broken output file. Never render output file when you encounter the issue of no sound during playback - load the project again instead.

Inconsistency of the sound quality in output file vs project output when project mode is chosen

Somehow it happens during exporting of a project to FLAC 16/44 that it sounds brighter than during playback in Magix.
The trick is, you need to chose object view (yellow) before exporting, instead of project view. 
Furthermore, if you use video sound optimizer in some audio part, and freshly loaded the project, you need to play this part of audio before, and then export. Sometimes it is not necessary when you just stopped to actively work on the project (most likely played that part after loading the project, but maybe not only).
If you have video sound optimizer selected in the whole project, don't play the project on its fresh reload, just pick project view (but it may result in blank output files or affect output quality in some cases).
Of course, this everything lies in your own taste and final evaluation of the output file.

Plugin's sound inconsistency in project and object view

Be aware that plugins applied in project and object sound differently, and their settings cannot be moved 1:1 between those layers.
As it comes from my testing, sound cloner always sounds the best when used in project view. The rest wasn't so obvious.

Output file sample rate setting is too low

It happens that if your first imported to the timeline file has different sample rate than 44kHz, and you've added new song to this timeline, during export it sometimes forces this different sample rate, and it needs to be set on every export manually, but sometimes it happens that result files won't exceed this samplerate. It's when playback samplerate (P) is the same as in the first track - and changing it, changes pitch.

Crash dumps take a lot of disc space

PS. Be aware that I think every crash creates memory dumps in ExceptionHandlerDll folder. I had 2GB of these .dmp files in number of 80 in total. They can be safely removed.

Possible fix for "The computer is overloaded by realtime effects calculation. Please reduce the number of effects, or select "Apply all Realtime Effects function"

Besides going to Edit>Apply all Realtime Effects function which will basically render the audio and prevent us from further changes to current chain previously set, you can also:

Go to Task Manager (CTRL+Shift)>Find Sound and Cleaning Lab process>Go to details>press RBM>Set affinity>uncheck CPU 0. It works for very old 4/4 CPUs. After some time the track is played from the beginning to the ending or rendered using export, the affinity trick seem to be no longer necessary, but it might change during editing the project and for sure after reopening it.


No comments yet - be the first to write a comment...