GUI Hotfix did not work for me

NewDream wrote on 10/16/2022, 9:08 AM

I decided to update to 31.0.1.13, had the loop name truncation display problem, followed the instructions in the Important Posts section, "Hotfix: GUI problems with soundpool loop table after update 31.0.1.13" and I still have the problem. Perhaps because my edition is Premium 21 instead of Premium 23?

 

Does anyone have any suggestions on how to get the full name of the loops to display? Does anyone know when the next patch will be available, as Magix says there is a fix there? Dragging a loop to the arranger will show the full name but it's not very convenient to be doing it all the time.

 

I am on Windows 7, but that shouldn't be the problem as others have had the problem too.

Comments

gjonny wrote on 10/21/2022, 2:05 AM

@NewDream

>> Perhaps because my edition is Premium 21 instead of Premium 23?
There seems to be some confusion here -- are you thinking that you're still on MM2021?  The versions go like this:
 29 ==> MM2021
 30 ==> MM2022
 31 ==> MM2023
MM2021 (or 2022) would have been removed when you installed v31. 


>> I am on Windows 7, but that shouldn't be the problem as others have had the problem too.
The thing is, Win7 isn't on the list of supported operating systems. 
 See:  https://www.magix.com/ca/music-editing/music-maker/specifications/
Just because you successfully installed v31 (MM2023) on Win7, there's no guarantee that every feature will work properly.

In your earlier post
https://www.magix.info/us/forum/31-0-1-13-update-patch-windows-7-64-bit-and-mm-premium-21--1306897/ 
You said: "I will stay with what I have unless I run into a problem bad enough to make me want to chance the upgrade."
I'm wondering what prompted you to go with the upgrade?
 

emmrecs wrote on 10/21/2022, 3:31 AM

@NewDream

I can only wholeheartedly endorse everything that @gjonny has written! All recent versions of MM are not designed to run under Win 7. In your situation, it is entirely possible that it is the Hotfix that is incompatible with your OS.

Jeff
Forum Moderator

Win 10 Pro 64 bit, Intel i7 Quad Core 6700K @ 4GHz, 32 GB RAM, NVidia GTX 1660TI and Intel HD530 Graphics, MOTU 8-Pre f/w audio interface, VPX, MEP, Music Maker, PhotoStory Deluxe, Photo Manager Deluxe, Xara 3D Maker 7, Reaper, Adobe Audition 3, CS6 and CC, 2 x Canon HG10 cameras, 1 x Canon EOS 600D

NewDream wrote on 10/21/2022, 7:50 AM

Too many corruptions prompted me to chance the upgrade. Particularly when trying to use the Ozone Izotope plug in. The scrolling wouldn't move when playing the music. Opening menus would show just an empty menu window. Exporting would only get the first 30 seconds of the music. Exiting the program and coming back in would get rid of the problems temporarily but it happened often enough to become a nuisance.

 

The last item I paid for was "Music Maker Premium Edition 2021". I will not be buying Premium Edition 2022, 2023, 2024 etc. while the loop display is not working for me. Perhaps the next upgrade will fix the problem. Due in a few months, I suppose.

 

I won't be upgrading to Windows 10 any time soon.

 

Thanks for the replies. I was hoping you would know of an .ini file I could edit but apparently not.

 

 

SP. wrote on 10/21/2022, 10:35 AM

@NewDream

 Try the following

Edit this file
C:\Users\*YourName*\AppData\Roaming\MAGIX\mm31\MusicMaker.ini

Find
[LoopsViewColumns]

and change the entries with really big values for the eastdock or southdock, depending on which side your Loops window is located. I my case some entries had huge values which caused columns to not fit correctly. Another user wrote that the following settings worked fine:

Got the problem resolve! Took several edits to the ini file, but here are the settings that corrected the problem.

[LoopsViewColumns]
WidthNameSouthdock=106
WidthNameEastdock=0
WidthBPMSouthdock=49
WidthBPMEastdock=0
WidthLengthSouthdock=63
WidthLengthEastdock=0
WidthSoundpoolSouthdock=0
WidthSoundpoolEastdock=0
WidthTypeSouthdock=136
WidthTypeEastdock=0
WidthHarmonySouthdock=0
WidthHarmonyEastdock=0
WidthFavouriteEastdock=0
WidthFavouriteSouthdock=38
WidthPreviewEastdock=0
WidthPreviewSouthdock=0
SortOrderSouthdock=0
SortOrderEastdock=0
OrientationMode=2
SortRoleSouthdock=instrumentGroup
SortRoleEastdock=instrumentGroup

https://www.magix.info/us/forum/lost-some-features-aftermusic-maker-31-0-13-update--1306685/#ca1814599

NewDream wrote on 10/22/2022, 11:32 AM

Thanks! Editing the .ini file has greatly improved the problem. Upon starting the program, the loops pane is off screen and has to be dragged into view. Then clicking on one of the instruments shoves the loops pane out of view again. Dragging the pane back into view then has the program keeping it in view. I can put up with this minor annoyance as the columns in the loops pane are looking normal. I believe I'm back in business.

 

To get to the directory with the ini file, I had to be in Administrator mode. I mention this in case someone else tries to get there and can't. Ordinarily, I am not running as Administrator. I will tag your post as the solution, and perhaps you can edit your post to mention the Administrator wrinkle, in case someone jumps to the solution and misses this requirement.

 

Thanks again.