How can I delete loops in the soundpools ?

Spoonful wrote on 7/26/2008, 9:45 AM
I have grouped all my loops in one location, but Music Maker still shows the links to non existent loops. I have every loop written three times, and only one for each works. It's ... quite annoying...
If someone knows, I'd be glad, and I'm sure so will billions of other people throughout the galaxy.


NoTurning wrote on 7/26/2008, 11:30 AM
What product/version are you using?
Spoonful wrote on 7/27/2008, 6:48 AM

I'm using Music Maker 2008 Producer Edition, XXL version (with the MIDI keyboard, even though I don't think there's any difference in the program)
Thanks for answering by the way !

ralftaro wrote on 7/30/2008, 8:17 AM
Hi there,

You need to reset the database that holds all the soundpool index information to get rid of the dead and invalid entires. If you haven't done so yet, make sure to download and install the latest patch for your Music Maker 2008 Producer Edition from the Magix support site or via the onine update function in the program's "Help" menu. This patch actually introduces new database-related functionality. Once you're up-to-date, go into the program settings to the "General" tab and you'll find a "Reset database" button. Click on it and exit the dialog again. Now go back to the soundpools browser. This will fill the database again with your actually existing soundpool files, but the invalid entries will be gone.

If the above doesn't work for you, you might have to reset the database manually by deleting the relevant file from your hard drive (outside of Music Maker). The file you need to locate is "MAGIX.FDB". Under Windows XP it will typically be located under:

C:\Documents and Settings\All Users\Application Data\MAGIX\Common\Database

Under Vista the location might be slightly different. You might want to use the search function and also configure your Windows file browser to show hidden files.

I hope this helps!
Spoonful wrote on 7/30/2008, 2:41 PM
Ok that did it, thanks a lot, I hope I'll have other problems !

In the meantime, I guess this topic should be marked as solved.

Thanks again !