rraud wrote on 3/4/2019, 8:53 AM

Options> Preferences> General, uncheck the box "Use Newsfeed to stay informed about MAGIX product updates" (towards the top of the list).

If "MAGIX Connect" got installed along with SF, (an easy to miss option) you can uninstall it.

Jamil-Taylor wrote on 3/4/2019, 9:32 AM

This did the trick.