How do i shorten the delay time between controller note on and note played on Music Maker synth?

smitha wrote on 7/23/2008, 1:22 PM
I have a midi controller that i am using with Music Maker 14.
When I play a note on my midi controller there is a time delay between the time when I play the note and when I hear the note played back by the Music Maker synth. when the Synthesizer latency is set at 0ms the delay is very long and when it is set at 200ms it is much shorter but still too long to play anything in real time. What else can I do?


ralftaro wrote on 7/25/2008, 10:48 AM
Instead of using the latency slider to try and compensate latency related offsets after the fact, you should try to prevent the problem from happening in the first place. The key element is the driver model you're using. Not sure whether you've already done this, but for low latency times, it's imperative that you configure the program to use ASIO drivers. Just go back into the program settings and switch to the "Audio/MIDI" tab again. Set the "driver selection" to ASIO and pick a suitable ASIO driver from the drop-down list. If your sound hardware doesn't have its own driver listed there, you will have to use a generic ASIO driver, like the "Magix Low Latency 2008" one that comes with the program. Confirm and try again. If you've been working with the default driver model so far, you will witness a significant difference.

Any remaining excessive latencies beyond that are probably related to factors like system performance and configuration. So, they would have to be rectified by performing some tweaking on a operating system and/or hardware level - certainly a subject matter a little too complex and specific to cover in a few sentences. But the ASIO driver might already sort everything out for you.

I hope this helps.
NoTurning wrote on 7/26/2008, 2:40 PM

Though Ralftaro gives some good advice - do not waste your time with ASIO settings. They only relate to audio recording and playback and have NOTHING to do with MIDI.

Start with your MIDI controller and see if you have any latency/buffer settings there. Also make sure you have the latest drivers for your MIDI controller. Keep your MIDI cable lengths down too.