independence-free-sampler-software only 1 Piano sound

Eli-Cohen wrote on 12/6/2022, 4:35 PM

I installed independence-free-sampler-software and the 2GB library but all I have is just 1 Piano sound.

ALL other sounds gives an error that sound file could not be found.

https://www.magix.com/ca/music-editing/free-download/independence-free-sampler-software/

How do I fix it? What is wrong?

Thanks.

Comments

SP. wrote on 12/6/2022, 5:15 PM

@Eli-Cohen I think if you start Independence for the first time, it will ask you for a serial number or if you want to use it for free. So you clicked on the button to use it for free, correct? After that it should ask you to download and install the free library. And you did that, correct?

And it still tells you that the instruments cannot be loaded? This is usually only the case, if the library installer wasn't able to run completely until the end and the library wasn't correctly registered in Windows.

It's probably a good idea to run the library installer (not the Independence installer) again to uninstall the free library and then reinstall it.

Chris-MacDonald wrote on 12/8/2022, 8:19 PM

I am getting something extremely similar. I downloaded independence_softwaresuite_32_dlm.exe to Windows 10 and ran it. Ran Independence and I could pick lots of instruments in the lower left corner, but they did not show up in the layer and it still played only piano. I then downloaded independence_freelibrary_dlm.exe and ran it. It complained that it couldn't find certain ytif files and offered to download them. This resulted in 330 MB download and some sort of installation on the fly. Now when I click a layer, I can select 'Independence Free - Instruments'. I select 'Acoustic Guitar Spanish'. It then says it can't find 'PHYT-MX NY-GT1 LONG C XA1 Y01' in image file 'Independence Free Content 03'. Find and Auto-Find don't work. I look in C:\ProgramData\MAGIX\Independence\image files and find:

Autoload Acoustic Piano.ytif
Autoload Sinus.ytif
Origami Content Vol 1.ytif
Origami LE Content Vol 1.ytif
Origami LE Content Vol 2.ytif
Special.ytif
vinyl noise.ytif

These seem to be the only ytif files in C:\ProgramData\MAGIX and C:\Program Files (x86)\MAGIX. If I tell it to 'Ignore All', 'Acoustic Guitar Spanish' shows up in the layer, but it doesn't play any sound at all when I press a key.

I tried various uninstalls and reinstalls and computer restarts with no effect.

SP. wrote on 12/9/2022, 3:18 AM

@Chris-MacDonald You did it the correct way. If you open Independence the path to the free library should be listed under the preferences > libraries. It's usually C:\Program Files (x86)\MAGIX\Independence Libraries\Independence Free\

The free downloader installs several Independence Free Content ytif files. All have the size of about 100 to several hundred megabytes each. So only downloading around 300 megabytes is not enough. It should be around 2 gigabytes.

So please make sure a firewall or security software doesn't block the download. Windows changed and tightened a lot of security settings over the past couple of years which interferes with these old installation programs and often blocks or deletes files the programs try to install.

It should look like this if you load an Independence Free instrument for the first time

If not, your system probably blocks the RegIndBundle.exe and RegINDLib.exe files in C:\Program Files\Common Files\MAGIX Services\Independence Libraries\ and C:\Program Files (x86)\Common Files\MAGIX Services\Independence Libraries\

Then the library cannot be unlocked and shows the "can't find file" error.

Chris-MacDonald wrote on 12/9/2022, 7:12 PM

I uninstalled everything, although I did not delete folders. I turned off Windows Defender, and redid the installs of independence_softwaresuite_32_dlm.exe and independence_freelibrary_dlm.exe. The latter caused the download of the various .ytif files, resulting in 'C:\Program Files (x86)\MAGIX\Independence Libraries\Independence Free\image files' containing

Note that the RegIndBundle.exe and RegINDLib.exe RegIndBundle.exe and RegINDLib.exe files are where they are supposed to be. If I try to run them from a command prompt they run without any errors, but no feedback either.

I still get the same problem. Note that when I try to find the .wav file, it looks in C:\Users\CHRIS\OneDrive\Documents\MAGIX\Independence\audio files. This is odd because I virtually never put anything into OneDrive. I try pointing it to the .ytif file indicated, but that does no good. In C:\Users\CHRIS\OneDrive\Documents\MAGIX\Independence, I have

The 'audio files' directory is empty. I suspect it should be full of .wav files. Is this true? It would seem that some process to extract the .wav files from .ytif files did not run. If this is so, is there a way to make it go? Thanks.

SP. wrote on 12/9/2022, 7:49 PM

@Chris-MacDonald The missing sample files are encrypted in the ytif containers. You cannot access them. If you load the library for the first time you should get this registration dialog

In your case this dialog doesn't come up which leads to the "file not found error". Pointing Independence to the directory with the ytif containers will not help. Independence cannot access the files because you didn't complete the registration process.

There is definitely something blocking it on your computer. Maybe you need to run the Independence stand alone version as administrator?

Here were some users in the past who could never get it to work on their systems. I personally never encountered a problem on multiple different computers. I'm not sure what the problem is. It could be modern Windows changes like using Microsoft online accounts instead of local user accounts, new security features added to Windows (my version of Windows 10 is up to date, but I disabled Defender and Antivirus in the settings).

SP. wrote on 12/9/2022, 7:58 PM

Does the Best Service Artists library (which is free) work on your computer?

It's also a library based on the Independence sampler engine and works with Best Service version called Engine (also free)

https://www.bestservice.com/downloads.html (Here you can download Best Service Engine)

https://www.bestservice.com/engine_artists_library.html