Initialising DirectX plug-in failure

Simon-Ring wrote on 11/8/2019, 10:38 AM

Hi, hope someone can help, and apologies if this has been discussed on a previous post.

I purchased Music Studio 11 64bit this morning and have yet to be able to use it. It installed fine, but on running the software for the 1st time it freezes during the "Initialising DirectX plug-ins..." and refuses to go any further. I've raised a ticket with tech support, but apparently it won't be processed for several days and I would really like to be able to use the software !

I'm running a Windows 10 64bit PC, i5-8400, 8gb ram, GTX1060 3gb graphic card. The only other software I have installed is Serato, Waveform 10 and Audacity.

I've tried numerous ways to solve the issue and searched the internet high and low and can't find a solution anywhere.

I hope someone out there will have an idea, or even better a solution.

Thanks in advance.


MarcoStorm wrote on 11/19/2019, 8:39 AM

Dear @Simon-Ring,

sorry to hear that you have such issues on starting with ACID. Please check our current public beta version here:

The scan of the directx plugins should work with that version. Please let me know if your issue is solved with that version.

Best regards,