David-Shuman wrote on 7/31/2020, 12:06 PM

I have installed your trial software; Sound Forge Audio Studio 14 on a windows 10 home laptop. I am attempting to record from a Sony PS-LX300USB Turntable.

In the sound control panel the USB AUDIO CODEC is the default recording device and My internal laptop speakers are the default playback device. The application is locked up and I cannot close the Vinyl Recording and Restoration window and must resort to closing the app using task manager. (a project report was sent.)

After restarting I again attempted Vinyl Recording and Restoration I get a message that says an error occurred while recording a device is not available.

In Options->Preferences->Audio tab the initial audio device type was Microsoft Sound Mapper. That had the device not found error. I then tried changing it to Windows Classic Wave Driver and when I do recording device channel 1 and 2 show left and right USB Audio CODEC devices but an attempt to record still gets a device not found message. Can you provide any guidance what to do in this case.

My laptop is an ASUS GL503GE-RS71 if that matters.




David Shuman


Former user wrote on 8/2/2020, 3:13 PM

Is the TT plugged directly into a USB port on your laptop, or into a hub? I'm using a USB interface with my archiving TT with AS14, and I haven't had any connectivity issues at all.

David-Shuman wrote on 8/2/2020, 3:25 PM

Directly into the laptop, I do not own a hub.

Former user wrote on 8/2/2020, 4:07 PM

Well, I could suggest a lot of things. But I suspect you've tried a lot of them already -- unplugging/plugging the turntable, using an analog instead of a USB connection, installing ASIO4All to see if AS14 is more cooperative with it, seeing if you have the same problem with another program, like Audacity, etc., etc. It sounds like you're just going to have to experiment.

David-Shuman wrote on 8/2/2020, 7:46 PM

Audacity also cannot find the device (-9999 return code I think) neither can wave pad. The pc will act as an amp for the turntable -- that does work. ASIO4All is something I have not heard of yet. Looked it up, it seems like it could be worth a try.

Former user wrote on 8/3/2020, 8:08 AM

It could also be a faulty USB cable. Just something to keep in mind.

David-Shuman wrote on 8/3/2020, 8:08 AM

ASIO4All fixed the access problem for the turntable. It took some trial and error to figure out how to configure ASIO4All to use the turntable as an input. It partially fixed problems with audacity changing the error message to improper sampling rate and not successfully recording. It did open recording to sound forge (the primary goal) and wavepad. I am running the trial version of sound forge without any manual. Just today minutes ago I got a link to soundforge's manual from magix. I successfully performed a vinyl recording and restoration for 2 and a fraction banded tracks with clear blank space. The tracking window that shows the oscilloscope during recording would not show the wave as recording was happening unless I clicked record, pause record and then the wave recording window only functioned for 15-20 seconds even though the recording was still happening for over 7 minutes in my test. The auto band selection was nice compared to audacity under linux. I doubt that would work on live recordings where bands are not delimited by significant blank space often a band starts over the applause of the prior band perhaps regions in the manual corresponds into the manual track marking I have done in audacity under linux, I need to read more. The trial version may have limited my sampling rate to 44,100 even though I had the recording and playback device set to 48,000. The output options were limited to wav and mp3 (various sampling rates) maybe because of the trial. I have been using m4a for my audacity output which I understand to be superior. The metadata loaded into files was poor at best (only one value per picard) possibly because I incorrectly saved using a wav format instead of mp3 (it was a quick test). Thanks for your help the major problem has been addressed the device is accessible to Sound Forge. Time for more testing by me.

David-Shuman wrote on 8/3/2020, 8:16 AM

PS the device worked with audacity under the opensuse tumbleweed OS not under windows 10. I doubt it was a cable issue. If I had not had that work that was valid suggestion.

rraud wrote on 8/3/2020, 10:54 AM

"I have been using m4a for my audacity output which I understand to be superior:

> AAC offers higher bit rates than MP3, which has a max of 320kbs .. which can be cheated to get better quality with mono material like spoken word

Both M4A and MP4 use an AAC audio codec. The Nero and FFmpeg AAC encoders are allegedly the best sounding, though my aging ears cannot detect a difference between them and the MainConcept and Sony AAC encoders in SF Pro.