Installed SF 12 - But Stange Buzzing sound upon recording - unusable

sathyme wrote on 9/28/2020, 3:16 PM

I just installed SoundForge 12 - Using Windows 7 - 64 bit - I use Scarlet 2i2 interface. WAS using SF 9 - which HAPPILY I didn't Uninstall or install over. I have a buzzing sound - sounds like an electrical buzz sound when I record - It is Obviously unusable.- But it is FINE EVERYWHERE else Including my SF 9. Yes - I have rebooted - Both a HARD reboot and Restart - Can't find an answer - Please anyone have any suggestions - Otherwise I have wasted my money! (I already have Izoptope RX 8 as a Stand Alone Soooo.....)


SP. wrote on 9/28/2020, 3:38 PM

What audio device is selected in the preferences?

Former user wrote on 9/28/2020, 3:54 PM

If you're using ASIO drivers, try Windows drivers, or vice versa, to see if that makes any difference.

sathyme wrote on 9/28/2020, 4:01 PM

The Scarlet 2i2 like it's supposed to be. Again, same setup as SF9.


sathyme wrote on 9/28/2020, 4:31 PM

OK - So as Poinzy said - I switched it to Windows Classic Wave Driver. I looked at the settings when I switched to it and it had my Scarlet as:

PLAYBACK - Channels 1 through 4 as my computer/laptop speakers (Which I obviously do not want it to be - I do Voice Overs) so I switched ALL the channels to Scarlet

RECORD: had the 1st 2 channels as my Scarlet and the rest my various Laptop default settings

I did a test - NO BUZZING!

SO - it seems to work - I don't understand WHY - as in the previous SF's and I have purchased SF from SF 5 or 6 through 9 - YOU ALWAYS had to make sure you selected your interface - so I guess in SF12 - you don't??? and you have to use the Windows Drivers??

ANYWAY Thanks POINZY and SP for your help - AND NOW IF ONLY THEY WOULD send a patch, a program or what have you and MAKE SURE WE ALL have the REMOTE RECORD back - I don't think the company understands how the product is used!! Especially with the advent of Source Connect , ipDTL and such - you want a floating window to make sure you are recording AND CAN SEE THE SCRIPT at the SAME TIME!!

I may post this on a Features Forum if there is one!

Former user wrote on 9/28/2020, 4:50 PM

SO - it seems to work - I don't understand WHY -

Welcome to the club. Electrical devices can be really capricious sometimes, especially audio devices connected to a computer. That's one of the reasons I keep isolation transformers handy.

rraud wrote on 9/29/2020, 4:31 PM

"That's one of the reasons I keep isolation transformers handy"

+11 Poinzy, I never leave home without my IL-19s.

Jonathan-Enderica wrote on 10/3/2020, 11:30 AM

I had this same issue. Buzzing when attempting to make plugin changes or just moving plugin around the window screen using ASIO drivers, no issues using windows drivers. I want to say it was an easy fix but it wasn't. Spent lots of time with Magix troubleshooting support as well.

Was super frustrated, almost jumped ship to Wavelab but figured before I spent 600 on a new program (it wasn't on sale at the time), I'd try reinstalling windows since I hadn't done so in almost 10 years since Windows xp to 7 upgrade.

Giant pain the rear, but solved almost all issue I had with pretty much all Magix software especially Sound Forge, and especially that weird plugin buzzing sound. Also solved the instant 99% DSP value when only using a single plugin.

Not sure if that's an option, but if you haven't fully reinstalled windows in a while, and like me had cloned one drive to another and then simply done the upgrades as they'd come out, might be worth a try.

I've literally had zero issues with Sound Forge ever since. Only crashes I get are self induced, when I forget to change sample rate from recording to not recording.

sathyme wrote on 10/3/2020, 12:09 PM

Thank you Jonathan for responding - I marked this issue solved as - Poinzy's suggestion (See above) which makes NO SENSE WHY it works -Worked BECAUSE with all the other SF's - and most software I know - will want you to use the drivers of the audio interface that you are using NOT Windows - unless you do not have an external interface - But SF12 - apparently does!