just purchased slpro4 cannot register process never completes

jeffdenny wrote on 12/26/2017, 6:02 PM

when i try to register it just gets stuck for hours in the enter serial number and email dialog i get 2 green checkmarks and then after hitting enter the process never completes.

also tried to activate offline it says wrong number


ReverendLove wrote on 12/29/2017, 3:34 AM

Same here!
Changed my interface and SL4 wants a new activation.
When did you get your DR stuff sorted finally?

jeffdenny wrote on 12/29/2017, 9:54 AM

I’m sorry what is Dr stuff

ReverendLove wrote on 12/29/2017, 11:10 AM

Not your fault.
There is a M missing. Short for Digital Rights Management.
But the activation process is a pure mess and marketing desaster while not a quality pass for software development.

Magix shouldn't wonder if people use cracked versions when they aren't able to give software access to people who already bought their stuff. Since Magix captured Sony Software this is an continuing nightmare.
I am not able to change an audio device or a network adapter without fighting against the worst DRM system I have ever seen.
The infamous iLok system is paradise against this crap.

DivideFrame wrote on 12/30/2017, 3:23 AM

Hi guys, sorry to hear about that. Will tell Magix about this issue ASAP.

Meanwhile, here's something you can try (assuming you're running the Windows version of SL and that SL is not running - let me know if running macOS) :

-You can try activation with a different user ID number: Win+R, cmd.exe, then type
"C:\Program Files\MAGIX\SpectraLayers Pro 4.0\Win64\SpectraLayers.exe" -register -user 200
(default user number is 175)

-If it doesn't work, you can delete the "C:\ProgramData\MAGIX\SpectraLayers Pro 4.0" folder which contains the activation data, and then retry activation (either by running SL normally, or by running SL with the above command line)

Let me know if any of the above work. If it still fails, we'll try something different.


Robin Lobel

ReverendLove wrote on 12/30/2017, 4:38 AM

Hi Robin
thanks so much for your fast reply.
It works now. I sent you more details per email.

I wonder why Magix does not use any proper and ubiquos call & response system like iLok or does not give the possibilities to deactivate/activate like waves do. Magix system is not very reliable for the apllications they got from sony. Oh, wait SL4 was released by magix... ;-)

Have a nice day


ReverendLove wrote on 12/31/2017, 6:08 AM

Hi Robin,
No, no, no!
It did run yesterday and now I am in this stupid activation circle again.
I am absolutely fed up by this unbearable situation caused by Magix' paranoid licens activation.
Dear Robin,
please look for another supplier. Your deserve a better company.

Darius_B wrote on 5/11/2018, 6:27 PM

Hello guys,

I have the same problem. I can not register and activate SpectraLayers Pro 4. Unfortunately the tips from Robin did not work. After trying them I get "protein register failed with code: -1 (general failure)". After that error message everything stays the same. The "register and activate" process gets stuck at please wait..

DivideFrame wrote on 5/12/2018, 1:18 AM

Hi Darius,

Please try the offline activation process:

A: Enter serial and email, click Activate program offline: https://i.imgur.com/cswMfEJ.png
B: Click Activate offline, Open form: https://i.imgur.com/VthAMOB.png
C: Note the Computer ID (starts by SLP4): https://i.imgur.com/ieLWI4N.png

1: Go to  click Login under SpectraLayers : https://i.imgur.com/0lxf1Mh.png
2: Login: https://i.imgur.com/ofZz8JT.png
3: Register Product: https://i.imgur.com/SsKB3QG.png
4: Enter your serial : https://i.imgur.com/1ij5pTD.png
5a: Go to My Products and click Create a new activation: https://i.imgur.com/RMircTX.png
5b: In User code, enter the Computer ID (starts by SLP4): https://i.imgur.com/lkdJq9P.png
5c: Note the activation code (starts by SLP4C): https://i.imgur.com/bI47HKE.png
5d: Back to the registration process, enter the activation code (starts by SLP4C): https://i.imgur.com/8umt2i5.png

Darius_B wrote on 5/14/2018, 9:23 AM

Thank you Robin for your very fast and very detailed (step by step and even with pictures) response. I followed your instructions and it worked. Now I can start to work with SLP4. Thank you so much.

natevenet wrote on 6/22/2018, 8:38 PM

I'm having the same problem. Tried to follow the instructions above, but the urls are no longer the same. I still created an account and tried to register my product, but, I get the following error (using the serial number copied directly from the offline activation form):


Wrong product registration number

Please check your entries again.
If necessary, use the product registration directly from within your MAGIX product.

Any help would be appreciated!

DivideFrame wrote on 6/23/2018, 3:35 AM

Hi natevenet,

You can download the online registration fix from here: https://drive.google.com/open?id=16utz1es9WFR7jQuaxwgsW5Zth84mB5tJ

Unzip this file in C:\Program Files\MAGIX\SpectraLayers Pro 4.0 (replace any existing file)

Let me know if the online registration works again.

natevenet wrote on 6/24/2018, 9:05 AM

That worked, thanks!

JaroslavKovac wrote on 8/7/2018, 4:30 AM

Thanks, thanks, thanks! This solved my problem!

Jason-Pegg wrote on 11/17/2018, 2:21 PM

That worked perfectly! Thank you!

Tomasz_Lida wrote on 11/24/2018, 9:26 AM

Unfortunately I have the same issue.

It is hard to understand how it is possible. I paid real money, want to have real product. If not, it's rubbery. The fact I'm looking for solution here, wasting time, instead of working on SL and making money with product I've paid for is unbelievable.

Hope someone from Magix is reading this.


Tomasz_Lida wrote on 11/24/2018, 9:35 AM

More - I'm writing it in November. DivideFrame wrote the solution with the patch in June. 6 month and issue is not solved properly. Magix, how is your coffee?

Tomasz_Lida wrote on 11/24/2018, 10:38 AM

Anyway - DivideFrame, thank you very much! It works :-)