Live Track Record Latency

Dylan-McD wrote on 10/28/2022, 10:58 AM

Hello, I posted a similar question awhile back but realized that I had accidentally posted in Samplitude so I am asking again under the Acid category.

I am using Acid Music Studio 11 and have a latency recording issue.  

There is a delay when I record a live track so that track inserts a bit of silence at the beginning which then requires me to manually resync it.

I am using a Yamaha AG03 external usb audio interface. (https://usa.yamaha.com/products/music_production/interfaces/ag_series/specs.html)

I received a tip that my audio interface and my project settings sample rate should match so I have set both to 48,000. And I have experimented with both at 44,100 but the problem still exists.

I also received a tip questioning my Yamaha AG03 audio interface speed but this unit claims to have an input latency of 15.896 msec and output 18.896 which I believe should be imperceptible to the ear?

And My Windows 10 PC has 12 GB RAM and an i5 3.20 GHz processor. My RAM is upgradable to 16 GB if needed.

Does anybody have advice for me on this?   

 

Comments

SP. wrote on 10/28/2022, 11:06 AM

@Dylan-McD To ensure that this delay isn't caused by your audio device or computer I would highly suggest you install a demo version of another DAW or the free Cakewalk and check if the delay also exists there. If not, there is likely a settings problem with ACID.

Dylan-McD wrote on 11/3/2022, 9:25 PM

@SP. Right, good idea. I have an older Cubase on my computer that I just tried and my live track track sounds synced, so I would have a problem with Acid in particular.

Dylan-McD wrote on 11/8/2022, 12:47 PM

Any advice on this?

I could uninstall and reinstall the program unless there are less drastic measures?

If I do this – is there anything I need to know?

As far as maintaining my Acid projects -  I’m hoping I won’t lose my loops and live tracks in the process, or ideally not need to point Acid to them again, if possible. I believe the live tracks are in the default folder. I’ll back them up and note the location just to be safe.

But if anybody knows what else I can try without reinstalling please let me know.     

SP. wrote on 11/8/2022, 4:41 PM

@Dylan-McD You would need to show us all your ACID audio settings in detail, including driver settings and buffer sizes to be able to guess what could be wrong. Also your Cubase settings as a comparison. You can upload screenshots with the blue arrow icon above the text box.

Dylan-McD wrote on 11/20/2022, 10:36 AM

Okay thanks, @SP. Firstly here is a screenshot of my live track where I am playing on beat. The cursor is where the beat is and the wave shows where it is playing back unsynced.

Dylan-McD wrote on 11/20/2022, 10:37 AM

Here are my Acid preferences.

Dylan-McD wrote on 11/20/2022, 10:38 AM

Acid Project Properties.

Dylan-McD wrote on 11/20/2022, 10:40 AM

Audio Interface Info.

Dylan-McD wrote on 11/20/2022, 10:41 AM

Cubase Info.

Dylan-McD wrote on 11/20/2022, 11:25 AM

Now that I'm looking at things IMHO I am especially wondering about the correlations between these latency settings?

Dylan-McD wrote on 11/21/2022, 10:06 AM

@SP. Please let me know if there is anything else you need.

Also, I am willing to upgrade to a pro version if this would likely solve my problem, as long as my previous .acd files stay intact.

Dylan-McD wrote on 11/21/2022, 10:48 AM

Wait I may have found the problem - Audio Device Type was not set to the right device. Unless anybody has additional advice I'll test out the sync again as soon as I get the chance.

SP. wrote on 11/21/2022, 1:26 PM

@Dylan-McD Thank you very much for the screenshots. Yes, it's looks like you found the possible cause of the problem. You selected the Steinberg ASIO driver in Cubase but not in Sound Forge. Please click on the "Apply" button in Sound Forge after you switched to the ASIO driver. You can then open the Advanced settings to configure it in detail (the button is disabled in your screenshot).

Dylan-McD wrote on 11/24/2022, 9:02 PM

Okay, worked like a charm! My live track sync sounds beautiful, latency problems are history. This may have been an easy fix, but hopefully the next people in my shoes can jump right to the solution - check that your (ASIO, low latency) Audio Device Type (options > preferences) is set to the right device.