Magix Music Maker 2023 Premium keep freezing

JohnFery-Jame wrote on 5/13/2023, 10:31 PM

ust bought this beautiful software yesterday. upon complete installation and launch the apps keep freezing randomly. I can even login or click anywhere on the app interface. Need to close it through task manager.

for info my pc:

Windows 11 64 bit | Intel Core i7 8700 @ 3.20GHz | 32.0GB Dual-Channel DDR4 @ 1336MHz | NVIDIA GeForce GTX 1060 6GB | ROG STRIX Z390-E GAMING (LGA1151)

please help, thank you

John Fery

Comments

SP. wrote on 5/14/2023, 2:50 AM

@JohnFery-Jame Try the following. Open the Windows accessibility settings and disable the text cursor indicator.

JohnFery-Jame wrote on 5/16/2023, 10:23 PM

@JohnFery-Jame Try the following. Open the Windows accessibility settings and disable the text cursor indicator.

Thank you for the response, by default Text cursor indicator is off or disabled. upon launching the app i only can click once and it will freeze 2-5 minutes and I can click or browse once and then it freezes again.

please help rectify

thanks

John Fj

SP. wrote on 5/16/2023, 11:17 PM

@JohnFery-Jame Do you restart your computer regularly? I recommend that. Also try to install all pending Windows updates. Sometimes Windows will install only parts of updates. This can impact your program negatively.

JohnFery-Jame wrote on 5/17/2023, 3:04 AM

yes, windows is updated just that Magix Music maker become unresponsive after a few mouse clicks

SP. wrote on 5/17/2023, 3:23 AM

@JohnFery-Jame And you restarted the computer via the Restart option? We just need to make sure it's not a problem caused by not restarting the computer for months.

JohnFery-Jame wrote on 5/17/2023, 7:24 AM

yes.. already tried. restart a few times but no luck. Shut down and turn it on again, the problem persist.

emmrecs wrote on 5/17/2023, 8:16 AM

@JohnFery-Jame

Assuming you mean that you quite literally Shut down (your computer) and turn it on again that is NOT a restart that @SP. is encouraging you to do, sorry.

To carry out a restart, using a right-click on the Windows Start icon, choose "Shut down or sign out" and on the screen that opens choose "Restart". This is the means by which Windows automatically resets all its drivers etc. Choosing to "Shut down" actually saves everything as it was at the time of shutting down and then, when you start your computer again it restores everything exactly as it was when you shut it down, which is NOT what you are being advised to do.

Jeff
Forum Moderator

Last changed by emmrecs on 5/17/2023, 8:16 AM, changed a total of 1 times.

Win 10 Pro 64 bit, Intel i7 Quad Core 6700K @ 4GHz, 32 GB RAM, NVidia GTX 1660TI and Intel HD530 Graphics, MOTU 8-Pre f/w audio interface, VPX, MEP, Music Maker, PhotoStory Deluxe, Photo Manager Deluxe, Xara 3D Maker 7, Reaper, Adobe Audition 3, CS6 and CC, 2 x Canon HG10 cameras, 1 x Canon EOS 600D, Akaso EK7000 Pro Action Cam

JohnFery-Jame wrote on 5/17/2023, 8:29 AM

thank you for the advice or instruction on how to "restart Windows properly " I am pretty aware I did it properly. in windows 11, Start button> Power> restart.. nothing changes to the Magix Music maker. I can open the program. after few clicks of the mouse, it becomes unresponsive.

SP. wrote on 5/17/2023, 9:23 AM

@JohnFery-Jame Are you able to get into the program settings? Close the welcome screen, go to File > Settings > Program Settings > Audio MIDI. Select Music Maker ASIO as your audio driver. Click on the Advanced button to open the driver settings and select your audio input and audio output. In case you want select the audio output of your graphics card to your monitor I would highly recommend against it. Better select the standard Realtek Audio output and connect speakers or headphones directly to the computer. Set the buffer size to something hig like 2048 samples. This will reduce load on your computer.

JohnFery-Jame wrote on 5/20/2023, 2:44 AM

I can access Program Setting even though I have to wait 3 to 5 minutes between every mouse click. Just accessing the Program setting menu takes about 25 minutes. All setting as advice but had no luck. still lagging.

I have no idea what the culprit was or what I had done wrong.

SP. wrote on 5/20/2023, 3:37 AM

@JohnFery-Jame This definitely sounds like the text cursor problem, you already tried to solve by disabling the text cursor indicator.

Since it is already off and it didn't help, you can try something different: some users reported that this was caused by apps running in the background, for example apps that access text like screenreader apps, writing assistance apps, programs that access the Windows clipboard, even antivirus apps.

It can help if you run Music Maker as administrator Windows by right clicking on the program icon. If this doesn't work you need to find the program running in the background and close it.

For example, apps like TextExpander, ProWrtingAid or Comodo Antivirus were named by users, and after closing them Music Maker ran completely fine.

JohnFery-Jame wrote on 5/20/2023, 9:11 AM

Just to inform.. I go for the shortcut. reformate my PC and start everything fresh.. yeah!. everything goes well. Now I can open Magix music maker. I suspect 3rd party plugins & vst were the culprits!

BTW , Thank you for all advice